Jump to content
InsanelyMac Forum

asdfjklsemicolon

Members
  • Content count

    6
  • Joined

  • Last visited

About asdfjklsemicolon

  • Rank
    InsanelyMac Protégé
  1. asdfjklsemicolon

    Backlight Control Sierra 10.12.5 AMD APU

    I have an HP Pavilion 15-p051us laptop that I have set up as a hackintosh. One of the last things I have not managed to get working is the backlight control. I have tried the ACPI Backlight (and Intel Backlight) method by rehabman (this has worked for some people by using Brightness by bergdesign) but it does not work for me. I have also tried the AppleBacklightInjector method mentioned here as well as patching my own by the method here. So far nothing has worked. I have not gotten a slider in the system preferences nor have I been able to change the brightness with the bergdesign app. I have used clover's PNLF fix only when the method says to do so (this was always the first thing I checked). I have attempted to create an IGPU device (yes on an AMD APU) by renaming _SB.PCI0.VGA to _SB.PCI0.IGPU and renaming the sub-device (LCD) to DD01. I also added methods in the IGPU device of my intel hackintosh but the brightness control still does not work with any method. I have attached the original DSDT (and SSDTs) as well as my modified DSDT (with IGPU, battery fix, and HPET fix). Is there any known way to control brightness on an AMD system or is there anything else I can try to make this work? Currently I can only use a semi-transparent overlay (brightness slider app in store) to "control" brightness. origin.zip patched.zip
  2. asdfjklsemicolon

    HELP: AMD APU Graphics Acceleration

    I have successfully set up my HP Pavilion 15-p051us as a hackintosh with Sierra 10.12.5. I have an AMD A10-5745M APU with Radeon 8610G Graphics. The OS boots and is usable, however there is no graphics acceleration which makes icons in finder and notification bar look strange and launchpad is really slow. How can I enable QE/CI acceleration on my APU?
  3. asdfjklsemicolon

    SOLVED: Still waiting for root device HP Pavilion AMD A10

    Got to installer. For anyone else with similar issues make sure to try all combinations of PCIRootUID=0 or PCIRootUID=1 and npci=0x3000 or npci=0x2000. Just npci=0x3000 worked for me. USBInjectAll by RehabMan was also needed in my case. USBInjectAll: https://github.com/RehabMan/OS-X-USB-Inject-All
  4. asdfjklsemicolon

    SOLVED: Still waiting for root device HP Pavilion AMD A10

    Another Update: I have been able to boot further by using cpus=1 and the clover OsxAptioFixDrv driver. Now I am stuck at a prohibited symbol with garbled text. At the bottom, Still waiting for root device can be seen. I am trying to install from my USB2.0 stick in a USB2.0 port on my laptop. I have tried Rehabman's USBInjectAll (with and without the limit patch) and I have tried GenericUSBXHCI kext without any luck. I have tried clover's fix usb patch and I havee tried to use clover's inject usb and usb ownership options. My BIOS does not have a legacy USB option (although legacy booting is disabled.) I am out of ideas. How do I get the USB ports to work?
  5. asdfjklsemicolon

    SOLVED: Still waiting for root device HP Pavilion AMD A10

    Update: I found this kernel for 10.12.5. I added the kext and kernel to the USB Installer. With this kernel I got past the plus line in clover by adding NullCPUPowerManagement. When I boot with cpus=1 and -v I get to FakeSMC Successfully initialized and then there are errors about USB XHCI. When I add GenericUSBXHCI I get the following output and then it freezes. FakeSMCDevice: successfully initialized 000001.119598 XHCI0: AppleUSBXHCI::start: hardware exception occurred 000001.121618 XHCI1: AppleUSBXHCI::start: hardware exception occurred Any idea how to solve this issue?
  6. EDIT: See post #3 for still waiting for root device issue! I have a HP Pavilion 15-p051us with an A10-5745M APU ( https://support.hp.com/us-en/document/c04346410 ).I created a USB installer for Sierra 10.12.5 using Pandora's Box and installed Enoch (I have a second USB drive with clover on it as well.) I copied the 10.12.4 kernel (I do not know of a 10.12.5 AMD kernel and the 10.12.4 has been reported to work) to /System/Library/Kernels and repaired permissions/rebuilt cache (This is the kernel: http://www.insanelymac.com/forum/topic/312714-amd-macos-1012x-sierra-kernel-testing-release-for-help-use-the-help-topic/page-31?p=2399141&do=findComment&comment=2399141 ). When booting with -v with Enoch I get the following error repeatedly. OPEMU: movzx ecx, byte [raw+0x16] warning: invalid kernel ip, won't attempt to handle trap When booting with my clover USB Drive with -v I get the line of pluses and then it auto reboots. Any ideas on what my problem is and how to fix it?
×