Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About artix123

  • Rank
    InsanelyMac Protégé
  1. Hey guys, I'm trying to get dual DVI working on my Sapphire 4870, in Mavericks DP1. (It should be roughly the same as ML) I've tried various kexts available through this thread, but all to no avail. Specifically, the ATIFramebuffer.kext on the first post will make my screen display gibberish black and white after the Apple logo during bootup (computer still runs fine, I can hear the volume adjustments) As for the exotic QE/CI patch, I get kext load errors when booting in verbose. Is there any manual editing of the kexts I need to do to get dual DVI to work? If so, will anyone kindly point in the right direction? Thanks!
  2. I'm not very sure about this, but my computer has sleep issues even on windows, appears to be an issue with X58. But my motherboard is R2E so it might differ.
  3. That did the trick. Thank you very much!
  4. Just wanna say I managed to get Mountain Lion working on my R2E. I replaced the DSDT in the Mountain-Lionize package with the one maltba uploaded in Page 35, and after installation I ran finalize before the installer restarted the computer (I chose not to install Chameleon). Booted from the USB stick to the HDD install, dropped AppleHDA.kext (uploaded by maltba) into Kext Utility, installed r2042 Chameleon, and restart, voila! sound. But boot time is extremely slow, takes up to 1.5 minutes. Haven't ran with verbose mode yet so I'm not sure what's the issue.. Use an older version of AppleACPIPlatform.kext (I used 1.3.5 as suggested by Sennen). EDIT: Updated to 10.8.1, no tweaking required. EDIT: Dual monitors not working! EDIT: Updated to 10.8.2, I reinstalled AppleACPIPlatform.kext and AppleHDA.kext through Kext Wizard.
  5. I'm on GUID and I always only have 1 hard disk installed when I attempt an installation, I'm sure I booted up the correct partition (through the Chameleon on my Mountain-Lionized install stick), and I'll always get errors pertaining to SMC (if I don't run finalize), and booting freezes here: I'm on 4870 and video works oob. Yep I'm using your file, I've installed DSDT.aml. I think I need to figure out how to make my ML boot up without running finalize. Did you select the options pertaining to making an ASUS X58 install when making the USB stick through Mountain-Lionize? It's ok btw, I wanna try to figure it out too haha.
  6. Hey maltba, I'm on R2E motherboard too. Just wondering how did you boot your ML without running finalize, after installation? My installation just doesn't boot if I don't run finalize, and if I do, my audio will be broken (even when I try to install your AppleHDA.kext over the old one). Also having problems with dual-booting - Chameleon just doesn't boot even after I installed it. Might have something to do with my Mountain Lion partition being the 5th one..
  7. Snow Leopard on VAIO P(VGN-P90HS) working!

    Found this: http://www.groths.org/?page_id=322 Not on 10.6.8 yet though, gonna try after I get a hard disk clone.
  8. Snow Leopard on VAIO P(VGN-P90HS) working!

    Ah, I think I made a mistake, HT is indeed enabled. Check Activity Monitor -> Window -> CPU Usage.
  9. Snow Leopard on VAIO P(VGN-P90HS) working!

    http://www.insanelymac.com/forum/index.php?showtopic=168426&st=160&p=1299430entry1299430 It's linked up there in my post too
  10. Snow Leopard on VAIO P(VGN-P90HS) working!

    Yeah the kext doesn't seem to load. I think IOGMA500Framebuffer.kext doesn't work too, I was using the 2010 files and I get KP after upgrading to 10.6.8. That's why I'm using the 2009 files (the IOGMA500Framebuffer.kext seems to be the only major difference)
  11. Snow Leopard on VAIO P(VGN-P90HS) working!

    Thanks for all the info man! Yeah I think I'm gonna backup a hard disk image too just in case. Just one last question.. Have you found a way to change display brightness?
  12. Snow Leopard on VAIO P(VGN-P90HS) working!

    Does Safari play Youtube correctly? And I'll check Onyx out. Any important things to do in Onyx to speed things up? I'm gonna develop on XCode so.. yeah I'll need all the power I've got. Heh. BTW it seems like only 1 thread out of 2 is activated.
  13. Snow Leopard on VAIO P(VGN-P90HS) working!

    I've heard that 10.6.8 is slower, but I'm not very sure. My Chrome is very laggy, how's yours? Nope, not working on Chrome, I think it's the same problem as yours, stuttering audio with black screen, page is practically unusable.
  14. Snow Leopard on VAIO P(VGN-P90HS) working!

    I got 10.6.7 working on my P15G (Z530, 64GB SSD). I attempted multiple times though, so I'm not sure whether my installation steps are correct. Sometimes I try the same thing, and it doesn't work on the first time but strangely on the second. Credits: ryuu123 (of course!) http://blog.livedoor...es/5145208.html http://www.insanelym...howtopic=277983 fr3z3rburn http://www.insanelym...dpost&p=1313083 0. Files 0.1 Snow Leopard 10.6.0.dmg (or DVD) 0.2 Chameleon-2.0-RC3-r658-bin.tar.gz 0.3 vaiop20091014us - the 2010 files didn't work for me when I tried to update. 0.4 Kext Helper b7 0.5 Mac OS X 10.6.7 Combo Update 0.6 10.6.7 Legacy Kernel 0.7 *vaiop20090910 (I'm not sure if you need this) 1. USB 1.1 Format USB as Mac OS X Extended (Journaled), GUID partition table. 1.2 Restore from Snow Leopard 10.6.0 Retail. 1.3 Extract Chameleon-2.0-RC3-r658-bin.tar.gz, vaiop20091014us 1.4 Terminal 1.4.1 df Check which volume is your flash drive with the SL installer on it. e.g. (/dev/disk1s3, /Volumes/Mac OS X Install DVD) 1.4.2 sudo -s 1.4.3 cd (Chameleon extract location)/i386 fdisk -f boot0 -u -y /dev/rdisk1 (replace accordingly) dd if=boot1h of=/dev/rdisk1s3 (replace accordingly) cp boot "/Volumes/Mac OS X Install DVD" (replace accordingly) 1.4.4 cd (vaiop20091014us extract location) cp DSDT.aml "/Volumes/Mac OS X Install DVD" (replace accordingly) cp -r Extra "/Volumes/Mac OS X Install DVD" (replace accordingly) 2. Install 2.1 Boot up from USB, select Snow Leopard installer 2.2 Partition your hard disk in GUID partition table I followed the guide and made this: - Snow (20GB) - Mac OS X Extended (Journaled) - Windows (20GB) - exFAT - Share (the rest) - MS-DOS (FAT) 2.3 Install 2.4 Leave the USB there when installation is done! 3. First boot 3.1 Boot from USB, select hard disk that you installed to 3.2 Setup like normal 3.3 Copy Chameleon-2.0-RC3-r658-bin.tar.gz, vaiop20091014us, Kext Helper b7 to Desktop If USB doesn't work for you, redownload them using wireless (wireless should be working) 3.4 Terminal 3.4.1 df Check which volume is your hard disk with SL on it. e.g. (/dev/disk0s2) 3.4.2 sudo -s 3.4.3 cd (Chameleon extract location)/i386 fdisk -f boot0 -u -y /dev/rdisk0 (replace accordingly) dd if=boot1h of=/dev/rdisk0s2 (replace accordingly) cp boot / 3.4.4 cd (vaiop20091014us extract location) cp DSDT.aml / cp -r Extra / 3.4.5 exit 3.5 Launch Kext Helper b7 3.5.1 Drag GMA500BacklightDisplay.kext, VoodooHDA.kext from vaiop20091014us into Kext Helper 3.5.2 Type in your password -> Easy Install 3.6 Terminal 3.6.1 sudo -s 3.6.2 rm -r /System/Library/Extensions/AppleHDA.kext (not sure if this step is needed) sh /Extra/extra.sh (wait very long here, until a lot of log text appears) 3.7 I rebooted here to make sure everything is working. 4. Update 4.1 Navigate to /System/Library/Extensions and copy IOATAFamily.kext to Desktop (backup) 4.2 Run Combo Update 10.6.7 4.3 DO NOT RESTART WHEN IT IS DONE 4.4 Terminal 4.4.1 sudo -s 4.4.2 cd (folder with your legacy kernel) cp legacy_kernel.10.6.7 / cd / rm mach_kernel mv legacy_kernel.10.6.7 mach_kernel 4.5 Kext Helper b7 4.5.1 Drag IOATAFamily.kext from Desktop into Kext Helper 4.5.2 Type in password -> Easy Install 4.6 Reboot Brightness controls stopped working for me after I updated to 10.6.7. I don't think Sleep works, and I'm not going to try. If anyone managed to get 10.6.8 to work, please let me know. Thanks EDIT: If you didn't install Windows first, follow this guide to get dual-boot working on Chameleon. (I had to format the Windows drive to exFAT in OS X to get it installable through Windows 7 installer.)
  15. Thank you Fabio for the amazing guide. I've (almost) successfully installed Lion 10.7.3 on my R2E: i7 920 Rampage II Extreme 6GB Kingston HyperX 1066MHz (only 4GB detected.. stupid Asus X58) ATI Radeon 4870 (works oob with GraphicsEnabler=No) Just a few questions: 1. How do I set Chameleon to use native screen resolutions? Currently it displays as a stretched screen. 2. After I ran the combo updates, I only ran Recrendae as I didn't have other Mac OSes installed. It seemed to work fine, but what would be the benefits if I actually ran vsdbutil and the cache rebuild commands? Thank you again! I've tried with the installer USB stick, but vsdbutil is not available in the installer. My updates worked without me using these commands though.