Jump to content

manta

Members
  • Content Count

    30
  • Joined

  • Last visited


Reputation Activity

  1. Like
    manta reacted to sailor25462 in clover issue with nvidia, relates to shutdown and blank screen issues   
    Makes sense. Indeed it looks like something went wrong with the native nvidia drivers.
     
    If you install the nvidia web drivers, you need to tell clover that you use them. (That has nothing to do with the nvidia pref pane where you can also select the native driver or web driver! In any case you need nvda_drv=1). So my boot options start like this:
    <key>Boot</key> <dict> <key>Arguments</key> <string>darkwake=no nvda_drv=1 kext-dev-mode=1</string>  
    step 1:
     
    disable the nvda driver by adding nv_disable=1.
     
    This will result in a non accelerated graphics system, so don't expect this to run smoothly and shiny. It's only to get around the error message from nvidia that you can't install the driver on this system.
     
    step 2:
     
    install the web driver. If you can't do it out of the box, you'll need to use pacifist to open the pkg and install the driver from within pacifist. There's also an option (right click) to install them to the designated target. (I used this option first)
     
    step 3:
     
    reboot and enter clover to activate the nvidia driver (nvda_drv=1) 
     
    step 4:
     
    install the web driver a 2nd time.
     
     
    Don't activate the nvidia graphics injection. This is not necessary anymore since the web driver will result in a proper shutdown.
×