Jump to content

a3om

Members
  • Content Count

    19
  • Joined

  • Last visited

About a3om

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

750 profile views
  1. Here's it. Thanks. patchedDSDT+SSDT.ioreg.zip
  2. Here's ioreg from IORegistryExplorer. Thanks. a3om.ioreg.zip
  3. Hi jl4c! Here's my IORegs with the original and patched DSTS. Also attached my current config.plist, screenshots and EDID information (moninfo.txt and dspinfo.bin received from Windows 10). Now NVidia works in the background (black screen) with the 1280x1024 resolution. Mac OS version is El Capitan 15G1421. Thanks. ioreg.originalDSDT.txt ioreg.patchedDSDT.txt currentConfig.plist.zip moninfo.txt dspinfo.bin.zip
  4. I've reinstalled OS X with the latest Clover bootloader and then updated Mac OS to 15G1421. Unfortunately, the screen was still black after reboot. Then I installed Web Driver and saw it defined my graphics card as NVIDIA 425m in the `About my mac` which is good I thought, but the screen was still black after reboot. Then I continued testing. Tried steps #1 and #2 and got nothing. On the #3 step I still saw black screen, but tried to connect mac through HDMI and I saw the screen! There's some progress! Then I tried various SMBios and got black screen on the internal LCD with working HDMI. Then I wanted to figure out what makes HDMI working. Deleted Natit.kext and got not working HDMI. So, Natit.kext helps somehow. Then I tried to remove the DSDT EDID modifications and nothing happened. Then I tried step #2 with Natit.kext and again it didn't make anything. I attached the Natit.kext I use. So, at least I have working HDMI and maybe we can see more details about the issue. How we can know where the issue is? Let me know your thoughts. Thanks a lot for your invaluable assistance. [edit] Attached screenshots I got with working HDMI by the Natit.kext. Natit.kext.zip
  5. OK, I have installed Windows 10 to another HDD, installed the native NVidia graphics driver (actually, that may not make sense, but anyway...) and run Monitor Asset Manager. Here's the dump I got from it. I compared this EDID with the one from DSDT and it looks the same. But maybe extra information from the dump yield results. Thanks for your help. moninfo.txt dspinfo.bin.zip
  6. Sorry for not quick answer. Yes, I extracted these EDID values from my machine display using Ubuntu 16.04. Then I found these values in my original DSDT and just copied and pasted these to the DSM method. Weird, I have no errors compiling my DSDT... I use MaciASL with the 5.1 ACPI specification. So, maybe that's the issue. And sorry for lack of information. I use the same build like you: Mac OS X El Capitan 10.11.6 15G31. Thanks.
  7. Unfortunately, still nothing. I noticed you enabled verbose mode by default and disabled InjectNvidia. I tried your version. Then I enabled InjectNvidia and tried again. Still no internal display. I noticed the text `nvdagf100hal loaded and registered` or something similar before I saw a black screen. Thanks.
  8. Hi, guys! I would like to say you all thanks for your time. I saw how much help you give to people like me. I respect you guys! So, my issue. I have a Sony VAIO VPC-F13S1R that has the NVIDIA 425m video card and FullHD resolution. I have red many topics and tried many options which work with any other laptops, but nothing. Now I am on the 6,2 SMBios. I also tried to use the 3,1. Internal display works with the nv_disable, but has no full hd resolution. But I would like to have that. How can I get it working? Any ideas? Also, if I can't get NVIDIA working, may I use the integrated Intel HD Graphics video card that my VAIO have as well? Will it support FullHD resolution? Seems it doesn't support Full HD resolution, so the only one way to have Full HD is to get the NVIDIA working... I also thought, maybe Clover don't load the patched DSDT.aml... How can I check this? Notebook: Sony VAIO VPC-F13S1R Graphics Adapter: NVIDIA GeForce GT 425m Display: LCD 16' FullHD (1920x1080) CPU: Intel Core i5 m560 Chipset: PM55 BIOS: AMI R0180Y9 Boot loader: Clover OS: OS X El Capitan DSDT: in the attached archive Clover Configuration: in the attached archive My Configuration.zip
  9. Hi, guys! I would like to say you all thanks for your time. I saw how much help you give to people like me. I respect you guys! So, my issue. I have a Sony VAIO VPC-F13S1R that has the NVIDIA 425m video card and FullHD resolution. I have red many topics and tried many options which work with any other laptops, but nothing. Now I am on the 6,2 SMBios. I also tried to use the 3,1. Internal display works with the nv_disable, but has no full hd resolution. But I would like to have that. How can I get it working? Any ideas? Also, if I can't get NVIDIA working, may I use the integrated Intel HD Graphics video card that my VAIO have as well? Will it support FullHD resolution? Seems it doesn't support Full HD resolution, so the only one way to have Full HD is to get the NVIDIA working... I also thought, maybe Clover don't load the patched DSDT.aml... How can I check this? Notebook: Sony VAIO VPC-F13S1R Graphics Adapter: NVIDIA GeForce GT 425m (max amount of memory: 1024MB) Display: LCD 16' FullHD (1920x1080) CPU: Intel Core i5 m560 Chipset: PM55 BIOS: AMI R0180Y9 Boot loader: Clover OS: Mac OS X El Capitan 10.11.6 15G31 DSDT: in the attached archive Clover Configuration: in the attached archive Thanks a lot for your help! My Configuration.zip
  10. Okey. Thank you, midi ッ
  11. Hi, guys! I tried to install MacOS Sierra but it was fail. I downloaded new VoodooPS2Controller.kext, new Clover Bootloader and everything run well but I got following bugs: "About my Mac" menu item doesn't work Touchpad preferences window is just empty The WiFi card (BCM94352) also doesn't work with the previous kext. And I gotta ask is there a way to get it to work? Please, tell me about your thoughts.
  12. a3om

    AppleALC — dynamic AppleHDA patching

    Thanks a lot! I've solved the problem through this tutorial: http://forum.osxlatitude.com/index.php?/topic/3084-eapdjack-sense-fix-no-sound-and-jack-sense-issue-after-sleep/ I used a type 4 and 5000 seconds delay after waking up. And after some time after waking sound comes back I'm being happy! Thank you so much!
  13. a3om

    AppleALC — dynamic AppleHDA patching

    Now layout_id = 3, but it works with layout_id = 13 as well (absolutely the same). But with layout_id = 28 the Internal Speakers works every time even after waking up, but the Headphones doesn't work at all
  14. This guide about disabling discrete nvidia videocard was helpful for me. My nvidia card is disabled now. The text version: https://github.com/mental-boy/DSDT-SSDT-GUIDE/blob/master/k2.md Just make changes in your DSDT and SSDT-7 only.
  15. Unfortunately, sound doesn't work. CodecCommander is installed. I did everything as you said. There is no sound from the speakers, but from the headphones it is.
×