Jump to content

steenamaroo

Members
  • Content count

    122
  • Joined

  • Last visited

About steenamaroo

  • Rank
    InsanelyMac Geek

Profile Information

  • Gender
    Male
  • Location
    U.K.
  • Interests
    Audio Production.
  1. 10.12.1 gtx970 macpro 4,1 gpu glitches

    Fair. Good luck man.
  2. 10.12.1 gtx970 macpro 4,1 gpu glitches

    By 'any card beyond that' I meant anything newer. Really, I should have said 'newer architectures'. Maybe 770 etc are a grey area. I don't know. 750ti is Maxwell and apple drivers have no maxwell support, as far as I know. I mean, I've never tried it but MVC website specifically lists 750ti as requiring 10.10 and nvidia web driver. If your concern is reducing maintenance, the safe money's on gtx680.
  3. 10.12.1 gtx970 macpro 4,1 gpu glitches

    Hi Scalar, Thanks for the reply. Unfortunately I can rule those things out but, like I say...Thanks for trying to help. As far as I'm aware the most powerful card that is officially supported by Apple is the GTX680. Your assertion is correct, to the best of my knowledge. Any card beyond that, whether flashed or not, will require the Nvidia web drivers. Having said that, you can just edit the NvdaStartup kext to reflect the new build number each time there's an update. Sounds like a pain but the Nvidia driver updater app has auto patching built in. Just type in the new build number, patch, then update the OS. (or just wait...?) Of course nothing's guaranteed, but I've used it to bridge the gap across the last few .* updates.
  4. 10.12.1 gtx970 macpro 4,1 gpu glitches

    Hi owbp, Thank you for the reply. No, I had no issues on El Capitan or any of the previous OSs. I was really reluctant to roll back just because of the amount of preferences and things I'd have to transfer but maybe that's the only way. Thanks again for the info! Edit. I do have a windows box here so I'll check for bios updates to rule it out. If you hear nothing more, assume nothing changed.
  5. Are there global nvidia/sierra issues?

    Hey, I had played with different driver versions and I'm confident that the hardware is good, but I hadn't considered trying other roms. Good call! I'm pretty sure my card is EVGA but I'd need to check. It's dual DVI, though. Not sure how relevant that is. Thanks man. I'll post back if I learn anything.
  6. Are there global nvidia/sierra issues?

    Do either of you know anything relating to the OP?
  7. Are there global nvidia/sierra issues?

    Damn, Sorry to hear that man. Can't even offer any advice - I've been out of osx86 since 10.5. I think I'm done with my issue. Can't even find people to compare notes with, let alone someone with the same issue.
  8. Are there global nvidia/sierra issues?

    I'm going to take a punt and say there was more to it.......
  9. Are there global nvidia/sierra issues?

    Hey, Thanks for the insight. Yeah, I don't get the SIP thing either but the change was black and white. Machine went from laggy p4 to 12 core xeon with the flick of that switch. It's not a hack - It's a real 5,1, although I realise I'm in the 0Sx86 section so my bad. Also realise that gtx cards aren't officially supported outside of 680 so point taken. I got chatting with one macpro+gtx970 owner who had the same artefacts in opengl extensions viewer but was aware of no other symptoms. He put it down to an app glitch. That may be the case and it may be coincidental, but he didn't game on his mac. If I didn't, I wouldn't be aware of the additional glitches either. It's my own fault but reverting to 10.11 would be a massive upheaval for me. Do you think is there any way to run El Capital graphics kexts and frameworks in 10.12? No idea if that's even logical but I'm out of ideas.
  10. 10.12.1 gtx970 macpro 4,1 gpu glitches

    Just me, huh? k. Happy Christmas, all.
  11. 10.12.1 gtx970 macpro 4,1 gpu glitches

    Same deal on 10.12.2 with official 267.15.10.25f01 and no cuda driver.
  12. Hi all, Just wondering if anyone else is experiencing the same issues as me. I run a GTX970, stock ROM, on 2009 4,1 flashed to 5,1- 3x8gb 1333 + 2x2.66 6 core. OSX 10.12.1 16B2657 with NVWD 367.15.10.15f03 + Cuda 8.0.53 I did have the same issues on 10.12.0 and 16b2555, with the appropriate nvidia driver versions. OpenGLExtensionsViewer show glitches on all tests when set to core - compatible works fine, so that means issue is specific to OpenGL 3.1 or higher, I suppose. It shows diagonal flickering distortions, and the top-left writing (gpu+display info) is cut off diagonally. The bottom right of the open GL info bar is also cut off. I have the same result with a gtx560TI that I happen to have, so that's the card ruled out. I've done a completely clean Sierra install on a blank drive with the same result, tried the card in slot1+slot2, and tried removing a pci-e->Sata card that I have. Always the same result. I can't really think of anything else to rule out other than the NV web drivers and the fact that I don't have the MacVidCards ROM, but if the drivers had issues I guess MacVidCards would have announced it on their site. Could the custom ROM make this kind of difference? I'm not really bothered about boot screens so I'd hate to buy a card or send mine to be flashed just to find out. Both of the tested cards are dual DVI though, and that's what I'm using - Might be worth mentioning. I have tried single screen on each port. Same same. I am seeing issues outside of OpenGLEV. Safari and other apps are very sluggish and I see glitches and crashes in game. Rust, for example, has no fog which, admittedly, is a pretty cool advantage. Long Dark has glitchy indoor textures and crashes (the whole machine) after a period of play. Usually under half an hour. Unfortunately I don't have an officially supported card to test with. I apologise for double posting - I have this in the osx86 section but with no interest. Any info at all is greatly appreciated.
  13. Are there global nvidia/sierra issues?

    Update: I disabled SIP blind, with the intention of testing different graphics versions. Upon restart everything was a shedload quicker. Boot time, ftp access+navigation, safari doesn't hang for 5 seconds per page now....Everything's like lightening. Graphics issue is still true, all the same.
  14. Are there global nvidia/sierra issues?

    Hi all, Not strictly an osx86 question but I figure you guys are way more likely to know. Are there global issues with 'unsupported' nvidia cards in Sierra? I run a GTX970, stock ROM, on 2009 4,1 flashed to 5,1- 3x8gb 1333 + 2x2.66 6 core. OSX 10.12.1 16B2657 with NVWD 367.15.10.15f03 + Cuda 8.0.53 I did have the same issues on 10.12.0 and 16b2555, with the appropriate nvidia driver versions. OpenGLExtensionsViewer show glitches on all tests when set to core - compatible works fine, so that means issue is specific to OpenGL 3.1 or higher, I suppose. It shows diagonal flickering distortions, and the top-left writing (gpu+display info) is cut off diagonally. The bottom right of the open GL info bar is also cut off. I have the same result with a gtx560TI that I happen to have, so that's the card ruled out. I've done a completely clean Sierra install on a blank drive with the same result, tried the card in slot1+slot2, and tried removing a pci-e->Sata card that I have. Always the same result. I can't really think of anything else to rule out other than the NV web drivers and the fact that I don't have the MacVidCards ROM, but if the drivers had issues I guess MacVidCards would have announced it on their site. Could the custom ROM make this kind of difference? I'm not really bothered about boot screens so I'd hate to buy a card or send mine to be flashed just to find out. Both of the tested cards are dual DVI though, and that's what I'm using - Might be worth mentioning. I have tried single screen on each port. Same same. I am seeing issues outside of OpenGLEV. Safari and other apps are very sluggish and I see glitches and crashes in game. Rust, for example, has no fog which, admittedly, is a pretty cool advantage. Long Dark has glitchy indoor textures and crashes (the whole machine) after a period of play. Usually under half an hour. Unfortunately I don't have a 8800/120/680 to test with. Putting it out there. Any info is much appreciated.
  15. nv_disable=1 not longer working with 10.12.1

    Nvidia released 367.15.10.15f03 tonight, which seems to be compatible with 10.12.1 (16b2657). I don't see it on Nvidia's website, but Nvidia WebDriver Updater 1.5 picked it up. OSX Nvidia Driver Manager may pick it up too. Not sure. I'm having glitches and minor issues with it, just as I was on 10.12.0 although, broadly speaking, it works... A quick and easy check is to run the basic test in OpenGLExtensionsViewer. If 'core' is selected rather than 'compatibility' I get glitches. Everything in the OS looks perfect so far, but I am getting no fog in Rust and flickering shadows and occasional crashes in The Long Dark, for example. Can any genuine mac pro w/ gtx card (excluding apple-supported) owners confirm the same? Edit: Derwolf - we're in the wrong place. Feel free to PM me.
×