Jump to content

Asxetos

Members
  • Content Count

    19
  • Joined

  • Last visited

About Asxetos

  • Rank
    InsanelyMac Protégé
  1. Asxetos

    Unlocker

    FYI 2, the code for downloading tools needs improovement. The darwinPre15.iso downloaded is just a duplicate darwin.iso, giving you problems when trying to install tools in i.e. Yosemite.
  2. Hi everyone, Looking for any guides - pointers on installing Sierra with Enoch (not Clover) on a Lenovo T460 Skylake laptop (DVMT patching etc). Any examples on similar hardware with Enoch? Thanks...
  3. @ ErmaC, Micky1979, anyone. Could you guys post some pointers for usb creation - install - post install for Sierra on a late hardware laptop? Seems like the whole world has moved to Clover and you guys are the only ones still doing actual work on this. The latest info on Chameleon i find all over the net covers up to Yosemite and on 3-4 generations older hardware. No info if later hardware is supported and how (pure Uefi, skylake, IntelHD, DVMT patching, etc). Even Pandora feels poor when it comes to Chameleon (perhaps it's me). Thanks...
  4. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    The new power management and backlight control methods are not completely clear to me, so please clarify these: Does the X86Platform injector kext need to be modified for each cpu option (i7-6600u in my case), or is it ready for all 4 cpu options? Is the new backlight control method generic and applies to all possible lcd's (after creating custom T460 kext with the script provided of course), or does the setup need some tuning per lcd type (ie edid injection or more is needed)? Any way, great work tluck, thanks...
  5. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Are these values from a real mac or did you generate them the usual way? +1 on the same question. iMessage and Facetime will drive me nuts...
  6. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    FYI only, Just updated to Sierra 10.12.3, no issues except the ethernet that appeared "inactive" after reboot. It was easily fixed by deleting all network interfaces and reassigning them. Thanks for this tluck...
  7. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    No. I do not mount the ESP on boot, but I did notice this behaviour myself. Those issues, the nvram.plist location and the black lcd on boot (I can swear I've seen the black lcd issue from cold boot also) are totally erratic. I did a few boots -reboots today to check and nvram.plist sticked in the ESP. PS. How the f**k can we make the power button work (i.e. shutdown the laptop???)
  8. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Same behaviour. Lcd is black on reboot until nvram backlight setting is applied (before the login window, I can see the brightness change). Then the lcd comes on and I can see the rest of the boot progress. One more annoying behaviour is that some times the press key bla-bla (if you want to press F1 or F12 for setup or boot menu) is not displayed from cold start. No way to get to setup for example until you reboot. Of course I guess this has nothing to do with OSX.
  9. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Not the most practical but what can you do. It's a hackintosh not a Mac...
  10. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    I am not a hakintosh expert, i just read around that osx cpu control is more "complete" when smbios definition matches the actual cpu. It makes sence. (I know the only user visible difference if any, will be in the logs...)
  11. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    A couple of minor issues i need help with, 1. Some times when i shut down from OSX, T460 restarts. 2. If last shutdown was from OSX and i remove the power plug from the T460, it powers on. How would i go about troubleshooting these? Thanks and happy new year everyone... PS. I wanted to try a Skylake SMBIOS definition. But with the old USB_Injector.kext version used here some internal ports stop working. They only work if MacBookPro11,1 SMBIOS is used (ex. the M2 bluetooth port). Solution: Update USBInjectAll.kext to latest version from Rehabmans repo, and delete SSDT-XHC-T460.aml. Now everything is working with a Skylake SMBIOS (tested MacBook9,1, will test MacBookPro13,1).
  12. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Thanks, i figured the nvram yesterday, reverted clover to v3911 (via installer) and then replaced the binaries. This way nvram works. I will check the new zip today. Great work!
  13. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Ok I just discovered my NVRAM is not working. EmuVariableUefi-64.efi is there, but nvram values (i manually enter the myvar=test to check) are not retained. Of course that includes backlight level etc. Any thoughts?
  14. Asxetos

    [GUIDE] Lenovo T460 macOS with Clover

    Thanks mangyvr, I went crazy yesterday digging around the forums for a solution and finally figured the same thing. ( https://www.tonymacx86.com/threads/intel-hd520-on-toshiba-satellite-pro-a50-c.205886/#post-1359911 ) Clover could not patch the AppleIntelSKLGraphics because it was not loading. Well, as you said, success!!! PS. Why rename the aml?
×