Jump to content
InsanelyMac Forum

dpgowan

Members
  • Content count

    15
  • Joined

  • Last visited

About dpgowan

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Not Telling
  1. I swapped for an AMD GPU due to some other Nvidia related errors (FXF RX 580) but it has its own sleep problems with an issue in the AMD9500Controller.kext that I am still working on. No need for a SSDT-USB.aml any longer as USBInjectAll.kext can be configured via Clover to not inject ports with an argument on boot. [Clover Configuratior] Boot / Custom Flags Copy and Paste the following into "Custom Flags" uia_exclude=HS01;HS02;HS11;SS01;SS02;SS03;SS04;SS07;SS08;SS09;SS10 [Clover Configuratior] Kernel and Kext Patches / KextsToPatch Set "AppleUSBXHCIPCI - Change 15 Port Limit" to "Disable" The ports "HS01;HS02;HS11;SS01;SS02;SS03;SS04;SS07;SS08;SS09;SS10" are what did not populate in IORegistry when I tested every port on the MB which incidentally enough ended up under the 15 port threshold for macOS. However I need someone to test the USB-C port in the back to see if it still works and report back with the port number to adjust. See if that works for you. Edit: On another note I manage to get sleep wake to somewhat work for a couple hours on the GTX 1060 using DarkWake=2 but if it slept more than two hours I was back to square one.
  2. Yikes! Updates: Perhaps a conflict with the FakeSMC.kext thats on my EFI? Managed to remove the kext's installed by your installer to get back in and will systematically include them with the rest of my kexts on the EFI drive to see if the problem still occurs. It is definitely "GeforceSensor.kext
  3. Hmmm, I see the same issue with my 1060 along with the provided animation but the UI is hardly effected on my end, sometimes once or twice I got glitches or artifacts randomly like with the Ginnie effect in the dock.
  4. Updated my BIOS to v0606, Nvidia Web Driver to 137.10.10.10.103/104 and I was able to successfully disable CSM. Primary Display = PCIE is still required to get my bios to get past post when multiple monitors are set up. I am going to test out the latest Nvidia Web Graphics kexts to see if any sleep issues have been fixed.
  5. dpgowan

    T2 Chip, bad news for Hackintosh?

    I wonder how this will fair for performance though, and the possibility of it becoming a required component in the future for specific features. Point made; do all kexts operate on the same level within the OS? As in are there system kexts that operate differently and on a higher security level than those for hardware components that may possibly be impacted by the absence of something like the T2 Chip? Or would that be a kernel level operation? Sent from my iPhone using Tapatalk
  6. dpgowan

    T2 Chip, bad news for Hackintosh?

    My worry is the bit about boot encryption to confirm the authenticity of the machine...sounds a lot like proprietary locks meant to keep people from building a Hackintosh or modify the machine. https://www.google.com/amp/appleinsider.com/articles/17/12/12/imac-pro-debuts-custom-apple-t2-chip-to-handle-secure-boot-password-encryption-more/amp/ Also I wouldn’t say Apple “supports Hackintosh” as the very concept violates Apples terms for its Operating System. They disable the use of third party kexts by default, we bypass this in order to make a Hackintosh work. Sent from my iPhone using Tapatalk
  7. https://www.macworld.com/article/3245764/macs/the-t2-chip-makes-the-imac-pro-the-start-of-a-mac-revolution.html Been reading up on the new T2 chip and how it manages crucial processes such as the system boot, encryption, and Internal storage management. What dose this say for the future of Hackintosh?
  8. This is still an issue, I am betting it’s an bug in the official Nvidia Web Driver. I am still unable to boot with multi-monitors while CSM is disabled though so it may be my 1060 6GB SSC + Z370-E seeing as I am also unable to get into BIOS while I have more than one monitor connected. I just updated my bios to the latest version and will be running some test in the next few days to see what has changed. Sent from my iPhone using Tapatalk
  9. dpgowan

    z370-g / 1080Ti Dual monitor boot issue

    Test to see if your card is reading the other monitor after booting with only one plugged in by hot swapping it after boot. If your Hack reads the second monitor after boot then its probably a BIOS configuration issue. I had to set Boot -> CSM to Enabled in the BIOS contrary to Glasgood's guide to get my Hack to boot with multi-monitor support on my Z370-E. You'll suffer form lower resolution in Clover but it should allow you to boot while more than one port is plugged in. However on my 1060 6GB SSC I have issues with multi-displays after sleep and occasionally on full reboot which require me to unplug all ports but the DVI-D and disconnect the power source for about 15 seconds to cycle down the mother board as it holds a charge (again seems more like a BIOS issue with my card than a Hack issue).
  10. DSDT Works great, still no solution to the Nvidia issues. I will look around other communities to see if anyone else has made any headway but it looks to be unanimous that the Nvidia Web Drivers being in Beta still have some faults. Thank you for your support!
  11. Greetings! I've been wrestling with this build for about a week now and have it near golden, but I am struggling with the Nvidia graphics card; I purchased the GeForce Gtx 1060 6GB SSC because is was recommended as the go-to card by the TonyMacx86 community on all of their Customac builds, but there doesn't seem to be much support for the card itself. I understand that Nvidia web drivers are relatively new and come with their own issues but I am reaching out to see if anyone has managed to squash these bugs. THE BUILD Asus ROG STRIX Z370-E Intel Core i7-8700k EVGA Nvidia GeForce GTX 1060 6GB SSC (3) Elite Display E221 (3 Display Port) THE SETUP The setup is based on Glasgood's build with the following alterations: BIOS SettingsPRIMARY DISPLAY = PCIE Clover Kexts Installed to EFI/Clover/Kexts/Other Lilu.kext 1.2.1 NvidiaGraphicsFixUp.kext 1.2.1 DSDT Z370-F (Near identical board to the Z370-E with the exception of the WIFI M.2, but I use a native apple wifi/bluetooth PCI-E card) Custom DSDT by @MaLd0n System Drivers Nvidia Web Driver 378.10.10.10.25.102 (17C88) 378.10.10.10.25.103 (17C89) 378.10.10.10.25.104 (17C205) Nvidia CUDA387.99 ISSUES [FIXED] System wont boot into GUI while multiple monitors are connected SOLUTION [bIOS] Update to v0606 [macOS] Update Nvidia Web Driver to 378.10.10.10.25.103 (17C89) [FIXED] Glitching and Artifacts during system utilization, randomly SOLUTION See Issue 1 [bUG] Glitching and Artifacts when waking from sleep while one monitor is in use. WORKAROUNDS Turn the monitor OFF and then back ON again Log out and back in again (use the keyboard shortcut "Shift + Opt + Cmd + Q") [bUG] Black screens when waking from sleep while multiple monitors are in use; no recovery. NO SOLUTION [FIXED] Stuck at BIOS loading screen when booting up while multiple monitors are in use; no recovery. SOLUTION [bIOS] PRIMARY DISPLAY = PCIE [bUG] RehabMan's FakeSMC_GPUSensors.kext is not reporting correctly (static/maxed values) NO SOLUTION ATTEMPTS MADE, NO SOLUTION Custom DSDT Disable Hibernate sudo pmset -a hibernatemode 0 sudo rm /private/var/vm/sleepimage sudo touch /private/var/vm/sleepimage sudo chflags uchg /private/var/vm/sleepimage Updated to the latest version of macOS10.13.2 (17C205) Updated to the latest kexts NvidiaGraphicsFixUp.kext v1.2.1 Lilu.kext v1.2.1 Updated to the latest version of Nvidia Web Driver & Cuda Driver104 (17C205) config.plist.zip
  12. I can confirm that the fix I needed to get a multi-display setup to work on boot was in fact to set CSM to ENABLED in BIOS along with the Lilu/NvidiaGraphicsFixUp kext combination on my Z370-E. See this post for more information.
  13. There are a couple of factors to consider with PCIE_x1 slots, try to place it on the first (PCIE1_1) slot available. If you are not running a custom DSDT or patched config.plist some of the other PCIE slots wont be recognized MacOS. Sometimes it also helpts to make sure its seated in the PCIE slot correctly, these cards don't always set so easily. The one I got needs a little extra push to set the front side of the pins into the slot. Even then sometimes I have to reboot to get it to recognize both WIFI and Bluetooth.
  14. Great guide! I have a similar build that I have near perfect working condition. Has anyone had any luck with the Pascal Multi-Display issues? I am running a triple monitor setup, currently I can only boot with one monitor connected and have to connect the other monitors afterwords. Currently using the Lilu/NvidiaGraphicsFixUp fix, Z370-F DSDT (near identical board, no solutions for the Z370-E that I could find).
×