Jump to content

msb

Members
  • Content count

    15
  • Joined

  • Last visited

  1. I was having the same problem while using MyHack method installing Mountain Lion getting black screen trying booting from my USB stick. The following is my fix based on my Gigabyte motherboard EP45-UD3R. Using champlist I saw my graphic resolution was set at 1024x768x32 and I change to my Lion default to 1600x1200x32 then copy my lion DSDT to USB stick in Extra and reboot and the black screen has gone. Right I a installing Mountain Lion in another partition. Hope this help.
  2. My EP45-UD3R Snow Leopard simple Guide using Cartri 0.8 bios running 10.6.4 with only 2 kext fakesmc , IOAHCIBlockStorageInjector.kext and no more LegacyHDA kext or No need for DSDT.aml. don't forget to donate to Cartri if you use this method. Also no more com.apple.Boot.plist and SMBIOS.plist because I am using a pre-release Chameleon RC5 build r168 bootloader from Cartri website modified specific for Cartri bios. 1- Install Cartri Gigabyte Mac Edition BIOS 0.8 follow his guide to the T. Here cartri.net 2- Boot into USB flash to install Mac OSX 10.6 retail. Use guide from Blackosx or this d00m42 to create this. 3- After successful installation of 10.6 now install 10.6.4 update combo. Use migration assistance to copy all your setups but do not select option copy files and folders do this latter when you are already into 10.6.4 system. 4- If you are installing 10.6.4 from scratch then you don't need to use migration assistance. But you need to know how to install bootloader then go blackosx or this d00m42 guide for more information. I would like to thanks blaclosx d00m42 for their guides and Cartri for his bios projects. I would not have done this without their contribution. msb
  3. My EP45-UD3R Snow Leopard simple Guide using Cartri 0.8 bios running 10.6.4 with only 3 kext fakesmc , IOAHCIBlockStorageInjector.kext and LegacyHDA kext or No need for DSDT.aml. don't forget to donate to Cartri if you use this method. Also no more com.apple.Boot.plist and SMBIOS.plist because I am using a pre-release Chameleon RC5 build r168 bootloader from Cartri website modified specific for Cartri bios. 1- Install Cartri Gigabyte Mac Edition BIOS 0.8 follow his guide to the T. Here cartri.net 2- Boot into USB flash to install Mac OSX 10.6 retail. Use guide from Blackosx or this d00m42 to create this. 3- After successful installation of 10.6 now install 10.6.4 update combo. Use migration assistance to copy all your setups but do not select option copy files and folders do this latter when you are already into 10.6.4 system. 4- If you are installing 10.6.4 from scratch then you don't need to use migration assistance. But you need to know how to install bootloader then go blackosx or this d00m42 guide for more information. I would like to thanks blaclosx d00m42 for their guides and Cartri for his bios projects. I would not have done this without their contribution. msb
  4. for Core 2 Quad: <key>entriesToAdd</key> <dict> <key>cpu-type</key> <data>AQU=0105</data> </dict> Then place CPUInjector.kext to /Extra/Extensions Also you could try this: thanks goes to DigitalDJ Hope it helps, and sorry my english Thanks THX The CPUInjector.kext to /Extra/Extensions works very well.
  5. Can somebody help me fix this small problem Getting Snow Leopard to recognize My CPU, mine shows "Unknown" I've tried to play with SMBIOS.plist but with no luck.
  6. A you telling me the mkext is not needed in this situation?, also how did you define the kernal flags in com.apple.boot.plist between blank in 10.5 and in 10.6 using "arch=i386"?. I would appreciate your reply.
  7. Thanks for the tip but where is your Extensions.mkext for 10.5 and 10.6 ?
  8. In relate to wake up from sleep this function was working fine before I went full DSDT using your own extensions, I don't know what has change that prevent to stop working.
  9. I think I will try to do more test to find the right combination of LegacyHDA.kexts 's. My DSDT's was patch with ALC889A and in case of LegacyHDA.kexts I did not use yours, I new you are using ALC888 so I picked up from another guide because he has the same MB like mine.
  10. No I have not chacked yet because I don't have external speakers yet. I'll get new and then check. But why I can't select anything? while in 10.5.7 I had that option. Also I just found out my machine does not comes up from sleep after moving network, graphics and audio to dsdt. Any ideas? also one of things I found out I don't need to apply SATA fix only USB needs fix, but when I try use your documented fix I get errors. USB High-Speed Bus: Host Controller Location: Expansion Slot Host Controller Driver: AppleUSBEHCI PCI Device ID: 0x3a3c PCI Revision ID: 0x0000 PCI Vendor ID: 0x8086 Bus Number: 0xfa
  11. Hi everyone I hope somebody would help resolve this problem. I have followed every step from this guide but I noticed the following when I moved to 10.6 and 10.6.1. For your info I have never get any KP for the last 7 days. I have compile a dsdt for my MB (EP45-UD3R V1.1) with network, graphic card and audio following your guide. I have no problem with network but audio(in system preferences selection) and graphic card(not sure this a problem or not). see below for more info. I also remove device property from boot.com. Leopard 10.5.7 nVidia GeForce 8800 GT: Chipset Model: nVidia GeForce 8800 GT Type: Display Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 512 MB Vendor: NVIDIA (0x10de) Device ID: 0x0611 Revision ID: 0x00a2 ROM Revision: nVidia GeForce 8800 GT OpenGL Engine [EFI] Displays: L206W: Resolution: 1680 x 1050 @ 60 Hz Depth: 32-Bit Color Core Image: Hardware Accelerated Main Display: Yes Mirror: Off Online: Yes Quartz Extreme: Supported Rotation: Supported Display Connector: Status: No Display Connected Snow Leopard 10.6.1 nVidia GeForce 8800 GT: Chipset Model: nVidia GeForce 8800 GT Type: GPU Bus: PCIe Slot: PCI PCIe Lane Width: x16 VRAM (Total): 512 MB Vendor: NVIDIA (0x10de) Device ID: 0x0611 Revision ID: 0x00a2 ROM Revision: nVidia GeForce 8800 GT OpenGL Engine Displays: L206W: Resolution: 1680 x 1050 @ 60 Hz Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Rotation: Supported Display Connector: Status: No Display Connected Any ideas why core image and Quarts Extreme does not show up? Intel High Definition Audio: Device ID: 0x1458A002 Audio ID: 889 Available Devices: Line Out: Connection: 1/8-Inch Jack External Microphone: Connection: 1/8-Inch Jack External Microphone: Connection: 1/8-Inch Jack Headphone: Connection: 1/8-Inch Jack S/P-DIF Out: Connection: Combo S/P-DIF In: Connection: Combo If you go to system preferences to select sound effects nothing to select any ideas?
  12. I would like to thanks Blackosx for snow Leopard guide and i would like to report a successful 10.6 retail installation including 10.6.1 update with the following hardware: Install method: Using Chameleon v2 RC3 r658 bootable USB thumb drive containing Mac OS X 10.6 including my own DSDT.aml. Fresh install of 10.6 this made build in network and audio to works including pci network card. I tried with upgrade from 10.5.7 to 10.6 and audio works and built in network did not. Hardware configuration: GA-EP43-UD3R, BIOS F6 Intel Core2 Duo Q9400 @ 2.67GHz nVidia GeForce 8800 GT, 512GB VRAM (running as 8800 GT via EFI string in boot.plist and DSDT patch too) 4GB DDR2 1066MHz Kingston I used different methodes to compile a working DSDT for my hardware but I am waiting to include audio and Video later.Tomorrow I will start to install Windows 7. I found out that you can't install 10.6 in port1 partition only port0, then I use carbon cloner to copy to port1 partition and use p12 to switch. I have chameleon1 in port0 10.5.7 and Chameleon 2 in port1 10.6.1. I would like to thank blackosx again for his best guide. Marthad
  13. First I would like to thank blackosx for his guide. Let me explain my situation right now. I have 2 500GB SATA drives, the 1st drive (0) one used for Leopard 10.5.7 works fine with DSDT but no build-in ethernet or sound working, partition as specified in the guide step 1 with chameleon partition. Then I decided to install 10.6 in a 2nd hard disk (1) same partition as 1st one but with chameleon 10.6.I finish to install 10.6 in the second drive but when and use Pf12 to switch to 2nd drive but I get 'Can't find Mach_kernel' while selecting Snow Leopard partition. Can somebody tell what I am missing? If I use boocd I have no problem booting to Snow Leopard. It seems I am having a problem with Chameleon 10.6 partition. for other information I did copy boot from chameleon v2 RC3 r658 to chameleon 10.6 partition. My setup: GA-EP45-UD3R PALIN 8800GT 512 Q9400 ethernet pci card 4 GB memory
  14. Hi Everyone and lots of thanks to blackosx, I've tried many guides and yours was the best and works with the above setup: running 10.5.7 Gigabyte EP45-UD3R( Greenbech shows as MacPro3,1) Processor: 2.67 GHz Quad Core Q9400 ( could not be able to fix the Unknown cpu. Tried changing in SMBIOS and also in System/Library/CoreServices/Resources/English.iproj fiel AppleSysteminfo.string with no luck. 4GB Kingstons 8500C5(1066MHz but it's still showing 800MHz). Tried to change the SMBIOS file with no luck. I still have no sound DS3 motherboard is using ALC888 codec while UD3R is using ALC889A and I am still looking for best solution. I am using External LAN using D-link PCI card DFE-528TX and it works very well. Right now I am going to start from scratch again installing 10.5.7 then move to 10.5.8 and finally to 10.6. Thanks again. msbhttp://www.insanelymac.com/forum/style_emoticons/default/biggrin.gif
×