Jump to content

TrustAugustus

Members
  • Content Count

    46
  • Joined

  • Last visited

About TrustAugustus

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

1,050 profile views
  1. Hi guys. I am asking for help patching my battery. The DSDT does not contain an embedded controller. Usually this would mean using the appropriate kext and voila finished. But no luck this time. I got some info here: "Take a look at your IOreg: BAT1 data are wrongly set, _BIX & _BST are not returning the correct values. In your Battery Status all data are 0xffffffff, which means null, they are not updated. Even _BIX is suffering the same problem. Your ACPI uses _SAN.RQST method to retrieve that information: Store (^^_SAN.RQST (0x02, 0x03, One, Zero, One), Local0) You should have to debug that part of the ACPI, paying attention to Local0 (try with rehabman's ACPIDebug) and its size should be 0x10 (for _BST) otherwise the statement "ElseIf (LEqual (SizeOf (Local0), 0x10))" cannot be executed and your battery data are wrong. The same for _BIX: in that case the Local0's bytes must be 0x77. In both cases Local0 is a record filled with all necessary battery data." I'd really, really appreciate it if someone can help or create a patch for working battery status. Ill buy you a coffee! debug-TrustAugustus.zip
  2. TrustAugustus

    HDMI with 1070

    I had the same issue with my 1060, except I was using DP. If the display would go to sleep I would lose connection and only a hotplug of the DP cable to the PC would solve the issue. I thought it was a problem with my monitor (it worked in windows) but the problem is with NVIDIA drivers. I recommend updating to 10.13.4 and using the latest stable drivers. The issue FINALLY resolved itself with my z270N gaming 5 mini itx board and GTX1060. If that doesn't help, make sure you have hdmi audio set up correctly. It can help with connection issues. Good luck!
  3. TrustAugustus

    Kernel Panic after Upgrading to High Sierra

    Great news. Making sure your lilu/intelgraphicis/nvidia kexts are updated solves a lot of problems for many people. I had the same problem where I had installed the kext and only updated the clover kexts folder. Please mark thread as [solved]
  4. Do you have the appropriate hfs+ or apfs driver in your clover folder?
  5. Are you using HDMI or DP? Also, what is your clover profile? Until recently Macs did not support 4k over hdmi
  6. I am not sure what how I did it. But following this guide and the others, I have bluetooth working in BIOS on the z270n gaming 5 along with CLOVER macOS High Sierra and Windows 10. Amazing. I did replace the wifi bt card with a legit Apple one and adapter. Thanks!
  7. Thanks MaLd0n. I appreciate what you are doing for everyone. The DSDT and/or clover you provided me doesn't seem to work. I get panics (and a weird Don't steal macOS). I've went back to mine for the time being. Thanks!
  8. TrustAugustus

    can't get my 1050Ti to work

    Are you upgrading or installing?
  9. TrustAugustus

    External SSD (APFS) won't boot! Help!

    Did you increase USB port limit for High Sierra in clover?
  10. I had this error too. I for the life of me couldn't figure it out. By any chance did you have multiple partitions with different OSes on the same drive? I tried reformating in windows with multiple tools. But I kept getting errors in the installer as well (after giving up trying to update). I followed this guide to use disk utility to reformat.
  11. TrustAugustus

    GA-Z270N Gaming 5 - Sleep issues

    Lol. Robots. So unpredictable. I deleted the "darkwake" in plist editor. The default setting is just "darkwake" It could be just a placeholder. Anyway. Ill keep tinkering with it. Cheers, man!
  12. You probably don't need to fake anything. You're running skylake, right?
  13. TrustAugustus

    Black screen after upgrade

    You need need to upgrade to the latest Nvidia drivers. You might not be able to get it. So here's what might work. At boot, go to the clover settings, disable "Allow untested kexts". This will boot the default OSx driver which looks awful. Install the Nvidia web drivers that matches your Build Number. Reboot. Edit: I apologize. I see you fixed your problem on your own. Nicely done!
  14. You probably need to update your IntelGraphicsFixup kext and Lilu.
  15. TrustAugustus

    GA-Z270N Gaming 5 - Sleep issues

    No go. It's probably something with the nvidia 1060. I'll keep at it.
×