Jump to content

xorg

Members
  • Content count

    15
  • Joined

  • Last visited

About xorg

  • Rank
    InsanelyMac Protégé

Contact Methods

  • Skype
    iamkaustavthakur

Profile Information

  • Gender
    Male
  • Location
    India

Recent Profile Visitors

1,163 profile views
  1. Hey try the steps as I wrote in my earlier post. It should work on any port.
  2. Apply patches only as needed. You don't need to apply too many patches if your system is up and running!!
  3. You should not have deleted the bluetooth kexts. Most people misunderstand the problem of "Bluetooth.........Transport successfully connected" error and delete bluetooth kexts. Maybe you can try this: Boot into single user mode using flags -v -f -s Make a folder named Backup and move all the graphics related kexts from /System/Library/Extensions to the Backup folder using the following command: fsck -fy mount -uw / mkdir Backup cd /System/Library/Extensions mv -f ATI* AMD* NVD* GeForce* AppleIntelHD* AppleIntelFramebuffer* AppleIntelSNB* /Backup touch /System/Library/Extensions reboot Now this should help you to go to the installer screen. But remember you might not get native/full resolution and acceleration. Once you install the OS X successfully, then you can restore the proper kexts needed and do the necessary dsdt and kext patching.
  4. xorg

    Install problem - Kernel panic,

    Ok. Good. I was too feeling like you when I started to build my first Hackintosh. But I kept on trying and after 3 sleepless nights I finally have it working on my Lenovo G570 notebook with full acceleration. I have installed FCP X, XCode, Logic Pro.... All are working! The journey was great and now I have got addicted to building hackintosh on my notebooks and PCs of my friends!!! Next I will try it on my AMD PC.
  5. xorg

    Install problem - Kernel panic,

    As Jithin said, this may be a problem with USB 3.0 port. Try plugging your USB flash drive in USB 2.0 port and it should boot fine. FakeSMC.kext is very very important file. Download the latest version of the following files: NullCPUPowerManagement.kext and FakeSMC.kext Copy them to /System/Library/Extensions on your pen drive to avoid general kernel panics. Boot with -v -f
  6. May you can try this: Boot into single user mode using flags -v -f -s Make a folder named Backup and move all the graphics related kexts from /System/Library/Extensions to the Backup folder using the following command: fsck -fy mount -uw / mkdir Backup cd /System/Library/Extensions mv -f ATI* AMD* NVD* GeForce* AppleIntelHD* AppleIntelFramebuffer* AppleIntelSNB* /Backup touch /System/Library/Extensions reboot Now this should help you to go to the installer screen using the VGA port. But remember you might not get native/full resolution and acceleration. Once you install the OS X successfully, then you can restore the proper kexts needed and do the necessary dsdt and kext patching.
  7. Update: I solved my problem after 3 sleepless nights and I'm happy!!! Happy Days for those who have eDP connector in their internal display. Now you can have full QE/CI through the VGA port!! Though my laptop has an eDP connector, I still could enable full acceleration with QE/CI on my VGA Monitor. Below is the solution no one could figure out. I am running Yosemite 10.10.2. You need the following kexts in System/Library/Extensions AppleIntelHD3000Graphics.kext AppleIntelHD3000GraphicsGA.plugin AppleIntelHD3000GraphicsGLDriver.bundle AppleIntelHD3000GraphicsVADriver.bundle AppleIntelSNBGraphicsFB.kext (patched to enable VGA and HDMI) AppleIntelSNBVA.bundle A big thank you to everyone who tried to help me!! EDIT: You also need to extract DSDT using DPCI Manager and place it in Extra folder for this to work properly
  8. Yes I have HDMI also. But do I have to patch AppleIntelSNBGraphicsFB.kext for HDMI to work or is it supported natively?
  9. Thank You Allan. I tried it. But I think it is not working because I am still getting screen flickers. I am using IGPEnabler and IGPlatformID bootflags in Chameleon. My laptop has eDP connector which does not support QE/CI but I am not using the internal display but VGA, so this should not be an issue,right? Also I have Resolution module installed for Chameleon, is this conflicting with the DSDT edit while injecting EDID? Please help. I am so confused. I can't figure out why?!!!
  10. Hey Allan Thank You man. But my device id is 0126 and I do not want dual link (1366x768). BTW what are graphics-options used for? And what is "onboard-1" under had-gfx used for? Very curious to know. Thank You
  11. Hey all, I have successfully installed Yosemite on my Lenovo G570 Core i5-2450M with Intel HD 3000. I am getting full resolution 1360x768 on my external monitor [detected] by patching AppleIntelSNBGraphics.kext. I am using Chameleon boot loader. But I am neither getting QE nor CI on my external vga monitor!!! Please help. Please someone help.
  12. xorg

    Help with HD3000 and battery

    Which boot loader are you using? Chameleon or Clover?
  13. Update 1: Hello everyone, I have successfully installed Yosemite on my laptop running at full resolution. After installation I booted into single user mode and removed or backed up all graphics kexts which turned on vga immediately. I could finish the setup and get straight to Yosemite desktop. I installed the Chameleon bootloader (my bios is legacy) with certain bootflags on mac os x partition. I am using mbr patch. Then I installed all other kexts except graphics such as ethernet, audio using patched apple hda. I extracted dsdt using dpci manager and put it in extra folder. Also used hackintosh vietnam tool to create smbios and apply other fixes like patch appleRTC. Then I fixed the app store problem by using efi studio. At last I patched appleintelsnb to enable vga and hdmi and installed the kext using kext utility. Also using resolution module from chameleon. Finally it detected my samsung syncmaster monitor which is running at 1360*768. This is my first hackintosh build,that too on a broken laptop lol. So far I am happy that my efforts and sleepless nights were indeed worth it! Some questions and doubts: I am seeing lines and artifacts, no lag though. How to fix them? Can I enable qe/ci on vga? Should I installed framebuffer kext and hd3000 kext?
  14. Yes i understand but how can i patch it without getting access to the yosemite desktop? Are there patched kexts available which can be copied to the partition using the terminal? Will HDMI work if I delete graphics kexts and boot using GraphicsEnabler=Yes -x flags?
  15. Hi everyone, I'm a newbie to this forum. I'm trying to install Yosemite on Lenovo G570 Laptop. It has following specs: InsydeH2O Bios Core i5 2450M Intel HD 3000 4 GB DDR3 1333MHz Problems are: The amd radeon discrete graphics card is damaged, so I have set it to UMA Graphic in BIOS from Switchess Graphics so that its disabled. I also deleted the amd kexts. The internal display monitor is damaged so I have only vga and hdmi available. Reached so far: Using vanilla installation method, I created a usb installer using Chameleon and retail copy of Yosemite from App Store. Used SMBios of MacBookPro 8,1. No Graphics Bootflag used in Chameleon. Deleted amd kexts. Deleted LPC Sensors from FakeSmc.kext. Used NullCPUPowerManagement.kext Got stuck at Transport Connected successfully while using VGA monitor. So I connected my laptop to my TV using HDMI which got me to the installer screen at full resolution. This enabled me to install Yosemite successfully. Then I copied fakesmc and NullCPUPowerManagement from the usb to my mac os x partition using terminal. But now I can't get to the yosemite desktop, not even using HDMI. VGA and HDMI both are not working. Note I can get access to the terminal still if I boot into the usb installer. I am feeling helpless. I want to develop ios apps using this hackintosh build. Is there a way to get to the yosemite desktop using vga or hdmi. Only after I can get to the Yosemite desktop, I can then edit kexts and dsdt to enable vga. Please help. Thank You.
×