Jump to content

JochiePiet

Members
  • Content Count

    40
  • Joined

  • Last visited

About JochiePiet

  • Rank
    InsanelyMac Protégé
  1. Hi, I have recently installed Mojave. Went flawlessly. Then I upgraded to Catalina 10.15.1. Went almost flawlessly as well. The only problem I have detected so far is a problem with the sleep/wake cycle. It is possible to let the computer fall asleep, but no wake up then. Hard reset required. In the process of investigating I discovered that it is impossible to safe boot into safe mode. So I downgraded to Mojave, only to discover that the safe boot problem wast there too. These are my specs: Motherboard Gigabyte GA H77 D3H rev 2.0 MacOS Catalina Version 10.15.1 (Build 19B88) Kernel Darwin 19.0.0 x86_64 RAM 4.00 GB Model Identifier iMac14,2 CPU Intel(R) Core(TM) i3-3225 CPU @ 3.30GHz Intel Generation Ivy Bridge This is the output I get trying to boot with Clover and the bootflags: -v -x (I have also tried -v -x -f and UseKernelCache=no): Thank you so much in advance!
  2. JochiePiet

    No wake-up from sleep

    Thank you for your answer. here is the output of pmset -q: System-wide power settings: Currently in use: hibernatemode 0 womp 1 networkoversleep 0 sleep 15 (sleep prevented by mds_stores) Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage disksleep 10 displaysleep 10 So to me this looks all-right. Although I do not get the phrase " sleep prevented by mds_stores". Looked for it on the Internet. Seems to be connected to Spotlight. My system seems to go to sleep so I still do not get it. I have checked /var/vm: no sleepimage.
  3. JochiePiet

    No wake-up from sleep

    Hi, I have upgraded from Mojave to Catalina 10.15.1. It went almost flawlessly. The only issue is the computer not waking up from sleep. Just a grey screen. Hard reset is required. Of course I have been searching the Internet but to no avail. The sleep-awake cycle did work on Mojave. I have noted that it is now impossible to boot in save mode. Trying to do so produces the message: " error loading kernel (0xe)" . Since I use Clover I have tried the bootflags -f en UseCache=no (in addition to -v en -x) . I wonder if the last one is a Clover bootflag? Here are my specs: Motherboard Gigabyte GA H77 D3H rev 2.0 MacOS Catalina Version 10.15.1 (Build 19B88) Kernel Darwin 19.0.0 x86_64 RAM 4.00 GB Model Identifier iMac14,2 CPU Intel(R) Core(TM) i3-3225 CPU @ 3.30GHz Intel Generation Ivy Bridge Any help is of course much appreciated! config.plist
  4. JochiePiet

    Cannot connect to appstore/connection failed

    For some reason everything is working again today so topic can be closed. I do no have any clue what has happened.
  5. JochiePiet

    Cannot connect to appstore/connection failed

    Thank you so much for your reply. I do not know how to check this. All I know that I have downloaded FileNVRAM.dylib in three different versions and replaced it in /Extra/Modules, repaired permissions and rebooted. No luck.
  6. A couple of months ago I finally succeeded in transforming my Medion Akoya E6221 laptop in a fully functional hackintosh (http://www.insanelymac.com/forum/topic/304259-medion-akoya-e6221/). The subject of interest in this post will be the appstore. Until last week I could connect to the appstore and download as well. Unfortunately this is not the case anymore. When I try to connect I am looking at the coloured wheel for a couple of minutes and then it sais "Cannot connect to the appstore". Sometimes it comes up with this message rightaway. In some rare cases it sais "connection failed". I am quite sure that I do not have a verification problem (I have dealt with en0, ethernetbuiltin and so at installation time a couple of monts ago). I have noticed that it sais "serial number not available" in the system overview (after clicking on "About this Mac" ). Now I am afraid that Apple has detected that I am using non-Apple hardware and has blacklisted me in some way or another. So I started reading and must have seen a zillion posts about related problems. I have tried all kinds of suggestions but no luck whatsoever. Extra information: Perhaps I have done something stupid: A friend of mine has her picture collection only on an USB stick since she got rid of her desktop in an impulse after buying an Ipad (women...). When she realized that she could not look at this collection anymore she turned to me for a solution. I am not familiar with Icloud bit I thought immediately to solve her problem by storing these pictures on the Idrive. Therefore I had to use her AppleID on my laptop. I succeeded in storing her pictures. But maybe I have caused my appstore problem myself by doing so. Anyway I need help. First of all: Why is it saying "Serialnumber not available" while there is a serial number in my smbios.plist (actually I finally put a real serial number there although that is a bit unethical, but that did not help either) Secondly: Is is possible to fool Apple in some (preferably legal) way. Thirdly: Am I on the right track in solving this problem? Thanks in advance for any help/suggestion!
  7. JochiePiet

    Medion Akoya E6221

    Finally I have succeeded in running this laptop as a MacBookPro. Partly by luck, mostly by very hard work. I have used the method described on Mackintosh.zone using the distro of Niresh for Yosemite 10.10. After installing from an USB stick I have changed the following: Installed the following kext's AppleACPIPlatform.kext version 1.3.6 AppleACPIPS2Nub.kext version unknown ApplePS2Controller.kext version 1.1.5 Removed VoodooPS2Controller.kext, VoodooPS2Keyboard.kext. VoodooPS2Mouse.kext and VoodooPS2Trackpad.kext. Repaired permissions, rebuild the cache Generated a ssdt according to the script of Pike R Alpha Did NOT use a DSDT! Smbios.plist as a MacBookPro 8,1 Used a org. chameleon.Boot.plist as attached. Rebooted and voila; Everything seems to be fine: Keyboard, mouse, trackpad, sleepmode, wifi (DWA-140 adapter, Ralink driver), appstore, audio, video and so on. Even the function keys are okay. ​ org.chameleon.Boot.plist.zip
  8. JochiePiet

    DSDT i3 2310M Sandybridge

    Well, with pure luck I have got my laptop fully functional as a MacBookPro. Everything seems to be working: mouse, keyboard, trackpad, sleepmode, wifi, audio, video, App Store, Battery indicator and so on. Even the function keys are okay. Here is what I did: 1. Ended up not using a DSDT at all. Only used a ssdt generated according to the script of Pike R Alpha. Also used a simbios.plist based on MacBookPro 8,1. 2. Replaced AppleACPIPlatform.kext by an older one (version 1.3.6) 3. Installed AppleIntelCPUPowermanagement. So no speedstep but that poses no problem to me as long as sleepmode is fine and it is. 4. Installed AppleACPIPS2Nub.kext version unknown. 5. Removed VoodooPS2Controller.kext, VoodooPS2Keyboard.kext, VoodooPS2Mouse.kext and VoodooPS2Trackpad.kext. 6. Installed ApplePS2Controller.kext version 1.1.5 Voila, after repairing permissions, rebuilding the cache and rebooting a fully functional Mackintosh. Updated OSX to 10.10.2 without any problem whatsoever.
  9. JochiePiet

    DSDT i3 2310M Sandybridge

    Okay. I understand. If I ever solve it I will let you know on this post. Thank you for all your effort.
  10. JochiePiet

    DSDT i3 2310M Sandybridge

    Here' s what I have done: - Extracted dsdt with Chameleon Wizard and used this dsdt. - Generated a ssdt with the script according to Pike R Alpha - Removed VoodooPS2Trackpad.kext AND VoodooPS2Mouse.kext - Repaired permissions and rebuild the cache - Rebooted Guess what?: - Keyboard is fine, never gets blocked/unconnected. - Mouse is fine although VoodooPS2Mouse.kext has been removed. Most likely because org.rehabman.voodoo.driver.PS2mouse is loaded (revealed bij kextstat) I found this driver in the contents of VoodooPS2Controller.kext - The trackpad is fine too!!! Although VoodooPS2Trackpad.kext has been removed. That is quite strange to me since I did not find anything loaded and referring to the trackpad. So what is going on here???? What is controlling the trackpad? BTW: Powermanagement is not working of course but that is not important right now. I have to fix this trackpad thing first.
  11. JochiePiet

    DSDT i3 2310M Sandybridge

    This post offers no solution unfortunately. Actually this does not sound like my problem. My keyboard keeps on working as long as I do not touch the trackpad. However, thanks for the suggestion!
  12. JochiePiet

    DSDT i3 2310M Sandybridge

    Thanks again for your effort. Unfortunately the problem returns right away after copy dsdt to Extra folder and reboot. Replacing the dsdt by an extracted one and rebooting causes disappearance of the problem.
  13. JochiePiet

    DSDT i3 2310M Sandybridge

    As said before I actually circumvented my problem. Did not solve it. So I have decided to spend some extra time. Finally I am pretty sure that I have isolated the problem. The problem must be caused by a faulty DSDT.aml file. The problem never occurs whatever I do until I copy the DSDT file to /Volumes/MacOSX/Extra and adapt org.chameleon.Boot.plist. Removing the DSDT and readapting org.chameleon.Boot.plist does get rid of the problem after reboot. But then the powemanagement does fail. Laptop will kind of fall asleep (power consumption remains the same) but will never wake up again. Reboot is necessary. All four kext' s: VoodooPS2Controller.kext ,VoodooPS2Keyboard.kext, VoodooPS2Trackpad.kext and VoodooPS2Mouse.kext are loaded even when the problem is not there. So it looks to me that blocking the keyboard as soon as the trackpad is once touched is not so much caused by a kext conflict but by a conflict in the DSDT file. So I would be very grateful if anyone (Allan?) will have a good look at the the attached DSDT file. The laptop specs are: Medion Akoya E6221, Intel i3 2330M SandyBridge, Intel serie 6 C200 chipset. DSDT.aml.zip
  14. JochiePiet

    DSDT i3 2310M Sandybridge

    So for the time being I have circumvented my problem by removing the mouse and trackpad kext. I will figure out how to get the trackpad working and place the final configuration (dsdt, ssdt, smbios, org,chameleon.Boot.plist and removing of the drivers) in the laptop section of this forum. I have deleted the posts which have proven not to be relevant. Special thanks to Allan for all the effort he has gone through. Thank you so much Allan!
  15. JochiePiet

    DSDT i3 2310M Sandybridge

    Absolutely no need for apologizing. I am very happy with your patience and help. Now I am back at post 42.... I removed both VoodooPS2Mouse.kext and VoodooPS2Trackpad.kext. The problem has disappeared. For the time being? Mouse is still working, trackpad is not. This appears to be in contradiction to my answer at post 42. I do not know if my answer was incorrect at post 42 of that the trackpad was indeed working at the time. Anyway we will see if the problem returns. I will let you know. FYI: In system preferences is still stated: " trackpad not found ". So I have to figure out how to fix this. In the log it talks about a Sentelics touchpad but as far as I know it is a Synaptics one.
×