Jump to content

ccx4700

Members
  • Content count

    10
  • Joined

  • Last visited

About ccx4700

  • Rank
    InsanelyMac Protégé
  1. Great tutorial! It may help many users who are using P6T Deluxe.
  2. @vailancer: Use this kext (at post #7). http://forum.insanelymac.com/index.php?sho...amp;mode=linear But only 2ch stereo output is working.
  3. @AiBear: I used retail Install method. I described how I did it at an older post. To run all cores, we must use bootloder that can loding DSDT.aml, so I installed pcefi_v9 manually. Congratulations! Your "Total Number Of Cores" string is really interesting, mine is showing 4. (even HT on) Maybe System Profiler says number of physical cores, not logical cores by HT tech. And I think Mac OS X finds Physical Processors by looking FSB, but i7 doesn't have FSB(yeah, renewed by QPI), so it shows 0. There is no evidence, just my idea. There is DSDT.aml that I'm using. For P6T deluxe. I'm not sure it works well for you, because of bios version, bios setteings. DSDT.zip
  4. ALL CORES WORKING ON P6T DELUXE!! Hey guys, I did it! First, I must apologize to THEHAWKs for my jumping conclusion. You are true, it was Alias problem. I believed that DSDT patcher deletes Alias strings automatically, but it doesn't. By deleting Alias, I can get all cores working. Not only 4 cores, I can enable HT so it works as 8 cores. So, here is a METHOD. 1. Run the DSDT Patcher to make dsdt.dsl. 2. Open a dsdt.dsl in Debug folder by nano. like: $ nano Debug/dsdt.dsl 3. Delete Alias strings. Scope (_PR) { Processor (P001, 0x01, 0x00000810, 0x06) {} Alias (P001, CPU1) Processor (P002, 0x02, 0x00000000, 0x00) {} Alias (P002, CPU2) Processor (P003, 0x03, 0x00000000, 0x00) {} Alias (P003, CPU3) Processor (P004, 0x04, 0x00000000, 0x00) {} Alias (P004, CPU4) Processor (P005, 0x05, 0x00000000, 0x00) {} Alias (P005, CPU5) Processor (P006, 0x06, 0x00000000, 0x00) {} Alias (P006, CPU6) Processor (P007, 0x07, 0x00000000, 0x00) {} Alias (P007, CPU7) Processor (P008, 0x08, 0x00000000, 0x00) {} Alias (P008, CPU8) Processor (P009, 0x09, 0x00000000, 0x00) {} Alias (P009, CPU9) Processor (P010, 0x0A, 0x00000000, 0x00) {} Processor (P011, 0x0B, 0x00000000, 0x00) {} Processor (P012, 0x0C, 0x00000000, 0x00) {} Processor (P013, 0x0D, 0x00000000, 0x00) {} Processor (P014, 0x0E, 0x00000000, 0x00) {} Processor (P015, 0x0F, 0x00000000, 0x00) {} Processor (P016, 0x10, 0x00000000, 0x00) {} } to Scope (_PR) { Processor (P001, 0x01, 0x00000810, 0x06) {} Processor (P002, 0x02, 0x00000000, 0x00) {} Processor (P003, 0x03, 0x00000000, 0x00) {} Processor (P004, 0x04, 0x00000000, 0x00) {} Processor (P005, 0x05, 0x00000000, 0x00) {} Processor (P006, 0x06, 0x00000000, 0x00) {} Processor (P007, 0x07, 0x00000000, 0x00) {} Processor (P008, 0x08, 0x00000000, 0x00) {} Processor (P009, 0x09, 0x00000000, 0x00) {} Processor (P010, 0x0A, 0x00000000, 0x00) {} Processor (P011, 0x0B, 0x00000000, 0x00) {} Processor (P012, 0x0C, 0x00000000, 0x00) {} Processor (P013, 0x0D, 0x00000000, 0x00) {} Processor (P014, 0x0E, 0x00000000, 0x00) {} Processor (P015, 0x0F, 0x00000000, 0x00) {} Processor (P016, 0x10, 0x00000000, 0x00) {} } 4. Run DSDT Patcher again on Terminal. $ ./DSDT\ Patcher Debug/dsdt.dsl 5. Rename and copy dsdt.aml to root. $ cp dsdt.aml /DSDT.aml 6. Now you can boot without cpus flag. ENJOY! Finally, I really want to say thank you to THEHAWKs, without your reply, I might not get this result.
  5. @ChipX You said "thats the only options i made", I'm curious about AppleACPIPlatform.kext what you are using. I used older one in iDeneb, so its verison is 1.0.3 (showed in Info.plist) I can't boot P6T without 1.0.3 kext. But you seemed NOT to use 1.0.3. What's your kext version? I'll very surprised if you're using vanilla AppleACPIPlatform.kext.
  6. @johnathandoe, M J, First, I prepared other PC that runs Mac OS X. (GA-P35-DS3R hackintosh) I connected SATA HDD to this PC, I followed this method: http://forum.insanelymac.com/index.php?showtopic=76404 But I didn't use custom kexts on this thread, I used Legacy@@@ kexts(to avoid orange icon), Disabler, SMBIOSEnabler, dsmos and so on. http://forum.insanelymac.com/index.php?showtopic=129279 And I booted this HDD on DS3R, and made user account. Shutdown this system, and boot main system on DS3R again. I used iDeneb 10.5.5 old AppleACPIPlatform package: "/Volumes/iDeneb v1.3 10.5.5/System/Installation/Packages/Patches/Fix/ACPI-Fix.pkg" I installed this pkg, voodoo9.5.0 kernel, pc_efi_v9 to new HDD. And I edited com.apple.Boot.plist on HDD (added flag busratio=22). You can add cpus=2, too. I didn't add cpus flag because of testing. I can boot this system on P6T deluxe with cpus=1 or cpus=2. BUT, as I said before, I cannot get CPU working 4 cores. If you can get all cores working, please tell me how did you do that. @THE HAWKs I used DSDT patcher, so It might remove "Alias". But I could get only 2 cores working... Because I'm Japanese, I'm using incorrect English. Sorry.
  7. I used retail install method to P6T Deluxe, but I could only 2 cores working. Most kexts are vanilla, but I had to use old ACPIPlatform, so I used ACPI-Fix.pkg from iDeneb10.5.5. Next, I installed voodoo 9.5.0 kernel and added busratio=20 to com.apple.boot.plist. This system can boot with cpus=1 or 2 flag, but can't boot with other cpus=x flag or without cpus flag. It reboots before verbose text start. I used other flag functions of voodoo kernel, many types of DSDT.aml(darwin, xp, -newHPET, ...) but I couldn't get good result. i7-920 with 2 cores working has better Xbench result than my Q9450. I want to make it all cores working... Does anyone have good idea? Please help. And I apologize about my poor English.
  8. ccx4700

    Fujitsu U810

    Can you use keyboard/mouse? I have U50WN that Japanese version of U810. But I can't use internal keyboard/mouse on this UMPC. What did you do for it?
  9. When you boot iAtkos DVD, use Darwin_Boot script in utilities menu bar. You can install EFI patch before installing. Darwin_Boot script needs answering Yes/No question only. So it's easy to use. I had PS/2 mouse trouble in ToH Leopard.
  10. I'm using 10.5.2 on rev2.1. Before installing EFI patch, It had kernel panic on ToH. After installing EFI, ToH works perfectly. (include software update.) I suggest using kalyway or iAtkos. I installed iAtkos on AHCI without any trouble. Do you use PS/2 device? When I use PS/2 mice, It can't boot. Use USB one.
×