Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About applehacker

  • Rank
    InsanelyMac Sage
  1. I got banned on tonyMacx86, what do I do?

    Tonymac has been cancer since day 1. The only home for Osx86 is insanelymac, been here since JaS's Tiger release lol
  2. Crossfire AMD 7970M?

    I know, but I would like to get OS X to load on internal LVDS with both cards plugged in instead of having to take one out, which requires disassembly of the whole laptop.
  3. Crossfire AMD 7970M?

    I couldn't get _OFF to work because that scope is inaccessible from crossfire mode. I did make some progress though. If I plug in my HDMI cord to my TV, it activates the laptop internal LVDS screen. If no HDMI, it remains black screen. What can I do to fix this?
  4. Crossfire AMD 7970M?

    FB is required, it is custom patched to support internal laptop LVDS
  5. Crossfire AMD 7970M?

    I have succeeded in making a single 7970M work in OS X, would it be possible to make two cards work in OSX86? Currently, even with frame buffer mod and DSDT edits, I am getting a black screen on LVDS. Would it be possible to get both cards working, or a way to disable one of the crossfire cards?
  6. [Working] ATi Mobility Radeon 7970M HD

    For now yes. HDMI output is expected to be working as well, it was working natively with Buri framebuffer so I didn't bother to edit/change it. No VGA to test and no display port to test either.
  7. [Working] ATi Mobility Radeon 7970M HD

    Guys, I've finally managed to do it. Two years (on/off) worth of testing, and I've finally managed to enable FULL dGPU ACCELERATION in OS X Mavericks for the ATi Mobility Radeon 7970M HD!!! I have something useful to contribute finally Proof: http://i57.tinypic.com/2r60jzs.png I found/decoded the correct connectors and patched the appropriate controller kext, and it works beautifully. So far, on the M17x R4, the following is working {Note: I am using Chameleon Bootloader r2380} Full CPU Support (all cores/threads) [native support] All RAM Recognized (in my case, 16GB) [native support] Intel HD 4000 Full Accleration (when set to iGPU or SG in BIOS) [patched in the DSDT] ATi Mobility Radeon 7970M Full Acceleration (When set to PEG in BIOS) [needs my patched kext] DVD/Blu ray drive (works natively) Touchpad mimicking Apple's Touchpad (works with VoodooPS2) All USB/ESATA Ports (works with correct DSDT) Webcam (works with correct DSDT) Wifi (replaced stock card with AR9280 card, recognized natively) Bluetooth (works natively) Things still need to be worked on: Audio (the flaky Recon3Di chip is not helping my case....) [probably will approach with voodooHDA, later with AppleHDA] Sleep/Wake support [needs DSDT tweaking] WORKING HDMI Output [needs connector patching in framebuffer] DP Output [needs connector patching in framebuffer] VGA Output [needs connector patching in framebuffer] AlienFX Control [no freaking clue.....] Memory card reader [will explore voodooSDXC] Additional cards may be made to work if they are donated to me to work on (talking about ATi cards, I refuse to work on nVidia) So all in all.....ITS POSSIBLE GUYS! Link to my "Extra" folder, including patched AMD kext: http://www.mediafire.com/download/vd037sda5anouur/M17x_R4_Extra.zip For those interested: Proper Framebuffer is: Buri Initial address in framebuffer: 02000000000100002905010010000505 the proper connector patch is: 02000000400000000901000010000005 M17x_R4 Extra.zip AMD7000Controller.kext.zip
  8. HD7970m and Clevo p370em

    I tried your patch, still getting blackscreen w/backlight. Very strange, even though we have exact same dumps......still not working.
  9. HD7970m and Clevo p370em

    I was actually experimenting on Yosemite
  10. HD7970m and Clevo p370em

    It might help to go on the netkas forums and ask about the color banding. Anyway, please upload the clover config.plist when you have time. I'd like to see if you have any patches or SMBIOS settings that could be giving you internel LCD
  11. HD7970m and Clevo p370em

    I've used that combination before, reported in my thread: http://www.insanelymac.com/forum/topic/298207-ati-mobility-radeon-7970m-help-achieving-qeci/ I was using this one before with no success: 02000000400000000901000010000005 It seems the only difference between your string and mine is 02000000400000000901010010000005 I will give this a try the next time i do hackintosh. Please send me your clover config.plist so I can examine. I think for the color banding problem, another user on here with a 7650M reported that using different senseID fixed his problems with banding (look up user Trucker MK)
  12. HD7970m and Clevo p370em

    Our dumps are exactly the same. What was the final connector patch that got your internal LCD working. I'm also confused, how are our dumps the same? You also have two HDMI ports, mini display port, VGA, and switchable graphics on LVDS?
  13. You may have to look at Rampage Dev's AMD 7xxx dsdt patch and apply with your card's values. some methods/values are introduced for power control, which may help for sleep, also probably may need to edit AGPM kext.
  14. ATI Mobility Radeon 7970M Help achieving QE/CI

    Here is what I have tried so far with clover patching: replaced 02000000000100002905010010000505 wtih: 02000000400000000901000010000005 No success GUI will not load. Load vBIOS enabled, custom EDID injected.
  15. Will this work with the Mobility 7970M? I tried doing this before, but it would never load the GUI/get past verbose. ID natively exists in AMD7000controller (0x6800) Dump RADEON BIOS DECODE DUMP: ATOM BIOS Rom: SubsystemVendorID: 0x1028 SubsystemID: 0x057b IOBaseAddress: 0x0000 Filename: C42904A1.117 BIOS Bootup Message: Wimbledon XT A01 MXM GDDR5 300e/150m 0.9V A1 PCI ID: 1002:6800 Connector at index 0 Type [@offset 45840]: (null) (-1055027892) Encoder [@offset 45844]: INTERNAL_UNIPHY2 (0x21) i2cid [@offset 45976]: 0x93, OSX senseid: 0x4 Connector at index 1 Type [@offset 45850]: (null) (-1055027892) Encoder [@offset 45854]: INTERNAL_UNIPHY (0x1e) i2cid [@offset 46003]: 0x94, OSX senseid: 0x5 Connector at index 2 Type [@offset 45860]: DisplayPort (10) Encoder [@offset 45864]: INTERNAL_UNIPHY1 (0x20) i2cid [@offset 46030]: 0x91, OSX senseid: 0x2 Connector at index 3 Type [@offset 45870]: HDMI-A (11) Encoder [@offset 45874]: INTERNAL_UNIPHY1 (0x20) i2cid [@offset 46057]: 0x90, OSX senseid: 0x1 Connector at index 4 Type [@offset 45880]: HDMI-A (11) Encoder [@offset 45884]: INTERNAL_UNIPHY2 (0x21) i2cid [@offset 46084]: 0x92, OSX senseid: 0x3 Connector at index 5 Type [@offset 45890]: VGA (1) Encoder [@offset 45894]: INTERNAL_KLDSCP_DAC1 (0x15) i2cid [@offset 46111]: 0x97, OSX senseid: 0x8 Redsocks BIOS DECODE Wimbledon XT A01 MXM GDDR5 300e/150m 0.9V A1 Subsystem Vendor ID: 1028 Subsystem ID: 57b Object Header Structure Size: 435 Connector Object Table Offset: 52 Router Object Table Offset: 0 Encoder Object Table Offset: 13f Display Path Table Offset: 12 Connector Object Id [22] which is [(unknown)] encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true Connector Object Id [22] which is [(unknown)] encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false Connector Object Id [19] which is [DISPLAY_PORT] encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x21 [duallink 0x1] enc 0x3)] linkb: true Connector Object Id [12] which is [HDMI_TYPE_A] encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false Connector Object Id [12] which is [HDMI_TYPE_A] encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false Connector Object Id [5] which is [VGA] encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false