Jump to content

Taptun

Members
  • Content Count

    97
  • Joined

  • Last visited

Posts posted by Taptun


  1. Taptun,

     

    My I know the specific brand and model of HD6870 you have?

    I am thinking of getting one to upgrade my Sapphire HD4870.

     

    How vanilla is this 6870? Does it works by just using graphicsenabler=Y?

     

    Cheers!

     

    On 10.7.5 framebuffer does not patch works right out of the box

    to 10.8.2, you need to patch

    The card is not reference: 2 - DVI, 1 - HDMI, 1 - big DP

    graphicsenabler = No

    It works through the DSDT

     

     

    @Taptun


  2. Hello everyone!

     

    Nice to see the thread is still going strong and is very helpful to all! I want to say a BIG THANK YOU to Taptun once again for all the fine kernels he has provided us all! There are many others here too who have been INCREDIBLY awesome people (you all know who they are), helping in big ways as often as they can.

     

    Wish me luck and pray for me as I am going in for an interview next week for an awesome wireless company called Xirrus http://www.xirrus.com (check 'em out)!

     

    Thanks again to everyone!

     

    Good luck :wink2:


  3. the last DSDT gives me "waiting for root device" and the system don't boot :(

     

    i tried to remove the device (IGPU), but there is alot of Methods that uses it

    is there any effect on sleep or something when removing !!

    if not please feel free to remove it :)

     

    thanks :)

     

    Hi

    I'm sorry ;)

    Try this one :)

    yehia Amer_3.zip


  4. hi everyone

    After updating to 10.7.4 audio is not working

    i replaced AppleHDA.kext with the patched one from taptun as usual but it don't work :(

     

    do anyone face the same problem, any solutions !!

     

     

    thanks

     

    Hi yehia Amer

    I have been using only the version of 10.6.2

    Everything works (SL , LION & ML)

    (LayoutID - 7603) :)

    AppleHDA.kext_10.6.2.zip


  5. Hi

     

    @Taptun

    Would you be able to fix my DSDT please :)

    (for MY laptop...not the one you did before (thanks again to you and Komano) which was for a friend of mine.... which was a nightmare of a thing :) ... 116 errors :( !! I should have just thrown it at a wall, at least then i would have slept)

     

    Thanks once again

     

    Macri

     

    The Laptop Config is in my signature

     

    Hi

    Try it

    macri81_2.zip


  6. Looks great yehia Amer

     

    Could you look into my DSDT and see if there is something to add to the the auto patcher? it have been updated a few times with some patches. maybe these are already in your auto patcher ;-)

     

    The only issue I have is sometimes the shut down is not working, so I need to force quit by pressing power button.

     

     

    //Peter

     

    Hi , Peter_sm

    all patched , try it

    Peter_sm.zip

    @Taptun


  7. @macri81: i have put that in the plist file already but it still doesnt work. Still get lapic error.

    Edit: ok got it, i deleted the mach_kernel at root and it worked.

     

    Now, after putting next files into /E/E, it takes ages for Mac to boot, through many loading pages. I've loaded Kext Utility to pack a mkext file but it still doesn't work.

     

    I've attached my dsdt.aml to this post. Can someone please help a look. Now, Battery, Brightness, Sound doesn't work. And when I scroll my mouse's middle button up, it goes down and vice versa.

     

    dsdt.aml.zip

     

    Hi .

    Try this DSDT

    Zell_Dinch.zip

     

    @Taptun


  8. You have already patched my DSDT but thank you for giving it another try for Brightness and HDMI audio :) .

    I'll upload them ASAP.

    UPDATE (Posted by Ubuntu 11.04 Live CD.)

    I used these commands and extracted my DSDT & SSDT:

    sudo cat /sys/firmware/acpi/tables/DSDT > DSDT.aml & sudo cat /sys/firmware/acpi/tables/SSDT > SSDT.aml.

     

    Hi!!!

    Try it DSDT+kexts

    nic.mroc.zip

    @Taptun


  9. Just got the sleep working...I was using Nawcom's 10.6.8 kernel and not Taptun's one. (Shame on me :rolleyes: !)

     

    Today I reinstalled everyhing and accidentally didn't copied the patched kernel.

    So I booted with kernel flag Cpus=1 and vanilla kernel and discovered that the sleep was working.

     

    Now with Taptun's one I have all two cores and sleep.

     

    So now I only have to get my brightness and HDMI sound to work to get a perfect install.

     

    Send me DSDT+SSDT(Linux or Windows)

    @Taptun


  10. @Taptun

     

    I was going through your DSDT edits. There certainly seem to be a lot. I saw that you shortened em, good call but i like it in the original way. xD But anyway, i was looking at the "Device (P0P2)" section. You edited the PEGP with NVIDIA Code, do you perhaps have code for ATI? :)

     

    Hi!

    DSDT code for ATI cards is very big :unsure:

    Simply use the chameleon and in boot.plist GraphicsEnabler-Yes :)

     

    You can use the short code ;)

    				Device (HDAU)
    			   {
    				   Name (_ADR, One)
    				   Method (_DSM, 4, NotSerialized)
    				   {
    					   Store (Package (0x02)
    						   {
    							   "hda-gfx", Buffer (0x0A){"onboard-1"}								
    						   }, Local0)
    					   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
    					   Return (Local0)
    				   }
    			   }
    
    			   Device (PEGP)
    			   {
    				   Name (_ADR, One)
    				   Method (_DSM, 4, NotSerialized)
    				   {
    					   Store (Package ()
    						   {
    							   "AAPL,HasPanel", 
    							   Buffer (0x04)
    							   {
    								   0x01, 0x00, 0x00, 0x00
    							   }, 
    
    							   "AAPL,Haslid", 
    							   Buffer (0x04)
    							   {
    								   0x01, 0x00, 0x00, 0x00
    							   }, 
    
    							   "AAPL,backlight-control", 
    							   Buffer (0x04)
    							   {
    								   0x01, 0x00, 0x00, 0x00
    							   }, 
    
    							   "@0,AAPL,boot-display", 
    							   Buffer (0x04)
    							   {
    								   0x01, 0x00, 0x00, 0x00
    							   }, 
    
    							   "AAPL,slot-name", 
    							   Buffer (0x06)
    							   {
    								   "PCI-1"
    							   }, 
    
    							   "@0,backlight-control", 
    							   Buffer (0x04)
    							   {
    								   0x01, 0x00, 0x00, 0x00
    							   }, 
    
    							   "@0,built-in", 
    							   Buffer (Zero) {}, 
    							   "@0,use-backlight-blanking", 
    							   Buffer (Zero) {}, 
    							   "@1,can-hot-plug", 
    							   Buffer (Zero) {}, 
    							   "model", 
    							   Buffer ()
    							   {
    								   "XXX"		<---- write the name of the card
    							   }, 
    
    							   "hda-gfx", Buffer (0x0A){"onboard-1"}
    						   }, Local0)
    					   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
    					   Return (Local0)
    				   }

     

    Try it, might need something remove

     

    @Taptun

×