Jump to content

FCU4ever

Members
  • Content Count

    43
  • Joined

  • Last visited

About FCU4ever

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

957 profile views
  1. I’ve successful installed MacOS Sierra 10.12.6 on my Asus G73SW Laptop with the following specs: - Mobile Intel HM65 Express - Intel Core I7 2630 QM 2.0 GHz - Nvidia GeForce GTX 460M 1,5gb I’ve got a lot of working but still can't control the brightness. What have I done so far: - Add "brightness fix" from Rehabman repo to my DSDT --> Brightness slider appear in Preference --> But brightness don't change when I slide the bar - Add into method label _Q0E replace_content begin // Brightness Down\n Notify(\_SB.PCI0.SBRG.PS2K, 0x0205)\n Notify(\_SB.PCI0.SBRG.PS2K, 0x0285)\n end; into method label _Q0F replace_content begin // Brightness Up\n Notify(\_SB.PCI0.SBRG.PS2K, 0x0206)\n Notify(\_SB.PCI0.SBRG.PS2K, 0x0286)\n end; to my DSDT --> with FN keys (FN+F5 and FN+F6) I can change the brightness slider --> But brightness don't change Then I tried AppleBacklightFixup.kext with SSDT-PNLF.aml --> Brightness slider dissappear in Preference Can someone help me to get the brightness control get working?
  2. I’ve successful installed MacOS Sierra 10.12.6 on my Asus G73SW Laptop with the following specs: - Mobile Intel HM65 Express - Intel Core I7 2630 QM 2.0 GHz - Nvidia GeForce GTX 460M 1,5gb I’ve got a lot of working but not the brightness control. I’ve done the following steps: - Patch DSDT with brightness fix to get the brightness slider in system preference - Patch DSDT to control the brightness with my FN keys The strange thing is that I can control the brightness bar going up and down with my FN keys but the brightness isn’t going up or down. Can someone help me to get this working?
  3. Just stay on SMBIOS10,1 and let Clover generate C-states and P-states instead of the SSDT that pike script generate?
  4. I succesfully installed MacOS Sierra 10.12.6 on my Asus G73sw laptop with the MacBookPro10,1 SMBios. My Hackintosh also work with the MacBookPro10,1 SMBios. The problem is that MacBookPro10,1 is for “Ivy Bridge” laptops and not for “Sandy Bridge” like mine. My Asus G73sw laptop has an Intel I7-2630QM processor and a Nvidia GTX460m videocard. The SMBios that comes close to my specifications is the MacBookPro8,2 SMBios. I changed the SMBios to MacBookPro8,2 with CloverConfigurator, copied the config.plist to my EFI folder and reboot -> black screen. Then I tried a few things to get the MacBookPro8,2 SMBios working: - Changed the SMBIOS to MacBookPro8,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> Apple bar won’t load - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 Reboot -> Apple bar load but get a blackscreen - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> laptop boots good So the laptop boots with the MacBookPro8,2 SMBios when I changed the productname and add a few lines to my kextToPatch. Changing the productname isn’t the right solution I think. Can someone help me to get the MacBookPro8,2 SMBios working or is it no problem to stay on MacBookPro10,1 SMBios? Even this SMBios is for Ivy Bridge laptops and not Sandy Bridge.
  5. Sorry for my very, very late reaction. Very busy the past few weeks. My device doesn't sleep with the lid close. What is the advantage to get PM and AGPM working instead of staying on SMB MBP10,1 without PM and AGPM working? See attachment for the folder. Clover.zip
  6. Thanks. See attachment Output.zip
  7. Can you tell me how I can do that?
  8. Thank you. I will wait for the files
  9. Hi, Thanks for your response. As you indicated, I will stay on SMbios MBP10,1 and edit my config.plist with CloverConfigurator to generate my C- and P-states. If I'm right I don't need an SSDT anymore? With the SMBios MBP10,1 I don't need to add 'Prevent AGDP from loading' to my kexttopatch. Is it still necessary to make a LegacyAGPM.kext? config_Test.plist
  10. I succesfully installed MacOS Sierra 10.12.6 on my Asus G73sw laptop with the MacBookPro10,1 SMBios. My Hackintosh also work with the MacBookPro10,1 SMBios. The problem is that MacBookPro10,1 is for “Ivy Bridge” laptops and not for “Sandy Bridge” like mine. Because of the MacBookPro10,1 SMBios I’m unable to generate a SSDT.aml file with ssdtPRGen.sh from Piker-Alpha (see attachment). My Asus G73sw laptop has an Intel I7-2630QM processor and a Nvidia GTX460m videocard. The SMBios that comes close to my specifications is the MacBookPro8,2 SMBios. I changed the SMBios to MacBookPro8,2 with CloverConfigurator, copied the config.plist to my EFI folder and reboot -> black screen. Then I tried a few things to get the MacBookPro8,2 SMBios working: - Changed the SMBIOS to MacBookPro8,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> Apple bar won’t load - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 Reboot -> Apple bar load but get a blackscreen - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> laptop boots good So the laptop boots with the MacBookPro8,2 SMBios when I changed the productname and add a few lines to my kextToPatch. Changing the productname isn’t the right solution I think because I’m again not able to generate a SSDT.aml. Can someone help me to get the MacBookPro8,2 SMBios working so that I can generate a correct SSDT.aml for my hackintosh
  11. I’ve succesfull installed Mac OS Sierra 10.12.6 on my Asus G73sw. Specifications: - Intel 2630QM-I7 / HM65 - Nvidia Geforce GTX460m So what is needed to install Sierra on a Asus G73sw? 1) Install Clover with Mac OS Sierra on a bootable USB 2) Copy FakeSMC.kext , USBInjectAll.kext and VoodooPS2Controller to USB\EFI\CLOVER\kexts\Other\ folder 3) Copy HFSPlus-64 , CsmVideoDxe-64 (needed full resolution in Clover) and OsxAptioFixDrv-64 to USB\EFI\CLOVER\drivers64UEFI\ folder 4) Install Mac OS Sierra After the installation you reach the desktop. FIRST install Clover with the following settings: - Installation for UEFI motherboards - Install Clover in the ESP - Drivers64UEFI -> OsxAptioFixDrv-64 - Drivers64UEFI -> CsmVideoDxe-64 - Install RC scripts on targetvolume - Install Clover preference panel Copy HFSPlus-64 to EFI/CLOVER/drivers64UEFI/ folder After that, install the following kexts with your favorite kext installer: - FakeSMC.kext -> Always needed - VoodooPS2Controller -> Needed to use your keyboard - USBInjectAll -> Needed to use USB2.0 ports - ACPIBatteryManager -> Shows batterystatus - AsusNBFnKeys -> Needed to use FN keys - AppleALC + Lilu -> Needed to get audio working - RealtekRTL8111 -> Needed to get LAN working (can’t test, LAN card defect) As last, copy the DSDT (many thanks to MaLd0n for creating the DSDT file) file to EFI/CLOVER/ACPI/PATCHED/ Reboot and see what is working: - Nvidia Geforce GTX460m -> Config.plist - Wifi -> DSDT - Audio -> DSDT + AppleALC + Lilu - USB2.0 -> USBInjectall - Batterypercentage -> DSDT - Asus FN keys -> AsusNBFnKeys And what is not working: - USB3.0 (Fresco Logic xHCI(USB3)) - Keyboard backlight - Brightness FN key - Cardreader - Bluetooth As last, I’m unable to generate a SSDT with ssdtPRGen.sh from Piker-Alpha. I’ve got the following error (see attached picture): The MacBookPro10,1 SMBios has an board-ID that is not compatible with my Sandy Bridge laptop. So I tried a few things: - Change the SMBios to MacBookPro8,2 Reboot -> Black screen - Changed the SMBIOS to MacBookPro8,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> Apple bar won’t load - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 Reboot -> Apple bar load but get a blackscreen - Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 and add the below to KextToPatch com.apple.driver.AppleGraphicsDevicePolicy BA050000 00 BA000000 00 Prevent AGDP from loading Reboot -> laptop boots good With the MacBookPro8,2 SMBIOS and the changed productname I’m still unable to generate an SSDT. So, can someone help me to: - Generate a correct SSDT - Get USB3.0 working - Get Keyboard backlight working - Get Brightness FN key working - Get Cardreader working - Get Bluetooth working USB files.zip After installation files.zip
  12. Hello, How to get my Fresco Logic USB3.0 port working on my Sierra 10.12.6 hackintosh (SMBIOS10,1)? And how to get the keyboard backlight working with the right FN keys? My specs are: - 2630QM-I7 / HM65 - Nvidia Geforce GTX460m
  13. After succesfull installing Sierra 10.12 on my Asus G73sw I experience a graphics issue with my Nvidia GTX460m graphics card. Without the Nvidiawebdrivers I can only boot with the nvdisable=1 bootflag and with the Nvidiawebdrivers installed I can boot Sierra normally untill I logged in to the system. My screen looks like {censored}, see attached picture. Can someone help me? CLOVER.zip
  14. After finally successfull installing macOS High Sierra 10.13.6 on my Asus G73sw, with I7-2630QM (2nd gen) CPU / HM65 chipset and nVidia GTX460m, I can’t login after installing the nVidia webdrivers. What have I done so far. After successfull installing High Sierra I first Installed Clover with AFPS.efi and OSXaptiofixdrv.efi. Then I edited the config.plist I used to install High Sierra. In the edited config.plist I’ve unchecked nv_disabled=1 and Inject intel and checked nvda_drv=1 and Inject NvidiaWeb. The SMBios I used is MacbookPro8,2 with a changed product name to iMac13,2. After editing I copied the config.plist to the EFI partition. Then I installed Lilu.kext and Whatevergreen.kext with kextutility and also copied them for sure to the drivers64UEFI folder on the EFI partition. Then I installed https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.105.pkg and reboot the laptop. After loading the half of the apple bar the screen screen flicker once and sets the resolution correctly. Then I reached the login screen. After typing my password and hit enter the screen goes white and won’t login. Then I retype my password and hit enter. Now the laptop reboots. The only way to reach the desktop is with nv_disabled=1 bootflag. Can someone please help me. Clover.zip
×