Jump to content

bOLEMO

Members
  • Content Count

    47
  • Joined

  • Last visited

About bOLEMO

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  • Location
    Normandy, France
  1. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    For me, 10.11.5, using a08c to 208d and all is ok.
  2. bOLEMO

    Kext Install

    Version 1.0

    1,845 downloads

    This is a very simple droplet application to install kexts and rebuild the kernel cache. Drag one or several Kexts on the application (not a folder), Select the destination (LE or SLE), Choose if you want to rebuild the kernel cache or not, If so, choose if you want to restart the computer or not. If the file already exists at destination, you will have the choice to skip or replace it (in that case, the original will be moved on a Backup folder on the Desktop).
  3. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    Thank you for the credit toleda. Also, after reconstructing the kext cache for something else, it took several restarts to have the device recognized again (I used method I.2). I though that this is what happened when I tried method I.3 (pikeralphaALC), so I tried again, and I confirm that it works (and the problem was not related to the method itself). So I.1, I.2 and I.3 are working.
  4. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    Follow up of post #200 and before (about testing the different methods on ALC1150 / C610 X99 with new working AppleHDAController patch for latests AppleHDA) Thank you. I will do a full report on the 1.3, but probably next week or later though. About II. (AppleHDA8series Script), I did read the related post for 10.11 fix, but I did not apply it, as it is related to HD5500 (I don't have any Intel HD on my system).
  5. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    This post is specifically about C610/X99 audio controller; ALC1150 on X99 System (Clover patch replacing 8c20 by 8ca0 in config.plist/KernelAndKextPatches/KextsToPatch/10.9.4-10.10-/x99 ALC Onboard Audio). You're welcome! Thank you for your incredible dedication to all of this. It did not work. Here is my report on different methods: I. 1. audio_cloverALC-110.command.zip => WORKS (Warning: script removed AppleHDAController kext clover patch, I had to add it back) I. 2. audio_realtekALC-110.command.zip => WORKS (Note: I don't know if it removed the clover patch as I tried this first and apply the X99 patch after) I.3. audio_pikeralphaALC-110.command.zip => DEVICE NOT RECOGNIZED (does not appear at all) II. Piker-Alpha AppleHDA8series Script -> tried with AppleHDA1150.kext in L/E/ => DEVICE NOT RECOGNIZED (does not appear at all) -> installed AppleHDA1150.kext in S/L/E/ => DEVICE NOT RECOGNIZED (does not appear at all) We are making progress on the X99 case, as we know can use latest AppleHDA. For some reason though, the Piker Alpha solutions (which I like the idea as it does not touch at all the AppleHDA.kext) are not working. Any thoughts on why or how to fix that? The patch from Clover by replacing 8C20 by 8CA0 in AppleHDAController is great. I wonder if there is a way to make an SSDT (to patch DSDT) to change the device-id of the C610/X99 audio controller to 8CA0 and trick AppleHDAController this way, without patching it at all from Clover. I tried to change IONAme, device-id and a few things this way, and it showed changes in IORegistry, but it did not work (no sound) ; I probably did not do the right thing, or maybe it is simply not possible to do that from SSDT/DSDT.
  6. bOLEMO

    AppleHDAController native Intel ids

    No problem You are welcome
  7. bOLEMO

    AppleHDAController native Intel ids

    Hi, My audio controller is 8086:8D20 (Name: C610/X99 series chipset HD Audio Controller) => NOT SUPPORTED by native AppleHDA. Until AppleHDA 10.9.5, it was possible to patch AppleHDAController replacing 8D20 by 8C20 (tricking Apple HDA from Clover). However, after 10.9.5, it stopped to work, and as any X99 based mb owners, I had to replace for each update AppleHDA by the patched 10.9.5 one. I discovered today that replacing 8D20 by 8CA0 (patching AppleHDAController) works with 10.11.4 AppleHDA. And yes, 8CA0 is indeed is in the binary and that is the whole idea as we trick the system to use a supported binary. There would be no point otherwise…). I did not try to repatch my kext using AppleHDA Patcher, I just had a look at your application, and it seems very nice, but I did not use it as I already patched mine ; furthermore, as layout-id are different, I would have to change my DSDT switching from one solution to another. I understand now that layout-id, it is purely a choice of the Authors, thank you for that precision ;-)
  8. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    Ok, I reinstalled AppleHDA by patching the 10.11.4 kext directly, using your method. For some reason, if I use the Clover patches, the device is not recognized. That being said, I have an excellent news: for the controller, I used 8CA0 to replace 8C20, and it works!! That means that X99 systems can again use the latest AppleHDA (and not be stuck with the 10.9.5 version). You can include that in your next guide update. KextsToPatch -> AppleHDAController -> Find "oIw=" Replace "II0=" Now, I need to get why keeping the genuine unpatched AppleHDA in /S/L/E and using the dummy AppleHDA-ALC1150 in /L/E and Clover patches (all done by your script) does not work (device is not recognized, not shown).
  9. bOLEMO

    AppleHDAController native Intel ids

    Nope, but it worked with 8CA0. :-) Thank you. I am using the Toleda method, patching the AppleHDA itself. If I use the Clover patch with a Dummy HDA, for some reasons, the device is not recognized. But that is another problem. Now at least, X99 systems can use the latest AppleHDA again! PS: I saw that AppleHDA Patcher, and it looks great. I am confused with the layout, as for Desktops, you offer 5, 7 and 9 whereas Toleda methods offers 1, 2 and 3, and for me, 1 is working fine.
  10. bOLEMO

    AppleHDAController native Intel ids

    Any success replacement to enable support of 8086:8D20 (C610/X99 series chipset HD Audio Controller) with 10.11.4 AppleHDA (274.7)? So far only replacing 8C20 by 8D20 in 10.9.5 AppleHDA (2.6.3) is working (with patches of course).
  11. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    Thank you toleda. I installed the native 10.11.4 AppleHDA, and followed your instructions (I used the solution that is not touching AppleHDA and creates one in L/E) and clover patches. I then added the X99 chipset patch in clover and tried 1D20, 0D0C, 9C20, 8C20, 9CA0, 8CA0, A170 and 9D70 without any success. I will try again, with more ids, but by using the patched AppleHDA itself (in S/L/E) instead of using the alternative L/E method (to be as close as possible to my 10.9.5 working situation). Regards.
  12. bOLEMO

    El Capitan: Realtek ALC AppleHDA Audio

    Hi, As I understand, the solution for x99 systems is still to use the AppleHDA kext from 10.9.5 Is there a way to use the one from 10.11.4? The other starts to get old and gives me (sometimes) random kernel panics under 10.11.4 (was fine under 10.11.3). There must be a way to patch the recent AppleHDA to work on X99 systems. Any idea on where to start? What changed after the 10.9.5 version to stop to work?
  13. bOLEMO

    Clover Builder.app

    It does not work, but there is an error while compiling: ================= Making all in clover-genconfig ================= [XCODE] clover-genconfig ** INSTALL FAILED ** The following build commands failed: CompileC /Users/grvg/src/edk2/Clover/CloverPackage/sym/build/clover-genconfig/clover-genconfig.build/Release/clover-genconfig.build/Objects-normal/i386/clover-genconfig.o clover-genconfig.c normal i386 c com.apple.compilers.llvm.clang.1_0.compiler CompileC /Users/grvg/src/edk2/Clover/CloverPackage/sym/build/clover-genconfig/clover-genconfig.build/Release/clover-genconfig.build/Objects-normal/x86_64/clover-genconfig.o clover-genconfig.c normal x86_64 c com.apple.compilers.llvm.clang.1_0.compiler (2 failures) make[2]: *** [/Users/grvg/src/edk2/Clover/CloverPackage/sym/utils/clover-genconfig] Error 65 make[1]: *** [all-recursive] Error 1 make: *** [pkg] Error 2 ================= Making all in fdisk440 ================= make[2]: Nothing to be done for `all'. ================= Making all in boot1-install ================= make[2]: Nothing to be done for `all'. ================= Making all in partutil ================= make[2]: Nothing to be done for `all'. ================= Making all in bdmesg ================= make[2]: Nothing to be done for `all'. ================= Making all in clover-genconfig ================= [XCODE] clover-genconfig ** INSTALL FAILED ** The following build commands failed: CompileC /Users/grvg/src/edk2/Clover/CloverPackage/sym/build/clover-genconfig/clover-genconfig.build/Release/clover-genconfig.build/Objects-normal/i386/clover-genconfig.o clover-genconfig.c normal i386 c com.apple.compilers.llvm.clang.1_0.compiler (1 failure) make[2]: *** [/Users/grvg/src/edk2/Clover/CloverPackage/sym/utils/clover-genconfig] Error 65 make[1]: *** [all-recursive] Error 1 make: *** [utils] Error 2 Complete Build time 48s ============== Finish working: 2016-03-29 14:02:27 +0200 ================== Syncing disk cache ... Done. All done. Have a nice ... day(night) Enjoy ...
  14. bOLEMO

    Clover Builder.app

    How do you build the package with this? It is building an ISO. I understand that it must be a setting in the script…
  15. bOLEMO

    Clover Problems and Solutions

    EDK2 problem is indeed solved, however, now I have this (Clover 3380): Traceback (most recent call last): File "/Volumes/Valinor/Hackintosh/CloverGrowerPro/edk2/BaseTools/BinWrappers/PosixLike/../../Source/Python/build/build.py", line 41, in <module> from AutoGen.AutoGen import * File "/Volumes/Valinor/Hackintosh/CloverGrowerPro/edk2/BaseTools/Source/Python/AutoGen/AutoGen.py", line 22, in <module> import GenC File "/Volumes/Valinor/Hackintosh/CloverGrowerPro/edk2/BaseTools/Source/Python/AutoGen/GenC.py", line 871 AutoGenH.Append('#define %s LibPcdGet%s(%s)\n' % (GetModeName, DatumSizeLib, PcdTokenName)) ^ IndentationError: expected an indented block Cloverx64 release ERROR!!
×