Jump to content

Barry_dhb52

Members
  • Content Count

    12
  • Joined

  • Last visited

About Barry_dhb52

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

925 profile views
  1. Barry_dhb52

    macOS Catalina Public Beta 1 - Freezes

    adgpmod=pikera catalina root is read only, so you cant install into / dir. I mount efi, rename the Efi folder, and install clover the esp way. now you got the new clover file. And the easier way is to download the cloverx64.efi directly from github release. while bootx64.efi actually inditical to cloverx64.efi
  2. latest lilu whatevergreen platform-id 0x3e9b0007(hex swapped: 07009b3e)
  3. Barry_dhb52

    Only mistake I have left in OSC:

    check if there's some data with real type.
  4. After a quite smooth running /w Mojave (both Clover, OC build), a few days ago I upgraded to Catalina soon after public release, and I found out DP output to black screen, then I switch to HDMI, it works. When DP goes black screen, unplug then plug the cable, screen comes back then gone. After a lot of searches, I found out some simalar cases, but none of them have a solution, today I was quite happy to find out this post is https://www.tonymacx86.com/threads/majove-to-catalina-displayport-not-working.284983/. which solving by swithing to iMac19,1, which I think WEG quite needs an enhancement But I tried with no luck. And I don't know is it relevant to this issue, sometimes wakeup, I got panic, somehow like this: Kernel Extensions in backtrace: com.apple.driver.AppleACPIPlatform(6.1)[927FAB0F-5B29-3E31-A1A4-DA7E904986C4]@0xffffff7f96b8c000->0xffffff7f96c26fff dependency: com.apple.iokit.IOACPIFamily(1.4)[9BA2613C-A129-3EDD-8DC1-2CFF6B62B832]@0xffffff7f9528f000 dependency: com.apple.iokit.IOPCIFamily(2.9)[E6E855AD-A5B2-3518-A997-1384B4360708]@0xffffff7f952a1000 dependency: com.apple.driver.AppleSMC(3.1.9)[EB9D605D-85B1-3506-8B2E-ABD195817A4F]@0xffffff7f952de000 whole panic log in attachment My build: Asrock z370 gaming itx/ac i3 8100 Only Intel UHD630 with LG UL550 4k monitor Or is there any guide how to do some logging for this issue? thanks panic-log.txt EFI.clover.zip
  5. Barry_dhb52

    How to boot directly into specific volume

    Sorry, what "need working NVRAM" means, how can I setup NVRAM, and how can I test out it's working or not. My config.plist is as below <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>ACPI</key> <dict> <key>Add</key> <array> <dict> <key>Comment</key> <string>My custom DSDT</string> <key>Enabled</key> <false/> <key>Path</key> <string>DSDT.aml</string> </dict> <dict> <key>Comment</key> <string>My custom SSDT</string> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-1.aml</string> </dict> <dict> <key>Comment</key> <string>plugin-type=1</string> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-PLUG.aml</string> </dict> <dict> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-SBUS-MCHC.aml</string> </dict> <dict> <key>Comment</key> <string>Notebook brightness</string> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-PNLF.aml</string> </dict> <dict> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-EC.aml</string> </dict> <dict> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-EC-USBX.aml</string> </dict> <dict> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-EHCx_OFF.aml</string> </dict> <dict> <key>Enabled</key> <false/> <key>Path</key> <string>SSDT-AWAC.aml</string> </dict> </array> <key>Block</key> <array> <dict> <key>All</key> <false/> <key>Comment</key> <string>Drop CpuPm</string> <key>Enabled</key> <false/> <key>OemTableId</key> <data> Q3B1UG0AAAA= </data> <key>TableLength</key> <integer>0</integer> <key>TableSignature</key> <data> U1NEVA== </data> </dict> <dict> <key>All</key> <false/> <key>Comment</key> <string>Drop Cpu0Ist</string> <key>Enabled</key> <false/> <key>OemTableId</key> <data> Q3B1MElzdAA= </data> <key>TableLength</key> <integer>0</integer> <key>TableSignature</key> <data> U1NEVA== </data> </dict> </array> <key>Patch</key> <array> <dict> <key>Comment</key> <string>_Q11 to XQ11</string> <key>Count</key> <integer>1</integer> <key>Enabled</key> <false/> <key>Find</key> <data> X1ExMQ== </data> <key>Limit</key> <integer>0</integer> <key>Mask</key> <data> </data> <key>OemTableId</key> <data> </data> <key>Replace</key> <data> WFExMQ== </data> <key>ReplaceMask</key> <data> </data> <key>Skip</key> <integer>0</integer> <key>TableLength</key> <integer>0</integer> <key>TableSignature</key> <data> RFNEVA== </data> </dict> <dict> <key>Comment</key> <string>_Q12 to XQ12</string> <key>Count</key> <integer>1</integer> <key>Enabled</key> <false/> <key>Find</key> <data> X1ExMg== </data> <key>Limit</key> <integer>0</integer> <key>Mask</key> <data> </data> <key>OemTableId</key> <data> </data> <key>Replace</key> <data> WFExMg== </data> <key>ReplaceMask</key> <data> </data> <key>Skip</key> <integer>0</integer> <key>TableLength</key> <integer>0</integer> <key>TableSignature</key> <data> RFNEVA== </data> </dict> </array> <key>Quirks</key> <dict> <key>FadtEnableReset</key> <false/> <key>NormalizeHeaders</key> <false/> <key>RebaseRegions</key> <false/> <key>ResetHwSig</key> <false/> <key>resetLogoStatus</key> <false/> </dict> </dict> <key>Booter</key> <dict> <key>Quirks</key> <dict> <key>AvoidRuntimeDefrag</key> <true/> <key>DevirtualiseMmio</key> <false/> <key>DisableSingleUser</key> <false/> <key>DisableVariableWrite</key> <false/> <key>DiscardHibernateMap</key> <false/> <key>EnableSafeModeSlide</key> <true/> <key>EnableWriteUnprotector</key> <true/> <key>ForceExitBootServices</key> <false/> <key>ProtectCsmRegion</key> <false/> <key>ProvideCustomSlide</key> <true/> <key>SetupVirtualMap</key> <true/> <key>ShrinkMemoryMap</key> <false/> </dict> </dict> <key>DeviceProperties</key> <dict> <key>Add</key> <dict> <key>PciRoot(0x0)/Pci(0x1f,0x3)</key> <dict> <key>layout-id</key> <data> CwAAAA== </data> </dict> </dict> </dict> <key>Kernel</key> <dict> <key>Add</key> <array> <dict> <key>BundlePath</key> <string>Lilu.kext</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/Lilu</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> <dict> <key>BundlePath</key> <string>VirtualSMC.kext</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/VirtualSMC</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> <dict> <key>BundlePath</key> <string>WhateverGreen.kext</string> <key>Comment</key> <string>Video card</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/WhateverGreen</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> <dict> <key>BundlePath</key> <string>AppleALC.kext</string> <key>Comment</key> <string>Sound</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/AppleALC</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> <dict> <key>BundlePath</key> <string>IntelMausi.kext</string> <key>Comment</key> <string>Intel Ethernet</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/IntelMausi</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> <dict> <key>BundlePath</key> <string>USBInjectAll.kext</string> <key>Comment</key> <string>Intel Ethernet</string> <key>Enabled</key> <true/> <key>ExecutablePath</key> <string>Contents/MacOS/USBInjectAll</string> <key>PlistPath</key> <string>Contents/Info.plist</string> </dict> </array> <key>Quirks</key> <dict> <key>AppleCpuPmCfgLock</key> <false/> <key>AppleXcpmCfgLock</key> <false/> <key>AppleXcpmExtraMsrs</key> <false/> <key>CustomSMBIOSGuid</key> <false/> <key>DisableIoMapper</key> <true/> <key>ExternalDiskIcons</key> <true/> <key>LapicKernelPanic</key> <false/> <key>PanicNoKextDump</key> <true/> <key>ThirdPartyTrim</key> <false/> <key>XhciPortLimit</key> <true/> </dict> </dict> <key>Misc</key> <dict> <key>Boot</key> <dict> <key>ConsoleBehaviourOs</key> <string>Graphics</string> <key>ConsoleBehaviourUi</key> <string>Text</string> <key>ConsoleMode</key> <string></string> <key>HibernateMode</key> <string>None</string> <key>HideSelf</key> <true/> <key>PollAppleHotKeys</key> <true/> <key>Resolution</key> <string></string> <key>ShowPicker</key> <true/> <key>Timeout</key> <integer>5</integer> <key>UsePicker</key> <true/> </dict> <key>Debug</key> <dict> <key>DisableWatchDog</key> <false/> <key>DisplayDelay</key> <integer>0</integer> <key>DisplayLevel</key> <integer>2147483650</integer> <key>Target</key> <integer>19</integer> </dict> <key>Entries</key> <array/> <key>Security</key> <dict> <key>AllowNvramReset</key> <true/> <key>ExposeSensitiveData</key> <integer>2</integer> <key>HaltLevel</key> <integer>2147483648</integer> <key>RequireSignature</key> <false/> <key>RequireVault</key> <false/> <key>ScanPolicy</key> <integer>0</integer> </dict> <key>Tools</key> <array> <dict> <key>Comment</key> <string>Not signed for security reasons</string> <key>Enabled</key> <false/> <key>Name</key> <string>UEFI Shell</string> <key>Path</key> <string>Shell.efi</string> </dict> <dict> <key>Comment</key> <string>Memory testing utility</string> <key>Enabled</key> <false/> <key>Name</key> <string>memcheck</string> <key>Path</key> <string>memcheck/memcheck.efi</string> </dict> </array> </dict> <key>NVRAM</key> <dict> <key>Add</key> <dict> <key>4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14</key> <dict> <key>UIScale</key> <data> Ag== </data> </dict> <key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key> <dict> <key>boot-args</key> <string>keepsyms=1 dart=0</string> <key>csr-active-config</key> <data> 5wMAAA== </data> </dict> </dict> <key>Block</key> <dict> <key>4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14</key> <array> <string>UIScale</string> </array> <key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key> <array> <string>boot-args</string> </array> </dict> <key>LegacyEnable</key> <false/> <key>LegacySchema</key> <dict> <key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key> <array> <string>EFIBluetoothDelay</string> <string>EFILoginHiDPI</string> <string>LocationServicesEnabled</string> <string>SystemAudioVolume</string> <string>SystemAudioVolumeDB</string> <string>bluetoothActiveControllerInfo</string> <string>bluetoothInternalControllerInfo</string> <string>flagstate</string> <string>fmm-computer-name</string> <string>nvda_drv</string> <string>prev-lang:kbd</string> </array> <key>8BE4DF61-93CA-11D2-AA0D-00E098032B8C</key> <array> <string>Boot0080</string> <string>Boot0081</string> <string>Boot0082</string> <string>BootNext</string> <string>BootOrder</string> </array> </dict> </dict> <key>PlatformInfo</key> <dict> <key>Automatic</key> <true/> <key>Generic</key> <dict> <key>MLB</key> <string>C078266004NKXPGJA</string> <key>ROM</key> <data> cIXCXLhK </data> <key>SpoofVendor</key> <true/> <key>SystemProductName</key> <string>Macmini8,1</string> <key>SystemSerialNumber</key> <string>C07WXGYJJYVX</string> <key>SystemUUID</key> <string>8410C3F4-5BC1-4579-A51A-EAF5770B3B11</string> </dict> <key>UpdateDataHub</key> <true/> <key>UpdateNVRAM</key> <true/> <key>UpdateSMBIOS</key> <true/> <key>UpdateSMBIOSMode</key> <string>Create</string> </dict> <key>UEFI</key> <dict> <key>ConnectDrivers</key> <true/> <key>Drivers</key> <array> <string>ApfsDriverLoader.efi</string> <string>FwRuntimeServices.efi</string> <string>AppleGenericInput.efi</string> <string>VirtualSmc.efi</string> </array> <key>Protocols</key> <dict> <key>ConsoleControl</key> <true/> <key>FirmwareVolume</key> <false/> <key>HashServices</key> <false/> <key>IgnoreTextInGraphics</key> <true/> <key>UnicodeCollation</key> <false/> </dict> <key>Quirks</key> <dict> <key>AvoidHighAlloc</key> <false/> <key>ClearScreenOnModeSwitch</key> <false/> <key>ExitBootServicesDelay</key> <integer>0</integer> <key>IgnoreInvalidFlexRatio</key> <false/> <key>IgnoreTextInGraphics</key> <true/> <key>ProvideConsoleGop</key> <true/> <key>ReleaseUsbOwnership</key> <false/> <key>ReplaceTabWithSpace</key> <false/> <key>RequestBootVarRouting</key> <false/> <key>SanitiseClearScreen</key> <true/> </dict> </dict> </dict> </plist>
  6. How to directly boot into specific volume, for me MACOS,Just like clover DefaultVolume. Thanks EFI: https://github.com/dhb52/z370-opencore BTW, another question. I use Clover install on ssd along with macOS installed. And I use a GUID partitioned HHD for TimeMachine backup, which I have my OC EFI installed to boot the same `macOS`. by comparing usage of both booters, it seems that when using OC, my Win7(Paralled Desktop 14 vm) uses more memory, by opening Task Manager.
  7. Using GUID as DefaultVolume solves the problem. Thanks very much.
  8. Have a try to modify your config.plist: <key>Graphics</key> <dict> <key>ig-platform-id</key> <string>0D220003</string> <key>Inject</key> <dict> <key>Intel</key> <true/> <key>ATI</key> <false/> <key>NVidia</key> <false/> </dict> </dict> <key>Devices</key> <dict> <key>FakeID</key> <dict> <key>IntelGFX</key> <string>0x0</string> </dict> <dict> hope it help
  9. System brief: 1. Win8.1/Ubuntu14.04/Mavericks 10.9.1, all installed on PLEXTOR SSD, using GPT UEFI mode. 2. Clover r2671. How can I boot into Win8.1 defaultly with timeout using clover. 1. NTFS.efi in /Volume/EFI/EFI/CLOVER/drivers64UEFI 2. Default Loader = bootmgfw.efi or \EFI\Microsoft\Boot\bootmgfw.efi 3. Gui: Scan: false; only customer entries Default Boot Volume = EFI bootlog.txt CLOVER.zip By studing this post, I still can't get this work. http://www.insanelymac.com/forum/topic/296000-force-clover-to-always-choose-win-81-efi-as-default-boot-option/
  10. 1. Just replace AppleIntelFramebufferAzul.kext from 10.9.1 (Before combo update from 10.9.1, I enable HDMI audio, it seems to modify this kext http://www.tonymacx86.com/graphics/125239-hd4600-hd4000-hd3000-framebuffer-edits-4.html) 2. Using HDMI thanks again
  11. Hardware brief: 1. Motherboard: Asus H87I-Plus 2. CPU: Intel i5 4430 3. Display: Asus VX239 (with speakers, connected via HDMI) 4. Disks: PLEXTOR PX-128M5Pro System brief: 1. Win8.1/Ubuntu14.04/Mavericks 10.9.1, all installed on PLEXTOR SSD, using GPT UEFI mode. 2. Clover r2671. 3. Graphics/Display info is correct according to my hardware spec. 4. HDMI audio output works. Graphics/Display: Intel HD Graphics 4600: Chipset Model: Intel HD Graphics 4600 Type: GPU Bus: Built-In VRAM (Total): 1024 MB Vendor: Intel (0x8086) Device ID: 0x0412 Revision ID: 0x0006 Displays: VX239: Resolution: 1920 x 1080 @ 60Hz (1080p) Pixel Depth: 32-Bit Color (ARGB8888) Display Serial Number: E1LMRS026930 Main Display: Yes Mirror: Off Online: Yes Rotation: Supported Television: Yes Problem description: Combo Update to 10.9.3, using the same clover config.plist, Mavericks 10.9.3 failed to boot. stucked on VM swap subsystem is ON Replace IntelGPU FakeID using "0x80860412" or "0x0412" or "0x8086" (originally "0x0"), then boot smoothly, but display not working properly. "About this Mac": Graphics Intel HD Graphics 4600 7 MB Graphics/Display: no kexts loaded using FakeID "0x80860412" to boot: Graphics/Display: deviceid: 8086; vendor id: 0412, which are twisted. So I tried 0x04128086, it failed to boot again. Here's my clover config: CLOVER.zip BTW: How can I boot into Win8.1 defaultly with timeout using clover. 1. NTFS.efi in /Volume/EFI/EFI/CLOVER/drivers64UEFI 2. Default Loader = bootmgfw.efi or \EFI\Microsoft\Boot\bootmgfw.efi Default Boot Volume = EFI Here's my clover boot log, (Mavericks 10.9.1): bootlog.txt Thanks!
×