Jump to content
InsanelyMac Forum

rootedheart

Members
  • Content count

    7
  • Joined

  • Last visited

About rootedheart

  • Rank
    InsanelyMac Protégé
  • Birthday 03/21/1996

Profile Information

  • Gender
    Male
  • Location
    Spain
  1. Tanto buenas como malas. Todo hay que decirlo.

  2. rootedheart

    Sapphire HD 7850 Full Works !

    Thank you!
  3. rootedheart

    Sapphire HD 7850 Full Works !

    I've done it and have obtained the following results. I'm in Mavericks 10.9.0, using HDMI. With the original kexts without edit: Ati_inject = Yes or GE=Yes. I've got a black screen when I boot. I think this is because, your kexts AMD7000controller has the video out ports edited and the original kexts, have the standar ports. So, I suspect, that how a user say in this post, If I buy a mdp adapter on ebay, I'd can use the original kexts. But now, I can see only a black screen then of boot. Ati_inject = No or GE= No. I've got GE, but not full, I can't play games, record the screen with Quicktime or anything like this, but I haven't got lagg. My card is recognized as a 7XXX 2048 MB. With your edited kext AMD7000controller on the op: Ati_inject = Yes or GE = Yes. My graphic card is recognized as 7850 7 MB. Lagg and no GE. Ati_inject = No or GE= No. My graphic card is recognized as 7XXX 7 MB. Lagg and no GE. Can you give me the two kext for your 7850 are you using now please?
  4. rootedheart

    Sapphire HD 7850 Full Works !

    The first, thank you for edit my DSDT. Now, I put clover boot loader and I downloaded your edited kext, now I'm using ATI_inject = Yes, that is the same GE=YES. Now I've got the card recognized as a 7850 card, but it's appear as 7850 7 MB instead of 2048 MB :S I record a video in that you can see how I've got use your kext, and AMDradeonx4000 kext with 0x68181002 device id. Now I think, the problem can be with the device id, when I booted in windows, I saw my divice id with GPU-Z, and my divice id is 0x68191002 how appear recognized by clover in the video (0x68191002) and inside the kexts, you can see 0x68181002. I've got a 7850 2 GB OC by Sapphire. I'm using your kext AMD7000 controller, the native Radeox4000 kext with 0x68181002 id and the DSDT you edited for me. So, I think, that maybe the problem is because, my correct device id is 0x68191002 how appear in GPU-Z. Really I don't know. Can you give me yours kexts please? The both. Radeonx400 and AMD7000controller. If you can give me a copy edited with my divice id 0x68191002 of AMD 7000controller, I'd appreciate it. When I try to edit you AMD 7000 controller kext, displays a similar message of this: "This file is damage". Or anything like this. https://www.youtube.com/watch?v=ZK7id6AV1MU&feature=youtube_gdata_player
  5. rootedheart

    Sapphire HD 7850 Full Works !

    When I used GE = yes I can't bot and I receive the next error: "Memory allocation error: Addr: 0x0, Szie 0x3ff1970, File: ati.c, Line 1557. This is a non recoverable error! System HALTED!!!" I used GE=1 or GE=No and I get the same result, 7850 recognized as 7XXX card series.
  6. rootedheart

    Sapphire HD 7850 Full Works !

    DSDT found now! You're a master, but I've got it recognized as 7XXX series card yet :S Have I got to edit DSDT with your patched lines of this thread? This? I download IOReg program, and I think that my port is PC02 Device (PEX) { Name (_ADR, 0x00010000) Device (GFX) { Name (_ADR, Zero) Method (_DSM, 4, NotSerialized) { Store (Package () { "device-id", Buffer () { 0x18, 0x68, 0x00, 0x00 }, "hda-gfx", Buffer () { "onboard-1" } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } Device (HDAU) { Name (_ADR, One) Method (_DSM, 4, NotSerialized) { Store (Package () { "hda-gfx", Buffer () { "onboard-1" } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } }
  7. The wire y a dormir la mona.

  8. rootedheart

    Sapphire HD 7850 Full Works !

    Can you download it now? I can upload it to another file hosting. Mediafire: https://www.mediafire.com/?2i0smqt3w2859ao I've got a: AMD FX 6300 processor. Motherboard - Gigabyte 970A-DS3 Graphic card - ATI 7850 sapphire 2 GB OC.
  9. rootedheart

    Sapphire HD 7850 Full Works !

    I've got a 7850 shappire card 2 GB OC, and I take around 2 months trying to get it recognized as a 7850. I'm very noob in hackintosh world. I ask you because I'm starting to go crazy. Today I've got it, recognized as a 7XXX 2048 MB series card. I'm using niresh mavericks, I only edited the kexts AMD7000controller.kext and AMDRadeonX4000.kext with the correct deviced id vendor (68191002) and I've got the card recognized as a 7XXX series card. I tried using a DSDT, but gived me 173 compilation errors, I'm so noob... I also extracted the vbios from windows and rename it to 1002_6819.rom but when I boot using ATIinject and Vbios load, I get a black screen and I can't use the system. ¿Anybody can help me please? I'm desperate please. Sorry for my english isn't my first language. MY DSDT.aml with a lot of errors. https://mega.co.nz/#!owUnhQhB!qgQMDQdvzOBiXSXw53Hge9UJeo0tYAxEYO_368FCA7o
×