Jump to content
InsanelyMac Forum

potuz

Members
  • Content count

    64
  • Joined

  • Last visited

About potuz

  • Rank
    InsanelyMac Protégé
  1. potuz

    ALC889A pin configuration

    Hello again, from time to time I spend some time in this problem. I looked again in the plists and I don't understand how I missed this, but I guess the relevant part of the plist is: <dict> <key>MicAttributes</key> <integer>28</integer> <key>MicInfo</key> <string>Sampled on rising edge</string> <key>NodeID</key> <integer>39</integer> <key>PinConfigDefault</key> <integer>2426405136</integer> </dict>[code] Which tells me nothing. In particular I don't have a node 0x27=39 (at least not that hda-analyzer sees) so it's not surprising that if I send the corresponding verbs to set_config_default I don't get anything. Also, I don't see how setting the pinconfigdefault could affect my not having the mic working. As for the sampled on rising edge, I don't know how to use this info.. any ideas? Thanks, R.
  2. potuz

    ALC889A pin configuration

    Alright, I've played quite a while looking through all the info.plist in the relevant kexts to no avail. The id is 0x10DECB79 which corresponds to an alc885 and I can't find anything in the kexts that is specific to this id. This I guess agrees with your comment: Also here, I couldn't find absolutely no information online about this. There's nothing in either the UEFI specification v 2.3 nor in the UEFI shell specification v. 2.0 so if there's a way of controlling the codec through EFI as you suggest I'd greatly appreciate if you can point me to any info online on the topic. Thanks, R.
  3. potuz

    ALC889A pin configuration

    My apologies, it seems that I forgot about this cause I hadn't touched this issue for a while, you were right, alsa finds the codec as ALC889a but the codec shows: odec: 0x10ec0885 Address: 0 Function Id: 0x101 Vendor Id: 0x10ec0885 Subsystem Id: 0x106b3500 Revision Id: 0x100103 Anyway, the question is the same, I'd like to know what are the pin configs and the verbs that mac os X sends to the vendor widgets to initialize the mic. Thanks R.
  4. potuz

    ALC889A pin configuration

    That's exactly what I am asking for. The codec identifies itself as alc889a. It is a real macbook air 2,1 and I know that the pin configuration is set on EFI, but I do not know how to get it so that I can tell ALSA what the layout is and what verbs it should use to initialize the mic. I am in the process of re-installing mac os X so that I can try and use IORegistryExplorer as suggested below. @RSN thanks for the offer, I am not sure if these are the same cards, but if I fail with IORegistryExplorer then I'll ask you for your dumps.
  5. potuz

    ALC889A pin configuration

    Thanks, I had seen that article and actually it confuses me even more cause there are a couple of pin configurations there in verbs.txt which don't even match up with the working ones in linux... Perhaps I'll try to bug someone on IRC. R. Actually, what I need is in some sense the opposite of the tools in that HOWTO. Namely, that text is based in collecting information from a system in which the audio works. But if I collect from linux I'd get what I fed myself the driver. So what I was wandering is if there's an application for Mac OS X that would return the codec info from a working codec. In that case I can just install mac OS here and then I'll get the info I need. Cheers, R.
  6. potuz

    ALC889A pin configuration

    Hello list, this might be in the opposite direction of what is usually asked here, but I have been having problems with this for over a year now. I own a macbook Air 2,1 with the Realtek ALC889A soundcard. I wiped out Mac OS X from it and installed only Linux (I have no interest on a flame war, just care about the codec in this post). The thing is that with the current Linux driver (ALSA) we can't make the mic work. Since you guys have developed tons of Kexts for this chip and the datasheet is not available I was wandering if you could put in me in the right direction. As of now I could only figure out that using 0x18 as main speaker 0x14 as HP and switch 0x19 as HP when it is connected I get audio in the main speaker and headphones appropriately. But I do not know which verb one should use to get the mic working. Any help will be greatly appreciated. Cheers, R.
  7. potuz

    Lenovo ThinkPad X61 Tablet

    Hi there, I was wandering two things 1) did anyone try 10.5.3 yet on a multi-touch, does it fix the tablet issue? 2) outZider, did you post the sources for your kexts somewhere? P.
  8. potuz

    Lenovo ThinkPad X61 Tablet

    Of course, I'd be eternally thankful for that. Just let me know what logs do you need. I still need to contact Scott to get a logging copy of TabletMagic though: as you pointed before, the port seems to be getting up right, so perhaps it's an issue at the driver level. P.
  9. potuz

    Lenovo ThinkPad X61 Tablet

    That's a pitty, I was putting all my money in you to fix the tablet in the multi-touch model P.
  10. potuz

    Lenovo ThinkPad X61 Tablet

    Did you try what the first post in this thread says? It's working fine in my x61T
  11. potuz

    TabletMagic for TabletPCs

    That's great news!, I guess it's good bye to Vista, thanks for the tip.... I'll try it right now. P.
  12. potuz

    TabletMagic for TabletPCs

    I tried all versions available, currently I run b13. Did this. Anyways, I was forcing the serial port running the Daemon in a terminal. Here's the log of the Console with running the daemon with "Don't Query", serial0 as the port on b13. The last [sENT] is just from the testing pane. If you want I can send you the different outputs from command line or console running different arguments (not forcing the tablet spits a "no Wacom Tablet Found!" error. Thanks, P. 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] TabletMagicDaemon v2.0b13 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] (c) 2007 Thinkyhead Software <www.thinkyhead.com> 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [INIT] renice -20 161 : Succeeded 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [INIT] Machine Type: 7764CTO (Hackintosh?) 4/13/08 4:27:59 PM System Preferences[139] Received [hello] 4/13/08 4:27:59 PM System Preferences[139] Received [port] serial0 4/13/08 4:27:59 PM System Preferences[139] Received [ready] 4/13/08 4:27:59 PM System Preferences[139] Received [model] ISD V4.0 (TabletPC) 4/13/08 4:27:59 PM System Preferences[139] Received [info] 0 7200C910,002,02,1270,1270 active 4/13/08 4:27:59 PM System Preferences[139] Received [geom] 0 0 1525 1003 : 0 0 1023 767 : 1 1 2 6 : 0 1.0000 4/13/08 4:27:59 PM System Preferences[139] Received [scale] 24570 18430 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [PROC] Tablet Bounds: (0, 0) - (1525, 1003) 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [PROC] Screen Bounds: (0, 0) - (1023, 767) 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [PORT] serial0: OPENED 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [PORT] Setting speed to 19200 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [PROC] "~#ISD V4" 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [INFO] ISD V4.00 (TabletPC) 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] [INIT] TabletPC Detected 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] Tablet Settings (imposed): 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] command set ..... Tablet PC 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] output format ... BINARY 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] terminator ...... CRLF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] packet size ..... 9 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] baud rate ....... 19200 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] data bits ....... 8 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] parity .......... N 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] stop bits ....... 1 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] cts ............. OFF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] dsr ............. OFF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] transfer mode ... suppressed 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] coord sys ....... ABS 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] transfer rate ... 200 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] resolution ...... 1270 lpi 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] origin .......... UL 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] oor data ........ OFF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] pnp ............. ON 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] sensitivity ..... firm 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] read height ..... 8mm+ 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] mdm ............. OFF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] tilt ............ ON 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] mm command set .. MM1201 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] orientation ..... landscape 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] cursor data ..... 1234 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] remote mode ..... OFF 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] increment ....... 2 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] interval ........ 2 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] xrez ............ 1270 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] yrez ............ 1270 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] tablet width .... 24570 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] tablet height ... 18430 4/13/08 4:27:58 PM [0x0-0x10010].com.apple.systempreferences[139] Tablet initialized. 4/13/08 4:28:42 PM [0x0-0x10010].com.apple.systempreferences[139] [SENT] "1"
  13. potuz

    TabletMagic for TabletPCs

    I did (this was noted a couple of pages ago in this thread in my original post) and this was to get the serial0 port recognized by tabletMagic. After editing the kexts as posted in that outZiders' thread you point out tabletMagic recognizes the port but not the tablet (unless you run with "Don't query digitizer" but anyways, nothing on the test pane). The weird thing is that running different versions of tabletmagic, I could get the "testing" pane to change some numbers as I approached the pen, as if it was recognizing the pen but I can't reproduce this in a controled manner. Finally, I tried to get the old logging version of TabletMagic to send you something, but I couldn't find that one either. Cheers, R.
  14. potuz

    TabletMagic for TabletPCs

    I can count at least three people in these forums with that situation on the WACF008 device for the X61T... no luck for us yet. Do you know if the port is coming up with the right settings? is it an issue of the enabler or of the daemon?. P.
  15. Hi there, this is a vicious circle, but there're so many posts on com.apple.Boot.plist that it's impossible to Google the topic anymore!. Anyways, I was wandering if there's any comprehensive documentation on how to customize Darwin's bootloader. The problem I'm interested in solving is: I'm booting a GUID setup and the osX partition is selected by default. I need to boot Vista by default. But in general, I'd like to see one place with all the posible customizations documented. I know about kernel flags and stuff in com.apple.Boot.plist, but how about changing the strings identifying different partitions "Foreing Boot" sounds strange.... How can I dissable the EFI partition?.... etc. Any help would be appreciated... I could only find people in this forum that asked the same question with no answer besides the classical: Why don't you install Grub or the Windows alternative...
×