Jump to content
InsanelyMac Forum

xristos

Members
  • Content count

    7
  • Joined

  • Last visited

About xristos

  • Rank
    InsanelyMac Protégé
  • Birthday 06/25/1986

Profile Information

  • Gender
    Male
  • Location
    cyprus
  1. xristos

    The NX9420 Thread

    fixed also the usb 2.0 problem!! Firstly install the vanilla iopcifamily else you will get kernel panic. then patch the dsdt HPET part as here: Device (C21D) { Name (_HID, EisaId ("PNP0103")) Name (C21E, 0xFFFFFFFD) Method (_STA, 0, NotSerialized) { If (LEqual (C21E, 0xFFFFFFFD)) { Store (0x00, Local0) Store (\_SB.C09F (), Local1) If (LGreaterEqual (\C009 (), 0x04)) { If (Local1) { Store (0x0F, Local0) } } Else { If (Local1) { Store (0x0B, Local0) } } Store (Local0, C21E) } Return (C21E) } Name (C020, ResourceTemplate () { [color="#FF0000"] IRQNoFlags () {0} IRQNoFlags () {8} IRQNoFlags () {11} IRQNoFlags () {15} [/color] Memory32Fixed (ReadOnly, 0xFED00000, // Address Base 0x00000400, // Address Length _Y0B) }) 4 IRQNoFlags () and you will get usb2.0 back with both cores enabled! Edid:On some machnes this section is a litle bit different. just go before memory32Fixed part and paste this IRQNoFlags()...
  2. xristos

    The NX9420 Thread

    I use Retail Snow leopard DVD 10.6.0 and then updated to 10.6.4 . You're right that fix broke usb 2.0 speed. I used to have iopcifamily.kext fix for usb 2.0 to work properly now not working , either with original iopcifamily.kext we should try another fix for usb 2.0 or maybe patching dsdt a litle bit more..
  3. xristos

    How to get both cores working?

    Finally i did it! HP NX9420 working with 2 cores enabled!!! This fix may also work for other NXxxxx series with centrino duo.. My cpu is T2500 2.00GHz os:snow leopard 10.6.4 dsdt patch needed just replace that value with 0x46: Name (C000, 0xFD) Name (C001, Zero) Processor (_PR.CPU0, 0x01, 0x00001010, 0x06) { Name (C002, Zero) Method (CSTH, 0, NotSerialized) { If (LEqual (C002, Zero)) { Store (One, C002) Store (Zero, \_SB.C003.C004.C005) } Store (\_SB.C003.C004.C006.C007 (), Local0) Return (Local0) } Method (INI, 0, NotSerialized) { If (LAnd (And (\_SB.C008, 0x01000000), LEqual (C009 (), 0x04))) { \_SB.ISMI ([color="#FF0000"]0x46[/color], Zero, Zero, Zero) } } Method (PPC, 0, NotSerialized) { Return (C00A ()) } } Processor (_PR.CPU1, 0x02, 0x00001010, 0x06) { Method (PPC, 0, NotSerialized) { Return (C00A ()) } } also here this line added:\_SB.ISMI (0x46, Zero, Zero, Zero): Method (_SB._INI, 0, NotSerialized) { \C009 () C01C () [color="#FF0000"]\_SB.ISMI (0x46, Zero, Zero, Zero)[/color] } sometimes it hangs at the very begining, if you did a hard shotdown previously(pressing pwr button for 5 sec) otherwise it boots and works fine!!!
  4. xristos

    HP NX9420 Both cores! No BIOS MOD!

    Finally i did it! HP NX9420 working with 2 cores enabled!!! This fix may also work for other NXxxxx series with centrino duo.. My cpu is T2500 2.00GHz os:snow leopard 10.6.4 dsdt patch needed just replace that value with 0x46: Name (C000, 0xFD) Name (C001, Zero) Processor (_PR.CPU0, 0x01, 0x00001010, 0x06) { Name (C002, Zero) Method (CSTH, 0, NotSerialized) { If (LEqual (C002, Zero)) { Store (One, C002) Store (Zero, \_SB.C003.C004.C005) } Store (\_SB.C003.C004.C006.C007 (), Local0) Return (Local0) } Method (INI, 0, NotSerialized) { If (LAnd (And (\_SB.C008, 0x01000000), LEqual (C009 (), 0x04))) { \_SB.ISMI ([color="#FF0000"]0x46[/color], Zero, Zero, Zero) } } Method (PPC, 0, NotSerialized) { Return (C00A ()) } } Processor (_PR.CPU1, 0x02, 0x00001010, 0x06) { Method (PPC, 0, NotSerialized) { Return (C00A ()) } } also here this line added:\_SB.ISMI (0x46, Zero, Zero, Zero): Method (_SB._INI, 0, NotSerialized) { \C009 () C01C () [color="#FF0000"]\_SB.ISMI (0x46, Zero, Zero, Zero)[/color] } sometimes it hangs at the very begining, if you did a hard shotdown previously(pressing pwr button for 5 sec) otherwise it boots and works fine even at 100% of cpu. Edit: 2/10/2010 ok ok that broke usb2 speed! patching hpet section in dsdt and they will work again! Device (C21D) { Name (_HID, EisaId ("PNP0103")) Name (C21E, 0xFFFFFFFD) Method (_STA, 0, NotSerialized) { If (LEqual (C21E, 0xFFFFFFFD)) { Store (0x00, Local0) Store (\_SB.C09F (), Local1) If (LGreaterEqual (\C009 (), 0x04)) { If (Local1) { Store (0x0F, Local0) } } Else { If (Local1) { Store (0x0B, Local0) } } Store (Local0, C21E) } Return (C21E) } Name (C020, ResourceTemplate () { [color="#FF0000"] IRQNoFlags () {0} IRQNoFlags () {8} IRQNoFlags () {11} IRQNoFlags () {15}[/color] Memory32Fixed (ReadOnly, 0xFED00000, // Address Base 0x00000400, // Address Length _Y0B) }) also you must use vanilla iopcifamily.kext or you will get a kernel panic
  5. xristos

    The NX9420 Thread

    Finally i did it! HP NX9420 working with 2 cores enabled!!! This fix may also work for other NXxxxx series with centrino duo.. My cpu is T2500 2.00GHz os:snow leopard 10.6.4 dsdt patch needed just replace that value with 0x46: Name (C000, 0xFD) Name (C001, Zero) Processor (_PR.CPU0, 0x01, 0x00001010, 0x06) { Name (C002, Zero) Method (CSTH, 0, NotSerialized) { If (LEqual (C002, Zero)) { Store (One, C002) Store (Zero, \_SB.C003.C004.C005) } Store (\_SB.C003.C004.C006.C007 (), Local0) Return (Local0) } Method (INI, 0, NotSerialized) { If (LAnd (And (\_SB.C008, 0x01000000), LEqual (C009 (), 0x04))) { \_SB.ISMI ([color="#FF0000"]0x46[/color], Zero, Zero, Zero) } } Method (PPC, 0, NotSerialized) { Return (C00A ()) } } Processor (_PR.CPU1, 0x02, 0x00001010, 0x06) { Method (PPC, 0, NotSerialized) { Return (C00A ()) } } also here this line added:\_SB.ISMI (0x46, Zero, Zero, Zero): Method (_SB._INI, 0, NotSerialized) { \C009 () C01C () [color="#FF0000"]\_SB.ISMI (0x46, Zero, Zero, Zero)[/color] } sometimes it hangs at the very begining, if you did a hard shotdown previously(pressing pwr button for 5 sec) otherwise it boots and works fine!!!
  6. xristos

    TSC sync XNU patch

    Please help me! i have tested everything and no way to get both cores working on HP NX9420 CPU:T2500 dual core
  7. Hi i'm having problem with ecs p4m800-m7 v3.1 motherboard. since i upgrade bios to tha latest version i can't install or boot mac osx. The computer reboots at the begining when the spinig bar of darwin is shown. I've tried many deferent optios from the bios menu but nothing... i have already dualboot ubuntu and xp. i have also an extra bios chip already programmed so i would appreciate any modified bios flash image. here is the link of my original bios firmware: http://www.ecs.com.tw/ECSWebSite/Downloads...D=6&LanID=0 My computer hardware: s-ata dvd drive cpu: intel celeron 2.8GHz ram: 1.5GB 40GB disk IDE Graphic: nvidia geforce4 440MX
×