Jump to content
InsanelyMac Forum

ziobacco

Members
  • Content count

    3
  • Joined

  • Last visited

About ziobacco

  • Rank
    InsanelyMac Protégé
  1. Peccato... la cosa che mi fa rabbia è che il device id lo riconosce. Ho provato a disattivare la scheda intel entrando nel bios advanced come spiegato qui (anche se li disattiva quelle Ati\Nvidia ma forse è lo stesso...) ma non succede niente. Per fortuna è già attiva l'accelerazione grafica sulla scheda Intel.
  2. Ho reinstallato di nuovo con la penna usb creata con myhack e ho notato che riconosce sia la scheda grafica Intel che quella AMD da subito. Il problema è che si attiva sempre e solo la scheda Intel HD3000. Come faccio a entrare nel sistema con l'a scheda video AMD? Inoltre la scheda video AMD la vede come 6470m. Grazie anticipatamente.
  3. Ciao a tutti. Premetto che mi sono affacciato da poco sul mondo dell'hackintosh ma conosco abbastanza bene quello di Linux. Ho un portatile HP Pavilion DV6 6B59EL su cui ho messo Mavericks tramite myhack. L'hardware è il seguente, con lspci -nn ho trovato anche l'id vendor e l'id device: video AMD Radeon HD 6490m 1002:6760; video Intel HD3000 8086:0116; Audio Intel 8086:1c20; Ethernet Realtek RTL 8111/8168B 10ec:8186; Wireless Broadcom BCM4312 14e4:4727; Card Reader Realtek RTS5116 10ec:5209. CPU Intel Core i7-2670QM @2,20GHz. Poiché c'è il boot anche con il Windows la partizione è con il MBR. Per far partire l'installazione ho inserito le seguenti flag che ora sono presenti all'interno del file org.chameleon.boot.plist poiché uso Chameleon (ho provato anche Chimera e sembra equivalente) cpus=1 npci=0x2000 UseKernelCache=No Inoltre ho inserito il file smbios.plist relativo al MacBook Pro 8,1. Per quanto riguarda l'hardware. La webcam la riconosce nativamente. Il trackpad lo riconosce nativamente. La batteria la riconosce dopo aver installato il kext VoodooBattery. La scheda wireless della Broadcom a quanto ho capito non è supportata, e ho risolto usando una della Edimax usb con i driver scaricati dal sito ufficiale. L'audio funziona con i kext VoodooHDA e modificando il file Info.plist. L'ethernet funziona dopo aver installato i driver della Realtek. La scheda video AMD Radeon HD 6490m non la riconosce, ma credo di aver capito che può funzionare. La scheda video Intel HD3000 funziona dopo aver inserito solo uno dei due file che ho trovato AppleIntelSNBGraphicsFB.kext poiché se metto anche AppleIntelFramebufferCapri.kext non riesco a mettere la risoluzione 1366x768x32 (nonostante ho inserito la direttiva nel file org.chameleon.boot.plist), ma non funziona l'accelerazione grafica QE/CI. Inoltre il boot è un po' lento e si sofferma quando trova la partizione in ntfs. Ho eliminato NullCpupower in Extra e AppleIntelCpuPowermanagent in System/Library/Extensions ma non sembra si sia velocizzato, poiché avevo letto che con i processori i7 si potevano anche togliere, anche se in realtà non ho ancora capito il loro utilizzo. Quello che vorrei è far funzionare la scheda video AMD Radeon HD 6490m con l'accelerazione grafica. Nel caso non fosse possibile vorrei abilitare l'accelerazione grafica all'Intel HD3000. Inoltre vorrei capire se c'è un modo di ripristinare i kexts iniziali poiché spostandoli, inserendone altri e patchandoli penso di aver modificato un po' di cose... Grazie anticipatamente dei consigli. EDIT1: mi sono dimenticato di scrivere che avevo fatto il file dsdt.aml ma ad un certo punto andava in kernel panic e per farlo partire ho dato la direttiva al chamaleon dsdt con un percorso errato, così non caricando quel file mi ha permesso di entrare nel sistema e di rimuoverlo, ma forse con -x avrebbe funzionato lo stesso. EDIT2: mi sono accorto che su questa comunità c'è il tool Pandora, mi consigliate di reinstallare il sistema utilizzando questo tool?
×