Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About katabathos

  • Rank
    InsanelyMac Protégé
  1. HD4000 on 6 series no QE

    Solved: use DSDT for series 7 / HD4000 on series six motherboard. Thanks to microsoftFTW who patched my DSDT for me. Use DSDT plus injection - e.g. with chameleon, the following worked for me: <key>Graphics Mode</key> <string>"1920x1080x32"</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>IntelCapriFB</key> <string>10</string> Full acceleration - QE and all. Good work.
  2. HD4000 on 6 series no QE

    Thanks for that. I've heard about the MEI patch, but don't know what to do to use it. Could you explain how I use that stuff? Cheers
  3. HD4000 on 6 series no QE

    Post Hello there, having a bit of difficulty getting HD4000 graphics to work fully. Current situation: About This Mac reports: Intel HD Graphics 4000 1024 MB Screen resolution is good - all seems to be working fine. Sleep / wake appears alright. Sound good. Mouse is not laggy - all seems fairly responsive except accelerated graphics=none. No QE - opaque menu bar etc No video such as bbc iplayer - black screen. Youtube works but is not being driven by card - uses lots of processor. Asus P8H61-I (6 series sandy bridge desktop) i3 3225 (7 series ivy desktop) 4gb RAM Yosemite 10.10 Vanilla install following these guides: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/ http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/ Chameleon 2.3svn r 2578 I’ve tried various combinations of bootflags: GraphicsEnabler=yes / =no IGPEnabler=yes / no IntelCapriFB=0 through to IntelCapriFB=11 - kernel panics every so often; nothing better than chameleon’s default. -f and loads of other things! kextstat reveals intelHD4000 is loading. also tried KemalAlkin’s patched AppleIntelFramebufferCapri.kext and AppleIntelSNBGraphicsFB.kext to see if that helps - no! https://www.hackintosh.zone/get-files/get/127-intel-hd-3000-hd-4000-driver-for-mavericks-109/ no SSDT or DSDT __________________________________________ Any suggestions on how to get HD4000 working properly? I’ve been doing a lot of reading around on this forum, but no luck so far. chameleon plist, kextstat output, and screenshots attached for more detail. cheers _________________ Chameleon plist: <key>Graphics Mode</key> <string>"1920x1080x32"</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>Kernel</key> <string>/System/Library/Kernels/mach_kernel</string> <key>Kernel Flags</key> <string>-v</string> <key>SMBIOS</key> <string>/Extra/SMBios.plist</string> <key>Timeout</key> <string>5</string> ________________ SMBIOS Pretending to be mac mini 6,2 kextstatoutput.rtf