Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

  • Days Won


joshhh last won the day on June 18 2012

joshhh had the most liked content!

About joshhh

  • Rank
    InsanelyMac Geek

Contact Methods

  • Skype

Profile Information

  • Gender
  • Location
    Russia, Israel
  1. Mavericks Installation from Install OS X Mavericks.app 1. Prepare USB flash drive or HDD-SSD Partition for OS X Installer For USB Flash - format it with options GUID, HFS+ Journaled For HDD-SDD partition, disk should be GUID, format partition as HFS+ Journaled. In this case we need 2 partitions: Installer partition and target partition for installed OS X. 2. Prepare Installer Open Install OS X Mavericks.app/Contents/SharedSupport/InstallESD.dmg. Restore OS X Install ESD/BaseSystem.dmg to USB Flash or Installer partition on HDD-SSD Copy folder OS X Install ESD/Packages to Flash or Partition into /System/Installation/ with overwrite. Extract mach_kernel from /System/Installation/Packages/BaseSystemBinaries.pkg with Pacifist tool. 3. Install bootloader and kexts For USB Flash: install Clover boot loader and necessary kexts into System/Library/Extensions. FakeSMC required for first Installer boot. For Installer HDD-SSD partition: install necessary kexts into System/Library/Extensions 4. Boot Installer with ignored kextcache and Install Mavericks to selected partition 5. Reboot to working system and install necessary kexts to Installed 10.9 partition 6. Boot Installed and configured Mavericks Kexts You can use AppleACPIPlatform.kext and AppleHDA.kext from previous OS X versions AppleIntelCPUPowerManagement and AppleRTC can be patched with Clover boot loader while boot You can use FakeSMC, IntelE1000e, VoodooBattery, VoodooPS2Controller and system monitoring kexts as is without modifications Files Mavericks in Appstore Latest Clover http://sourceforge.net/projects/cloverefiboot/ Clover Configuration Converter to convert clover config from versions 1xxx to 2xxx http://www.osx86.net/files/file/49-clover-configuratorconverter/ Older kexts and dsdt http://www.insanelymac.com/forum/topic/274218-guide-lenovo-thinkpad-t510510i-plus-t410-and-w510-106-107-108-all-working-ok-20121202-update/?p=1783268 PS: Since I've sold my T510 this summer I no longer can test OS X on this hardware, but initial DP builds of Mavericks worked fine on it. So final version should too.
  2. Anyone mobile Kepler 6xxM working?

    On Lenovo W530 I've tried to unplug internal screen connector and use only external monitor. Booting hangs in this way too
  3. Anyone mobile Kepler 6xxM working?

    I have this ioregs you've mentioned above with nvidia drivers loaded and logged in via VNC. All my dumps from lenovo w530 in this post http://www.insanelymac.com/forum/topic/284767-anyone-mobile-kepler-6xxm-working/?p=1915493 But unfortunately I've sold w530 few weeks ago and hope this info may help to other users with mobile keplers. Cheers!
  4. Anyone mobile Kepler 6xxM working?

    Here it is, IOReg dump from my current Macbook Pro Retina 15 inch. After few month of kepler headaches with Lenovo W530 laptop I've sold it and bought Apple one. Hope this info may help to people with Keplers in laptops Andrew’s MacBook Pro.zip
  5. Anyone mobile Kepler 6xxM working?

    Yeah! Only one idea - sell pc laptop and buy mac one
  6. Anyone mobile Kepler 6xxM working?

    Really don't know if all of 26 occurrences is related to this problem. But in case of bios whitelist patching most of offsets is relative and we don't need to worry about it...
  7. Anyone mobile Kepler 6xxM working?

    OK! I've decompiled NVDAResman with hopper disassembler If someone can try to find probe function asm file is attached below NVDAResman.asm.zip
  8. Anyone mobile Kepler 6xxM working?

    -v -f and debug=0x100 or debug=0x144 and maybe io=0xffffffff
  9. Anyone mobile Kepler 6xxM working?

    Another attempt to find out what's wrong with mobile keplers With additional debug info I get lines in log with NVDAHal NVDAgl registering - this is acceleration modules for QE/CI I get it working on retinabook. But when we remove NVDAResman we lost it. So some checks in driver stop loading osx to GUI Some shots from 10.8.5/10.9DP2
  10. Here it is. Vbios from macbook retina and quadro k2000m both gk107 chip vbios-from-work-system.zip
  11. AppleHDA Patching in 10.9 Mavericks

    Replace AD1984 to ALC662, and ALC884 to zero 8419d411 > 6206ec10 8408ec10 > 00000000
  12. Lenovo ThinkPad T420 with UEFI Only

    Hello! I have same situation. I've got old T510 and new W530 and little stuck with W530 in case of nvidia gpu. Boots fine with latest Clover without any trouble on both laptops. And even installed new 10.9 with clover with no problems) About your T430 I have few suggestions: 1) Wi-Fi card can be replaced with AzureWare AW-NU706H it's in mPCIe form factor but instead of pci-e it use usb pins , based on USB chipset Ralink RT3070 which works fine in OSX with ralink drivers. Also some realtek usb cards may work well 2) HD4000 need's correct id injection, I think in T430 we've got same layout of outs on HD4000 and Nvidia NVS. HD4000 can only drive internal LCD, nvidia can drive LCD + all outs (VGA+DP+Dock outs) In my case I use AAPL,ig-platform-id: 01660004, and HD4000 works fine with it Method (_DSM, 4, NotSerialized) { Store (Package (0x0E) { "AAPL,ig-platform-id", Buffer (0x04) { 0x04, 0x00, 0x66, 0x01 }, "device-id", Buffer (0x04) { 0x66, 0x01, 0x00, 0x00 }, "vendor-id", Buffer (0x04) { 0x86, 0x80, 0x00, 0x00 }, "subsystem-vendor-id", Buffer (0x04) { 0x6B, 0x10, 0x00, 0x00 }, "subsystem-id", Buffer (0x04) { 0xEA, 0x00, 0x00, 0x00 }, "revision-id", Buffer (0x04) { 0x09, 0x00, 0x00, 0x00 }, "hda-gfx", Buffer (0x0A) { "onboard-1" } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } But I've also have some differences: USB3 works ooh but only with usb 3.0 devices - my seagate flex hdd and transcend card reader works in usb 3.0 ports but usb 2.0 devices doesn't. Also I can't boot fine from usb devices, boot stuck after some time on wait for root device... *** W530 specific My nvidia gpu doesn't boot to gui and stuck in console. It's kepler based on gk107 chip as GT 650m in my retina mac but it simple doesn't work. All tries with no luck
  13. Anyone mobile Kepler 6xxM working?

    Installed first beta of 10.9 and still no luck with Keplers, stuck after NVDAStartup official...
  14. Anyone mobile Kepler 6xxM working?

    Repeat, not all 6xx cards is Keplers 670M is Fermi, so don't post anything about it here
  15. Anyone mobile Kepler 6xxM working?

    tried, didn't help