Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

harbri

Members
  • Content count

    42
  • Joined

  • Last visited

About harbri

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  1. TRIM support

    Of course it was only a matter of time before someone would figure out how to use the TRIM-command on non-Apple SSD's. Click here to read how to do it.
  2. TRIM support

    Hi, There's an interesting article on TRIM-support in Lion (10.7) but also in Snow Leopard (10.6.6) on hardmac.com: TRIM-support
  3. DeviceMergeNub for _DSM style injection

    I also join Scrax in his request for more info, I'd also love to know how you did it. Thx! harbri
  4. DeviceMergeNub for _DSM style injection

    Thx! That's an impressive piece of work, I can learn a lot from it. harbri
  5. DeviceMergeNub

    Hi, In this post you can read about the DeviceMergeNub kext made by Andy vanDijck. This kext can be used to inject values into pci-devices by entering values in de plist file. It is already used succesfully for audio, DVD-drive and firewire. In the thread it is mentioned that it can also be used for graphic cards. Is there anyone who would like to give it a try? harbri P.S. I did try myself but I'm not sure what values to enter in the plist.
  6. DeviceMergeNub for _DSM style injection

    Could you please post your plist. I'm curious how you got your graphic card working as I get a kernel panic each time I try it this way. Thx! harbri
  7. I've had the problem with the preview application not showing anything since I replaced my nvidia 8800GTS with a new Sapphire HD4890 Vapor-X. Last week I finally solved the problem thanks to a thread in the ati-subforum. Here's the link to what I did to solve it.
  8. [Guide] HD 4890 in SL 10.6.3

    I have the Sapphire Vapor-X HD4890 1Gb. Device-id: 9460 Vendor-id: 1002
  9. [Guide] HD 4890 in SL 10.6.3

    No I don't think that is normal. I just tried it at my own hackintosh but when I click on the Preview icon in the Dock it just starts up.
  10. [Guide] HD 4890 in SL 10.6.3

    I finally got preview working with my Sapphire HD4890 Vapor-X today! Here's how I did it: - I did a clean install of OSX. - Installed Chameleon RC4 - Installed the Extra folder in root containing dsdt, smbios.plist, com.apple.Boot.plist (without the graphicsenabler option!!) and Extensions subfolder (fakesmc, EVOEnabler, OSXRestart, LegacyYukon2). - Rebooted into the newly installed OSX - Installed 10.6.3 combo update package (don't use Apple Software Update!!) but didn't reboot - Installed QE CI Exotic cards 10.6.3.pkg - Installed Fix for a fix package - Rebooted Bingo!! I finally have a fully working 4890 with working preview :-)
  11. ATI Rom in Chameleon RC4

    Thanx for the fast responses, I really appreciate it. Sorry for my bad English but that's because English isn't my native language. I tried that this morning, I renamed my file to ati_9460_1002.rom and put it in the Extra directory on the hidden EFI-partition but it still doesn't work. Strange thing is though that the "built-in image" which gets loaded when only using the GraphicsEnabler switch works excellent. Maybe it's because I have the bootloader on the hidden efi-partition? Today I'll do a full reinstall from Snow Leopard on an USB-disk and try it with the boatloader on the OSX-partition. If you have other suggestions please let me know as I'd like to get it working. Ok thanx for the info. I first noticed it when I started experimenting with the ati-rom so it has probably been there way before that. Any hints what I have to do to solve this? As for kexts, thanks to the Gigabyte DSDT thread I've got an excellent DSDT-file for my mobo. I only need the FakeSMC.kext and the LegacyATI4800Controller.kext, the rest is all done in the DSDT-file.
  12. ATI Rom in Chameleon RC4

    Hi, I've tried several things to get the ATI-Rom from my own 4890 Card working with Chameleon RC4, but so far without any succes. This is what I did so far: * Startup in Windows, used GPU-Z 0.3.8 to save the bios to file. Result is the file: RV790.bin * Still in Windows I then used Radeon BIOS editor v1.22, loaded the bin-file in this tool and saved it as type *.rom. Result is the file:2D - 240, 1050, 1.053 3D - 870, 1050, 1.313.rom * I renamed the rom-file to ati.rom * Started up OSX, copied the ati.rom file to desktop in OSX. * Chameleon RC4 is installed on my hidden efi-partition so I copied the ati.rom to the root of the efi partition. * Next I've added this option in the com.apple.boot.plist on the efi-partition: <key>VideoROM</key <string>/ati.rom</string> * On booting I get the error: Failed to read bootsector from BIOS device 100h. Error=1 I've also added the parameters GraphicsEnabler=Yes|No and VBIOS=Yes|No alone or in combinations but I still get the same error. I've also downloaded an 4890 rom image from an internetforum but it gave me the exact same error. Does anyone know what's wrong and how to solve it? harbri
  13. DSDT fixes for Gigabyte boards

    With the help of this thread I've achieved quite a lot over the last weeks with my dsdt file but now I'm completely stuck. I've got most things working like sleep and speedstep but anything I'm trying to change now results in either a kernelpanic or loss of funcionality. For example I've tried to implement the wake from keyboard fix but I simply can't get it to work most of the times resulting in the loss of the sleep functonality. Is there anyone who can point me in the right direction? I've attached the dsdt-file I've made for my mobo (EP35-DS4). I haven't seen a response from formerlyknownas so I thought I'd give it a try as it's the same motherboard but with a different processor. I've changed the processor info with my info and gave it a try. Unfortunately that dsdt-file doesn't work, USB1 through 6 are shown as "Expansion Slot" and the SATA controller is reported as "Unknown Standard Controller". The device-id's of USB1 through 6 should be 0x3a34 through 0x3a39 instead of 0x2934 through 0x2939 but I can't figure out how to change that in your dsdt. dsdt.dsl.zip
  14. DSDT fixes for Gigabyte boards

    I'm more then happy to test it but my _PTS method looks like this: Method (_PTS, 1, NotSerialized) { Or (Arg0, 0xF0, Local0) Store (Local0, DBG1) OSTP () If (LEqual (Arg0, One)) {} If (LEqual (Arg0, 0x03)) {} If (LEqual (Arg0, 0x05)) { Store (ESMI, Local0) And (Local0, 0xFB, Local0) Store (Local0, ESMI) } If (LEqual (Arg0, 0x04)) { If (LNot (PICF)) { Sleep (0x64) } } } So please let me know what to add/change and I'll give it a try.
  15. bluetooth dongle for SNOW?

    Yes there are, take a look at this: http://stellarola.tumblr.com/post/20218155...-dbt-120-rev-b2
×