Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About jumono

  • Rank
    InsanelyMac Protégé
  • Birthday 06/11/1999

Contact Methods

  • Website URL
  • Skype

Profile Information

  • Gender
  • Location
    Québec, Canada
  • Interests
    I love coding and stuff. I'm just that young one with alot of computer skills.
  1. Good news for El Capitan users, the second beta fix'd the bug where if unplugging/going into sleep mode made the computer crash.
  2. [Tuto] Installer OS X 10.10 DP1

    Salut les gens, j'ai réussi a installer Yosemite sur mon Lenovo Thinkpad T530 et puis je ne suis pas capable d'activer ma carte graphiques avec clover. Normalement j'utilise les bootflags de Chameleon pour ma carte Intel HD4000 (Cela inclut le flag "HD4000PlatformID", "IntelCapriFB" et "device-properties") et je trouve pas les alternatives a ces bootflags sous Clover. Quelqu'un aurais t'il une astuces pour moi ? J'ai aussi essayer avec mon dsdt de Mavericks sans succès et du coup je peut nulement utiliser 10.10 qui semble magnifique.
  3. what works what doesnt 10.10

    I can start the system with OS X 10.10 installed but my graphics acceleration are very slow, I'm trying to find a way to active my Intel Graphics 4000, i've never used Clover before and I can't find any answer, btw does somebody could help me enabling my gpu ? In chameleon I need to set IntelCapriFB=9 and HD4000PlatformID=9 and I also have a very long device-properties that I can't find any alternative inside Clover. The system look very good but I can't run it correctly, also the system information tells me that no kext is loaded for my gpu.
  4. Just before we start, this is my first post and also i've seen nobody that have fixed this by using my way and I don't guarantee that this will work for you. If you're just here for the fix just go at the point #2. This is mostly for users using Ethernet Cable and for laptop users which have installed VodooBattery or any other kind of battery patch. DON'T APPLY THIS PATCH IF A CUSTOM AppleACPIPlatform.kext IS NEEDED FOR YOUR HACKINTOSH TO BOOT, IF YOU TRY TO APPLY THIS YOU MIGHT NOT BE ABLE TO BOOT AGAIN. I also don't know if this fix also iMessage, Icloud and some others apple apps like these. Also, this things worked for me so I don't see why would this doesn't work with others people but as I only tested it on my laptop, I can't confirm that work everywhere and also if this post was just my personal fix, I will sure delete it after. 1- Bunch of informations: If you are a laptop hackintosh user you've might have installed VoodooBattery or some others fix like these and i've realized that all of these fixes needed to install a rollback of the "AppleACPIPlatform.kext" from Mountain Lion, which allow some users to get their battery meter working. But of some reasons, since the 10.9.2 update, this cause a bug that change somehow my ethernet connection to "Ethernet adapter (en0)" or something like instead of simply "Ethernet". For somehow, Apple Store will block you from connecting if your Ethernet interface is like these. I've found this while working around with my external OS X installation with the same version but I wasn't having the same "AppleACPIPlatform.kext" and the Apple Store was working great. 2 - The fix itself : There's no big deal to fix this problems (Well that's how I fixed mine). First : To know if this fix apply to you here is my internet specs: I'm using ethernet cable. When you try to add a new Ethernet interface inside of the Network Manager, the name of the ethernet interface will be only "Ethernet" and might not be "Ethernet adapter (en0)" or something like that. If you're using Wi-Fi or your Ethernet interface is named only "Ethernet", this patch might not be used at your own risk. (I don't guarantee again that this fix is universal or it is just for me.) Second : Check if you have an edited "AppleACPIPlatform.kext". The best way to do this is by checking his own size inside /System/Library/Extensions/AppleACPIPlatform.kext The original kext is about 627kb. (If your file is that size, that must means that your problems is not coming from this file and maybe you will need to find a another answer.) Also the rollbacked kext is about 1,1mb. Third : You will need to reinstall the original kext from Mavericks. Don't worry, I will post mine on this post but i'm not sure if it's going to work for everyone so you should make a backup first of yours because I have only tested this on my laptop. To install it : You can use "Kext utility" that can be found easily around forums and hackintosh websites and it's free or you can use the manuel method. With Kext Utility: To use it, simply open it, enter your password. and just drag the "AppleACPIPlatform.kext" downloaded from attached files inside the Kext Utility window. And you're done, Kext Utility repair disk permissions by itself so no need to do this. (This method sometime takes a little bit of times so please be patient) Manuel method: (I use this one because of Kext Utility being slows at installation but kinda more complex) Make a backup of /System/Library/Extensions/AppleACPIPlatform.kext to your desktop or whatever you wants. Drag my copy of the kext inside the Extensions folder from above. Enter your password when asked. After installation you will need to repair disk permissions. Repair disk permissions: (If you used the Kext Utility method for installing the kext, you can skip this step) Using Kext Utility: (I use this method) Just launch it, enter your password when prompted and wait for it to be done. Using Disk Utility: (Inside your application/utilities) Open it, click on your hackintosh installation partition and click on the "Repair disk permission" button. Wait while it's doing it (I recommend you to bring Popcorn while using this method, seriously Disk Utilities is taking forever) If you have some problems or don't understand this part, just go look on Google for some Kext installation tutorial, installing kext isn't that easy but if you're looking at this I presume that you have a great understanding of how hackintosh work. Fourth : Reboot your hackintosh and now go check if the App Store is working If it's working well have fun with this! 3- "But what if I wanna have my battery meter working back?" Well as I said before, some users need the ML kext to get their battery meter to works, and that's why I asked you to do a backup of your old one before applying the patch. Just before, I have to tells you there is no kind of patched ML kext for Mavericks, well basically, you can't use this patch and have your battery meter working at the same time. The only way to reactivate your battery meter from using VoodooBattery or AppleSmartBatteryManager (Patched one) is to reinstall it each time you need it. I know, that kind of suck but this isn't that hard to do. All you've got to do is simply do the same step from above but instead of using the Mavericks Kext, use the ML one and it should makes your battery meter works again. But it will also make the App Store and others apps using Apple Account will not work. I'm also working on a simple script that will make you able to switch between the two kexts when the needs is here. I recommend using the Mavericks kext only when you needs to do update or install new apps from the App Stores and then switch back to the old one after. Thanks you everyone from reading it, also sorry again for my bad english, my main language is French Canadian and I hope that this will help some of you! If you have any kind of problems or you can't understand this post, just ask in the comments below or contact me via pm or Skype. AppleACPIPlatform.kext.zip