Jump to content

Ingwie Phoenix

Members
  • Content count

    13
  • Joined

  • Last visited

About Ingwie Phoenix

  • Rank
    InsanelyMac Protégé
  • Birthday 12/30/1993

Contact Methods

  • MSN
    keviningwersen@hotmail.de
  • Yahoo
    kinglegiza
  • Skype
    wlaningwie

Profile Information

  • Gender
    Male
  • Location
    Germany
  • Interests
    PHP, DJ, Drums, Tinkering&Tuning of technical devices
  1. Hey! So, I saw this, and I feel like sharing this. I am working on quite a big project since a year now - the drag0n installer, short: d0. d0 is a PHP-CLI based programm to manage and install software....yah i know, sounds similar. But which package manager could install mods for games like Minecraft - natively? It also brings a GUI interface and can be commanded thru an URI scheme which is close to the CLI interface - though the URI one needs user-verification since we dont want people to install malware into our systems. Since d0 is based on PHP, JavaScript, NodeJS, AppleScript and a little bit of bash, it is completely open-source. I am planning on a web-service which currently goes by the codename "ph03nix" which will give developers a web-access to create their own repositories for d0. Benefits in d0: - Everyone can upload their packages. - The system knows so-called "Trusted Resources" which can be added by a name instead of a full URL. Like, if there was a dev-team called BugNutz and they registered a trusted resource by the name "bugnutz", then a user will not need to type in a long URL and instead can just type in a simple name and is good to go. Untrusted resources will be highlighted if they arent found in a database of the software. - The same as above can be archived for packages. - It supports every *NIX platform, and will be ported to Windows once it works. Because of its rather minimal requirement, it may be ported to handhelts. The extraction-process of a package and the configuration files are fully parsed by PHP. The only thing which is not PHP, is the way the GUI is created - in a web-interface. To spawn such, we use appJS. But within the browser, we have PHP running with Yii 1.1.11 :3 - It does not modify any system files during installation and can be drag-and-drop installed. - Developers can declare pre and post scritps for install, update, remove and reinstall. - d0 supports source-code installations with its pre and post scripts. The source will be saved somewhere, where the user may have access to. - d0 will install its packages into the system default locations - no stupid PATH editing. It will just fit right within to avoid having the same library seven times on the system, each located to a different PKmanager. - Allows to be controlled via GUI, CLI and URI (d0:-scheme) - Own package-format which manages to shrink 90MB to 50MB...so it has a good compression. - Installation is also possible from other files. Developers can extend Drag0nPackage in PHP and add their own types - like DebianPackage? - Completely open-source and no obfuscation. - Runs on technically every version of PHP 5.x - but once I decide to namespace it, it will only work with php 5.3+ - Does not require any additional thing. But if you want to install a source-code, d0 will tell you to download neccessary things first. - Finds and lists already installed things, like the native OS, so packages can be OS-dependent. - Dependency check. Allows to recrusively install all dependencies. Once I have finished editing some files I might upload the current version. The one on GitHub is absolutely {censored}, and is only ment to give a basic idea on how it may look like behind the scenes. Suggestions, and help, is welcome. Email me at ingwie2000@googlemail.com because this forum refuses to send me emails x)
  2. Brightness on HD 4000

    Oh yeah, the ever-frustrating brightness, is it not? ._. So I tried a BUNCH of topics to solve my issue - here are the links to each: In Topic: [Guide] Backlight + Brightness for Intel 8086:0046 (1st gen HD) (GMA 5700MHD) In Topic: ACPI Backlight Driver In Topic: ACPIBrightness level Fix problem ...result? Zero. My PNLF device exists, and works, and changes brightness...without a kext. BUT. It stays incredibly dark. Only when my screen wakes, from sleep, it suddenly decides to work again...errrrm, yeah? >.> So, in the second link, I just recently posted my DSDT, though I realized I have a duplicate of the _DSM method...I might reupload my DSDT at some point and put a link into my signature. Whatever. Anybody who can give me a working solution would be a hero in my eyes. Im not too dumb to work with scripts and learned to understand my DSDT. But I am still new on that one. Regards, Ingwie
  3. ACPI Backlight Driver

    So I just ran thru the forst of messages, and Now i realized my issue...the injector-code. I absolutely have NO CLUE where to put it X3. I know the method, but when I compile, I get a "already exists" error. >.>... Gonna try the patched version up there real quick since I hae the same issue, mayby by some magic it makes my brightness work. Besides. I am able to change my brightness without the driver, however...it says its on maximum, but its horribly dark. Only when my screen sleeps and comes back, THEN it suddenly becomes all normal (or better said, bright) again... waaaat o.o". It seems though that my emulated NVRAM does a nice trick and saves my brightness level! ... but, it doesnt affect the hardware, booo. v.v Ill attach my DSDT later. Edit: Weeeeell, here we go! Sony Vaio Duo 11 (SVD1121X9EB) [Pre-Patched]
  4. So I followed all the instructions given, but, my issue isnt solved. ._. The brightness works, yes, but it isnt bright. I just need the PNLF device and it'll suddenly get me a slider and such - not even need a kext. But its not bright. When my screen sleeps and gets back on, its as bright as it should be. What do I need to fix? :/ it's frustrating...especially because my DSDT now feels 2x as long as its original dump was. o-o
  5. ACPI Backlight Driver

    Hi! So I put this into my ML install by side-loading it via injectKext in Clover (.../CLOVER/kext/10.8(). It did load properly, but now when I change my brightness, it doesnt change at all x). I didn test if it is my emulated NVRAM, but that shouldnt be a cause O.o Any help would be great. My DSDT is patched with PNLF.
  6. ACPIBrightness level Fix problem

    Hello to a dead topic... well, not as dead as it seems. I have been trying to get my Vaio to work completely. It keeeeeeps acting weird, but it somehow works. But I have the odd issue myself. Poking the DSDT didnt solve it, replacing VoodooBattery with a patched Apple-thing didnt do it, and the last download wont extract - error 20 "not a directory". Derp? So, what possibilities do I have to restore my 4 states? I can easily post my DSDT, though it's prepatched with PNLF and alike, which work very well - even my emulated NVRAM does =)
  7. Sony Vaio Duo 11: Fixing Brigntness, Sleep, USB3, Touchscreen?

    Ah, right - reminds me on PHP's namespaces x) So, in a tutorial I read, they said I need to figure out which "idendifyer" my display has. In yours i see APP0002. When I roam around my DSDT, I can't find anything like LCD or alike. I do find my GFX0 though. Where approx. is the screen's idendifyer usualy? Regards, and thanks for the help so far! :3
  8. Sony Vaio Duo 11: Fixing Brigntness, Sleep, USB3, Touchscreen?

    Greeeeeat! Applied both and got them working. In fact, the USB3 was my own fault - I got foobar'd by my BIOS. While installation, I set XHCI=false so my ports were forced into USB2, since I knew this would work better with Mac. Now, I found the XHCI patch - but forgot to turn USB3 back on xD. But it works now. I also got rid of NullCPUM and have a native booting experience But I am still not sure on the PNLF. Can you tell me the approx. line number to add the piece of code to? BTW, I am a PHP coder, so I understand a fair bit of file/code editing - in fact, im going ot studdy your little SH script when i am not busy Regards, Ingwie
  9. Changing Intel Centrino Advanced N 6235

    I dont have the same notebook - I have a Vaio duo 11. But I am in a similar issue, same Intel-chip. I saw iwidarwin had a project going, but they never made it to the 6235 it seems...
  10. Hello everyone! I am sharing the DSDT that DSDT Editor was able to extract for me. I have a near-complete installation, I am just missing small things like the brightness, USB 3, Sleep and to somehow disable the touchscreen since it is acting up the OS. I know that, for brightness, I need to add a PNLF (or similar...) device. But I am not able to spot my screen - I only find GFX0, but I am unable to idendify my screen like LCD0. The same comes in for sleep - when I select the Stand-By option from the shutdown-dialog it does indeed go down, but when I press the On/Off button again, it seems to crash as it tries to wake up, then completely reboots and prints me an error message in the dialog "The system wasnt shut down properly". But due to my Impairment, I am unable to actually read the error report :/ For USB 3, I installed "GenericXHCI" - or something like that - but it didn't work as well. Furthermore, if I make the OS boot with caches (In clover, "NoCaches"=>false) then I actualy loose my 2nd USB hub which correspondents to the actual ports on the device where I could plug in a device. I also have to use NullCPU because the OS doesnt seem tor eally like my processor - but idendifies it completely correctly as an intel i5. O.o I hope somebody is able to help me. My setup: Mashine: Vaio Duo 11 (SVD1121X--) Processor: Intel i5 (1,7GHz, dual-core) HD: 128GB SSD Graphics: Intel HD 4000 Screen (/ Touchscreen): some 1920-like resolution, its a retina-display, because when I reduce the actual screen resolution, the image litterally appears multiple times. It's 11" widescreen Boot: UEFI. Using CloverEFI Boot-args: slide=0 Regards, Ingwie! PS: Since uploading doesnt work at all since I am "not permitted": http://ingwiephoenix.tk/DSDT.aml
  11. Applying DSDT patches to Clover

    Hey everyone! I have managed to get Mac OS X 10.8.4 working on a Vaio Duo 11 and have used the Clover EFI bootloader since I really didn't want to return to BIOS/MBR booting after having gotten used to UEFI/GPT booting ^^;. Now, I have the issue that my screen is recognized as an external monitor. So when I sleep my Hackintosh, the screen stays all bright - thus, I can't change the brightness at all. Here are some of the details that I know of about the Vaio: Name: Vaio Duo 11 Version: SVD1121X9EB Graphics: Intel HD 4000 RAM: 4GB CPU: Intel i5 HD: 128GB SSD (currently 3 partitions, GPT/GUID) Ethernet: Some Realtek, its recognized properly WiFi: an Intel WIFI card...I heared I can not get this one to work in OS X which is kinda bad. Screen is a retina display - it can do some 1900-something resolution, and its an 11" one. The clover instructions have been confusing me forth and back. I can't figure out where to playe the DSDT file, and especially, I can't really tell what the piece of DSDT means. The bit of DSDT I found here: http://www.insanelymac.com/forum/topic/236835-updated-2012-genericbrightnesskext/ Also I must say, very nice forum here =). Regards, Ingwie!
  12. Intel® Centrino® Advanced-N 6235

    Hey everyone. I have a Sony Vaio Duo 11 - and appearently, it comes with the driver named in the title. I have the system itself fully set up. Ethernet behaves a little strange although I have installed all the drivers - and appearently I dont have osund and brightness just yet. But what bugs me most is the WiFi. Does anyone know a way I can get my hands on this device's driver? Regards Ingwie.
  13. Sony Vaio Duo 11

    Hello everyone! First of all, I'd really like to say thanks to all these that contribute to this "scene" - or as it was said int he quiz, "hobby". Yestarday, I bought a Vaio duo 11 to side with my MacBook and I knew about hackintosh, so I had all the resources - especially, a real mac - just at hand, and tried everything out. Here are my results: Prepairing a usb device with myHack: Works like a charm. But you seriously must make sure you use MBR. Otherwise, it's acting funny. Thus, make sure you DISABLE intel VT and XHPI mode in BIOS. But once that is done, it just...boots. Installing Clover to a GPT formatted drive: Yes, works, but not OOB. To get Clover to boot, do this: 1. Download the Clover EFI package. 2. Start the installer, click "Select volume" and then your volume, then click next. 3. Now click customize. Here, you gotta check "Install to ESP", "Drivers64" and under themes, check the "metal" theme - it's the default. You may check another theme as well so you have an option later. I recommend bootcamp, its very nice for your eyes and if you used a mac before, its just like "Aha!". 4. Now we gotta edit the EFI files. Since a sort of "bug" in the clover installer, it lets the EFI partition stay mounted...which it actually shouldn't imo. Anyway, we can use that fact for something good. ( In case it didn't stay mounted, read my footnotes below. ) Open your Finder, and open the EFI partition. Or, press CMD+SHIFT+G and type /Volumes/EFI and hit ENTER. In there, open the EFI folder and create a new folder called BOOT. In this folder, you'll copy the files CLOVERX64.efi, CLOVERIA32.efi AND the config.plist file. Now rename the CLOVER files into boot - i.e.: BOOTX64.efi. If you installed a different theme, like the bootcamp one, open config.plist BEFORE you copy your files, edit the Theme setting and THEN copy the file into the BOOT folder. 5. You should end up with a structure like this: /Volumes/EFI/ /Volumes/EFI/EFI/ /Volumes/EFI/BOOT/ /Volumes/EFI/BOOT/BOOTX64.efi /Volumes/EFI/BOOT/BOOTIA32.efi /Volumes/EFI/BOOT/config.plist /Volumes/EFI/CLOVER /Volumes/EFI/CLOVER/......... Now, plug the device into your Vaio, press the ASSIST key, select "Boot from external" and Clover should pop up. However, when I use clover to boot, I get stuck at a "Waiting for root device" message - it obviously waits for a device. Its the same error that occured to some other people, and it is actulyl the only message in which you'll see a piece of XML! However, it looks like it has troubble with some drivers. I sadly don't have all the myHack drivers at hand, nor do I know how to install them myself. By the way, I used an entirely vanilla install of OS X. I used the one I bought from the App Store. Thus, I placed the Extras folder that is put into the drive's root by myhack into my clover folder into kexts/10.8 - of course, i moved the contents of the folder into the one i just mentioned, otherwise it wouldnt work...afaik o.o; As soon as I manage to get this working, Ill inform you. Again, when I legacy-boot Mac with chamelion and the image created by myHack, it works like a charm. I just didnt install it because I dont want to wipe my windows just yet Regards, Ingwie Phoenix EDIT 1 I managed to determine how myHack installed the image...and what mistake I did. You have to restore from InstallESD.dmg/BaseSystem.dmg first - then copy al the files fromt he root of InstallESD.dmg into the device as well. In other words, merge InstallESD and BaseSystem. Also, use myHack and run myFix to integrate all the missing kexts. that totally worked for me. I am now EFI booiting OS X. Touchscreen - who didnt expect it? - doesnt work. Stylus does, but with some oddities. Wifi isnt recognized yet. I dont know about the rest yet. Also, to boot up, you need to use Safe Mode (3rd entry in Clover when hiting spacebar on the OS X icon.)
×