Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About brawson36

  • Rank
    InsanelyMac Protégé
  1. Lenovo ThinkPad T420 with UEFI Only

    @tluck EDIT: could it be that my system definition is 8,3 instead of 8,1? If so, how would i go about changing this definition? EDIT: changing definition from 8,3 to 8,1 in clover bootloader/options/smbios worked, but i have to change the definition every time. anyway to keep this permanent? As far as the track pad, I noticed that in the 1888 pack, the tracking would be sometimes inconsistent and even turn off when i accidentally hit an unsupported key on the keyboard (f1-f12). So I went on the original install I made using the first posts instructions, looked in efi/clover/kexts and took the voodoops2.kext and brought it over to my main install. put it in my extra folder ran ihack and the darn thing worked like a charm. accurate tracking no ghost scrolling 2 finger scroll x and y 4 finger swipe for desktop, all open apps, and switch to dashboard
  2. Lenovo ThinkPad T420 with UEFI Only

    got better trackpad by rolling back to original voodoops2 kext. now im wondering how to run my lenovo display AND displayport to hdmi monitor as extended displays.
  3. Lenovo ThinkPad T420 with UEFI Only

    @fdandy006 yes i notice that when using the trackpad. (and also, after updating to 1888 with tlucks pack, i have lost multi gesture support?) now that ive had a much needed dumbed down explanation haha, I finally got this thing booting with 1888 and sound. however i did run into the mute-freeze problem along with the trackpad going out on me after sleep.
  4. Lenovo ThinkPad T420 with UEFI Only

    @tluck heres what I'm running into. I first fresh install, run myhack using the extra folder with the added kexts from that other forum. I then run clover v2 r1625 (lenovo edition) so i can boot from hdd. then i see that you guys are running r1888 so then i download that from source forge and install. seems legit? =) then i can no longer boot once installing that generic version from source forge so i must use my flash drive to boot via 1625 again id really appreciate a step by step haha. I thought id be able to figure this out but seeing as its my first time hackintoshing (albeit on a laptop) im having great difficulty. and as far as dsdt.aml edits, i have no real idea where to begin. i extract my current one using DSDT editor and i know changes need to be made, but im not sure where your tailored dsdt,aml file is located in this pack? and what kind of edits would i have to make for my system?
  5. Lenovo ThinkPad T420 with UEFI Only

    This is the first method that has allowed me to boot into OSX without a pen drive. However, I'm still coming across some issues. I've read this thread over countless times and still cannot figure out what Im doing wrong. My Specs: Lenovo t420-4178AFU 2.7ghz i7 2620m 16gb corsair vengeance 1600mhz ONLY intel hd3000 320gb hdd (dell 1510 half pci wifi card on its way) So, I use the method start to finish in the first post and it works wonderfully. boots with full 1600x900 resolution and myhack+extra allows me to connect via ethernet. However the things that I notice that arent working OOB (and to be expected) are as follows: battery meter sd card reader (ive read on another post this is able to work) display port out via dp to hdmi cord sleep works half the time, never consistant. and sometimes the track pad will not work after coming back from sleep along with usb ports not returning aswell. wifi (duh) brightness controls via Fn Home and End keys *audio (can get audio using my audio kontrol 1 sound card, but thats it)*. audio controls via built in keys Im sure these are all possible to work and I know you guys pretty blatently explained how to update clover and whatnot (I assume that this is what allows the other features to work), but im doing something wrong and i just dont know it. Ive read the past post about clover 1888 and its efi package and I tried to apply that but when I do, I cant boot. I changed the folder name in EFI/Clover/OEM to my 4178AFU and replaced all the folders in the EFI partition with the ones in the lenovo install pack. Which step am I missing?
  6. I've tried installing osx via original method with 10.6 retail disk. I could get it to install no problem but never able to boot off the hdd to run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and wrap it all up. Also tried iAtkos ML2 thinking itd be a simpler all in one solution but no avail. same results. I feel like its something as simple as putting in the right boot flag. Tried: -v, -x, -s, maxmem=4096, cpus=1 My system is a lenovo thinkpad t420 Intel i7 2620m 16gb corsair vengeance 16gb ddr3 1600mhz 320gb 7200 hdd. Integrated intel 3000. I've read over multiple guides and I guess they just assume I know basic install techniques that im just not getting. Can anyone help me out?