Jump to content

karlamba

Members
  • Content count

    28
  • Joined

  • Last visited

About karlamba

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  • Location
    Poland, Wroclaw
  • Interests
    Trash metall music (my band - ltno.pl), IT general, vmware technology, linux and hackintosh
  1. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Gents, Maybe a little different topic but anyway it is also related with all the stuff we are doing here (if anyone would like to have possibility of use the original lenovo recovery image). So this is the problem that when I've created lenovo recovery image on the usb key then I can't boot from it... I've tried many many different bios options and and I'm sure that my USB lenovo recovery is prepared ok because I can boot from it my other laptop (dell inspiron). If I create recovery image but on usb disk drive then it is booting ok... but why it can't boot from usb key and exactly on my T420?
  2. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    artheros wifi is perfect for me, installed modded bios and finally have wifi fully working... all takes not longer than half hour to update modded bios and switch wifi cards... I've bought: AR5BHB92 HP Pavilion DV6-2XXX FVGW6837 it costs me around 10$ in Poland... chears! PS - Guys it is really nice and wonderful that this topic is life for so long time and still there is always something new here...
  3. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    tluck, Somez - check this out... and the Guy put this T420 hackintosh guide on his youtube film... so the question is how he did it? PS - @tluck, many thx again about this guide and your help. I've just bought artheros wifi, installed modded bios and finally have wifi fully working... all takes not longer than half hour to update modded bios and switch wifi cards... chears!
  4. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    well - I don't have working wifi but I was thinking about TP-LINK TL-wn823n mini nano usb 300... Which exactly internal wifi do you use? 1510 from dell? Do you have a link to modded bios or I should just look into the history of this thread? Will it be enough to just install modded bios and put new wifi card (for example the same as you have) or I need also "edit" the white list of supported cards?
  5. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Guys, can someone recommend an USB WiFi card which will work even when I will wake laptop from a suspend? I see some wifi cards mentioned in the history of this thread but maybe something changed?
  6. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Gents I know that in this topic history there was mentioned about some examples of woking wifi cards or wifi usb adapters which can be used without any problems for T420... but... Maybe we could make some update into this and all of users who have working wifi could put some info about it? Then we could gather all of this info and create even an 'table' with description so everyone new could chose the best for his needs and budget?
  7. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Exacly... I'm very sorry because it is really shame... the simplest thing was the root cause here and I didn't notice this before... but as you said: I had set up in my BIOS startup order to boot first from WIN7 bootloader, then next OSX and at the end from primary HDD... so at the end... the fix was to set up boot order from HDD first... and finally I have the clover booted and I can choose between OSX and WIN7!!! many thx tluck again! for your patience and really fast help...
  8. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    eh... and it just worked for you as it is? because I did this: 1. I had El Capitan installed - and during its installation I have created additional partition for future win7 install 2. I recreated this win7 partition in disk utility app and format it as OSX too - it fixed partition table as you said and I have PMBR... so it is OK 3. I've started win7 installation and deleted this win7 partition... then created new one which also created an additional windows partition as we know. I've installed successfully win7 and... it just booted but now I can't run OSX without my USB stick with OSX installation - so something is messed up... so now I'm trying to figure out what will be the best aprouch to fix this: 1. recovery OSX from recovery partition? 2. or just boot OSX using USB but from HDD and reinstall clover?
  9. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    ok Guys - I've installed win7 as tluck suggested... but... now I have no option at boot to choose OS how I can fix that and boot OSX again? just boot from USB OSC inst and do "repair"? I suppose that this stomp on /EFI/Clover somehow... I still can boot via USB installer OSX and run El Capitan from HDD... I know that fix will be easy but I don't want to make any mistake and install everything again... so waiting for your advice...
  10. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    thx tluck for this info... I think the last question to this matter - to create UEFI installer will it be enough to use for example "Rufus" tool and windows installer should automatically detect that it runs in UEFI mode and will install his bootloader into /EFI/Microsoft folder partition?
  11. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Sounds good but do you mean I should reformat whole disk drive or I can in my case just reformat second partition (dedicated for win7) and install win7 on it with no damaging my current Capitan installation on the first partition? and what about UEFI win7 usb boot? should I worry about it or just install win7 normally and make corrections EFI partition after all? @trifero - I'm using second disk on my second laptop - Dell. The main problem is obvious - you need to have second disk drive... For T420 I want to finally have configured dual boot from 1 HDD - this is the plan.
  12. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Exactly - I'm trying to set up dual boot with win7... I have currently installed El Capitan on the "first" partition (as we know not first in fact) and Win7 on the "second" half of the same HDD... I've just booted from USB Win7 key prepared by - Windows 7 USB DVD Download Tool - and I've successfully run the installation. I had defined before at the beginning of installation El Capitan (but then I've formated it by using disk utils to MSDOS just to have it) the partition which I've reformated by using Win7 installator now... and this is probably the cause that now I see MBR instead of PMBR I suppose? In this case (I want to make dual boot now) - what should I do first? because I suppose it is not needed now to reformat this second partition to HFS if I want to install win7 there? so I should choose option 1 and use gdisk to convert MBR to PMBR first and after that I can just install win7 and at the end just modify/add some files/config to the existin EFI partition?
  13. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Is there any way to fix MBR to PMBR without repartitioning whole drive and reinstalling all from the beginning? I want to install Windows 7 into the same disk as OSX... Do I need a special Windows 7 USB UEFI instalator prepared or I can just install WIN7 if it just boots and see all my currently created partitions? After this win7 install can I still boot OSX? $ sudo gpt -r show disk0 start size index contents 0 1 MBR 1 1 Pri GPT header 2 32 Pri GPT table
  14. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    @tluck - 1 more observation from my side about trackpad... today I've boot with Recovery mode from HD drive... and it seems that trackpad is working very well at the beginning. The other thing is that normally when I boot my El Capitan normally the "touchpad" is working always but - if I "tap" on it then it is not recognized as Left button click whatever I do... During recovery mode this is also working like a charm... so what can be the cause? Maybe you can figure out it and have any idea? I can do some more tests...
  15. karlamba

    Lenovo ThinkPad T420 with UEFI Only

    Hi Guys again, I have 2 additional questions/remarks: 1) When I boot my T420 hackintosh then my 'trackball' not working - only works the touchpad. To fix that I have to bring laptop into sleep (by closing the cover) and then bring it up again... - it works then... Do anydobdy knows if this is normal behavior here or is there any way to fix this? 2) Thanks tluck for reminder about bluetooth - I've boot with Ubuntu Live DVD and now I have automatically bluetooth enabled on my hackintosh I've tested it with Android phone and windows phone - in both I can sent files to the phones but in the opposite way (from phone -> hackintosh) it is not possible. Is it also correct behavior and I need for example some additional tool installed on my hackintosh to be able to receive any files from android or windows phones? Cheers!
×