Jump to content

Pike R. Alpha

Developers
  • Content count

    517
  • Joined

  • Last visited

  • Days Won

    9

Pike R. Alpha last won the day on November 6 2015

Pike R. Alpha had the most liked content!

About Pike R. Alpha

  • Rank
    InsanelyMac Legend

Profile Information

  • Gender
    Male

Recent Profile Visitors

11,207 profile views
  1. I'm so sorry. Had to take a break first. Ok. Power management. Well. Open your DSDT and GPU related SSDT table(s) and then you quickly find that certain calls to the GPU bits in the ACPI tables are not there anymore, and some of them are related to GPU Power Management. Let's not forget that Skylake is the first chipset/CPU combination to introduce new power managment features for desktops. The real question is if you can do away with the missing ACPI bits and pieces
  2. Renaming the GPU device also works, but then the ACPI calls to it all fail. Not so great for power management.
  3. Try this: <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>AppleGraphicsDevicePolicy (board-id) Patch © Pike R. Alpha</string> <key>Find</key> <data> Ym9hcmQtaWQ= </data> <key>Name</key> <string>AppleGraphicsDevicePolicy</string> <key>Replace</key> <data> Ym9hcmQtaXg= </data> </dict> </array>
  4. Chameleon 2.4svn Official PKG Installer

    This should not be a problem. I have the same Samsung SM951 and it boots, but you not only need to set the partition active, but you also need to write boot0 and boot1h to it.
  5. Andres, I am going to look into this because I strongly believe that we don't need a kext. We just have to drop the "xh_rvp10" table, with help of the boot loader, and load a fixed copy of the same table. This will cure the USB troubles once and for all.
  6. Asus Z170-Deluxe And You!

    What do you want me to test? I have all but two Gigabyte motherboards to test here. Need to return them by the end of next week. Yikes! Please remove my post here and PM. This is the wrong thread for this kind of stuff. Sorry. /me ducks.
  7. Asus Z170-Deluxe And You!

    @Luke, You said: "I was able to get 1 of the ports working using AppleIGB.kext but was that the l211-AT or the l219V? Some of you may remember this post http://www.insanelymac.com/forum/topic/289729-success-gigabyte-z87-d3hp-first-haswell-hackintosh/page-7?do=findComment&comment=1928712 and all it takes now is to do the same to add support the latest Intel LAN.
  8. You can now read the background information about my work and the patch itself at AppleAPIC.kext binary patch for Skylake Reminder: I would like to remind everyone here to always add my name "Pike R. Alpha" and to add a link to the above blog article wherever this patch is being discussed and used (see https://pikeralpha.wordpress.com/license/). Thank you.
  9. Your USRn ports are disabled by the BIOS. Look here: Scope (\_SB.PCI0.XHC.RHUB.USR1) { Method (_UPC, 0, NotSerialized) // _UPC: USB Port Capabilities { Return (GUPC (Zero)) } Method (_PLD, 0, NotSerialized) // _PLD: Physical Location of Device { Return (GPLD (Zero, Zero)) } } Scope (\_SB.PCI0.XHC.RHUB.USR2) { Method (_UPC, 0, NotSerialized) // _UPC: USB Port Capabilities { Return (GUPC (Zero)) } Method (_PLD, 0, NotSerialized) // _PLD: Physical Location of Device { Return (GPLD (Zero, Zero)) } } Now look at this Method: Method (GUPC, 1, Serialized) { Name (PCKG, Package (0x04) { Zero, 0xFF, Zero, Zero }) Store (Arg0, Index (PCKG, Zero)) Return (PCKG) } The call: Return (GUPC (Zero)) Basically disables it, by storing 'Zero' into the first location of Package 'PCKG'. Now you know how it works/what it does.
  10. Asus Z170-Deluxe And You!

    I have yet to test NVMe myself, but NVMe support is built-in.
  11. Asus Z170-Deluxe And You!

    No. Gigabyte.
  12. Asus Z170-Deluxe And You!

    What Luke said is correct – I installed a Samsung SM951 and that works out of the box.
  13. We should keep this thread clean from any unrelated issues. That is. Anything not related to the Z170 HD3 should not be posted here. USB/Network issues deserve a new thread on its own. otherwise I am out of here real quick. Edit: Anyone else besides me using the IGPU? What AAPL,ig-platform-id are you using? What connectors work/don't work? Anything else that need to be fixed?
  14. Jan, I had the same errors, but now I use El Capitan 10.11.1 and I also changed "XHC1" into "XHC" in AppleUSBXHCIPCI.kext/Contents/Info.plist (look for iMac17,1) and now the errors are gone.
×