Jump to content

ksc91u

Members
  • Content count

    8
  • Joined

  • Last visited

About ksc91u

  • Rank
    InsanelyMac Protégé
  1. Hi, could you tell me which kernel you use ? And how did you install 10.13.6 ? I could not boot to 10.13.6 installer USB with 10.13.3 kernel Thanks
  2. ksc91u

    capslock not working fine

    I am using voodoo ps2 known problem: https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller/issues/81
  3. ksc91u

    Clover General discussion

    I thought 0x00 means enable SIP and other security settings? I reinstall to Developer Beta 1,keep 0x67 settings in clover. Then install all beta updates to beta 6. Now SIP is disabled.
  4. ksc91u

    Clover General discussion

    In my recovery, CSR always disabled, try to enable it via UI got "Mach error -536870212 - (iokit/common) general error" I thought it might have something to do with Clover nvram injection, so I remove RtVariables from clover config.plist, also remove kext-dev-mode=1 and rootless =0, then downgrade clover to 3241. But I can still always see csr-active-config g%00%00%00 in my nvram. Reset BIOS settings does not help either. csrutil status always says enabled. Will try to create Mavericks boot usb to disable/remove the variable.
  5. ksc91u

    Clover General discussion

    No, I did not have EmuVariableUEFI.efi, but after I install EmuVariableUEFI-64.efi , and I saw EmuVariableUEFI-64.efi load success, initialize success... in my bdmesg. csrutils status still enabled.
  6. ksc91u

    Clover General discussion

    Still can not disable csr using Clover 3253 shyhjie@temps-mbp ~ $ csrutil status System Integrity Protection status: enabled. nvram -p shows nvram is set correctly, also tried 0x55 shyhjie@temps-mbp ~ $ nvram -p bootercfg (%00 fmm-computer-name temps-mbp prev-lang:kbd en:0 security-mode none efi-boot-device <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>AA82655B-00B3-4282-90D1-536D4EA6B3BB</string></dict></dict></dict></array> backlight-level H%04 tbt-options %04 efi-boot-device-data %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%00%00%00%00%00%00%04%01*%00%03%00%00%00%00pV%09%00%00%00%00%e00%cd"%00%00%00%00[e%82%aa%b3%00%82B%90%d1SmN%a6%b3%bb%02%02%7f%ff%04%00 LocationServicesEnabled %01 csr-active-config g%00%00%00 kernel version and boot param, with/without rootless = 0 doesn't matter. shyhjie@temps-mbp ~ $ uname -a Darwin temps-mbp 15.0.0 Darwin Kernel Version 15.0.0: Tue Jul 21 21:47:25 PDT 2015; root:xnu-3247.1.68~32/RELEASE_X86_64 x86_64 shyhjie@temps-mbp ~ $ bdmesg|grep kext-dev 16:447 6:016 EDITED: -v -xcpm kext-dev-mode=1
  7. ksc91u

    device is unsuitable for gl - disabling OpenGL

    OK, I found a temporary way to work. Boot to single user mode. kextload AppleGraphicsPowerManagement.kext/ kextload AppleIntelHD4000Graphics.kext kextload AppleIntelFramebufferCapri.kext/ and launchctl bootstrap -S System Full QE/CI.
  8. My device is Lenovo T430s with i5 3230m, Intel HD 4000 I have patched my DSDT, and set IGPEnabler = Yes and IGPlatformID = 01660004 in org.chameleon.Boot.plist . But in /var/log/system.log always shows WindowServer[250]: update_gl_acceleration: device (0x7fc919e152d0) is unsuitable for gl - disabling OpenGL WindowServer[250]: initialize_display_context: dev counts are zero (0, 0) - disabling OpenGL I can boot normally, but no QE/CI. kextstat shows AppleIntelHD4000Graphics.kext and AppleGraphicsPowerManagement.kext does not load automatically. Only AppleIntelFramebufferCapri.kext loads. My _DSM Method in IGPU is like Method (_DSM, 4, NotSerialized) { Store (Package (0x14) { "AAPL,slot-name", "Built In", "name", "Intel Graphics Controller", "model", Buffer (0x17) { "Intel HD Graphics 4000" }, "device_type", Buffer (0x14) { "Graphics Controller" }, "device-id", Buffer (0x04) { 0x66, 0x01, 0x00, 0x00 }, "AAPL,ig-platform-id", Buffer (0x04) { 0x04, 0x00, 0x66, 0x01 }, "hda-gfx", Buffer (0x0A) { "onboard-1" }, "AAPL00,DualLink", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "subsystem-vendor-id", Buffer (0x04) { 0x6B, 0x10, 0x00, 0x00 }, "subsystem-id", Buffer (0x04) { 0xEA, 0x00, 0x00, 0x00 } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } Can someone help please?
×