Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About vladichimescu

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
  1. New Driver for Realtek RTL8111

    @Meize, do you have any idea why 8168E works only on cold boot ? restarting messes up the card (on Windows 10 and OS X 10.11.1) with recycling message continuous like connected but no ip, then no cable connected
  2. HP Omen 15 USB Installer not booting

    Although I removed the OS X (at least for now, until OS X El Capitan is released, don't know if I'll hackin' it again, not having much time available)... https://www.youtube.com/watch?v=Oc1laFHM6Kg for now, you can get it here: http://s.go.ro/l3pstf82 pass: 849103
  3. [Guide] 10.10 On the Surface Pro 3

    @eminarcissus sorry for not answering promptly but I'll sold my Surface Pro 3 and had no time other than work. the best thing to do is ask Mirone because he's the daddy of hackintosh sound, for a new pathmap based on my system info dump and fixed verbs available on my website: http://vladichimescu.me/consultant/SurfacePro3/project/dump_surfacePro3/Surface_Pro_3/Surface_Pro_3-codec_0-Realtek_ALC288-verbit.txt just use his resources [pathmap and layout] with my clover dsdt edit to make it update proof. other than that, if he will not do it, fixing things shouldn't be hard as you have the fixed verbs - just read a applehda patching tutorial if no one will do it, I'll check it up when I'm getting some free time [not in near future] I'll fix it
  4. [Guide] 10.10 On the Surface Pro 3

    @eminarcissus I think that the hardwareconfig does not get loaded correctly on yours, did you do all steps I described ? also concerning HPET and IPIC in CLOVER the audio pathmap should be refactored as: http://vladichimescu.me/consultant/SurfacePro3/project/dump_surfacePro3/Surface_Pro_3/Surface_Pro_3-codec_0-Realtek_ALC288-verbit.txt
  5. [Guide] 10.10 On the Surface Pro 3

    check about mac > audio, should say layout 3 - if you injected correctly [because you're saying layout 3 in clover but layout 28 in DSDT I think] if still an issue, just check the Contents of AppleHDA288 should be - Info.plist - Resources [layout 3 and platforms] - MacOS/AppleHDA [here AppleHDA is just a symbolic link/shortcut to S/L/E/AppleHDA.kext/Contents/MacOS/AppleHDA] - sometimes during zip/unzip this becomes a file rather than link, so just recreate it I will also upload all dumps to http://vladichimescu.me/consultant/SurfacePro3/project/ support is only coding as I've sent my surface pro 3 away Also, do keep in mind that sound patching is based also on HPET, and sometimes can be improved [the poping and those kind using IPIC] So, unless you use patching in DSDT, you should enable in CLOVER: DTGP, HPET, IPIC, SBUS
  6. [Guide] 10.10 On the Surface Pro 3

    Sound should be easily patched to use AppleHDA for ALC288 [update proof] - based on present configs Inject layout 3 using CLOVER or in your DSDT, use binary patch from KextsToPatch section and just copy the AppleHDA288.kext [dont' touch the original AppleHDA] just rebuild, and restart [if problems, may required two restarts or manually load appehda288, then rebuild and restart] http://vladichimescu.me/consultant/SurfacePro3/project Also, I do mention that sound works native with the dock and clear [although sometimes starting a bit later]
  7. os x 10.10 on lenovo g580

    that leads me to think that you didn't inject the GenericUSBXHCI.kext... ough well, good it's working
  8. os x 10.10 on lenovo g580

    the clover.config from my website it's already configured with workaround for bluetooth pm so there's no need to remove the bluetooth DO not try any other arguments to disable the graphics [everything it's working - to be sure, just set the video to UMA in bios to enable only the internal graphics, however from my testing CLOVER is setting the internal as primary with my config - tested and aproved] please try the following, but each a time, not all once: - using all kexts and the clover config from me [with no additional stuff from any 'tools'] - press O to get to options and set kernel arguments to kext-dev-mode=1, then press space and Inject kexts, it should work - if the method above is not working, then remove from the usb installer the bluetooth kext IOath3kfrmwr and try again the method above AGAIN: - do not use anything else than my clover folder place in the EFI partition of the stick [you may copy the kexts as well in the /System/Library/Extensions of the usb installer [but watch for the IOath3kfrmwr to remove from both location if done so] - do not delete any official kext The task is quite simple - make the usb installer like for a real mac: restore basesystem.dmg to the usb, then copy both basesystem to the root of the stick and the packages in stick System/Library/Installation - additional for hackintosh, the bootloader: copy clover [from my site] - for Yosemite, after install you must rebuild the cache but before unload AppleHDA and load my AppleHDA269 [which is kinda' weird and working differently in Yosemite from Mavericks] also you may want to show me your device: dump the lspci and lsusb using linux or any program you want so I can see the devices id.
  9. os x 10.10 on lenovo g580

    use the kexts and the config from http://vladichimescu.me/consultant/LenovoG580/project/ also, press space and use: inject kext [until you copy the kexts to /S/L/E and you rebuild the caches]
  10. [Guide] ML Install Guide for Lenovo G580

    For fully functional system, you may use the files from my host [i've modfied the latest kext available and created a config file for CLOVER] The installation method is simple: just copy > paste [do not use other kexts, DSDT file or anything else than the ones from my site] - everything should work, including sleep, power management, graphics, audio with mic, etc - keyboard shortcut all works [i've disabled for now Fn+ Up/Down for brightness until I'll make a proper fix but you can use ContextMenu+ Up/Down] - set the bios to use only the integrated graphics, and to legacy support with legacy first - the CLOVER folder as /Volumes/EFI/EFI/CLOVER/ - the kexts goes to System/Library/Extensions/ - any information about the system is present in the dump folder - wireless card is changed to AR5B195 and rebranded using Windows 7 to make it present as whitelisted Lenovo G580 20157, i5, 8gb ram, hd4000 http://vladichimescu.me/consultant/LenovoG580/project/ Check the _changes.txt file to keep up with the updates [if there's none, that means I'm working on it] // you may set the FastBoot to false in config if you have dual boot
  11. Installing Mountain lion on Asus G75VW

    I didn't make the 'next step' described in the previous post [although I cleaned the DSDT but I haven't moded further to working sound and battery - I could clean it again and provide you as .dsl to further work - there's someone who does the battery _BIF fix and instructions to native sound are already available, just need to read] - use DSDT Patcher to extract the DSDT.dsl [not the compiled .aml] and post a html report using CPU-Z -last tab in the program], I will clean the DSDT for you [i sold my g75vw and don't seem to find my DSDT] Read my previous post as I explained you don't need DSDT for first steps http://www.insanelymac.com/forum/topic/285143-installing-mountain-lion-on-asus-g75vw/page-3?do=findComment&comment=1949206
  12. Installing Mountain lion on Asus G75VW

    so... From my test and render to this result: -Chameleon bootloader can boot legacy and does just fine with AppleIntelCpu* patch -Clover is even better providing full resolution in UEFI native with automatic DSDT patch - this is what I recommand, just select Install for UEFI motherboard and select only OsxAptioFixDrv ! I had full graphics with QE/CI and most working, so I used: - MacBookPro10,1 retina early2013 definitions - FakeSMC.kext from https://code.google.com/p/os-x-fake-smc-kozlek/downloads/list - AppleACPIPS2Nub.kext and ApplePS2Controller.kext for keyboard and touch [use from my host as it's edited to have perfect layout US] http://vladichimescu.me/pages/consultant/asus_g75vw/osx/Extra/Extensions/ - AtherosL1cEthernet.kext for LAN http://www.insanelymac.com/forum/topic/283086-updated-atheros-ar8131325152-driver-for-107108/ What to do next [DSDT]: - change wifi to AR5B195 and use DSDT for AR9285 to have native wifi [if doesn't work automatically] - DSDT HDEF + patch AppleHDA.kext + IOAudioFamily.kext [for perfect sound even when waking from sleep] - DSDT _BIF for native battery + AppleACPIBatteryManager.kext - DSDT ACPI for keyboard ilumination and display brightness level - DSDT sleep - I had some kind of sleep working with only clean DSDT [when sending to sleep takes a long time but waking is fast: hibernatemode=0 for sleep to ram, however] the only kernel argument I used and works great is -v for checking everything, but you don't need to ! [for sure do not use others! like npci=0x2000 or npci=0x3000! or it will lockup] As I sold my g75vw, the only thing I can provide is ideas, no testing. [bought the Dell XPS Developer Edition great tool for dev]
  13. Installing Mountain lion on Asus G75VW

    That's interesting... would you send me a pm with some details like the method used, the name of the bootloader and the files ? I'm always using only manual setup, like creating vanilla usb installer, using bootloader like Chameleon Bootloader [i rather use Clover because of pure UEFI support], DSDT and the kexts needed to activate.. again, I opt for vanilla. [i have 2x ssd raid0 with Windows, but OS X doesn't support native raid within bios but rather the in-software method]
  14. Installing Mountain lion on Asus G75VW

    Using Chameleon or Clover renders to the same thing [without DSDT], only one problem, just boot with -v: - need bios patch with PMPatch or AICPM in bootloader Other than that, you need only FakeSMC.kext to get system working with full graphics, but you need DSDT patches to get thing working: - hardware replace the wifi card with one compatible - DSDT for display backlight level and keyboard light - DSDT for sleep - DSDT and .kext for sound - .kext for keyboard and touchpad - .kext for lan [using Clover, select only the following: Install for UEFI motherboard and OsxAptioFixDrv-64]
  15. [UEFIPatch] UEFI patching utility

    Lenovo Y500 UEFI based on InsydeH2O patched succesfully [but still unable to boot installer because of black screen, then colling goes maximum speed for like 20sec, then shutdown -tried everything, DSDT, fixes, bootloader commands, vanilla files, hacked distros.. nothing, so waiting for a bootloader fix]