Jump to content
InsanelyMac Forum

MegaCookie

Members
  • Content count

    13
  • Joined

  • Last visited

About MegaCookie

  • Rank
    InsanelyMac Protégé
  1. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Yup that's fine! Oddly, when rebooting several times it is suddenly gone! Only thing I need to fix is getting 'Headphone' output to work, after sleep. Internal Speakers are working after sleep. I assume to fix this in CodecCommander.kext/ EAPDFix.kext? Anyway thanks for your help! Yup I have a combo output, so there was something wrong I guess.
  2. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Unfortunately both trials had the same red led on inside the headphone port, sound was still working right as expected.
  3. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Hi MacPeet, sorry for replying that late. Here are my test results: Trial 5: Only ‘Internal Speakers’ are working on the ‘Internal Speakers’ mode. Headphones are not working. Trial 6: Just like the previous attempts, speakers and headphones are both working on the ‘Headphone’ mode. Trial 7: This switch mode, shows 'Headphones' when headphones are attached, and ‘Internal speakers’ when sound is playing over the internal speakers. So this is actually working! The only thing is that the headphone port constantly is is red, even when no data is emitted.
  4. MegaCookie

    AppleALC — dynamic AppleHDA patching

    @MacPeet Yes it's very strange. With this trial it didn't change anything noticeable. I can live with it though, audio and microphone are actually working fine. Switching between Headphones and Speakers also kinda works, I just have to leave it to 'Headphones'.
  5. MegaCookie

    AppleALC — dynamic AppleHDA patching

    With these settings the speakers and headphones are working: So yes you are right that I got two different outputs using the manual mode, however the 'Internal Speakers' setting is not working. I have to set it to Headphones even when I'm using the integrated speakers. Switching to 'Internal speakers' simply does result in not working audio.
  6. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Thanks! The internal speakers are finally working when the audio output is set to 'Headphone'. Audio with headphones is also working when the audio device is set to: 'Headphone', is that what you mean with 'Speaker and HP in ManualMode'? The internal microphone works fine as well, but I cannot test an external microphone as I don't have one. BTW: should EAPD now covered in AppleALC as well, or do I need another kext for that? The audio doesn't work after 'sleep' with your AppleALC.kext.
  7. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Unfortunately still not working. Headphones are working fine. Anyway thanks you put effort into it!
  8. MegaCookie

    AppleALC — dynamic AppleHDA patching

    I think that is because my laptop I made the IOReg after 'sleep'. What kind of fix is recommend for EAPD then (if I don't may use CodecCommander.kext)? I think the speaker problem is somewhere with the pinconfigs/ pathmaps. Attached is a fresh IOReg which I made directly after a reboot, when headphones are working IOReg-MegaCookie3.zip
  9. MegaCookie

    AppleALC — dynamic AppleHDA patching

    It's stupid that I forgot that, but after rebuilding the kernel caches and rebooted several times the sound over the internal speakers isn't working yet. IOReg-MegaCookie2.zip
  10. MegaCookie

    AppleALC — dynamic AppleHDA patching

    Thanks a lot! The headphone output and the microphone input are working with the Clover method. However, sound over the internal speakers is not working. I do not know which debug files you might need beside that codecgraph folder, so I added my IORegistery file. Edit: also my sound over HDMI through the Nvidia GTX1070 is not working. IORegistery-megacookie.zip
  11. MegaCookie

    AppleALC — dynamic AppleHDA patching

    I currently have the Clevo P950HR laptop. AppleALC.kext is not working for me :(, probably because there is only desktop support for the ALC1220 codec. Attached is my 'codecgraph' folder with the codec_dump.txt. In the verbs.txt I also added my changes after playing with PinConfigurator.app. There is also a PathMap flowchart based on that Vietnamese video on YouTube. Can anyone help me out? codecgraph.zip
  12. MegaCookie

    Clover General discussion

    I don't know if it exists, but is there an option in Clover to auto boot to the latest chosen OS (when no OS is chosen after the timeout) ? This can be useful for Windows/ Mac updates which requires restarting several times. Edit, yea I found it: https://clover-wiki.zetam.org/configuration/boot#boot_defaultvolume
  13. MegaCookie

    Airport - PCIe Half Mini

    Hello everyone! Maybe I'm just missing something but I can't get Handoff to work. I've applied the Clover patches for 10.10.2 but that isn't working. I think it has something todo that I have two separate cards, one Atheros card for Wifi and Broadcom module for Bluetooth. Can anyone confirm these problems with a conflicting Atheros card and a separate Broadcom module?
×