Jump to content

gpatpandp

Members
  • Content Count

    41
  • Joined

  • Last visited

Everything posted by gpatpandp

  1. Firstly thank you for your replies both on this thread and the "High Sierra release" thread. Since this relates exclusively to my Optiplex hacks, I thought it best that I reply here. I am reporting back after successfully identifying the issues I was encountering in attempting to update to the macOS 10.13.1 Public Beta 1 release. Among the multitude of PC hacks I own, I have two (2) 790 SFF machines. Both are 3.4 GHz Intel Core i7 CPUs, one has a Nvidia GT 720 1 GB GPU and 16 GB's of RAM, the other has a ATI Radeon HD 5450 1 GB GPU and 12 GB's of RAM. Both have A18 Bios installed. I was getting the dreaded "AppleACPICPU" kext stall initially on both machines during the 2nd boot when trying to update to 10.13.1 Public Beta 1. Unfortunately google listed solutions in addressing the error didn't fix the issue though in the Nvidia GT 720, I discovered that maybe perhaps during migration the residual of 10.12.6 Nvidia Web drivers were present in the System/Library/Extension folder. Since macOS 10.13 runs the GT 720 natively, removing them as well as both the NvidiaGraphicsFixup as well as the Lillu.kext, which are also not needed, finally allowed the update to go through. I must say however that compared to the initial 10.13 17A362a install, the 10.13.1 Public Beta 1 update is far less stable and I was forced to add "-v" in arguments in order to get the system to boot with any consistency. I never was able to get the ATI Radeon HD 5450 past the AppleACPICPU kext stall. I don't know if it is due to the fact as I am not a big fan of rolling back kexts as MacPeet recommends though I have instead preferred using the Frame Buffer Eulemur and injecting The Fake ID 68E01002 in Clover which has also worked in any macOS 10.13 version I have installed thus far. Anyway I finally just gave up attempting to apply the 10.13.1 Public Beta 1 update on my ATI Radeon HD 5450 790 Optiplex SFF and elected to instead upgrade that machine to the macOS 10.13 17A365 Public GM.
  2. Weird, while my Optiplex 790 SFF had no issues whatsoever with a clean install of the 10.13 GM release, attempting to update to the 10.13.1 Public Beta release has been a complete joke and never gets past the initial reboot.
  3. It's still a "No Go" as far as attempting to update to 10.13.1 Public Beta 1 from the App Store. Things I have tried: - running sudo nvram -c in terminal ​- updating Clover to v2.4k_r4220 - completely removing Windows 10 system which exists on a separate SSD from my rig - Out of desperation and even though its been reported as no longer necessary, I even tried inserting 0xe907f537 within the Firmware Features in Clover SMBIOS field Each attempt resulted in the same occurrence; Clover stalls/crashes on the installations initial reboot. Verbose reports some nonsense about needing to rebuild the prelinked-kernel however my suspicion is that I am still not able to circumvent Apple's Firmware check. Upon hard booting my rig, macOS 10.13 boots with no issue and I am left with the macOS Install Data folder as a reminder that updating has indeed failed once again.
  4. I too experienced this exact same issue when attempting to update a legacy ESP system to the 10.13.1 Beta 1 update directly from the App Store. Could you list any/all terminal commands (is it just: sudo nvram -c ?) you used to delete the nvram files from your system which then allowed you to successfully apply the update ? Thank you !
  5. Why are some electing to update the initial 17A362a GM release with yesterday's 17A365 GM release. Won't either GM update to the 1st update (10.13.1) when it is released eventually just as in years past ?
  6. Likely due to the "newness" factor I imagine as macOS 10.13 High Sierra is just hitting the scene though in searching, I have not been able to locate yet a comprehensive price range list of (low to mid to high) GPU's that will work right out of the box. While not completely hopeless, I am beginning to prepare for the likelihood of no Nvidia Web drivers and therefore no practical/functional support for my GTX 960 2GB in 10.13. And while I have returned the GT 640 1GB back into my rig as it is natively supported in macOS 10.13, should the void of web drivers continue, I will most likely want to upgrade the GT 640 yet once again with something comparable in both specs and price (not much of a gamer) to the GTX 960. With that said, might anyone have a suggestion ?
  7. gpatpandp

    [pre-release] macOS High Sierra

    Is there something askew with my partition makeup ? Is the fact that my EFI partition is shared by both 10.12 & 10.13 partition the culprit ? (as recommended by rehabman, I do not install kexts in Clover EFI at all. Instead I install them at the root level /Library/Extension folder)
  8. gpatpandp

    [pre-release] macOS High Sierra

    I originally contributed the above post on 7/2 and now after searching for a solution while rummaging through the various theories, suggestions, and others conclusions posted since then, my situation still remains stagnant re: my HP Envy laptop in that I am unable to upgrade to the latest 10.13 release via the app store. For me nothing listed here has made a difference; the version of Clover, the removal of the EmuVariableUefi-64.efi driver, upgrading the apfs.efi etc. The only way I have been able to upgrade previously was via the "Core.pkg" method as mentioned and this past time through using Pike Alpha's DP3 (17A306f) update script. The truly frustrating aspect is that once installed, my 10.13 partition operates smoothly/perfectly. Is it possible that a solution exist and I have just missed it ?
  9. gpatpandp

    [pre-release] macOS High Sierra

    While I am not entirely sure if my experience is relevant in effecting the presence or absence of the EmuVariableUefi-64 theory however in checking my drivers64UEFI folder a moment ago, the successful 10.13 Public Beta release APFS formatted installation I reported the other day on my HP Envy 15T-k200 "Haswell" laptop was indeed accomplished with the EmuVariableUefi-64 driver inside my folder.
  10. gpatpandp

    [pre-release] macOS High Sierra

    How completely odd it is that each individuals installation success so far with High Sierra 10.13 seems so random and unique. With the initial Developer Preview release, I had absolutely no issues with installing it in either HFS+ or APFS on my Dell Optiplex 790 (SFF) (and I believe with Clover v4046) on an SSD adjacent to my macOS Sierra 10.12.5 partition. When using the same USB installer, upgrading to Clover v4084 (different config.plist, DSDT, SSDT, patches etc obviously) and trying both firmware features and new SMBIOS information, nothing worked and I was forced to resort to the "Core.pkg" install method on my HP Envy K series laptop. After downloading the 10.13 Public Beta release, I wiped the 10.13 DP partition clean on my laptop and tried installing it from scratch though was met with the same firmware obstacles with either formats (HFS+ or APFS). I attempted the "Core.pkg" install though this time even that failed. Once however I upgraded Clover from v4084 to v4097, I finally was able to achieve a complete, error free install on my laptop. On a side note, I noticed that in upgrading to Clover v4097, the Clover boot menu displayed/listed partitions (10.13 recovery etc.) that v4084 did not. Point being is that to me in carefully sifting through this forum it appears that a definitive, "one size fits all" solution to installing macOS 10.13 High Sierra remains somewhat elusive thus far.
  11. gpatpandp

    [pre-release] macOS High Sierra

    Rebuild 10.13/APFS Cache: sudo touch /System/Library/Extensions && sudo kextcache -u / Repair 10.13/APFS Permissions...Download App V3.7.2315 here:
  12. gpatpandp

    [pre-release] macOS High Sierra

    I believe we are following the same post regarding 10.13 Beta installation and we are both stuck at the same point
  13. gpatpandp

    [pre-release] macOS High Sierra

    Creating the actual installer is as simple as: 1) Place your "Install macOS 10.13 Beta" app in your applications folder 2) Designate a drive or partition as your installer 3) Format & Name it as "NEW" 4) Open Terminal and paste following command: (the sudo command will require your password) sudo /Applications/Install\ macOS\ 10.13\ beta.app/Contents/Resources/createinstallmedia --volume /Volumes/NEW --applicationpath /Applications/Install\ macOS\ 10.13\ beta.app
  14. gpatpandp

    Mac os High sierra installation attempts

    I too was stuck at this point and after following this advice, I was able to proceed with my installation. When unhiding all files after completing the 1st part of the installation, I could not locate a IABootFiles folder on my target volume.
  15. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    Aside from the SMBIOS section, It was automatically populated through following a El Capitan guide for the HP Envy 15T K-series created by "Rehabman".
  16. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    Unfortunately, just as all the other potential solutions proposed in this thread this one did not work for me either. In my case, the situation remains that Darkvoids patch hasn't worked for any of the Developer Preview or Public Beta updates other then the very first DP release. Though I have an external USB Wi-Fi Adapter working, I am wondering what other internal solutions exist. Will a DW 1510 AGN Half BCM4322 Dual-Band N PCI-E Card fit in the same slot ? I have an old Dell Latitude E6400 running mac OS Sierra with that card and the internal Wi-Fi has continued to work through each incremental PB update without any issue whatsoever.
  17. gpatpandp

    Apple unveils "macOS Sierra"

    Oh sorry...the patch comes from the link/forum you located/posted here for me upon my initial inquiry too you a few weeks ago wondering if you were aware of any methods for getting Wi-Fi working in the HP Envy 15T K series Broadcom BCM94352HMB PCI card. http://www.insanelym...bcm94532z-wifi/ Applying this patch worked for DP1: Kext: AirPortBrcm4360 Find: 81F952AA00007529 Replace: 81F952AA00006690 This additional fix is required to keep Wi-Fi working: in DP2: 1- Place the following full path in the "force kexts to load" option of clover: \System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext 2- In the ACPI patches menu make sure to have "AddDTGP" and "FixAirport" selected 3- in Devices menu, copy and paste into the wifi box 0x43BA14E4 Despite applying the additional fix, not only have lost Wi-Fi functionality in DP2, Clover always boots to a black/blank screen as long as the "AddDTGP" box is checked as described in the instructions. I thought you might be able to offer some insight as to why I am experiencing this conflict.
  18. gpatpandp

    Apple unveils "macOS Sierra"

    @ Rehabman: As I previously posted here, while this clover patch: Kext: AirPortBrcm4360 Find: 81F952AA00007529 Replace: 81F952AA00006690 ...initially worked perfectly in my HP Envy 15T K series Broadcom BCM94352HMB PCI card within the 1st Sierra DP, Wi-Fi has ceased to work in upgrading to the Public Beta release. The suggested fix: 1- Place the following full path in the "force kexts to load" option of clover: \System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext 2- In the ACPI patches menu make sure to have "AddDTGP" and "FixAirport" selected 3- in Devices menu, copy and paste into the wifi box 0x43BA14E4 …does not work in enabling Wi-Fi and in fact with the “AddDTGP” option checked, Clover boots to a blank/black screen when attempting to boot to either my El Capitan 10.11.5 or Sierra Public Beta partition. Might you have any ideas on what might be conflicting and suggest a possible adjustment I might want to implement in order to combat this sudden loss of Wi-Fi functionality ?
  19. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    Unchecked the "AddDTGP" box and while that enabled both of my El Capitan 10.11.5 & Sierra Public Beta partitions to boot with all the changes in place, still no Wi-Fi in Sierra. My hack consist entirely of a method developed by "Rehabman" and doesn't utilize a DSDT so I am not sure what/why it is conflicting when the "AddDTGP" is checked. Very frustrating.
  20. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    Firstly, thanks for your reply and specific instructions. After carefully inputing all of your directed changes, Clover booted to a blank/black screen on both my El Capitan 10.11.5 & Sierra Public Beta partitions. My only confusion is are the above changes to be made in addition to or instead of your first listed hack ? Kext: AirPortBrcm4360 Find: 81F952AA00007529 Replace: 81F952AA00006690 I assumed the new changes were to be made in addition to so I left the 1st/DP1 hack alone and did not remove it. Maybe the additional changes require Sierra to be the only Volume that clover is booting ?
  21. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    I applied the edits in clover (as shown) however I did not quite get the additional edit needed to the Brcm kext you described. Where exactly is the Brcm kext and where in the info.plist should the string be placed ?
  22. gpatpandp

    [FIX] macOS Sierra DP1 BCM94532Z WiFi

    While this patch worked perfectly on my BCM94352HMB card in the DP1 Beta, after applying the DP2 Update though the Bluetooth/USB side of the card remains functional, Wi-Fi no longer works.
  23. gpatpandp

    [pre-releases] macOS Sierra

    Although I am only able to Boot into my DP2 partition in Safe mode, my Broadcom card works without issue after applying this new patch for Sierra: http://www.insanelymac.com/forum/topic/312759-fix-macos-sierra-dp1-bcm94532z-wifi/. I'm not certain what exactly is going on with my laptop as kext seem to be injecting (though in my case since my kexts are all located/housed in my Library/Extensions folder (not S/L/E) kext injection itself is mostly likely not even applicable) I know at least one of my patches is working (Broadcom Wi-Fi). Something remains broken as my Bluetooth functionality is now gone. No new Clover edition released yet has improved my boot process though I have not yet located/tried Clover r3589. My DP2 partition gets through the 1st part of boot then stops and reboots itself except as previously mentioned when booting in safe mode.
  24. gpatpandp

    Apple unveils "macOS Sierra"

    I too am experiencing an odd, brief, visual glitch during boot. It begins immediately after the 1st stage of boot where then an image of eight unevenly spaced "zebra striped" apples appear in a horizontal row. Some of them are also underlined with jaggedly, broken underlines also arranged horizontally. The image flashes on screen for no more then a couple of seconds then it quickly disappears. Then the 2nd stage of boot appears and occurs normally (followed immediately by the my Sierra login screen).
  25. gpatpandp

    Apple unveils "macOS Sierra"

    Thank you very much...worked perfectly.
×