Jump to content
InsanelyMac Forum

THX

Members
  • Content count

    18
  • Joined

  • Last visited

About THX

  • Rank
    InsanelyMac Protégé
  • Birthday 10/20/1985

Contact Methods

  • Website URL
    http://pushme.to/slassh

Profile Information

  • Gender
    Male
  • Location
    Russia
  1. Hi there. Same problem, almost. I'm running ML 12A269 with default (native) AppleHDA and this HDEF section in dsdt: Device (HDEF) { Name (_ADR, 0x001B0000) Method (_PRW, 0, NotSerialized) { Return (Package (0x02) { 0x0D, 0x05 }) } Method (_DSM, 4, NotSerialized) { Store (Package () { "codec-id", Buffer (0x04) { 0x89, 0x08, 0xEC, 0x10 }, "hda-gfx", Buffer (0x0A) { "onboard-1" }, "layout-id", Unicode ("B"), "device-type", Buffer (0x10) { "Realtek ALC889a" }, "PinConfigurations", Buffer (One) { 0x00 } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } Sound works, but I get a bunch of sound assertion errors in logs: 7/12/12 9:19:09.000 PM kernel[0]: Sound assertion in AppleHDADriver at line 1746 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDAWidget at line 4142 7/12/12 9:19:10.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1207 Any suggestions how to fix it?
  2. Sleep doesn't working correctly with ESI Juli@ for me. Got kernel panic after waking up and when try to play some audio. Any suggestions?
  3. DSDT fixes for Gigabyte boards

    Whoops... i've continued to stripping my dsdt and get kernel panic on system boot. Can somebody be so kind to look into this dsdt.dsl.zip
  4. DSDT fixes for Gigabyte boards

    Thanks! I've stripped a USB device sections (EHCI, UHCI, UHC1-6) as you did in you dsdt - works for me now. But with other devices, such as EC, SBUS i'm totally stuck. IORegistryExplorer show me PX43 device under PCI0@0 section, seems it's a SBUS (i can rename PX43 to SBUS). I've tried to rename it according to you last stripped dsdt version, but lost IEEE1394 dsdt_v.1.12.zip
  5. DSDT fixes for Gigabyte boards

    Hello, Sorry my noob questions and poor english... mm67 sorry for disturbing, but maybe you can help me. I've tried to apply some fixes as you do in your dsdt file and get kernel panic immediately after booting up... I have EP45-DS3P mobo (as you can see in my signature). Can you take a look on my dsdt file, maybe i've cut some useful things from it, but i have no errors while compiling it. For now i get working video (there is an issue with incorrect PCI-E link speed, system profiler shows only 2.5GT/s), lan, native sound (only 2.1) and usb via my dsdt. Also i remove some devices such as FDD, system speaker, PS2 mouse & keyboard from dsdt file. kexts in Extra/Extensions: fakesmc, NullCPUPowerManagment, OpenHaltRestart, PlatformUUID, SleepEnabler. There is my working dsdt: dsdt_v1.08.dsl.zip
  6. Hi, msb! You should try this: http://www.insanelymac.com/forum/index.php?showtopic=189562 In few words you shoul do this: Download CPUInjector and edit info.plist to match you CPU for Core 2 Duo: <key>entriesToAdd</key> <dict> <key>cpu-type</key> <data>AQM=0103</data> </dict> for Core 2 Quad: <key>entriesToAdd</key> <dict> <key>cpu-type</key> <data>AQU=0105</data> </dict> Then place CPUInjector.kext to /Extra/Extensions Also you could try this: thanks goes to DigitalDJ Hope it helps, and sorry my english
  7. imacken, blackosx - thanks to you guys! It's work!
  8. I tested it with 64 bit kernel - works for me. Bonjour not working, if you need it, you should read blackosx guide he explain how to get it to work. SATA fix is to have OS recognise your SATA devices natively, in system profiler you should see them as Intel ESB2 AHCI. And if you see that you can remove IOAHCIBlockStorageInjector.kext in /Extra/Extensions USB fix does 2 things: 1. Stops the USB drive being unmounted when you put your system to sleep (i didn't test it yet, but should be work) 2. Presents the high speed usb devices (EHCI) to OS as built-in usb, rather than expansion slot. upd: just tested time machine - works, bonjour works also.
  9. Hi, blackosx! Thanks for this great guide! Works perfect for me (second install method, using usb flash drive) without any kernel panics at all! I've made my custom dsdt for lan, audio and all fixes using dsdt guide kindly provided by you also Thanks again for you hard work. One little question: system profiler shows my processor as 2,93GHz unknown, what can i do with this? Sorry my poor english... Regards, Sergey
  10. Nice to hear that it's works for you With audio you can try this guide (needs iaslme utility to decompile dsdt.aml to a dsdt.dsl file for editing and then compile in dsdt.aml again to using it with bootloader) upd: updated to F9c BIOS, so i'll try to make new dsdt with audio supported. upd2: working dsdt with networking, audio (including patched AppleHDA.kext in archive), CMOS reset, SATA & EHCI USB fixes dsdt_for_EP45_DS3P__F9c__with_audio.zip
  11. Hi, irontony Those file is bios rom, yes. But you don't need to install them! (it's for extracting dsdt from it) I'm currently use F9b BIOS you can download it from gigabyte site and flash via Q-Flash or @BIOS windows utility. I upload my dsdt file and some useful kexts, hope it will work for you. For you video try Aquamac's EFI Strings method it's working for me. And one more thing, i didn't use onboard sound, so i can't tell how it works... dsdt.aml.zip only dsdt file
  12. 9800 GTX working in OSX86

    Hi guys! Try Aquamac's GFX strings method it's work for me without any problems, except mouse glitches while i'm running itunes or quicktime. But, seems it may be fixed by deleting AppleUpstreamUserClient.kext from /System/Library/Extensions/ or you can disable this kext sudo -s kextunload /System/Library/Extensions/AppleUpstreamUserClient.kext and then, if it solve the problem, delete it. Unfortunately i haven't try this method yet... When i come home i'll check this. Sorry my poor english upd: it's works! Also you can download Disabler.kext to fix glitches from here
  13. Seems i've got it sorted! Just ignored 2 warnings while making dsdt.aml, then with iaslMe utility decrypted it and fix cmos resets by editing dsdt file: Device (RTC) { Name (_HID, EisaId ("PNP0B00")) Name (_CRS, ResourceTemplate () { IO (Decode16, 0x0070, // Range Minimum 0x0070, // Range Maximum 0x00, // Alignment 0x02, // Length (default value is 0x04) ) }) } Today i'll try to add LAN and HDEF fixes to my dsdt. Kizwan, thanks again for the tip! offtop: now SL runs with my fixed dsdt without any KP's, but a have some minor light freezez for about a second or less in aol aim program... that can cause this?
  14. Hi guys! Firts of all really big thanks to Koalala for this utility. Sorry my noob question and also bad english... I have some problems with patching bios and generating proper dsdt.aml I use Gigabyte EP45-DS3P mobo with F8 bios. In General tab i selected HPET, RTC & Aliases Patches, and all fixes after pressing "Fixes" button. In Network tab i selected LAN, PEX4 and Fix GP9; Graphics - nVidia GeForce 9800GTX (but i have GTX+ on G92 chip) 512Mb, nVCAP = DUAL DVI+TV/HC12 and "use DSDT GFX"; Audio is Realtek ALC889a with Use HDEF Audio selected Here is log of ACPI Patcher 0.2 Beta 5 Hope somebody can help me with this to make a proper DSDT.aml. Now a'm runnig SL without DSDT and every reboot BIOS drops to defaults... Video get working with EFI string in com.apple.Boot.plist Also, maybe it helps... Registry Explorer shows this values: for ethernet (a have 2 interfaces) PEX4@1C,4 and PEX4@1C,5 for video PCI0@0 for audio i can't see values cause seems i killed this section after installing driver for my ESI Juli@ (it doesn't working anyway) ep45ds3p.zip
×