Jump to content

Matgen84

Donators
  • Content Count

    1,828
  • Joined

  • Last visited

  • Days Won

    8

Reputation Activity

  1. Like
    Matgen84 reacted to ITzTravelInTime in TINU: The bootable macOS installer creation tool - Mac app   
    i am working on a TINU version with black mode support for macOS Mojave and also with some bug fix for that version, so here is how the application does currently looks like in dark mode, there are still some bugs and glitches that I am trying to fix, and the new Xcode 10 is still quite buggy for some things

  2. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    Uhm... no. The idea is that it should simply work with no other changes.
     
    YOU DO, however, need -lilubeta -alcbeta boot arguments.
  3. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    When Apple releases 10.14 final.  Basically when it won't be a Beta anymore.
  4. Thanks
    Matgen84 got a reaction from ammoune78 in AppleALC — dynamic AppleHDA patching   
    I just follow indications above by vit9696: "All in all: do not touch anything it will just work." And AppleALC 1.2.8 work fine with -lilubeta boot-args.
    What is difference with appleALC 1.2.8? Please.
  5. Like
    Matgen84 reacted to SavageAUS in AppleALC — dynamic AppleHDA patching   
    When can we expect full 10.14 support? Meaning without using boot args?
    Great work thus far.

    Sent from my SM-G930F using Tapatalk


  6. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    You have the changes posted above by vit9696.
     
    I just rebuilt it for people who needed those changes (and to make sure it doesn't break anything on my rig, which it doesn't). So, if you wanna give it a try, go ahead. Basically, the last build includes the latest changes. That's the difference between them.
  7. Like
    Matgen84 reacted to vit9696 in AppleALC — dynamic AppleHDA patching   
    This is correct. I replied on the changelog on github:
    https://github.com/vit9696/AppleALC/commit/74e99dc3a405b2f9d72add35c784339edb1e5322#commitcomment-29273586
    All in all: do not touch anything it will just work.
  8. Like
    Matgen84 reacted to Pavo in AppleALC — dynamic AppleHDA patching   
    Does this mean we need to change SSDT/DSDT patches or clover config to alc-layout-id?
  9. Like
    Matgen84 reacted to Pavo in AppleALC — dynamic AppleHDA patching   
    Think someone needs to explain this little more, because I changed layout-id to alc-layout-id in SSDT for HDEF device and this is what I get in IORegistry.

    alc-layout-id = 2
    apple-layout-id = 7
    layout-id = 7
    #scratcheshead
  10. Like
    Matgen84 reacted to Pavo in [pre-release] macOS Mojave   
    Add -lilubetaall as a boot arg to your clover config.plist and use this new AppleALC kext
    AppleALC1.2.8.1.kext.zip
  11. Like
    Matgen84 reacted to nmano in Clover General discussion   
    Apple update FirmwareFeatures & FirmwareFeaturesMask to 10.14
    FirmwareFeatures 0xFD0FF536
    FirmwareFeaturesMask 0xFF1FFF3F
  12. Like
    Matgen84 reacted to ITzTravelInTime in TINU: The bootable macOS installer creation tool - Mac app   
    Now on my macOS Mojave hakintosh, i am setting up my developer equipment to port the TINU source code to xCode 10 and also to add some new mojave-specific features and also some bugfix, i want to implement dark mode in tinu as well, because an app to support the new dark mode, needs to be compiled with the new xcode and sdk
  13. Like
    Matgen84 reacted to Sherlocks in [pre-release] macOS Mojave   
    remain only QE for HD 3000.
    except QE, all is working like HS.
    hope someone find solution
     
  14. Like
    Matgen84 reacted to Slice in [pre-release] macOS Mojave   
    @all
    Did you notice there is old High Sierra picture? It is not Mojave picture.
  15. Like
    Matgen84 got a reaction from arsradu in AppleALC — dynamic AppleHDA patching   
    I do that.
     
    I use EFI/Clover/Kext/XX folder instead of S/L/E.
     
    Thanks
    Edit: all work fine on Mojave and High Sierra with your file (applealc 1.2.8) layoutID=1 as before. I think my files were badly compiled: I don't know why. Yet I copy well lilu before. 
    Thanks again
     
  16. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    1. Make a backup of AppleALC 1.2.7
    2. Replace it with AppleALC 1.2.8 (the one from my archive)
    3. Inject a layout ID (I tried both LayoutID 1 and LayoutID5) in Clover config.
    4. Add Boot Arguments: -lilubeta -alcbeta
    5. Restart.
     
  17. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    I'd say that worked out beautifully on ALC 1150. I'll test ALC 892 when I get home. But I'm pretty confident it will work, as well.
     
    This is with Layout ID 1 (which didn't work before). Also tried Layout ID 5 (which DID work with release 1.2.7, as well). Both work fine with this build.

     
    Also, AppleALC 1.2.8 (for whoever wants to test it) attached.
     
    Tested with Lilu v1.2.3 on both Mojito Beta and High Sierra.
    AppleALC 1.2.8.zip
  18. Like
    Matgen84 reacted to gengik84 in AppleALC — dynamic AppleHDA patching   
    download the new source for AppleALC and lilu
    Compile...
     
  19. Like
    Matgen84 reacted to vit9696 in AppleALC — dynamic AppleHDA patching   
    AppleALC now behaves differently in regards to layout-id submission to AppleHDA. Please check the changelog out:
    https://github.com/vit9696/AppleALC/blob/master/Changelog.md#v128
    Be aware that it needs to be compiled from source, will not land very soon, and may require some changes in GPU Fixup kexts to work with their codecs. Test with caution.
  20. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    Mmmm...careful with VoodooHDA. You need a VANILA/STOCK AppleHDA kext in order for AppleALC to work.
     
    If you used VoodooHDA, you need to uninstall it and revert to stock AppleHDA kext.
  21. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    Guys, I have a curiosity about this whole "no sound in Mojave with older layout IDs" issue.
     
    I was using Layout ID 1 ever since I started with my first hack. I never knew why 1. Why Layout ID 1. Now I started to understand more about it and actually I was always wondering why the hell do I have two "digital out" options with Layout ID 1. Funny is that my motherboard doesn't have Digital/Optical Output. So those were just options with no actual hardware to use. And it never bothered me.
     
    Now, I'm curious, is there a way to tell exactly which of those available layouts is the right for your actual motherboard? 
     
    That's a CLOVER issue. Update your Clover to at least version 4513.
     
    You can try a newer build of Clover from here.
     
    NOTE: Pay attention to the drivers section and only select the ones YOU KNOW are absolutely necessary FOR YOU. These unofficial builds (at least the ones downloaded from the git I gave you) have a lot more drivers than the official version. Choose carefully.
     
    Or, if you want something close to stock, I can compile Clover now and give you another version which should be pretty much the same as the official one.
  22. Like
    Matgen84 reacted to arsradu in AppleALC — dynamic AppleHDA patching   
    Try a fresh config.
     
    Also, take a look at Helipilot2's post above: 
    Maybe some of that can be applied to you.
     
    It worked perfectly fine for me by simply switching the injection in Clover config from Layout ID 1 to Layout ID 2 or 5. It's most likely gonna work with any of the supported layouts according to the Wiki page I posted above.
  23. Like
    Matgen84 reacted to arsradu in [pre-release] macOS Mojave   
    Actually, I didn't have to rebuild anything.  Just switched from one Layout ID to another in Clover config ( and -alcbeta & -lilubeta). That's it.
     
  24. Like
    Matgen84 reacted to aytic in [pre-release] macOS Mojave   
    ALC892 fixed with layout-id 2 and -lilubetaall -alcbeta

  25. Like
    Matgen84 reacted to arsradu in [pre-release] macOS Mojave   
    That fixed it for me. Just switched from Layout ID 1 to Layout ID 2 in Config. That's all.
     
    Thank you very much for the tip.
     
×