Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About skforty

  • Rank
    InsanelyMac Protégé
  1. No unfortunately i have never seen the slider in display prefs. I am using clover boot loader and I have that DSDT.aml in /EFI/ACPI/PATCHED/ as well as /Extra Is there anyway i can verify that is the DSDT.aml that is being used? When i tried using different ones, i just renamed them to something like DSDT1.aml and iput them in the /EFI/ACPI/PATCHED folder. Then in the boot options of clover, i changed the name of the DSDT.aml, it was only for that boot as the name setting wouldnt persist through reboot. It always affected boot = crashed, or didnt work, so it seemed like my setting change was being used. That seemed the best way to try different dsdt files without hosing the boot. That said, assuming that is the DSDT being used, i am unsure why i dont see the slider.
  2. Thanks, I see the following sections in the DSDT i am using. Are these entries correct for my W510 with nvidia 880m (1GB)? Device (PNLF) { Name (_HID, EisaId ("APP0002")) Name (_CID, "backlight") Name (_UID, 0x0A) Name (_STA, 0x0B) } Method (_DSM, 4, NotSerialized) { Store (Package (0x06) { "AAPL,backlight-control", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "@0,backlight-control", Buffer (0x04) { 0x01, 0x00, 0x00, 0x00 }, "@0,pwm-info", Buffer (0x14) { /* 0000 */ 0x01, 0x14, 0x00, 0x64, 0xA8, 0x61, 0x00, 0x00, /* 0008 */ 0x1C, 0x02, 0x00, 0x00, 0x64, 0x00, 0x00, 0x00, /* 0010 */ 0x00, 0x04, 0x00, 0x00 } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) }
  3. Thanks, sadly ScrLk/Pause doesnt work for me either, but the applications "ScreenDimmer" and "Shades" (shades only sometimes). They dont look like they adjust the brightness the same way though. As far as the boot log text, i didnt know where to look. But i went into the system log queries and found the following (relevant) entries: 11/28/12 11:36:05.000 PM kernel[0]: AppleIntelCPUPowerManagement: Turbo Ratios 1169 11/28/12 11:36:05.000 PM kernel[0]: AppleIntelCPUPowerManagement: (built 00:59:42 Aug 25 2012) initialization complete 11/28/12 11:36:05.000 PM kernel[0]: AppleIntelE1000e(Info): changing MTU from 0 to 1500 11/28/12 11:36:05.000 PM kernel[0]: AppleIntelCPUPowerManagementClient: ready Also maybe something of note, i have sound assertion crapping all over the log file, like this: 11/29/12 12:08:08.000 AM kernel[0]: Sound assertion in AppleHDAWidget at line 3095
  4. First off, thanks for all the hard work Joshhh!! I tried this yesterday on my W510 and everything went pretty smooth using your files. I had to install the PXHCD.KEXT found on page 9 to get USB 3.0(super speed) working. I am using Clover-boot with your attached files. I ordered the Atheros AR5BHB9 and hopefully it will just work when i get it. The only 2 things I dont have working are the SD Card Reader and Adjustable Brightness. For the SD Card Reader it sounds like no one has gotten that to work and to be honest, i dont care much about it. But for the Adjustable Brightness i have tried using the DSDT.aml from the "Extra" folder of your "W510-Files.zip" as well as the other DSDT.aml file from your https://www.dropbox.com/s/rd1mninhu0jyqfk/DSDT-for-Thinkpads.zip since mine is the W510 with Quadro 880M but the FN+home/end doesnt affect brightness once the Mountain Lion Login screen appears. I've read about a slider in the "Display settings" as well, but don't see it. Unplugging the laptop doesnt affect it either. Is FN+home/end still the correct hotkeys? Sorry for the ignorance (I'm a hackintosh noob), but should i be doing something with the .DSL files? I am unsure of their purpose. Lastly, how do i know or how can i tell if speedstep and turbo are working? Thanks again!