Jump to content

Mage66

Members
  • Content count

    35
  • Joined

  • Last visited

About Mage66

  • Rank
    InsanelyMac Protégé
  1. I recently pulled my Shuttle K45 off the shelf, and decided to play with it again. It had 10.5.8, and that is quite old now. I upgraded the processor to a Core 2 Duo 2ghz, and added a GB of RAM to make 2gb total. It also has a 400gb SATA drive and a slimline DVD-RW drive. I bought a $5.00 Ralink USB wireless adapter on eBay to add WIFI to the system. Many things don't run on 10.5.8. So, I decided that since it wasn't useful, I'd try this guide and bring it up to 10.6.x. I had a 10.6.3 Install DVD, and used that to make the USB stick. I followed the instructions, and all went pretty well. But, when I ran the software update to go to 10.6.8, the system would crash on boot. Based on the text on the screen, there was something about 64bit Kernel mode that it didn't like.So, I put it back to 10.6.3 and found the terminal command line to default the system to 32bit Kernel. I only have 2gb of RAM anyway, so no advantage to 64bit Kernel. This time, the upgrade to 10.6.8 took, and all I had to do was copy the AppleHDA.kext from 10.6.2 to get the sound back. SleepEnabler.kext crashes the system, so since I don't care about sleep mode, I removed it using terminal, while booted to the USB stick. Seems to be runing ok now. Though a few things like VLC Player don't install properly. Anyone know if I can put anything newer on here?
  2. Leopard on a Shuttle K45 - MiniHack

    I used Yoni's 10.5.x instructions to install my K45, but "About My Macintosh" doesn't show the correct processor type (Currently a Celeron 1.6 Core Duo, it shows a Core 2 Duo 3.02ghz). Is there any fix to get it to show the right chip?
  3. You probably have another dead capacitor. It's why I recommended replacing them all. I should probably do mine as well. Al
  4. While you have them both open, you might as well upgrade them both with all new caps. Maybe you'll do a Lion HowTo in the future?
  5. Maybe they both have bad caps? Check out this thread: http://us.shuttle.com/scgforum/tm.aspx?m=3...;key=ಌ
  6. I'm sorry to hear that news. I'm really upset that Shuttle discontinued these units. I wanted to get a couple more to use as a server and a media PC. They don't seem to show up on eBay all that often either. I hope you'll be able to fix it in the future.
  7. Is there any way you could re-write these directions to make them easy and step by step? I'm sorry to say that they are very confusing. I currently have my K45 running 10.5.8 using Yoni's old website, which is now gone. Luckily, I saved the contents. I'm afraid to tamper with a working system, unless I'm sure it will work. I have a K45 and a Legal, purchased Snow Leopard upgrade. I had to sell my Mac Mini, and I'd like to use my K45 while I save for either a Macbook or a new Mini in the future. So, real clear step-by-step directions would be helpful.
  8. Leopard on a Shuttle K45 - MiniHack

    There's no signature with a link. I used these directions to get Leopard working: http://yoni.homeserver.com/k45/k45/Home.html I wish there was an easy way to get Snow Leopard working as well on my K45. I just downloaded Rebel EFI from Psystar, and I might give that a try.
  9. ASRock P4Dual-915GL

    I have the same problem. I think Apple dropped support for Celeron processors from tthe OS.
  10. Has anyone done this yet? Can you share the procedure?
  11. ASRock P4Dual-915GL

    I tried to use Kalway 10.5.2 on mine, and it seemed to work until I ran About this Mac. Finder crashes when I do that. Installing the 10.5.5 Combo update the same way that worked on my K45 results in a system that reboots over and over. I've never got anything other than the original 10.4.1 to work on this board.
  12. Leopard on a Shuttle K45 - MiniHack

    I'm not having NIC problems. I'm having problems with sound, and Video not going higher than 1024x768, and shutdown issues. I never use sleep, so I don't care about that.
  13. Leopard on a Shuttle K45 - MiniHack

    I have my K45 working, except I have no sound. Can anyone point me to a method I can get sound working? Also, rebooting doesn't work. It just sits at the background screen and you see the spinner forever. Any fix for that? I bought a Slim Laptop Combo Drive from geeks.com for about $25.00 and it works fine. I got the adapter and a metal front plate from www.zigs-place.com for $25.00 including shipping, and he threw in goodies besides. I like the system, it's nice enough that I'm thinking of getting rid of my Mac Mini. It bought a 1.6ghz Dual Core Celeron processor, 1gb of RAM, 400gb SATA HDD for it. Once I get the sound working, I should be a happy camper. I used Kalyway 10.5.2, installed the 10.5.3 Kalyway Combo Update, and then used the Apple 10.5.4 Delta update. I tried using the straight Kalyway 10.5.4, and it didn't work. It wouldn't let the NIC work. Strange that they have allowed regressions in subsequent versions. Also, even applying the GMA050 fix, I'm stuck at 1024 x 768 even though my display is capable of much larger resolution. Any help would be appreciated.
  14. I bought one of these, and I can't get it to work with Leo4ALL or any 10.5.4 release I've been able to get. The networking doesn't work, and none of the options for Intel Networking make a difference. I was able to install a $25.00 Combo Drive I bought from Geeks.com with an inexpensive adapter I bought from an eBayer named Ziggs-place.com He also sells metal front panels with the cutout for the CD-Drive for $10.00 along with the CD-ROM Adapter for another $10.00 I found one post that said to apply the "IONetwork" patch. But, there's no such option on any of the DVD images, and there's no link to get it. I tried someone's fix to a .plist file, but didn't find the key that was needed to be changed in the place it said it would be. Anyone get this to work? Or, can anyone recommend a NIC that "just works" that I can install in the PCI Slot?
×