Jump to content

Ivan G.

Members
  • Content count

    10
  • Joined

  • Last visited

About Ivan G.

  • Rank
    InsanelyMac Protégé
  1. Ivan G.

    [HOW TO] Getting IDT Audio Working

    Just in case if this might help someone - I have patched AppleHDA.kext and have internal connectors working now (sound and mic). My laptop model: HP 2754TX, Intel High Definition Audio ID: 0x103C30CD and here's my Linux dump of the sound codec: Codec: Conexant CX20549 (Venice) Address: 0 Vendor Id: 0x14f15045 Subsystem Id: 0x103c30cd Revision Id: 0x100100 Modem Function Group: 0x2 Default PCM: rates [0x140]: 48000 96000 bits [0xe]: 16 20 24 formats [0x1]: PCM Default Amp-In caps: N/A Default Amp-Out caps: N/A GPIO: io=0, o=0, i=0, unsolicited=0, wake=0 Node 0x10 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1 Amp-Out vals: [0x23 0x23] Pincap 0x0810014: OUT EAPD Detect EAPD 0x2: EAPD Pin Default 0x95170110: [Fixed] Speaker at Int Top Conn = Analog, Color = Unknown DefAssociation = 0x1, Sequence = 0x0 Misc = NO_PRESENCE Pin-ctls: 0x40: OUT Unsolicited: tag=00, enabled=0 Power: setting=D0, actual=D0 Connection: 2 0x19 0x17* Node 0x11 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1 Amp-Out vals: [0x23 0x23] Pincap 0x08113c: IN OUT HP Detect Vref caps: HIZ 80 Pin Default 0x0221401f: [Jack] HP Out at Ext Front Conn = 1/8, Color = Green DefAssociation = 0x1, Sequence = 0xf Pin-ctls: 0xc0: OUT HP VREF_HIZ Unsolicited: tag=37, enabled=1 Power: setting=D0, actual=D0 Connection: 2 0x19 0x17* Node 0x12 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1 Amp-Out vals: [0xab 0xab] Pincap 0x08113c: IN OUT HP Detect Vref caps: HIZ 80 Pin Default 0x62a1902e: [N/A] Mic at Sep Front Conn = 1/8, Color = Pink DefAssociation = 0x2, Sequence = 0xe Pin-ctls: 0x24: IN VREF_80 Unsolicited: tag=00, enabled=0 Power: setting=D0, actual=D0 Connection: 2 0x19* 0x17 Node 0x13 [Pin Complex] wcaps 0x400301: Stereo Digital Pincap 0x0810: OUT Pin Default 0x21451130: [Jack] SPDIF Out at Sep Rear Conn = Optical, Color = Black DefAssociation = 0x3, Sequence = 0x0 Misc = NO_PRESENCE Pin-ctls: 0x40: OUT Connection: 1 0x18 Node 0x14 [Pin Complex] wcaps 0x400081: Stereo Pincap 0x081124: IN Detect Vref caps: HIZ 80 Pin Default 0x97a701f0: [Fixed] Mic at Int Riser Conn = Analog, Color = Unknown DefAssociation = 0xf, Sequence = 0x0 Misc = NO_PRESENCE Pin-ctls: 0x24: IN VREF_80 Unsolicited: tag=00, enabled=0 Node 0x15 [Pin Complex] wcaps 0x400001: Stereo Pincap 0x0820: IN Pin Default 0x54330121: [N/A] CD at Int Right Conn = ATAPI, Color = Unknown DefAssociation = 0x2, Sequence = 0x1 Misc = NO_PRESENCE Pin-ctls: 0x00: Node 0x16 [beep Generator Widget] wcaps 0x70000c: Mono Amp-Out Amp-Out caps: ofs=0x07, nsteps=0x07, stepsize=0x0b, mute=1 Amp-Out vals: [0x06] Node 0x17 [Audio Mixer] wcaps 0x20050b: Stereo Amp-In Amp-In caps: ofs=0x14, nsteps=0x2b, stepsize=0x05, mute=1 Amp-In vals: [0x10 0x10] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] Power: setting=D0, actual=D0 Connection: 5 0x19 0x14 0x12 0x11 0x15 Node 0x18 [Audio Output] wcaps 0x211: Stereo Digital Converter: stream=0, channel=0 Digital: Digital category: 0x0 PCM: rates [0x40]: 48000 bits [0x6]: 16 20 formats [0x5]: PCM AC3 Node 0x19 [Audio Output] wcaps 0xc11: Stereo R/L Converter: stream=0, channel=0 PCM: rates [0x540]: 48000 96000 192000 bits [0xe]: 16 20 24 formats [0x1]: PCM Power: setting=D0, actual=D0 Node 0x1a [Audio Input] wcaps 0x100d0b: Stereo Amp-In R/L Amp-In caps: ofs=0x00, nsteps=0x17, stepsize=0x05, mute=1 Amp-In vals: [0x17 0x17] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] Converter: stream=0, channel=0 SDI-Select: 0 Power: setting=D0, actual=D0 Connection: 5 0x17 0x14* 0x12 0x11 0x15 Node 0x1b [Vendor Defined Widget] wcaps 0xf00000: Mono Attaching the modified kext and HDALoader.kext so you can try to use this one. HP_IntelSound_Kexts.zip
  2. Ivan G.

    HP DV2700

    Easy. 1. Vanilla kernel 2. Kalyway kernels pack for 10.5.2 has a kernel with speed step support.
  3. Hi. I have HP Pavilion dv2754tx laptop and Intel Wireless 4965 card. Installed latest 4965 driver but can't see any interface in Networks configurations The log brings this messages: Jul 30 13:04:43 My-MacBook-Pro kernel[0]: iwl4965: U iwl4965_rx_handle r = 15, i = 14, REPLY_4965_RX, 0xc3 Jul 30 13:04:43 My-MacBook-Pro kernel[0]: iwl4965: U iwl4965_calc_rssi Rssi In A 23 B 16 C 24 Max 24 AGC dB 47 Jul 30 13:04:43 My-MacBook-Pro kernel[0]: iwl4965: U iwl4965_report_frame Beacon: 0x0080, dst=0xff, src=0x49, rssi=0, tim=0 usec, phy=0x22ab, chnl=792 Jul 30 13:04:43 My-MacBook-Pro kernel[0]: iwl4965: U iwl4965_rx_reply_rx Rssi -67, noise -127, qual 66, TSF 725778298 which looks to me like this working fine. Any ideas of what to I can do? ifconfig lists this interface without any IP address, Networks Configuration doesn't show it.
  4. Ivan G.

    Scrolling for Hackintosh's

    rm -rf /System/Library/Extensions/ApplePS2Controller.kext/Contents/PlugIns/ApplePS2Trackpad.kext did work on my HP Pavilion dv2700 series. I have even single/double tap working. Modifying the abovementioned file didn't work, though. I use Kaly10.5.2
  5. Ivan G.

    Conexant HD Audio

    Hi, Anti-user. How did you manage to enable Broadcom wireless? Which driver did you use? I use Kalyway 10.5.2 and my Broadcom wireless adapter (as found in HP website) is: ======= Broadcom 802.11 a/b/g WLAN Broadcom 802.11 b/g WLAN Broadcom 4321AG 802.11a/b/g/draft-n Wi-Fi Adapter Broadcom 4322AG 802.11a/b/g/draft-n Wi-Fi Adapter ======= It doesn't work out of box, though. My laptop is HP Pavilion dv2754tx Notebook PC
  6. Ivan G.

    HP DV2700

    Hi. I have the same laptop, probably newer model, as my CPU is Core 2 Duo 2.0 GHz and video: Nvidia 8400M 256Mb I have installed Kalyway 10.5.1 -> 10.5.2 Kalyway update and with NVinject 0.2.0 driver it works fine. Kalyway 10.5.3 combo update prevents the system from loading, though I can load into single user mode I have working: CPU/Speedstep Bluetooth touchpad USB LAN (with downloaded from this forum AppleYukon.kext.zip file, modified to work with Marwel LAN cards) Don't work: sound - Work but only speakers with AppleAzaliaOut.kext webcam - work if an application using it is enabled as "Launch with Rozetta" battery icon doesn't appear - Does with Power Management Bundle sleep mode External VGA connector Can you post the screenshot about you sound card into this forum. Maybe it'll help me to make my sound working.
  7. Ivan G.

    GIGABYTE GA-945GCMX-S2 with Leopard

    Does anyone succeed with 'make disk bootable' patch here? I am not a newbie with osx86 installs of Tiger, but this one - can't make it. Do exactly what patch says with no error messages but still can't see Darwin after all. Just black screen.
  8. Ivan G.

    GIGABYTE GA-945GCMX-S2 with Leopard

    Hi, everyone. Followed all steps in BrazilMac's tutorial but can't see Darwin when starting from Leopard HD. Applied his patch to make disk bootable with no success. In my opinion disk partition isn't bootable. Tried also to play with BIOS settings for my IDE/jMicron controller. The only mode when leopard installs is AHCI.
  9. Hi. I have the same problem. Dreamweaver runs slow. I think it is AppleSMBIOS.kext. BTW, there's a new version of AppleSMBIOS.kext, which doesn't crash About This Mac application. (at least in 10.4.10)
  10. Hi. Was browsing this topic and found interested claim about GF6800 (as this card works). I have GS6800GS (Leadtek) running on nForce4 SLI MB from Gigabyte, AMD Dual Core 3800. I tried everything that I could find in this forum - nothing changes resolution of my display from 1024x768. Darwin recongnises my video card upon loading as VESA 3.0 (NVIDIA). I tried to load macvidia drivers (1.7.x, 1.8.1) - the outcome - computer hangs during booting. All to do to fix it - reinstall osX10.4.8(Jas release for AMD/Intel). Tried also bootin options "Graphics Mode"="my resolutionXcolor@rate" and tried to change com.apple.boot.plist file with these options - nothing helps. The question is: can I do anything else? If not - what could be the best motherboard for Intel Core Duo and what videocard to run this osX 10.4.8? Thank you. Hi. Was browsing this topic and found interested claim about GF6800 (as this card works). I have GS6800GS (Leadtek) running on nForce4 SLI MB from Gigabyte, AMD Dual Core 3800. I tried everything that I could find in this forum - nothing changes resolution of my display from 1024x768. Darwin recongnises my video card upon loading as VESA 3.0 (NVIDIA). I tried to load macvidia drivers (1.7.x, 1.8.1) - the outcome - computer hangs during booting. All to do to fix it - reinstall osX10.4.8(Jas release for AMD/Intel). Tried also bootin options "Graphics Mode"="my resolutionXcolor@rate" and tried to change com.apple.boot.plist file with these options - nothing helps. The question is: can I do anything else? If not - what could be the best motherboard for Intel Core Duo and what videocard to run this osX 10.4.8? Thank you.
×