Jump to content

Tiberio Galbiati

Members
  • Content Count

    24
  • Joined

  • Last visited

Posts posted by Tiberio Galbiati


  1. On 9/29/2018 at 11:22 AM, Lockzi said:

    What Mac OS version are you running? I'm still on 10.13.3 due to DisplayLink driver issues.

    Hello I am currently running 10.13.6.

    Now I have also upgraded VoodooI2C to 2.1.4 and the number of jumps has reduced but the issues comes also after boot and does's seems related to sleep anymore.

    I am also using APCIBatteryManager.

    If you need I can also upload my troubleshooting files like ACPI or Ioreg.

     

    For the DA200 issue I can confirm the USB-C network adapter works only if plugged in after boot and it breaks after sleep.

    Should I use USBInjectall?

    By the way I have also ordered on eBay a USB 3 (non C) ethernet adapter...


  2. 4 hours ago, Lockzi said:

    Hey Guys,

     

    just wanted to quickly check here before I report a bug and troubleshoot with the developer.

    I've switched to VoodooI2C v 2.1.4 today, and if I draw a circle with the mousepointer using the trackpad continuously I can see how it teleports in the last known direction of the circle - exactly every second, which makes it impossible to do a circle.

    Is anyone else seeing this on our machines? Are everyone else still using the SSDT-I2CX.aml and SSDT-XOSI.aml from the linked post or has the development of the kext changed so it's no longer needed?

    Hello, I'm  experiencing the same issue, but only after sleep. In my case the cursor jumps randomly, I can reproduce the issue moving the cursor or in a straight line or making circles.

    I'm using VoodooI2C v2.1 with SSDT from the git repo and patched with  SSDT-I2CX.aml and SSDT-XOSI.aml from the same post.

    I really don't know the cause, so now I'm going to update to the last version and I'll tell you

     


  3. Hello,

    I have DELL XPS 15 95504K

    I have to report a strange problem, If I connect the Dell Adapter DA200 , Ethernet works but then breaks after sleep.

    I have tried with a HP usb-c adapter and it works even after sleep. I don't know why there is this difference.

    Also, after disconnecting the usb-c adapters it happens that the pointer, using trackpad with VoodooI2C  jumps by himself, I was able to reproduce this issue and it  happens only after disconnecting USB-C. If I connect again the adapter the cursor works normally again.

    I don't know the reason of this behaviour, since I followed the guide and patched ACPI for I2C.

    I attach files for reporting.

    Thank you in advance for help.

    Archive.zip


  4. See Post #1/Broadcom Device_IDs/2. Supported Device_IDs (injection required)

     

    I have discovered that my card, bought on ebay as BCM43225HMB is not supported because it has a8d8 as device id.

    I'll have to buy a new one, but you can I be sure that the card I'llbuy has the right device id?

    for example is this  card supported?

    thank you in advance

    Edit: i have found also this one


  5. Hi folks,

    My macbook pro 17" early 2011 is broken and in order to repair it the Apple premium reseller asked me 900€. So i'm going to sell it for spare parts or maybe try to modd it and create a hackbook, so what do you think i could do with the case, the lcd, the speakers and maybe the keyboard if is not broken as the service said of my dead macbook?

    Actually I have only one idea: the 17" led lcd is awesome so i could use it as a monitor, in fact I have yet succeed in making an external monitor from a laptop ( in the photo is the third from left).

     

    i need a LVDS controller and on ebay there are some, also for the lcd of the macbook that is a LP171WU6-TLA1

     

    for example do you think that this could work?

    http://www.ebay.com/itm/HDMI-DVI-VGA-Audio-Board-17-1inch-1920-1200-LP171WU6-TLA1-2-LP171WU6-TLB1-2-/190950252722?pt=LH_DefaultDomain_0&var=&hash=item722280c2d4

     

    in my opinion is too big because I would like to hide it inside the macbook and use the magsafe modded with an adaptor to 12V

     

    or what do you think I could build with my macbook?

    I will sell the ram, the fried logic board but i think the lcd, superdrive, wi-fi and bluetooth and other parts I could recycle in a modding project.

     

    thank you in advance for help and any suggestions.

     

    Tiberio

    post-1087351-0-73944300-1404581383_thumb.jpg


  6. just to clarify ... we talk about a hackintosh or a real mac?

     

    Thanks for response, it's a real mac pro, but officially it doesn't support 10.9 so I have patched the boot.efi in order to use it.

     

     

    I know the graphics it's supported oob, and in fact it works, everything is perfect, only after sleep it hangs.


  7. Hello!
    I have an Asus EAH5770 (0x68b8) in my mac pro 1.1 with Mavericks using patched efi.boot

    I have used the card with the original ROM (recognized as ATI Radeon HD 5000)
    and also with the rom patched with EFI  (recognized correctly as 5770)

    But in the two cases I have graphics hangs.

    I collected some info about the issue:
    1) the GPU hang occurs after a wake from sleep
    2) the system tries to restart the GPU
     

    kernel[0]: GPU Hang State = 0x00000000
     kernel[0]: GPU hang: 
     kernel[0]: Trying restart GPU ...
     kernel[0]: AMDJuniperGraphicsAccelerator: bad busy count (255,1)
     ** GPU ASIC Log Start **

    long log omitted

     

    02/02/14 21:08:01,546 DumpGPURestart[2936]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
    02/02/14 21:08:01,664 sandboxd[508]: ([2936]) DumpGPURestart(2936) deny network-outbound /private/var/run/mDNSResponder
    02/02/14 21:08:02,000 kernel[0]: GPU Hang State = 0x00000000
    02/02/14 21:08:02,000 kernel[0]: GPU hang: 
    02/02/14 21:08:02,000 kernel[0]: Trying restart GPU ...
    02/02/14 21:08:02,622 DumpGPURestart[2936]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
    02/02/14 21:08:02,627 sandboxd[508]: ([2936]) DumpGPURestart(2936) deny network-outbound /private/var/run/mDNSResponder
    02/02/14 21:08:03,000 kernel[0]: GPU Hang State = 0x00000000
    02/02/14 21:08:03,000 kernel[0]: GPU hang: 
    02/02/14 21:08:03,000 kernel[0]: Trying restart GPU ...
    02/02/14 21:08:03,690 DumpGPURestart[2936]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
    02/02/14 21:08:03,695 sandboxd[508]: ([2936]) DumpGPURestart(2936) deny network-outbound /private/var/run/mDNSResponder
    02/02/14 21:08:04,000 kernel[0]: GPU Hang State = 0x00000000
    02/02/14 21:08:04,000 kernel[0]: GPU hang: 
    02/02/14 21:08:04,000 kernel[0]: Trying restart GPU ...
    02/02/14 21:08:04,751 DumpGPURestart[2936]: dnssd_clientstub ConnectToServer: connect() failed Socket:5 Err:-1 Errno:1 Operation not permitted
    02/02/14 21:08:04,806 sandboxd[508]: ([2936]) DumpGPURestart(2936) deny network-outbound /private/var/run/mDNSResponder
    02/02/14 21:08:05,000 kernel[0]: GPU Hang State = 0x00000000
    02/02/14 21:08:05,000 kernel[0]: GPU hang: 
     

     

     

    3) the problem is related to these kext:

     

     
    kernel[0]: com.apple.iokit.IOAcceleratorFamily(98.7.1)[024BF8EC-2925-3C4B-ADBB-CFE36F7D41C5]@0xffffff7f8e8cf000->0xffffff7f8e927fff
    
     kernel[0]: dependency: com.apple.iokit.IOPCIFamily(2.8)[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff7f8d2ba000
    
     kernel[0]: dependency: com.apple.iokit.IOGraphicsFamily(2.3.6)[38E388A5-92D6-3388-B799-F2498E582287]@0xffffff7f8dc54000

    4) only once or twice there was kernel panic
     

    Code:
    panic(cpu 2 caller 0xffffff800f6dc19e): Kernel trap at 0xffffff7f9127cba6, type 0=divide error, registers:
    CR0: 0x000000008001003b, CR2: 0x00000001178f4000, CR3: 0x00000000120b4000, CR4: 0x0000000000000660
    RAX: 0x00000000002a8500, RBX: 0xffffff8138d4bbf0, RCX: 0x0000000000000000, RDX: 0x0000000000000000
    RSP: 0xffffff8138d4bbd0, RBP: 0xffffff8138d4bbe0, RSI: 0x0000000000000000, RDI: 0x0000000000000000
    R8:  0xffffff7f912981f0, R9:  0x0000000000000027, R10: 0x0000000000000004, R11: 0xffffff7f91298218
    R12: 0xffffff803b2417d0, R13: 0xffffff7f91298280, R14: 0xffffff8138d4bc90, R15: 0xffffff8138d4bbf0
    RFL: 0x0000000000010246, RIP: 0xffffff7f9127cba6, CS:  0x0000000000000008, SS:  0x0000000000000010
    Fault CR2: 0x00000001178f4000, Error code: 0x0000000000000000, Fault CPU: 0x2

    With these kext in backtrace:
     

    Code:
    com.apple.iokit.IOGraphicsFamily(2.3.6)
    com.apple.kext.AMDSupport(1.1.4)
    com.apple.kext.AMD5000Controller(1.1.4)
    com.apple.kext.AMDFramebuffer(1.1.4)

     

     

    I have found an AMD5000Controller.kext patched for 5770 at osx86.net
    The framebuffer now is correctly set as vervet :

     
    Ioreg | grep ATY
    
    | | | | +-o ATY,Vervet@0 <class AtiFbStub, id 0x1000002d4, registered, matched, active, busy 0 (5 ms), retain 8>
    | | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x1000002d7, registered, matched, active, busy 0 (4 ms), retain 18>
    | | | | +-o ATY,Vervet@1 <class AtiFbStub, id 0x1000002d5, registered, matched, active, busy 0 (9 ms), retain 8>
    | | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x1000002dd, registered, matched, active, busy 0 (9 ms), retain 18>
    | | | | +-o ATY,Vervet@2 <class AtiFbStub, id 0x1000002d6, registered, matched, active, busy 0 (26 ms), retain 8>
    | | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x1000002f9, registered, matched, active, busy 0 (2 ms), retain 15>

    It's strange because the card works well, it crashes only after sleep! 

    I also found in a forum the advice to disable wake on LAN.
     

     

    With my old nVidia 8500gt with 8400gs I haven't had any problem.
    Thanks for advice, I hope to find a guru of graphics card in order to solve the issue.


  8. Oggi ho provato, funziona il boot.efi

    infatti carica l'installazione di mavericks (tra l'altro pure con la scheda 7300, oltre che con la 8500) solo che l'installer non parte e dà un errore: dice che manca il software essenziale del sistema.

     

    Avete idee a riguardo, su come sistemare l'installer, visto che il resto va al 100% ?


  9. Buonasera,

    Come saprete il mac Pro 1.1 del 2006 non può installare nativamente os superiori a lion per via del fatto che supporta il boot solo da efi a 32bit.

     

    Per aggiornarlo a os superiori era necessario usare chameleon bootloader che aggirava questa limitazione, ma da oggi grazie ad un utente di Macrumors (Tiamo) è possibile effettuare un'installazione di mavericks sul mac pro senza usare chameleon.

     

    Qui tutti i dettagli (in inglese)

    http://forums.macrumors.com/showthread.php?t=1598176&page=2

     

    Altrimenti qui trovate il tool per creare l'installer bello che pronto, si chiama SFOTT

    http://oemden.com/?p=556

     

    Ordunque, quando si parla di hackerare il mac pro 1.1 bisogna pure tirare in ballo la scheda grafica giacchè quella standard 7300 nVidia non è più supportata ( e fa proprio ca...) e qui nascono i casini, almeno per me, che non ho una card supportata nativamente (si veda per esempio la serie 6xx nvidia) disponibile.

    Domani proverò una nvidia 8500 e vi faccio sapere, altrimenti c'è qualcuno che, come me, ha un mac pro 1.1 con os superiori a lion che gli girano su?


  10. Buongiorno a tutti, il mio nome è Tiberio, Tiberio Galbiati, finalmente mi son deciso ad entrare pure nel forum italiano dopo aver iniziato a scrivere in quello internazionale.

     

     

    Sono un utente Apple ( MacBook pro 2011 17", MacPro 1,1, PowerMac G5, iPad, iPhone 2G, iPod touch 1G) e mi sono assemblato per ora solo un hackintosh decente (i7 3770k@ 4,3GHz cooled by H90 Corsair, GA-Z77-DS3H, 16GB DDR3 @ 2000mHz, MSI nVidia GTX 660Ti OC, SSD 250gb + SSD 100gb) ho anche un paio di PC su cui ho provato OS X ma senza un completo supporto per via di hardware incompatibile.

     

    Saluti


  11. It's really a useful guide for OC with Hackintosh.

     

    But returning to my hardware: I read some stuff about SSDT and Power Management and I tried to do what Gringo said.

     

    First:  there is no need to patch BIOS on Z77-based Gigabyte boards because they aren't locked by default.

    Second: I found a SSDT.aml with P-States for a maximum speed of 4.7 GHz and I put it into /Extra

    I also upgraded HWMonitor and FakeSMC 

     

    Of course I removed NullCpuPowerManagement from /Extra/Extensions

     

    And now happens a very strange thing:

    when I boot on Mac OS X, HWMonitor recognizes a maximum CPU multiplier of 35

    but if I go to sleep and after I wake from sleep, suddenly (by magic) HWMonitor works!  My OC is really effective only after a wake from sleep. I'm stunned.

     

    I don't understand what happens, because also my USB 3 ports work only after a wake from sleep and before devices plugged into that ports are not recognized by the system.

     

     

    I'm sorry but I still need help, thanks a lot for the time spent reading my posts and for your answers that made me happy.

     

    Tiberio Galbiati


  12. Yes, you can just increase the multiplier of the CPU because it's unlocked. In order to reach 4.3 Ghz I raised to 43 the multiplier but I cannot put up it more. If my mobo had the Vcore setting I could reach higher frequencies.

     

    In my Ga-Z77-DS3H I also set profile 1 for the RAM with manual ratio @20 so the clock of the RAM is 2000 MHz (instead of the standard 1866 MHz, i use Corsair vengeance PRO).

     

    But I have a problem with OSX and the overclocking could you help me in this post


  13. I have the same board but with an i7 3770K cooled by Corsair H90 liquid (closed loop).

    The problem of that mobo is the lack of the Vcore setting so it's difficult to reach very high frequencies because you cannot over volt the CPU

    in my case the max stable speed is 4.3 Ghz

    but you can increase the clock of the ram...


  14. Hi!

    This is my second post, i'm italian and my english is not perfect so be patient with me!

    I overclocked  my CPU into the BIOS @4.3Ghz and the RAM @2000mhz  (GA-Z77-DS3H   i7 3770K  16 gb DDR3 Corsair vengeance pro Corsair H90 cooler )

     

    But OSX info shows that my CPU's clock is the standard 3.5Ghz (the RAM is correct @2000mhz) and also HWMonitor detect the same.

     

    I tried to put into /Extra different SSDT but nothing changed. I also edited smbios with Chamelen Wizard in order to set the maximum clock speed of the CPU at over 4.3 Ghz and changed system definition a few times.

    Geekbench score was about 13500.

     

    When I decided to remove NullCpuPowerManagment.kext from /Extra/Extensions in my hackintosh HWMonitor recognized the OC and showed the correct CPU ratio and also my Geekbench score bumped up at 16446

    But with this change made the system not working well: audio (from USB speakers and also from the jack port) was broken, internet was slow.

     

    At the end I restored the NullCpuPowerManagment.kext and now my system is working like at the beginning: is not overcloked!

     

    Is there a solution? Can I use my Hackintosh at the full of his performance? I want a machine that shows the correct CPU's frequency and works well. It's a dream or...?

     

    Thank you for listening my story and for the help that you will give me.

     

    Tiberio Galbiati


  15. Hello, my name is Tiberio, I came from Milan, Italy.

    MacBook user and now I'm going to install OS X also on my new Hackintosh

    (Gigabyte GA-Z77-DS3H rev 1.1 |   i7-3770K cooled by Corsair Hydro Series H90 | MSI N660Ti-2GD5/OC nVidia GeForce GTX 660 Ti | 16GB DDR3 Corsair Vengeance Pro 1866MHz SSD SanDisk Extreme 240GB SSD SanDisk 128GB | Seagate Barracuda 7200.12 1TB 3.5" Corsair GS600 PSU | Corsair Carbide Series 500R case ) with a little overclock.

    Fountain pen lover, I'm the only here or not? I also like listening to progressive rock.

×