Jump to content

SavageAUS

Donators
  • Content Count

    2,645
  • Joined

  • Last visited

  • Days Won

    6

Reputation Activity

  1. Like
    SavageAUS reacted to vit9696 in OpenCore Discussion   
    Well, the advice is not really different: EnableWriteUnprotector, ProtectMemoryRegions, RebuildAppleMemoryMap, SetupVirtualMap, SyncRuntimePermissions. Try all combinations. 2^5 variants.
     
  2. Like
    SavageAUS got a reaction from xtddd in [pre-release] macOS Catalina 10.15.6   
    Smooth update for me.
    OpenCore 0.5.9

  3. Like
    SavageAUS reacted to headkaze in Hackintool v3.x.x   
    Use Xcode
    I'd like to add bootlog output for OpenCore.
  4. Like
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    I’m trying to boot Arch Linux on my laptop from OC. macOS and windows boot just fine but Arch Linux doesn’t appear in boot picker, just the EFI entry that boots to black screen.
     
    @anyone where would I put .contentDetails to change the name of a Linux entry? On my desktop it appears as NO NAME and I want to rename it (It is Arch Linux) and boots just fine which is why I don’t understand why it won’t on my laptop. Booting Arch Linux via bios menu works fine too but want to use picker.
     
     
    Sent from my iPhone using Tapatalk
  5. Like
    SavageAUS got a reaction from AlfredoM in RELEASE 10.5.5 is online....   
    I don’t know if it was OC or not. iGPU config not changed from 10.14 - 10.15.5 betas - 10.15.5 release.
    I have UHD630 in laptop.
     
    Sent from my iPhone using Tapatalk
  6. Sad
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    Yeah CFG lock. I used modified grub shell to change the var to unlocked.
    I also uploaded config.plist to check for errors.


    Sent from my iPhone using Tapatalk
    Yeah CFG lock. I used modified grub shell to change the var to unlocked.
    I also uploaded config.plist to check for errors.


    Sent from my iPhone using Tapatalk
  7. Like
    SavageAUS reacted to Matgen84 in OpenCore Discussion   
    If you use OpenCore 0.5.9 up to date: see in changelog.
    Removed RequestBootVarFallback due to numerous bugs So delete it in your config.plist
  8. Like
    SavageAUS got a reaction from arsradu in OpenCore Discussion   
    The windows install works 100% with Clover. I remember OC used to have a setting that wouldn’t pass its specifics to windows but that’s since been removed.
    I guess I’ll have to work out how to implement the _OSI checks to my SSDT’s so they don’t get passed through to windows. 
  9. Sad
    SavageAUS got a reaction from Matgen84 in Customized OpenCore with additional features   
    Dev is AFK? Not much movement in the repo for a while now. 
  10. Like
    SavageAUS reacted to ameris_cyning in SMBIOS choice   
    As far as I am aware between the two MacBookPro15,X and MacBookPro16,1 have no differences besides cosmetic
     
    The 9th gen and 8th gen Intel CPUs are both Coffee Lake
     
    https://en.wikipedia.org/wiki/Coffee_Lake
  11. Like
    SavageAUS reacted to Cyberdevs in SMBIOS choice   
    run this in terminal and see what's the output:
    sysctl -n machdep.cpu.brand_string if the results is the exact model of your CPU then what's shown in the About This Mac is cosmetic which can also be changed by adding the correct CPU type in the config.
     
  12. Like
    SavageAUS got a reaction from MacNB in OpenCore Discussion   
    Does anyone have a guide/instructions as to what needs to be done in detail to make Windows 10 boot from OC? I get a acpi bios error when trying to boot windows from OC but boots fine for UEFI boot menu but i would prefer to use bootloader (wife friendly) I know i can use a fork of this project to get what i need but i would rather use the origin for better support...
  13. Like
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    Hi guys,
    Long time clover user here but i got a new laptop and thought it was time to switch to OC. I have setup my USB but i get stuck at PCI Configuration Begin or i get KP (depends which options i boot with (npci=0xX000)).
    My new laptop is a metabox Alpha (Clevo)
    i7-9750H @ 2.60Ghz
    16G Ram
    Inteh UHD Graphics 630
    GTX1650 (I know, won't work)
    1080p 144hz ips screen
    Realtek ALC269
    Intel Killer WiFi 6 AX1650x ( I know, won't work, waiting on delivery of new Broadcom card)
     
    I'll attach config at a later point when i get time.
    But i'll take any guidance in the mean time.
    OC.zip
    opencore-2020-04-02-003840.txt
  14. Sad
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    I can’t give you a yes or no if OC corrupts uefi or not but I can say with my skylake rig if I boot (accidentally from USB) with wrong acpi config in OC it noops my uefi bios back to defaults and gives me an acpi error.
     
     
    Sent from my iPhone using Tapatalk
  15. Sad
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    I can’t give you a yes or no if OC corrupts uefi or not but I can say with my skylake rig if I boot (accidentally from USB) with wrong acpi config in OC it noops my uefi bios back to defaults and gives me an acpi error.
     
     
    Sent from my iPhone using Tapatalk
  16. Like
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    You should only be using FwRuntimeServices.efi with opencore. Not AptioMemory at all.


    Sent from my iPhone using Tapatalk
  17. Like
    SavageAUS got a reaction from gengik84 in [SOLVED] A Bunch of S**T!   
    https://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/


    Sent from my iPhone using Tapatalk
  18. Like
    SavageAUS got a reaction from gengik84 in [SOLVED] A Bunch of S**T!   
    https://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/


    Sent from my iPhone using Tapatalk
  19. Like
    SavageAUS got a reaction from gengik84 in [SOLVED] A Bunch of S**T!   
    https://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/


    Sent from my iPhone using Tapatalk
  20. Sad
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    I left them empty after inputting MinKernel and MaxKernel on each kext entry and still no boot, same KP.


    Sent from my iPhone using Tapatalk
  21. Sad
    SavageAUS got a reaction from Matgen84 in OpenCore Discussion   
    Anyone?


    Sent from my iPhone using Tapatalk
  22. Like
    SavageAUS got a reaction from matclara19 in Fenvi FV-T919   
    I just received the card above for my desktop and I must say it’s fantastic, wifi and bt 4.0 on my hack with NO extra kexts (I do have AirportFixUp to fix region but that’s it) needed at all. Plug and play.
    Windows drivers available on the Fenvi site for dual booting.
    100% Broadcom and 100% working oob.
    I’ll post pics of install and details when I can.
     
     
    Sent from my iPhone using Tapatalk
  23. Like
    SavageAUS got a reaction from Matgen84 in Intel Framebuffer patching using WhateverGreen   
    I fixed the instant reboot but still have cursor lag.
     
    config.plist
  24. Like
    SavageAUS got a reaction from Matgen84 in [Pre-Release] macOS Catalina 10.15.1   
    My laptop has 8 series and I updated from release - .1 b1 - b2 no issues. No tweaking needed.
     
     
    Sent from my iPhone using Tapatalk
  25. Like
    SavageAUS got a reaction from Matgen84 in Clover General discussion   
    Thanks for that. To keep my PC wife friendly I need it to boot straight into windows 10, she doesn’t like the “stupid countdown” even though with clover Windows is set as default. So I’ll keep my EFI’s separate and just deal with the occasional ghost entry. 
×