Jump to content

roto31

Members
  • Content Count

    3
  • Joined

  • Last visited

About roto31

  • Rank
    InsanelyMac Protégé
  1. roto31

    Lenovo ThinkPad T420 with UEFI Only

    After the resolution and acceleration frustration with Mojave I wiped the drive and installed High Sierra. During the install it had four separate spaces looking like 4 separate monitors. I figured it was a fluke and thought it might go to normal at first boot. The issue persisted. I’ve tried the default config.plist as well the the other 3 included .plists for High Sierra. Could it be something to do with the dual link display settings? *Update* I reverted to the EFI Folder that was from 10.08.2018 which was linked form the McDonnell Tech guide. I now have normal resolution no "multi-display" issue on the screen and things to be working fine. As much as I would love to have Mojave on this machine I think I'll stay with High Sierra. It'll get security and application updates for the next few years for sure. It's not a primary machine and more or less one to experiment with. In my number of actual Macs and Hackintoshesin my house it's #8. It's something I tinker with to keep my skills with OS X fresh and up to date. Working with and building Hackintoshes (especially laptops) have helped keep my skills on the inner workings of OS X up to date. Great job at being able to keep the T420/X220 series up to date with the macOS. It definitely helped those who cannot afford a Mac be able to have a "Mac", if you are willing to do some tinkering and some experimentation.
  2. roto31

    Lenovo ThinkPad T420 with UEFI Only

    Not sure what I did wrong, but my T420 is stuck at 900x600 resolution. I've tried to boot with all of the Mojave compatible .plist files. I have not been able to get the Intel GMA300 .kexts to install? What is the proper way to install the .kext files to S/L/E ? Tried copying them directly - then running the permission fix. Used kext beast from tonymac.x86 and that worked to install the kexts, but I do not have acceleration.
  3. roto31

    Lenovo ThinkPad T420 with UEFI Only

    I'm coming back to my Lenovo T420 after a LONG time away from this thread. Based on the kext packages from TLuck, am I right in my assumption that Mojave can be installed on the T420 based on the .plists as well? Or and I wrong in that assumption? Any issues with compatibility? I know support for Intel GMA3000 has been dropped from being supported in Mojave, what is the work around?
×