Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About speedy859

  • Rank
    InsanelyMac Protégé
  1. I've noticed something weird on my D830 with NVS 140m...the whole OS X interface seems a little laggy when i first boot up, but if i sleep the display after booting and wake the display up again, everything becomes quite snappy again (expose, dock, etc.) I suppose its probably just a drivers issue of some sort...just thought it was rather interesting. Oh, and running the xbench graphics tests before and after sleeping my display indicates that sleeping my display essentially doubles my overall scores. Wonder if anyone else had noticed this?
  2. Sigmatel 9205 with iATKOS (Leopard)

    Model: Dell Latitude D830, BIOS A02, Kalyway 10.5.1 Version: kext2: everything that is supposed to work, works Version: kext3: simply does not work at all. I dont know, maybe i need to update bios? although it seems strange that kext2 should work completely and kext3 not at all
  3. Fixing Time Synchronization

    Oh haha...makes me feel kind of stupid That's what i get for only checking in to the scene sporadically.
  4. Most people have probably noticed how the clocks of OS X and Windows (at least, windows xp, i don't know about vista) are always wrong after rebooting from one OS into the other (unless you live at GMT). This is because of the way OS X and Windows read the time from the BIOS. I found the fix to this problem here, but it doesn't work entirely: http://wiki.osx86project.org/wiki/index.ph...iversal_for_RTC The first method seemed the best to me, but it had a few issues: [skip to the dashed line if you just want my final solution. My only new contribution are two modifications to the original procedure detailed in the wiki] 1. The way it works is that on boot OS X sets its own local time to the BIOS time (what OS X thinks is UTC). On shut down, OS X then sets UTC to be the current time, so that the BIOS clock will match local time (in other words, it saves local time into the BIOS). This probably seems a little confusing, so here's an example: Let's say we're in GMT -5 (aka U.S. Eastern Time). Booting up the comp, the BIOS reads 11:00 AM. Starting up OS X, the date command is run -> 11:00 AM becomes local time. Without that date command, OS X would think that is 6:00 AM. Anyway, we do our stuff, then restart the comp to use Windows. Let's say its 11:10 AM at this point. If OS X shows 11:10 AM, that means in the BIOS right now it reads 4:10 PM. The second date command sets the BIOS time to 11:10 AM. Without this date command, Windows would show the time as 4:10 PM instead of 11:10 AM. The issue is that the date commands on the wiki don't set seconds. If it is 11:00:55 in the BIOS, the first date command makes it 11:00:00 in OS X. Of course, this isn't a huge problem, but it annoyed me. 2. If you leave automatic time synchronization enabled in OS X, it seems sometimes the synchronization will run before the first date command while booting. This causes time to actually get further messed up. Example: It is 11:00 AM in the BIOS. OS X synchronizes to 11:00 AM local time before the first date command is run, which means it is now 4:00 PM in the BIOS. the date command then runs, setting local time to match BIOS time, which means OS X now displays 4:00 PM when it is really 11:00 AM. Anyway, fixing the second issue is easy; just turn off time synchronization in OS X. However, without fixing the first issue, this means that with enough reboots the time will be significantly off. I managed to figure out modifications to the two date commands that will allow them to set seconds as well, fixing the first issue. ------------------------------------------------------------------------------------------------------------------------------- -Open terminal. -Type "sudo nano /etc/rc.local" without the quotes. The file likely doesn't exist, so you'll be creating a new one. -paste this line to the file: date `date -u +%m%d%H%M%Y.%S` -press Ctrl-O, then enter to save. press Ctrl-X to get back to terminal. -type "sudo nano /etc/rc.shutdown.local" without the quotes. Again, the file probably doesn't exist. -paste this line to the file: date -u `date +%m%d%H%M%Y.%S` -press Ctrl-O, then enter to save. press Ctrl-X to get back to terminal. -Turn off automatic time synchronization in OS X under system preferences. We can let windows do the sync'ing, or just manually sync every now and time. That should be it. Hope it works for you!
  5. Sigmatel 9205 with iATKOS (Leopard)

    hmm, i dont know what im doing wrong...ill stick to the previous version for now.
  6. Sigmatel 9205 with iATKOS (Leopard)

    Paulo I can't get it to work on my Latitude D830...do I need to install something else other than your kext?
  7. Sigmatel 9205 with iATKOS (Leopard)

    new kext also does not work for me
  8. Sigmatel 9205 with iATKOS (Leopard)

    Oh, that makes sense, i had totally forgotten about AppleAzaliaAudio the first step.
  9. Sigmatel 9205 with iATKOS (Leopard)

    I managed to get this working on my Latitude D830 running kalyway 10.5.1 with vanilla kernel, although kind of in a roundabout way. First i installed the kext Paulo provided, which didn't work. Then i used appleHDA 1.20 with the D630 codec dump from wiruzik (the first one he posted), which still didn't work Then I reinstalled Paulo's kext again, and suddenly speakers, headphones, and line-in all worked!