Jump to content

crossray

Members
  • Content count

    11
  • Joined

  • Last visited

About crossray

  • Rank
    InsanelyMac Protégé
  1. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Thank you GhostRaider for your help. I am biting Yosemite on my Thinkpad x201 now. I tried to delete NV*.kext, AMD*.kext and AppleKextExcludeList.kext, and apply my SMBIOS and patched AppleIntelHD*.kext from your attachments. To my surprise it ran into installation screen. After installation, the new Yosemite couldn't boot to desktop, and then I just boot to my MountainLion on USB HDD and remove NV*.kext, AMD*.kext, Geforce*.kext, ATI*.kext, and AppleIntelHD*.kext, and apply patched AppleIntelHD*.kext to the /S/L/E of new Yosemite. Just boot the Yosemite with installation USB driver, and apply post installation with "OS X Yosemite Chameleon" to install Chameleon. And now The new Yosemite running well
  2. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Have tried various options. It seems that Apple Intel HD kexts in /S/L/E of installer, actually in BaseSystem.dmg, should be patch for laptop and PC which get only one video card to install Yosemite. As there are only FOUR Apple Intel HD kexts in BaseSystem.dmg.
  3. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Plus, it seems the installer can only load original Apple Intel HD kexts in /S/L/E. It can also load my AppleIntelEther1000 kext. But if I copy the original Apple Intel HD kexts out of /S/L/E and then copy back again, it still failed to enter Installation UI. Frustrated.
  4. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    I am trying to install Yosemite from USB installer. But the AppleHD*.kext in installer cannot be removed as there is only one DisplayCard in my laptop Thinkpad X201. If the Intel HD kexts are removed, it couldn't be boot into installation UI. Could the Intel HD kexts in installer be patched?
  5. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Plus, kext-dev-mode=1 was set in chameleon boot option plist file. So the patched kext should had work but failed.
  6. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Hi gvanderwindt, thanks for the hint. I guess it would solve my problems. But how do I install patched kext to my bootable USB installer? I tried Kext Wizard 3.7.10 and it now worked. And Kext Utility cannot install kext to bootable USB installer too.
  7. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Dear GhostRaider, Thanks for the updates in time. The kext and patcher had worked perfect for my Thinkpad x201 on OSX 10.8~10.9.5. But for the final OSX 10.10, the kext and patcher not work now. As there are only Four AppleIntelHD*.kext in Yosemite (Missing AppleIntelGraphicsGLDriver.bundle). I used "OSX Yosemite Chameleon" (Downloaded from http://www.insanelymac.com/forum/topic/301138-new-usb-installer-os-x-yosemite-chameleon-enoch-r2403/) to make bootable USB from Yosemite Installer downloaded from AppStore. And the USB installer worked fine would enter installation UI with fuzzy language setting screen as well as OSX 10.8~10.9.5. If I try to patch the FB again or use the Patched V10.0.19 kext, it can not enter installation UI. I guess there were something missing with the Patcher or patched kext. Would you please give a glance?
  8. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Another issue besides electric current noise during web page scrolling is ripple effect still not available (LotsaWater screen saver preview not function). Maybe I missed something.
  9. Thanks to mnorthern and warraisraw, my backlight kext are all loaded with sun bezel (ScrollLock and PauseBreak) and slider in preference. Following the guides with my own sub device LCD0
  10. My laptop is the same model with you Felix, and BAR1 is 0xF2000004 too. Only "Interrupt Line" is none which Felixs' is IRQ11. I changed _WAK to Method (_WAK, 1, NotSerialized) { Store (0x80000000, LEVW) Store (0x061A061A, LEVX) // This value should vary based on the RW Everything inspect results Store (0x80000000, LEV2) Store (0x12FF, LEVL) Return (Package (0x02) { Zero, Zero }) } and added OperationRegion (BRIT, SystemMemory, 0xF2048254, 0x04) Field (BRIT, AnyAcc, Lock, Preserve) { LEVL, 32 } OperationRegion (BRI2, SystemMemory, 0xF2048250, 0x04) Field (BRI2, AnyAcc, Lock, Preserve) { LEV2, 32 } OperationRegion (BRI3, SystemMemory, 0xF20C8250, 0x04) Field (BRI3, AnyAcc, Lock, Preserve) { LEVW, 32 } OperationRegion (BRI4, SystemMemory, 0xF20C8254, 0x04) Field (BRI4, AnyAcc, Lock, Preserve) { LEVX, 32 } I but still no brightness bar in System Preference I can always control brightness with Fn+Brightness keys, but could not load AcpiBacklight.kext How to load AcpiBacklight.kext and get the brightness bar in System Preference and Brightness Sun Bezel?
  11. crossray

    [GUIDE] 1st Generation Intel HD Graphics QE/CI

    Thanks all! Thinkpad x201 works! A little bit noise during page scrolling on safari/chrome
×