Jump to content
InsanelyMac Forum

miaumiau2

Members
  • Content count

    12
  • Joined

  • Last visited

About miaumiau2

  • Rank
    InsanelyMac Protégé
  1. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Well... cable is fine, I can boot into ML and the monitor works. No cat at work here.
  2. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Ok, back on track... I had only changed one of the values. I now have 4 frame buffers. However, when connecting to my External Display via Displayport it crashes. Not mavericks, the display! I can't switch sources our even turn it off anymore and need to unplug it... Never knew Monitors could Crash. 21/03/14 21:43:40,115 WindowServer[90]: Received display connect changed for display 0x3900b600 21/03/14 21:43:40,117 WindowServer[90]: Found 11 modes for display 0x3900b600 [6, 5] 21/03/14 21:43:40,121 WindowServer[90]: Received display connect changed for display 0x3f003d 21/03/14 21:43:40,123 WindowServer[90]: Found 15 modes for display 0x003f003d [12, 3] 21/03/14 21:43:40,124 WindowServer[90]: Display 0x003f003d changed state to online 21/03/14 21:43:40,132 WindowServer[90]: Received display connect changed for display 0x3f003e 21/03/14 21:43:40,132 WindowServer[90]: Found 1 modes for display 0x003f003e [1, 0] 21/03/14 21:43:40,132 WindowServer[90]: Received display connect changed for display 0x3f003f 21/03/14 21:43:40,132 WindowServer[90]: Found 1 modes for display 0x003f003f [1, 0] 21/03/14 21:43:40,157 WindowServer[90]: Display 0x3900b600: GL mask 0x1; bounds (0, 0)[1366 x 768], 11 modes available Main, Active, on-line, enabled, built-in, boot, OpenGL-accel, Vendor 30e4, Model 2d8, S/N 0, Unit 0, Rotation 0 UUID 0x56a261ac023a91a83de96bf5cb585786, ColorProfile { 3, "Generic RGB Profile"} 21/03/14 21:43:40,157 WindowServer[90]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:43:40,158 WindowServer[90]: Display 0x003f0040: GL mask 0x10; bounds (2390, 0)[1 x 1], 2 modes available off-line, enabled, OpenGL-accel, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 4, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,158 WindowServer[90]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:43:40,158 WindowServer[90]: Display 0x003f003f: GL mask 0x8; bounds (2391, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,159 WindowServer[90]: Display 0x003f003e: GL mask 0x4; bounds (2392, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,159 WindowServer[90]: Display 0x70c81a01: GL mask 0x2; bounds (1366, 0)[1920 x 1080], 15 modes available Active, on-line, enabled, Vendor 15c3, Model 2068, S/N 0, Unit 1, Rotation 0 UUID 0x3816f6df8e010805ab26430c1aa32b1b, ColorProfile { 4, "EV2333W"} 21/03/14 21:43:40,160 Dock[205]: Set a breakpoint at CGSLogError to catch errors as they are logged. 21/03/14 21:43:40,160 Dock[205]: CGSCopyDisplayUUID: Invalid display 0x70c81a01 21/03/14 21:43:40,160 Dock[205]: uuid_callback_master: failed to retrieve UUID for display 0x70c81a01 (1001) (invariant failure) 21/03/14 21:43:40,161 Dock[205]: CGSCopyDisplayUUID: Invalid display 0x70c81a01 21/03/14 21:43:40,161 Dock[205]: uuid_callback_master: failed to retrieve UUID for display 0x70c81a01 (1001) (invariant failure) 21/03/14 21:43:40,162 Dock[205]: CGSCopyDisplayUUID: Invalid display 0x70c81a01 21/03/14 21:43:40,162 Dock[205]: uuid_callback_master: failed to retrieve UUID for display 0x70c81a01 (1001) (invariant failure) 21/03/14 21:43:40,166 WindowServer[90]: Display 0x3900b600: Unit 0: Startup Mode 1366 x 768, CGSThirtytwoBitColor, Resolution 1, ioModeID 0x80000000, ioModeDepth 0x0, IOReturn 0x0 21/03/14 21:43:40,166 WindowServer[90]: Display 0x70c81a01: Unit 1: Startup Mode 1920 x 1080, CGSThirtytwoBitColor, Resolution 1, ioModeID 0x80000000, ioModeDepth 0x0, IOReturn 0x0 21/03/14 21:43:40,166 WindowServer[90]: Display added 21/03/14 21:43:40,166 WindowServer[90]: Display removed 21/03/14 21:43:40,168 WindowServer[90]: Display 0x3900b600: GL mask 0x1; bounds (0, 0)[1366 x 768], 11 modes available Main, Active, on-line, enabled, built-in, boot, OpenGL-accel, Vendor 30e4, Model 2d8, S/N 0, Unit 0, Rotation 0 UUID 0x56a261ac023a91a83de96bf5cb585786, ColorProfile { 3, "Generic RGB Profile"} 21/03/14 21:43:40,169 WindowServer[90]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:43:40,169 WindowServer[90]: Display 0x003f0040: GL mask 0x10; bounds (4310, 0)[1 x 1], 2 modes available off-line, enabled, OpenGL-accel, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 4, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,169 WindowServer[90]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:43:40,169 WindowServer[90]: Display 0x003f003f: GL mask 0x8; bounds (4311, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,169 WindowServer[90]: Display 0x003f003e: GL mask 0x4; bounds (4312, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:43:40,169 WindowServer[90]: Display 0x70c81a01: GL mask 0x2; bounds (1366, 0)[1920 x 1080], 15 modes available Active, on-line, enabled, Vendor 15c3, Model 2068, S/N 0, Unit 1, Rotation 0 UUID 0x3816f6df8e010805ab26430c1aa32b1b, ColorProfile { 4, "EV2333W"} 21/03/14 21:43:40,169 WindowServer[90]: _CGXGLDisplayContextForDisplayDevice: acquired display context (0x7fb30ac11ff0) - enabling OpenGL 21/03/14 21:43:40,170 WindowServer[90]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:43:42,122 WindowServer[90]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:43:42,133 WindowServer[90]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:43:42,164 WindowServer[90]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:43:42,168 WindowServer[90]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:43:42,173 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,174 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,195 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,196 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,216 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,217 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,246 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,247 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,260 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,261 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,270 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,271 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,280 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,280 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,290 WindowServer[90]: Display 0x3900b600: Unit 0; ColorProfile { 3, "Generic RGB Profile"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:43:42,290 WindowServer[90]: Display 0x70c81a01: Unit 1; ColorProfile { 4, "EV2333W"}; TransferFormula (1.000000, 1.000000, 1.000000) EDIT: I switched to sot's DSDT and it looks better in the logs, but still freezes my external monitor (black screen, no more reaction on button presses) 21/03/14 21:54:18,100 WindowServer[92]: Received display connect changed for display 0x2b903800 21/03/14 21:54:18,102 WindowServer[92]: Found 12 modes for display 0x2b903800 [7, 5] 21/03/14 21:54:18,105 WindowServer[92]: Received display connect changed for display 0x70c81a01 21/03/14 21:54:18,106 WindowServer[92]: Found 1 modes for display 0x70c81a01 [1, 0] 21/03/14 21:54:18,106 WindowServer[92]: Display 0x70c81a01 changed state to offline 21/03/14 21:54:18,106 WindowServer[92]: Received display connect changed for display 0x3f003e 21/03/14 21:54:18,107 WindowServer[92]: Found 1 modes for display 0x003f003e [1, 0] 21/03/14 21:54:18,107 WindowServer[92]: Received display connect changed for display 0x3f003f 21/03/14 21:54:18,107 WindowServer[92]: Found 1 modes for display 0x003f003f [1, 0] 21/03/14 21:54:18,123 WindowServer[92]: Display 0x2b903800: GL mask 0x1; bounds (0, 0)[1366 x 768], 12 modes available Main, Active, on-line, enabled, built-in, boot, OpenGL-accel, Vendor 30ae, Model 40e0, S/N 0, Unit 0, Rotation 0 UUID 0xb5952b58f709432e814c28b243072c9b, ColorProfile { 2, "Display"} 21/03/14 21:54:18,123 WindowServer[92]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:54:18,123 WindowServer[92]: Display 0x003f0040: GL mask 0x10; bounds (4310, 0)[1 x 1], 2 modes available off-line, enabled, OpenGL-accel, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 4, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,123 WindowServer[92]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:54:18,123 WindowServer[92]: Display 0x003f003f: GL mask 0x8; bounds (4311, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,123 WindowServer[92]: Display 0x003f003e: GL mask 0x4; bounds (4312, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,123 WindowServer[92]: Display 0x003f003d: GL mask 0x2; bounds (1366, 0)[1 x 1], 1 modes available off-line, enabled, OpenGL-accel, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff, ColorProfile { 3, "EV2333W"} 21/03/14 21:54:18,123 WindowServer[92]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:54:18,127 WindowServer[92]: Display 0x2b903800: Unit 0: Startup Mode 1366 x 768, CGSThirtytwoBitColor, Resolution 1, ioModeID 0x80001000, ioModeDepth 0x0, IOReturn 0x0 21/03/14 21:54:18,127 WindowServer[92]: Display added 21/03/14 21:54:18,127 WindowServer[92]: Display removed 21/03/14 21:54:18,129 WindowServer[92]: Display 0x2b903800: GL mask 0x1; bounds (0, 0)[1366 x 768], 12 modes available Main, Active, on-line, enabled, built-in, boot, OpenGL-accel, Vendor 30ae, Model 40e0, S/N 0, Unit 0, Rotation 0 UUID 0xb5952b58f709432e814c28b243072c9b, ColorProfile { 2, "Display"} 21/03/14 21:54:18,129 WindowServer[92]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:54:18,129 WindowServer[92]: Display 0x003f0040: GL mask 0x10; bounds (2390, 0)[1 x 1], 2 modes available off-line, enabled, OpenGL-accel, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 4, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,129 WindowServer[92]: GLCompositor: GL renderer id 0x01024301, GL mask 0x0000001f, accelerator 0x000049cb, unit 0, caps QEX|MIPMAP, vram 579 MB texture max 8192, viewport max {8192, 8192}, extensions FPRG|NPOT|GLSL|FLOAT 21/03/14 21:54:18,129 WindowServer[92]: Display 0x003f003f: GL mask 0x8; bounds (2391, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,129 WindowServer[92]: Display 0x003f003e: GL mask 0x4; bounds (2392, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 21/03/14 21:54:18,129 WindowServer[92]: Display 0x003f003d: GL mask 0x2; bounds (2393, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff, ColorProfile { 3, "EV2333W"} 21/03/14 21:54:20,106 WindowServer[92]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:54:20,127 WindowServer[92]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'. 21/03/14 21:54:20,137 WindowServer[92]: Display 0x2b903800: Unit 0; ColorProfile { 2, "Display"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:54:20,158 WindowServer[92]: Display 0x2b903800: Unit 0; ColorProfile { 2, "Display"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:54:20,170 WindowServer[92]: Display 0x2b903800: Unit 0; ColorProfile { 2, "Display"}; TransferFormula (1.000000, 1.000000, 1.000000) 21/03/14 21:54:20,179 WindowServer[92]: Display 0x2b903800: Unit 0; ColorProfile { 2, "Display"}; TransferFormula (1.000000, 1.000000, 1.000000) EDIT 2: I suspect it has to do with hardware acceleration not working... no ripple effect on dashboard. But hey the unknown platform is gone EDIT 3: Nope, hardware acceleration works, I have ripples :-) But still no progress on display port monitor. Looks like display is added and removed. is it normal?
  3. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Hey truck, funny someone had the same problem... I also had figured out I need to set to MacbookPro8,1 which I did (Clover was setting MacbookPro8,3). However, the problem persists. Looks like I also only have one frame buffer, but why? | | | +-o AppleIntelSNBGraphicsFB <class AppleIntelSNBGraphicsFB, id 0x1000002b3, registered, matched, active, busy 0 (114 ms), retain 7> | | | | | { | | | | | "IOClass" = "AppleIntelSNBGraphicsFB" | | | | | "CFBundleIdentifier" = "com.apple.driver.AppleIntelSNBGraphicsFB" | | | | | "FeatureControl" = {"Watermarks"=1,"RenderStandby"=1,"GPUInterruptHandling"=1,"DPM"=1,"MaximumSelfRefreshLevel"=3,"Gamma"=1,"PowerStates"=1,"IgnorePanelTimings"=0,"UseInterruptFilter"=1,"SpreadON"=1,"CachedEDIDDisable"=0,"FastDisplayDetectDisable"=0,"FBC"=0,"SetRC6Voltage"=0} | | | | | "IOProviderClass" = "IOPCIDevice" | | | | | "IOPCIClassMatch" = "0x03000000&0xff000000" | | | | | "IOSourceVersion" = "0.0.0.0.0" | | | | | "FBCControl" = {"Compression"=0} | | | | | "IOProbeScore" = 80000 | | | | | "NumFrameBuffer" = <01> | | | | | "VRAM,totalsize" = <00000020> | | | | | "IOMatchCategory" = "IOFramebuffer" | | | | | "dpm" = <01000000> | | | | | "fRC6HandlingFuncs" = <b881261180ffffff> | | | | | "IOPCIPrimaryMatch" = "0x01068086 0x11068086 0x16018086 01168086 01268086" | | | | | } This is using your DSDT. I tried using the one I had for ML, but ports don't work there either (though I haven't tried ioreg there). Also have this in the logs: 21/03/14 16:08:58,000 kernel[0]: [AGPM Controller] unknownPlatform There is a fix here for it I could try, can I somehow patch using Clover or does it only patch binaries? http://forum.thinkpads.com/viewtopic.php?f=32&t=105334&start=60#p705777
  4. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Actually, I just installed VoodooHDA 2.8.4 which works great so far. One things that does not work out of the box is the displayport. Any idea where to begin? DSDT or missing kext? Great work by the way! An installation was never so easy... Thanks!
  5. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Hey! Does anyone have an AppleHDA for 10.9.2 and X220? I believe my codec is a conexant 20672. I successfully used the appended AppleHDA on 10.8.5. Has anyone tried the approach described here on a thinkpad? http://www.tonymacx86.com/hp-probook-mavericks/118877-patch-applehda-kext-fly-clover-bootloader.html Thanks for the help! AppleHDA.kext.zip
  6. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    @tluck - Ok, will check if I find the battery stuff. currently I also have problems using rehabmans latest AcpiBattery so need to look at it anyways. I used gdisk, you can install it in OSX, but I used http://gparted.sourceforge.net/livecd.php most of the time. See http://www.rodsbooks.com/gdisk/hybrid.html for general info on hybrid MBRs. As far as I recall, this is how Bootcamp makes a mac ready for Windows installation as well. Once you have a hybrid mbr, you can install a MBR / PBR to it while keeping the disk in GPT and thus editable in DiskUtil. Here is my layout. I actually did not manage to boot from /dev/disk1 where my main OSX resides so I boot via /dev/disk0 MBR -> /dev/disk0s1 PBR -> boot(Chameleon v2.2svn r2255) EDIT: oh and about going from pure GPT to hybrid, it is a non-destructive operation. Basically GPT fills the old MBR with a reserved data pattern, so that MBR tools don't damage any GPT disk. When having an hybrid, a valid MBR is added that points to the same partitions (but max 4, but OSX will still see all partitions as it uses the GPT, only MBR booted systems will see max 4). So you can safely add / remove the hybrid mbr without repartitioning, just Windows might because unbootable.
  7. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Hey, after some time off from clover (happily running 10.8.4 on my x220 with chameleon) I was reading whether the UEFI boot issues with mute button and sleep were fixed, but I can see it is not the case. @tluck: if you don't want to use a usb stick you can change your gpt to a hybrid disk and then use MBR clover from disk. unfortunately gpt windows won't work (gpt windows does not like hybrid MBR) in this setup so you need to use MBR windows as well (don't have windows at all currently). I just had a look at your DSDT and will compare it with mine. Do you remember which changes were needed to make it compatible to AppleACPIPlatform.kext? I didn't find it mentioned in the comments. Thanks and keep up the good work ;-)
  8. miaumiau2

    Lenovo X220 using MaciASL

    Use rehabs patches for laptops from https://github.com/RehabMan/Laptop-DSDT-Patch (Installation instruction in readme, see "https://github.com/RehabMan/Laptop-DSDT-Patch"). Apply 1.1 (Fix _PLD), 1.4 (Fix _IRC), maybe other 1.x fixes.
  9. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Hey! Thanks to Kogen's awesome explanations I finally moved from 10.7.4 to 10.8.3. However, I was hoping that upgrading would help to get rid of some problems I had with 10.7.4, but unfortunately I seem to still have issues: - sometimes sleep / wake hangs, it looks like it writes the hibernation file, and when the LED is supposed to blink slowly, it starts to blink fast and the FAN goes loud and the PC hangs... nothing I can do then just reboot. - I noticed that sometimes when I push the speaker off button (vs lowering the volume all the way to the button) the system hangs. no fan noise here and reboot needed too. - Finally, sometimes when waking after sleep the track/touchpad is not working. Keyboard works but not the trackpad. I tried to find something in the logs, but all I could find was a sound card error just after wake: 31.03.13 00:45:52,000 kernel[0]: No interval found for . Using 8000000 31.03.13 00:45:52,000 kernel[0]: RTC: PowerByCalendarDate setting ignored 31.03.13 00:45:52,000 kernel[0]: Previous Sleep Cause: 5 31.03.13 00:45:52,000 kernel[0]: The USB device HubDevice (Port 1 of Hub at 0x1a000000) may have caused a wake by issuing a remote wakeup (2) 31.03.13 00:45:52,000 kernel[0]: 758.600117: ATHR: unknown locale: 60 31.03.13 00:45:52,000 kernel[0]: 758.625142: ATHR: unknown locale: 60 31.03.13 00:45:52,000 kernel[0]: 758.626024: ATHR: unknown locale: 60 31.03.13 00:45:52,000 kernel[0]: en1: 802.11d country code set to 'DE '. 31.03.13 00:45:52,000 kernel[0]: 758.752203: ATHR: unknown locale: 60 31.03.13 00:45:52,000 kernel[0]: en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 31.03.13 00:45:52,000 kernel[0]: [0xffffff8016994600](0)/(5) Device not responding 31.03.13 00:45:52,000 kernel[0]: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit 31.03.13 00:45:52,000 kernel[0]: USBMSC Identifier (non-unique): 001CC0EC346CBB40971B022B 0x951 0x162d 0x100 31.03.13 00:45:54,910 com.apple.launchd[1]: (com.apple.qtkittrustedmoviesservice[432]) Could not terminate job: 3: No such process 31.03.13 00:45:54,910 com.apple.launchd[1]: (com.apple.qtkittrustedmoviesservice[432]) Using fallback option to terminate job... 31.03.13 00:45:55,000 kernel[0]: en1: BSSID changed to 24:65:11:6d:6e:7c 31.03.13 00:45:55,000 kernel[0]: en1::IO80211Interface::postMessage bssid changed 31.03.13 00:45:55,000 kernel[0]: AirPort: Link Up on en1 31.03.13 00:45:55,000 kernel[0]: en1: BSSID changed to 24:65:11:6d:6e:7c 31.03.13 00:45:55,000 kernel[0]: en1::IO80211Interface::postMessage bssid changed 31.03.13 00:45:55,000 kernel[0]: 761.819746: apple80211Request[10310] Unsupported ioctl 111 31.03.13 00:45:55,000 kernel[0]: AirPort: RSN handshake complete on en1 BTW, I am on a X220. I've patched my DSDT according to this guide: http://forum.thinkpads.com/viewtopic.php?f=32&t=102098 (linked from http://forum.thinkpads.com/viewtopic.php?f=32&t=105334). Any ideas?
  10. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Ok, cool, I'll see if I find the time to try this this weekend. If not it will have to wait after my holiday ;-) Whats the reason of using MyHack vs. Clover's own fsinject to load texts without touching System/Library/Extension? My startup disk is GPT (I also run a windows EFI from another partition), so I guess it is not compatible with Chameleon anyway, or am I wrong here?
  11. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Thanks Kogen! Amazing... this had been holding off my ML install for more than a month now! However, after the install I can still use VT-d, right? Will reinstall wipe applications or will it keep everything? I have some custom kexts installed for Chameleon, but those should get replaced, right? Or would you recommend a complete fresh install (if reinstall is not that anyway). Thanks again!
  12. miaumiau2

    Lenovo ThinkPad T420 with UEFI Only

    Hey! You're looking for feedback from other Thinkpad users. Here I am - proud owner of a X220 :-) I'm currently running 10.7.4 on it and would like to update to ML, but unfortunately all my attempts (clover / chameleon) have not leaded to success. I have the i7 2640M version with usb 3.0. I followed your guide and can't even completely boot the installer. The GUI is launched (I see a grey screen), but then I get different types of KP... sometimes reboots, sometimes I see a mouse, sometimes not. Really weird. See screenshots of different KPs and logs below. I have not changed any of the config files you submitted. Anything I could try? system.log.zip
×