Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×

Leaderboard


Popular Content

Showing content with the highest reputation on 10/17/2019 in all areas

  1. 2 points
    Matgen84

    Clover General discussion

    It's better to post to 10.15.1 Beta 1 Topic: several users had this issue. Not in my case on my Z390 rig (Clover r5096).
  2. 1 point
    This project is dedicated to the memory of Mausi, the cat I loved more than anybody else. A few days before Christmas I started my latest project, a new driver for recent Intel onboard LAN controllers. My intention was not to replace hnak's AppleIntelE1000e.kext completely but to deliver best performance and stability on recent hardware. That's why I dropped support for a number of older NICs. Currently the driver supports: 5 Series 82578LM 82578LC 82578DM 82578DC 6 and 7 Series 82579LM 82579V 8 and 9 Series I217LM I217V I218LM I218V I218LM2 I218V2 I218LM3 100 Series (since V2.1.0d0) I219LM I219V 200 Series (since V2.3.0d0) I219LM I219V 300 Series (since V2.4.0d0) I219LM I219V 400 Series (since V2.5.1d1) I219LM I219V Key Features of the Driver Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). Support for TCP/IPv6 and UDP/IPv6 checksum offload. Makes use of the chip's TCP Segmentation Offload (TSO) feature with IPv4 and IPv6 in order to reduce CPU load while sending large amounts of data (disabled due to hardware bugs). Fully optimized for Sierra (64bit architecture) but should work with older 64bit versions of macOS too, provided you build from source with the appropriate SDK for the target OS. Support for Energy Efficient Ethernet (EEE). VLAN support is implemented but untested as I have no need for it. The driver is published under GPLv2. Current Status The driver has been tested successfully with I217V, I218V, I219V and 82579V under 10.9.5 and above. The attached archive includes source code as well as a prebuilt binary (debug version) for Mavericks and newer versions of macOS. Known Issues There seem to be problems while using VMware with version 1.x.x of the driver. In case you are affected use version 2.0.0 or newer. FAQ Could you add support of for...? Well, you are probably asking me to add support for one of the older NICs like the 82571/2/3/4L or 82583 and the answer will be no as I dropped support for these chips intentionally. They are broken and I lost more than 2 weeks trying to make it work on the 82574L without success. I was asked to add support for I210, I211 and I350 but as these chips have a completely different architecture, which isn't supported by the underlying Linux driver, this is impossible, sorry. Does it work with Snow Leopard or 32 bit kernels? No and I have no plans to make a version for 32 bit kernels or anything older than Lion. WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug? No it isn't, the driver is working as it should because OS X doesn't support WoL from S5. Installation Goto /S/L/E and delete AppleIntelE1000e.kext. Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface. Help - I'm getting kernel panics! Well, before you start complaining about bugs after you upgraded macOS and ask me to publish a driver update, you should first try to resolve the issue on your own by cleaning the system caches. As the driver uses macOS's private network driver interface, which is supposed to be used by Apple provided drivers only, you might run into problems after an OS update because the linker may fail to recognize that IONetworking.kext has been updated and that the driver needs to be linked against the new version (Apple provided drivers avoid this problem because they are always updated together with IONetworking.kext). As a result, the linking process produces garbage and the driver may call arbitrary code when trying to call functions from IONetworking.kext. This usually results in unpredicted behavior or a kernel panic. In order to recover from such a situation, you should clean the System Caches forcing the linker to recreate it's caches: Delete all the files in /System/Library/Caches and it's subdirectories but leave the directories and the symbolic links intact. This is very important! Reboot. Recreate the kernel cache. Reboot again. Troubleshooting Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be retrieved with "grep kernel /var/log/system.log" in Terminal. Starting from Sierra use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Don't copy and paste large amounts of log data to your post. Create an archive with the log data and attach it to your post. In case you don't want to make your log data publicly accessible, contact me via PM and I will provide you a mail address to send it directly to me. Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any AppleIntelE1000e.kext from your system because it could prevent the driver from working properly. Delete the following files: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/preferences.plist Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000. In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard, different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable. Changelog Version 2.5.0 (2019-10-15) Reworked interrupt throttling code and added new configuration parameters. Version 2.4.0 (2018-04-14) Added support for 300 series versions of I219LM and I219V. Updated underlying Linux source code. Version 2.3.0 (2017-06-20) Added support for 200 series versions of I219LM and I219V. Version 2.2.0 (2016-09-23) Disabled TSO to work around a hardware bug. Version 2.1.0 (2016-05-24) Added support for I219LM and I219V Version 2.0.0 (2015-04-22) First official release which is identical to 2.0.0d2 (only the version number has been changed). Version 2.0.0d2 (2015-04-04) Changed the tx descriptor write back policy for 82579, I217 and I218 to prevent random tx deadlocks. Version 2.0.0d1 (2015-03-14) Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ Solves the VMware issue. Version 1.0.0d6 (2015-03-04) Reworked TSO6 support to avoid problems with VMware. Wake-on-LAN now working. Version 1.0.0d5 (2015-02-27) Reworked TSO4 support to eliminate the bug of 1.0.0d4. Added some debug code in order to collect information about the VMware related issue. Version 1.0.0d4 (2015-02-25) Set total length field of the IP-header to zero for TSO4 operations. Report EEE activation state in kernel log message when the link has been established. Version 1.0.0d3 (2015-02-11) Reworked media selection and EEE support (EEE is now activated when both link partners support it. It can be disabled selecting the medium manually). Duplex setting for 10/100 MBit connections is now reported correctly. The number of tx descriptors has been reduced from 2048 to 1024. The code has been cleaned up and obsolete files have been removed. Version 1.0.0d2 (2015-01-31) First development release. Getting the Driver The source code can be found on GitHub: https://github.com/Mieze/IntelMausiEthernet There is also a prebuilt binary for 10.11 and above in the download section: http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/ Build from Source for 10.8 Register as a developer on Apple's developer website. A free membership is sufficient. Download a copy of Xcode 5.1.1 and install it on your machine. In the project select 10.8 as the "Base SDK" and the "Deployment Target". Call "Archive" from the menu "Product" and save the built driver. Credits Thanks to RehabMan and Yung Raj for running tests and pointing me in the right direction while I was trying to fix TSO. Special thanks to Yung Raj for motivating me when I was about to give up.
  3. 1 point
    yapan4

    [Pre-Release] macOS Catalina 10.15.1

    @D-an-W Yes, in this part: In Terminal sudo mount -uw / as the drive is locked. (The drive will re-lock after reboot.) Then just backup and delete old Energy Saver from /S/L/PreferencePanes and copy new one To replace Energy Saver.zip
  4. 1 point
    It works dear... I successfully Installed Mojave 10.14.6
  5. 1 point
    D-an-W

    Clover General discussion

    Thanks for the tip @Matgen84 I did search but clearly missed that topic!
  6. 1 point
    VMware Workstation 15.5.0 build-14665864 now has full built in Catalina Support, patched with modified unlocker from this post and latest VMware tools darwin.iso. Awaiting @Donk for "official" update to v3.0.2. For older VMware versions, attached is the prelinkedkernel copyprelinkedkernel_19A602.zip macOS_iso_creator_19A602.zip
  7. 1 point
    I disabled the wireless button in BIOS setup because I realized that macOS doesn't cope well with it because there is no such button on real Macs. EDIT: Pin-taping devices may cause trouble as the BIOS will assume that the device isn't present and may fail to power it properly on boot/wakeup but I know the problems with WIFI whitelisting on HP and Lenovo notebooks.
  8. 1 point
    Derty

    macOS Catalina 10.15 is out !!!

    run good here...
  9. 1 point
    Andres ZeroCross

    OpenCore Discussion

    Try this.. replace OC and BOOT folder with this
  10. 1 point
    Clover auto-injects ig-platform-id 0x3E920000 for device id 0x3e91, and it worked under Mojave which I believe has nearly the same table, and the entry for 0x3E920000 is the same parameters. I don't set ig-platform-id manually in config.plist. I've now installed the system (to a different volume, not over Mojave) so I can have more flexibility rebuilding prelinkedkernel with kextcache. I've tried both with and without WhateverGreen/Lilu and AppleIntelCFLGraphicsFramebuffer freezes. Last time I had a freeze was in ComputeLaneCount, which is also overcome by setting boot-arg HDMI_2_0_Disable=1, but that doesn't work either. It's a new freeze. So now I have Catalina installation, but it onlly boots if I set boot-arg -DisableIOFB to suppress CFL and run IONDRVFramebuffer instead. Of course, the graphics performance is sh*t this way.
  11. 1 point
    Just pitching in with my freshly installed Catalina 10.15.0 T460: I got Wifi on a Dell DW1560 working with tlucks three kexts and the new AirportBrcmFixup.kext. Also, the SD card reader works with Sineteks kext (both attached to this post) Sinetek-rtsx.kext.zip Wifi and BTW DW1560 T460.zip
  12. 1 point
    @ellaosx Yes, but BrcmPatchRAM3 has also been successfully tested under Mojave!
  13. 1 point
    Updated. All are fine here Catalina 10.15 (19A602)
  14. 1 point
    yapan4

    [Pre-Release] macOS Catalina 10.15.1

    EnergySaver.prefPane replaced by the same from build 19A602 and now works as usually
  15. 1 point
    omg.....what is your setting? I'm interested too
  16. 1 point
    Hervé

    OSX86.net taken down?

    It's no longer a very active forum, full stop. Not been for a long time now. Used to be an excellent place as a repository for kexts/apps/tools though.
  17. 1 point
    Use DisplayPort for installation
  18. 1 point
    CMMChris

    [Pre-Release] macOS Catalina 10.15.1

    Can someone with a Navi card please verify Apple's claim? I don't see any trace of Navi support looking at the Radeon Kexts. Edit: As expected, no Navi support. They smoke funny things over at Apple it seems.
  19. 1 point
    Cyberdevs

    Catalina Bootable USB

    it's the same as creating other versions of macOS USB installer. You need to download the installer from App Store or use Mac Downloader app and once the app is downloaded put it in the Applications folder and run the following command in terminal: sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /volumes/Untitled
  20. 1 point
    omg.....what is your setting?
  21. 1 point
    Lol, I am not sure if we should be using LuxMark, I don't think its results can always be trusted:
  22. 1 point
    The Radeon VII has a hardware frequency throttle at 110 degrees C along with a hardware current/voltage throttle at 115°C, and while the true maximum temperature is not publicly known, there is definitely a good margin of thermal headroom on top of that. And that temperature and throttle is controlled by a junction temperature sensor - in other words, a sensor (really, a network of sensors) that is integrated into the silicon itself. This means the closed control loop is very tight (vs most prior GPUS, AMD or NVIDIA, which used sensors external to the silicon die). The radeon VII, out of any card out there, is the one card you can just go nuts and push as hard as you want. The worst that can happen is that the voltage is too high that it throttles prematurely and your performance will actually suffer and be a fair bit less than it would be even at normal frequencies. There is essentially zero risk of damaging the card, especially considering the stock card defaults to running at the frequency temperature throttle point (110° C) anyway so it can keep the fan noise lower. macOS isn't responsible for keeping the card in its SOA (safe operating area), the card is. The only risk is if you don't have the settings right, you will have stability issues under load and might have the program crash or get forcefully logged out of macOS as the GPU resets, but you won't even get a kernel panic or need to restart. As outcomes go, that is mostly harmless. And of course, finding your specific silicon's sweet spot can take a lot of trial and error which is a pain. But there is no need to be overly cautious. People have cranked their VIIs up to 1400mv+ without issue even with a stock cooler. It just makes the card throttle itself down and you get no benefit, but if you modify the card to improve cooling, and if you got a decent bin of silicon, there are many examples of people who have gotten their Radeon VIIs chooching faster than an RTX 2080 Ti. The Radeon VII overclocks like watchmaker on crack. I'm able to monitor the junction temperature under macOS which is all one needs, and again, that's just to gauge if the card is throttling itself, you don't need to monitor it for safety.
  23. 1 point
    Tony Arnold

    ThunderBolt Drivers

    @Mork vom Ork what's the onboard TB3 controller on the Z270? Alpine Ridge? I have a Titan Ridge installed in my ASUS X299 rig, but it causes problems at boot unless CSM is enabled (which in turn causes other problems). I have a spare Alpine Ridge card that doesn't have the same problems, but never worked properly in terms of hot plug/sleep - I wonder if your SSDT changes would help?
  24. 1 point
    Update: i downloaded Lilu kext and Whathevergreen Kext and put them in my kext folder and one monitor is working.. Any way to get both? the 2nd monitor i still have to power off then on
  25. 0 points
    Hello Everyone.I would like to know if anybody here got the correct custom USB SSDT for the Gigabyte Z390 Pro motherboard ?I got a Corsaire Carbide 275R case which got 2 extra USB 3.1 Gen 1 ports connected to the motherboard. I use my hackintosh for 4 months from now. I followed the Glasgood installation guides (attached at the bottom).I can't figure out how to clean the total mess I got when I plug my usb devices... And the process that I found here and there is a true nightmare for my noob skills. Any help would be awesome !!Links if needed :https://www.corsair.com/ww/en/Categories/Products/Cases/Carbide-Series-275R-Mid-Tower-Gaming-Case/p/CC-9011130-WWhttps://www.gigabyte.com/Motherboard/Z390-AORUS-PRO-rev-10#kfThanks guys !
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×