Jump to content

Leaderboard

Popular Content

Showing content with the highest reputation on 09/02/2018 in all areas

  1. LAbyOne

    Lilu Suite builder

    Lilu Suite Builder version 1.2.8, and VirtualSMC Builder version 1.1.5 ************************************************************************* Rewritten the code in order to make a Cleaner and faster build Added automatic detection and installation of Xcode Tools, Nasm + Disasm, Mtoc + Mtoc.NEW * Added Build Logs to the compilation Now the application generate the log for each build process you will find all of them into Logs folder inside package folder of both Debug and Release version *** Updated Xcode Application detection, now w
    6 points
  2. You were right . With Lilu 1.2.6 and AppleALC 1.3.1, there were error messages saying "alc-layout-id was not provided by controller at HDEF" in debug log... 2018-09-01 16:22:37.226609+1000 localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.2.6 DEBUG build (Lilu) 2018-09-01 16:23:11.249818+1000 localhost kernel[0]: (kernel) AppleALC: alc @ alc-layout-id was not provided by controller at HDEF In this situation, I had to inject both layout-id=7 and alc-layout-id=1 through Clover config.plist/Devices/Properties. With newly compiled kex
    3 points
  3. savvas

    FileVault 2

    AppleImageLoader used for fat binaries support. AppleUiSupport - for FileVault UI. However I documented it inside README on github @bratwurstinhalator, Please update AptioMemoryFix and AppleUiSupport as I mention above
    2 points
  4. savvas

    FileVault 2

    Apfs-64.efi AppleImageCodec-64.efi AppleImageLoader-64.efi AppleKeyAggregator-64.efi AppleKeyFeeder.efi AppleKeyMapAggregator.efi AppleUISupport-64.efi AppleUITheme-64.efi AptioMemoryFix-64.efi DataHubDxe-64.efi EnglishDxe-64.efi FSInject-64.efi Fat-64.efi FirmwareVolume-64.efi HFSPlus.efi HashServiceFix-64.efi NvmExpressDxe-64.efi OsxAptioFixDrv-64.efi SMCHelper-64.efi UsbKbDxe-64.efi UsbMouseDxe-64.efi Remove HashServiceFix-64.efi, FirmwareVolume-64.efi, EnglishDxe-64.efi, AppleUITheme-64.efi, AppleKeyMapAggregator.efi, AppleKeyAggregator-64.efi and AppleImageCodec-64.efi. AppleUiSupport
    2 points
  5. 2018.0821 AMD ThreadRipper 2990WX is hackintosh succes Thanks @Shaneee, Bronya~
    2 points
  6. fusion71au, are you sure that both alc-layout-id and layout-id are necessary? If that is the case, I suspect that I know what the issue is all about. The property reader/writer fails, and you have to manually simulate it via device properties. What is most likely the cause of a failure, is a bug in Lilu, which caused device detection failure, and effectively prevented all the device discovery: https://github.com/acidanthera/Lilu/commit/7eab62a9c4ed56b2a1375f530f8c981dd44f2fa0 Does upgrading to master Lilu version work? With just layout-id set to 7, and alc-layout-id remov
    2 points
  7. I also lost sound when upgrading AppleALC to v1.3.1 from v1.2.8. Confirm that remapping layout-id broken by v1.3.0. What is your codec/layout? Realtek ALC888S-VD, normally works with layout-id=1 (Devices/Audio/Inject=1 set in Clover confg.plist). Layout-id remapped automatically to 7 by AppleALC.kext v1.2.8... When did it break? When upgraded to v1.3.1 from v1.2.8 Is the issue 10.14 only or 10.13.6 too? Fails in both 10.13.6 & 10.14 Does adding alcapplid=X boot-arg, where X is your layout-id, solve the issue? Test on 10.13, because some layouts are mi
    2 points
  8. SMC emulator with 2nd generation SMC support. Includes some monitoring plugins as API usage examples. New plugin additions are very welcome, given that they are well-written. Source code: repository. FAQ and documentation: link. Features and configuration: link. I wish to express my deep gratitude to all the people who worked on this project with me.
    1 point
  9. The AirPortAtheros40.kext as similiar code found on linux freebsd. This first patch was tested on OS X 10.11.0 Working card: Qualcomm Atheros AR9565 pci168c,36 with bluetooth Download v01 for 0036 card + BTFirmwareUploader in attachments. Post your questions here You can find updates on EMlyDinEsH BTFirmwareUploader here http://forum.osxlatitude.com/index.php?/topic/2925-bluetooth-firmware-uploader/ v01 also works on 10.11.4 TOFIX: Bands/Channels limitation exist in macosx/windows driver but not in linux UPDATE: v03 fixed eprom local check. This kext ch
    1 point
  10. vit9696

    FileVault 2

    Alright, after a couple of weeks of hard work performed by: ath, Download-Fritz, slice, savvas, and myself FileVault 2 should work everywhere now. Additionally thanks to iNDi for help and initial discovery of certain FV aspects. This means that everybody gets some pros for this but mainly Clover. Everything works in test mode for the time being, so you better wreck your disk drives and tell us how much fun it was Clover: In brief you are required to install a set of drivers present at least in r3876. There are two driver categories, and each one will be addressed separatel
    1 point
  11. No è quello giusto per volerci 2 ore al download
    1 point
  12. Ok intanto riprova e se hai il solito problema fai sapere
    1 point
  13. Ciao Wifi75, scusa per la risposta tardiva ma sono incasintato, tanto per cambiare. Non so cosa possa essere, ti allego la mia EFI che va bene su High Sierra e su Sierra, fino a poco fa avevo 10.12.6 EFI Portatile.zip
    1 point
  14. quando puoi prova a sostituire controlla la batteria... Però io ho usato la EFI allegata da te ieri, quindi in caso modificala aggiungendo VoodooHDA e disabler oltre ad altre cose in caso tu avessi apportato ulteriori modifiche CLOVER 3.zip EDIT: oppure semplicemente prendi DSDT e config dalla mia ultima clover e li sostituisci alla tua attuale
    1 point
  15. You do not ned to disable VT-d anymore, since like Yosemite.
    1 point
  16. vit9696

    FileVault 2

    Erm, a quick glance at your EFI folder shows that you have 3 input drivers at once. That will not work (as stated in the first message). Remove: AppleKeyFeeder.efi, AptioInputFix-64.efi Also remove other stuff: DataHubDxe-64.efi, Fat-64.efi, FSInject-64.efi, NvmExpressDxe-64.efi. Additionally remove BooterConfig from your config.plist, which is a misunderstanding of how the variable works. Not promising for anything to fix, but that is certainly a required change necessary to be done first of all.
    1 point
  17. Hi vit9696 As you may know I too have had the issue with the automatic layout-id re-mapping not working with AppleALC 1.3.0 & 1.3.1. As with fusion71au the automatic layout re-mapping works fine when using AppleALC ver 1.28 The only way for me to get it working with 1.3.1 is to manually inject both layout-id and alc-layout-id as device properties just like fusion71au above which i detailed in this post. Having read above that fusion71au had success with the latest beta build of Lilu (1.2.7) and AppleALC i also tried doing the same. I installed the tes
    1 point
  18. Grande ICanaro. Ho appena aggiornato la chiavetta e rimosso le cartelle 32 indicate date in precedenza. vediamo che succede. ti aggiorno.. grazie ancora per le dritte . Inviato dal mio MI 5s Plus utilizzando Tapatalk intanto questo errore appare sempre.. cosa vuol dire? Inviato dal mio MI 5s Plus utilizzando Tapatalk
    1 point
  19. savvas

    FileVault 2

    Very interesting stuff " if (!gDriversFlags.AptioMemFixLoaded) { DeleteNvramVariable(L"recovery-boot-mode", &gEfiAppleBootGuid); } " Clover doesn't touch this variable if AptioMemoryFix loaded, so problem inside something different Try to reset nvram with tool CleanNvram from https://github.com/acidanthera/AptioFixPkg from UEFI shell
    1 point
  20. arsradu

    FileVault 2

    Crystal clear and very well documented. Many thanks. Time for some cleanup.
    1 point
  21. @vit9696 , to come back to my original question.. All three Sensor kexts distributed with VirtualSMC seem to work as expected.. However, yet we are missing several sensor data not distributed by any Sensor.kext compatible with VirtualSMC, correct? Is there any possibility to develop or adopt the following sensor kexts of the FakeSMC distribution https://github.com/interferenc/HWSensors?: a.) ACPISensors.kext.zip b.) LPCSensors.kext.zip c.) GPUSensors.kext.zip Such kexts would tremendously increase impact and value o
    1 point
  22. Ciao e buona domenica, ho fatto il fix di en0 ora ethernet e riconosciuta come en0 e il wifi en1, sono riuscito a far funzionare meglio audio tramite il plist di voodoohda
    1 point
  23. acabei de pegar uma gtx 970 hoje mesmo, acho que n vou ter mais esses problemas
    1 point
  24. Not required as far as I know. I only rebuild cache & permissions when dealing with kexts installed in S/L/E only.
    1 point
  25. Yes i swear i used before a modifed one but after that i formated everything and i'm using a clean version they call it vanilla but i use the icon from a modifed version otherwise I'm using a clean vanilla version i will use your dsdt and i will tel you for any thing news Thank you i use also abm_delaypole boot-flag for battery
    1 point
  26. Google usbinjectallkext and follow rehabmans guide.
    1 point
  27. 1 point
  28. Usa a ultima versão do HS, e baixa e instala WhateverGreen + Lilu
    1 point
  29. LAbyOne

    Lilu Suite builder

    oh didn't notice that, but i believe I had the idea from an old post from vit9696, if i'm not mistaken, but without the VirtualSMC, so i added to my script and voila.. Anyway nice hearing it works fine for you too.
    1 point
  30. Hello @FernandoCoverdale. Welcome to InsanelyMac
    1 point
  31. From Recovery/Terminal (Macintosh HD - your disk name) # v="/Volumes/Macintosh HD" # cd "$v"/Library/Extensions# rm -rf GeForce*# rm -rf NVDA*# touch .# cd "$v"/System/Library/Extensions# rm -rf GeForce*Web*# touch . # kextcache -u "$v"# reboot From Desktop $ sudo su# cd /Library/Extensions# rm -rf GeForce*# rm -rf NVDA*# touch .# cd /System/Library/Extensions# rm -rf GeForce*Web*# rm -rf NVDA*Web*# touch .# kextcache -u /# exit$ reboot Reinstall previous drivers that worked.
    1 point
  32. Slice

    HWSensors3

    it shows all it can.
    1 point
  33. chris1111

    Clover Themes

    all themes chris111 is Update with new icons Volumes Optimise themes
    1 point
  34. Hey @Oliver@Cheme I still cant believe it that 'AppleUITheme' protocol thing were responsible to read our 'DefaultBackgroundColor'. I thought it just for FileVault, so I never installed it before LOLOL ... I dont use Clover, but AppleSupportPkg came with AppleUiSupport last day (which pretty much same with Fritz EfiPkg) to try and i confirmed it works here. Far as I can remember, IOGraphicsFamily need to be patched too to get grey apple black logo before reach the login screen. The code has much changed since my last try. Did some more trial patches with 10.13.6 without
    1 point
  35. Rev 4653 Fixed potential icon problem for apfs and hfs partition. Clover automatically detect partition icon according to partition type.
    1 point
  36. Badruzeus

    Clover Themes

    Updated all of my Clover v2.4k Themes on repo with Solus linux support, it only needs 2 hours for syncing 65 theme's changes to the server. For God's sake, thanks #SourceForge.
    1 point
  37. Rev 4639 New design for Clover.prefPane, CloverUpdater, Clover Package and embedded theme. By Clovy.
    1 point
  38. @max.1974 Just tried your kext. Unfortunately not getting any picture both on DP and HDMI. Switched back to mine.
    0 points
  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×