Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 04/24/2018 in all areas

  1. 1 point
    Hi @fabiosun Could you please have a look at my attached files. Now booting without the TSCAdjustReset.kext . Sleep/wake and everything is working perfect without that kext so I can run my rig without it but I'm to much "noob" to understand if this is the best way for my CPU performance. Is there a way to check this? Then I would like to ask you another thing about my MSR 0xE2 register. According to KGP's site the output from voltageshift should be something similar with: RDMSR e2 returns value 0x7e000003 but when I run this test the output is: RDMSR e2 returns value 0x402? on the other hand my bootlog and AppleIntelInfo.kext output is showing quite clear that the bios is unlocked: MSR 0xE2 before patch 00000402 MSR 0xCE 00070A2C_F3811900 MSR 0x1B0 00000000 Everything shows that my MSR 0xE2 register is unlocked but still need FakeCpuid or/alt. an old XCPM bootstrap patch together with xcpm_program_msrs (c) Pike R. Alpha for booting. I can't understand that i9-7980xe processor with the same signature 0x50654 can boot perfect without this kernel patch and without FakeCpuid when at least on the paper a more native processor like the Xeon W fail. Is there anybody else out there how could help to solve this problem. I'm just a super noob trying to put this rig together and the only skill I have is my insistence and that is not enough for this project. With TSC kext.rtf without TSC kext.rtf
  2. 1 point
    SSDT will do the things needed, to make DSDT, it require you to properly Disassemble your ACPI files, patch them for OS X then compile your DSDT, it may take some time! EFI\CLOVER\ACPI\patched\here
  3. 1 point
    Sure thing. I'll do me best but no promises I guess you the file you attached is corrupted.
  4. 1 point
    i'll check it, back to home in a few hours what boot problem u have?
  5. 1 point
    lelet

    ThunderBolt Drivers

    SUCCESS!!! Finally all my THUNDERBOLT devices are hotpluggable!! The solution is unbelievable, seems to work on all chipsets without using SSDT, and shifts the focus on the cause of all problems Thunderbolt: the cable THB_C!! Already in my previous post I noticed strange behavior by inserting the _DSM method in DSB2: PCIHotplugcapable Zero. Since then I've been trying to figure out how the XHC controller affected the Thunderbolt hotplug, until Crismac2013 suggested I disconnect the THB_C cable from the motherboard. Once disconnected, it was enough to add as an arbitrary inject my first Thunderbolt address (PXSX): <dict> <key>Comment</key> <string>PCI THUNDERBOLT 15d3 first entry</string> <key>CustomProperties</key> <array> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>PCI-Thunderbolt</string> <key>Value</key> <integer>1</integer> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>IOName</string> <key>Value</key> <string>pci-bridge</string> </dict> </array> <key>PciAddr</key> <string>01:00.00</string> </dict> and it works!! Now I have also added my last SSDT to get PCI information on System info. Probably with my last SSDT the arbitrary inject are not needed, as PCI-Thunderbolt One is already inserted as a _DSM method in UPSB. I suspect, however, that in this way the USB-C functionality will be lost, you should do a test! In any case this is a huge step forward and makes it obvious that we need to work on XHCs controller to solve the problems with the hotplug with THB_C cable connected.
  6. 1 point
    DSDT.aml.zip check if audio work ur codec work with 11 or 13 only
  7. 1 point
    Can you share the Clover folder that lets you boot? I will edit it to includes Allan changes
  8. 1 point
    I'm sorry but I've not been able to control it... -.-
  9. 1 point
    FredWst

    (pre-release) macOS High Sierra 10.13.5

    I got same trouble. In my case I solved that by putting kexts in clover kexts/Other directory. Fred
  10. 1 point
    Updated BIOS Image with APFS.EFI from 10.13.4 embedded (not required to install 10.13.4 but just to keep things tidy) Note: I haven't tested the ROM image (I just replaced the APFS module in a working and tested image) because I am on pager duty atm and need a working computer just in case ... 10.13.4 QUO ROM Image
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×