Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. ---------------------------------------------------------------------------- UPDATE 2 - [SOLVED!] ---------------------------------------------------------------------------- So the problem seems to lie within whatever version ApfsDriverLoader-64.efi I was using prior to update, or perhaps the OS needed to load one last time to enable some sort of permission for accessing the apfs.efi file from the /usr/standalone/i386/ folder that I am unaware of??? Either way, I am marking this solved at this point- just update your ApfsDriverLoader-64.efi in your drivers64UEFI folder with the latest (2.0.7 release as of this post) https://github.com/acidanthera/AppleSupportPkg/releases I just dumped all the files in the Driver folder within the latest zip into my drivers64UEFI and removed apfs.efi from my previous "Update 1" edit, and it booted with no issues.
  3. OK, so based on Apple's EULA only Snow Leopard Server can be virtualised so the functionality is disabled in Workstation. However Donk removed the functionality to support Snow Leopard Workstation in the latest unlocker 302, but a separate utility is available to allow Snow Leopard Workstation to install and run, see link to thread below:
  4. MacFriedIntel

    OpenCore Discussion

    Clover is full of broken code and bloated, OC is a fresh approach to a Bootloader which is based mostly from the Osmosis Bootloader. Opencore is lightweight and only uses drivers and kexts and patches you put into the config.plist. The Manual gives clear instructions and is constantly updated.
  5. There's no need to duplicate your script for the "Beta" and "Release" statement. #!/bin/bash # Vars apptitle="makeLegitApp" version="1.1" # Set Icon directory and file iconfile="/System/Library/CoreServices/Installer.app/Contents/Resources/Installer.icns" current_date_time="`date "+%Y-%m-%d %H:%M:%S"`"; echo $current_date_time; echo "Starting makeLegitApp" # Select response=$(osascript -e 'tell app "System Events" to display dialog "Welcome makeLegitApp Select a choice to create your Install macOS Mojave.app" buttons {"Cancel","Beta","Release"} default button 3 with title "'"$apptitle"' '"$version"'" with icon POSIX file "'"$iconfile"'" ') action=$(echo $response | cut -d ':' -f2) # Exit if Canceled if [ "$action" == "Cancel" ] ; then osascript -e 'display notification "Program closing" with title "'"$apptitle"'" subtitle "User cancelled"' echo "User cancelled" exit 0 fi # Conditions based on user's selection if [ "$action" == "Beta" ] ; then APPNAME="Install macOS Mojave Beta" MOUNTPOINT="/Volumes/OS X Base System" URL_PATH="34/47/041-03369/rsbnsn82mun7a480ipgu4r7inb0307i5sq" else # We can only assume that the user selected "Release" ... APPNAME="Install macOS Mojave" MOUNTPOINT="/Volumes/macOS Base System" URL_PATH="21/07/041-59913/m210y0lkn7bsiqsi98vfuyk08x2z4to1qk" fi osascript -e 'display notification "Program makeLegitApp" with title "'"$apptitle"'" subtitle "User Selected '"$action"'"' Sleep 1 # Remove BUILD if exist if [ "/Private/tmp/src" ]; then rm -rf "/Private/tmp/src" fi if [ "/Private/tmp/Install macOS Mojave Beta.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave Beta.app" fi if [ "/Private/tmp/Install macOS Mojave.app" ]; then rm -rf "/Private/tmp/Install macOS Mojave.app" fi if [ "/$HOME/Desktop/makeLegitApp" ]; then rm -rf "/$HOME/Desktop/makeLegitApp" fi osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF # Root location of file #-------------------------- srcDir="/Private/tmp/src" # Create Source folder #---------------------- mkdir -p /Private/tmp/src echo "PROGRESS:0" echo "Build Install ${APPNAME}.app" sleep 1 printf "${RED}Script created by Hanger1${NC}\n" printf "${GREEN}Script adapt and modify by chris1111${NC}\n" printf "${GREEN}Spacial thanks to @fusion71au from insanelymac for guide.${NC}\n\n" printf "Download following files from Orignal Apple server\n\n" printf "1) BaseSystem.dmg\n" printf "2) BaseSystem.chunklist\n" printf "3) InstallInfo.plist\n" printf "4) InstallESDDmg.pkg\n" printf "5) AppleDiagnostics.dmg\n" printf "6) AppleDiagnostics.chunklist\n\n" printf "${BLUE}Catalog link: https://swscan.apple.com/content/catalogs/others/index-10.14seed-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz${NC}\n" printf "\n\nPut Above files into \"src\" folder\n\n\n" Sleep 3 echo "PROGRESS:10" sleep 1 echo "PROGRESS:20" sleep 1 echo " " sleep 1 echo "PROGRESS:30" sleep 1 echo " Build Start " Sleep 3 echo "DETAILS:SHOW" Sleep 2 # Check for Source files exist or not. #---------------------------------------- if [ ! -f $srcDir/BaseSystem.dmg ]; then # Check for BaseSystem.dmg echo "Downloading: BaseSystem.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.dmg" -o "/Private/tmp/src/BaseSystem.dmg" echo "Download: Complete ➣ Done!" fi echo "PROGRESS:40" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/BaseSystem.chunklist ]; then # Check for BaseSystem.chunklist echo "Downloading: BaseSystem.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/BaseSystem.chunklist" -o "/Private/tmp/src/BaseSystem.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:50" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallInfo.plist ]; then # Check for InstallInfo.plist echo "Downloading: InstallInfo.plist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallInfo.plist" -o "/Private/tmp/src/InstallInfo.plist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:60" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/InstallESDDmg.pkg ]; then # Check for InstallESDDmg.pkg echo "Downloading: InstallESDDmg.pkg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/InstallESDDmg.pkg" -o "/Private/tmp/src/InstallESDDmg.pkg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:70" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.dmg ]; then # Check for AppleDiagnostics.dmg echo "Downloading: AppleDiagnostics.dmg ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.dmg" -o "/Private/tmp/src/AppleDiagnostics.dmg" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:80" sleep 1 echo "DETAILS:SHOW" Sleep 2 if [ ! -f $srcDir/AppleDiagnostics.chunklist ]; then # Check for AppleDiagnostics.chunklist echo "Downloading: AppleDiagnostics.chunklist ➣ Wait!" Sleep 2 echo "DETAILS:HIDE" sleep 1 curl -L "http://swcdn.apple.com/content/downloads/${URL_PATH}/AppleDiagnostics.chunklist" -o "/Private/tmp/src/AppleDiagnostics.chunklist" echo "Download: Complete ➣ Done!" fi echo "DETAILS:HIDE" sleep 1 echo "PROGRESS:90" sleep 1 echo "DETAILS:SHOW" Sleep 2 # Taking ownership of downloaded files #------------------------------------------------- chmod a+x /Private/tmp/src/BaseSystem.dmg chmod a+x /Private/tmp/src/BaseSystem.chunklist chmod a+x /Private/tmp/src/InstallInfo.plist chmod a+x /Private/tmp/src/InstallESDDmg.pkg chmod a+x /Private/tmp/src/AppleDiagnostics.dmg chmod a+x /Private/tmp/src/AppleDiagnostics.chunklist # Mount 'BaseSystem.dmg' #------------------------- $(hdiutil attach /Private/tmp/src/BaseSystem.dmg -noverify -nobrowse 2>&1 >/dev/null) echo "Make sure \"macOS Base System\" volume is mounted" Sleep 3 # Pull 'Install macOS XXXX.app' from 'BaseSystem.dmg' #----------------------------------------------------- findApp(){ for file in "${MOUNTPOINT}"/*; do # Find XXXX.app in mounted volume if [[ $file == *.app ]]; then let index=${#name_array[@]} name_array[$index]="${file##*/}" fi done echo ${name_array[0]} } installAppName=$(findApp) printf "\n\nCopying $installAppName to out folder...\n" cp -R "${MOUNTPOINT}/$installAppName" /Private/tmp # UnMount 'BaseSystem.dmg' #------------------------- $(hdiutil detach "${MOUNTPOINT}" 2>&1 >/dev/null) printf "Copying Files to SharedSupport folder... Wait!\n" sleep 3 echo "DETAILS:HIDE" sleep 1 # Create SharedSupport folder inside 'Install macOS XXXX.app/Contents' #---------------------------------------------------------------------- SharedSupportDir="/Private/tmp/$installAppName/Contents/SharedSupport" if [ ! -d "$SharedSupportDir" ]; then mkdir "$SharedSupportDir"; fi # Copy All contents of src folder to 'Install macOS XXXX.app/Contents/SharedSupport' #---------------------------------------------------------------------- # cp -R /Private/tmp/src/* /Private/tmp/Install\ macOS\ Mojave\ Beta.app/Contents/SharedSupport cp -R "/Private/tmp/src/BaseSystem.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/BaseSystem.chunklist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallInfo.plist" "$SharedSupportDir" cp -R "/Private/tmp/src/InstallESDDmg.pkg" "$SharedSupportDir/InstallESD.dmg" cp -R "/Private/tmp/src/AppleDiagnostics.dmg" "$SharedSupportDir" cp -R "/Private/tmp/src/AppleDiagnostics.chunklist" "$SharedSupportDir" # Replace <string>InstallESDDmg.pkg</string> to <string>InstallESD.dmg</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>InstallESDDmg.pkg<\/string>/<string>InstallESD.dmg<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Remove these lines from 'src/InstallInfo.plist' #------------------------------------------------ # <key>chunklistURL</key> # <string>InstallESDDmg.chunklist</string> # <key>chunklistid</key> # <string>com.apple.chunklist.InstallESDDmg</string> sed -i "" '30,33d' "$SharedSupportDir/InstallInfo.plist" # Replace <string>com.apple.pkg.InstallESDDmg</string> to <string>com.apple.dmg.InstallESD</string> in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/<string>com.apple.pkg.InstallESDDmg<\/string>/<string>com.apple.dmg.InstallESD<\/string>/g' "$SharedSupportDir/InstallInfo.plist" # Replace InstallESDDmg.pkg to InstallESD.dmg in 'src/InstallInfo.plist' #---------------------------------------------------------------------------------------------------------- sed -i "" 's/InstallESDDmg.pkg/InstallESD.dmg/g' "$SharedSupportDir/InstallInfo.plist" echo "PROGRESS:95" sleep 1 echo "DETAILS:SHOW" Sleep 2 mkdir -p /$HOME/Desktop/makeLegitApp Sleep 1 mv /Private/tmp/"{APPNAME}.app" $HOME/Desktop/makeLegitApp/"{APPNAME}.app" echo $current_date_time; sleep 1 Open /$HOME/Desktop/makeLegitApp sleep 2 osascript <<EOF tell application "makeLegitApp.app" activate end tell EOF echo "DETAILS:HIDE" sleep 1 echo "Build {APPNAME}.app ➣ Done" echo "PROGRESS:100"
  6. Today
  7. Yes, I used nv_disable=1. I wonder if I can add that to boot-args in defaults instead? Ok, I tried with the defaults posted above and updated values from clover configurator. I will post Defaults again when I'm home. Thank you! I apparently remembered wrong, I meant "BIOS Features" and not System... :S These settings look pretty much like optimized defaults, I have followed the instruction from the wiki and tried changing stuff with init first GPU and UEFI/Legacy for GPU, but that info might not be applicable anymore.
  8. AlMoselly

    HP EliteBook 840 G3 / macOS Mojave

    I hope this will help SysInfo02.txt
  9. SardusX86

    Clover Themes

    Hi All, Is this version of the "embedded" Clover theme available for download? Thanks in advance for Your reply
  10. Hello I think these are ASMedia USB ports it's not a problem, it's going to stay that way thanks for your help
  11. [SOLVED TEMPORARILY - SEE END OF POST] Upgrading from Mojave 10.14.4, I did not make any changes to my Clover EFI folder. The version BEFORE upgrade was r4920, and latest necessary kexts to boot 10.14.5 were already installed and working for me on 10.14.4, so everything was ready to go. 10.14.4 worked fine with no issues for a while now, with the latest Clover and kexts. Upon installing macOS update, after completing the grey progress bar / apple logo screen, the computer rebooted and now Clover is not loading, and I am greeted with this screen: It's just a black screen with a solid cursor. No mouse input, no keyboard input, nothing else loads. Left it there for a while- no progress. to be clear: CLOVER DOES NOT LOAD if I select the UEFI 'Clover HDD' entry on my boot selection list. it shows the screen above I then created a bootable USB via my hackintosh laptop using the Mojave Installer and installed Clover UEFI on the ESP of the bootable USB, and then overwrote the EFI folder with my known good EFI folder backup. result: CLOVER DOES NOT LOAD if I select 'UEFI: Bootable USB' entry on my boot selection list. it shows the same screen above. I then attempted to create a bootable legacy CLOVER USB via windows: result: CLOVER BOOTS as LEGACY USB. The resulting Clover is indeed r4920 as it should be, but it does NOT list any of the MacOS partitions, I am trying now again with APFS loader for legacy . I cannot boot into UEFI Shell either on USB or on Clover drive. I tried EasyUEFI to redirect the UEFI entries to the SHELL-X64.efi file so that I can perhaps inspect the UEFI boot table to see if there is something wrong: result: Shell does not boot. Same screen as above. What is the possibility that the UEFI table in my bios suddenly corrupted? If possible, why does my Windows Boot Manager entry seem to work fine? Anyone ever experience something similar? ---------------------------------------------------------------------------- [SOLVED TEMPORARILY] The problem lies with ApfsDriverLoader.efi I managed to fix the issue by doing the following: Boot into Windows 10 Used UFS Explorer Standard Trial version to browse the newly updated, but unbootable MacOS 10.14.5 to retrieve the apfs.efi file from /usr/standalone/i386/apfs.efi Used Explorer++ opened with Administrator Privileges to access EFI partition on MacOS drive: Remove ApfsDriverLoader.efi Replace with apfs.efi from macOS drive in previous step. Reboot using MacOS EFI partition that was just modified Successfully booted and typed this post update It seems there may be an issue with ApfsDriverLoader-64.efi. Has anyone experienced anything similar? I am going to try again now with the latest version, which I believe I tried already- but perhaps it needed to do one final last load for some reason before being able to use the loader file and report back.
  12. Anyone updated to 10.14.5 ? This will be my first update so want to make sure I don’t miss anything. Clover and kext update first needed?
  13. I also ran into the same problem with sound when I tested EFI folder on a test install of macOS, the solution I found was to update config.plist with a new pciidevices.plist export and sound was resolved.
  14. Juvanta

    Donation related query

    Thanks for sharing
  15. Is this error going to be fixed in script? Status: gettext-latest.tar.xz not found. % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0 curl: (22) The requested URL returned error: 404 Not Found
  16. @BSouza Tutorial will work with i7-9700k
  17. Matgen84

    Clover problems report & features request

    Hi @Slice Clover r4928: I've a problem with Windows partition name (see pictures below). One in french language: é is not recognized, another is blank no name at all. I don't understand why?
  18. Very interesting, but I can't access the internet. I can't even install my network driver. Can you help me?
  19. telepati

    Clover General discussion

    @Sherlocks why are you using i7 for 9900K? Isn't this i9?
  20. telepati

    OpenCore Discussion

    What are the differences, OC and Clover? And what are the benefits of the OC?
  21. telepati

    Mac'os Mojave 10.14.5 is OuT

    It is common problem who update to 10.14.5 and no fix yet.
  22. Yesterday
  23. BWR

    APFS support is coming!

    Any Updates? I am still not seeing any code submitted to forge.voodooprojects for any APFS read support.
  24. IronManJFF

    New OS X compatible motherboard -> QUO

    The correct syntax is nv_disable=1 This indicates that BIOSDate and BIOSVersion are below the 'Apple Firmware', the values depends on which Mac you are pretending to be
  25. I use the first pci x16 slot. To be honest I am not sure anymore the panic was graphics related. There ist one small change I made to the config.plist: drop OEM is enabled in the Acpi/SSDT Section. I am still testing and keep you updated.
  26. I just noticed a day or so ago that under System Information - PCI I haven't any entries since I updated my build with the new EFI and config.plist. To fix it I followed the steps and I used the Hackintool to export my pcidevices.plist and copied everything over, through Plistedit Pro, and save for the default names all looked good. Unfortunately on reboot I onboard sound was disabled. I fiddled with it a bit, and I am guessing, maybe having "hda-gfx" entry present in Devices: Properties caused something to go awry. Once I deleted that entry from the table, I rebooted and all was back to normal. I was wondering if anyone else ran into that, as I am unsure what the hda-gfx string would do to cause the hiccup. Anyhow its working now, and I did a GB benchmark after the 10.14.5 upgrade and it looks good to me for the cpu. Not sure if this counts as overclocking, but I did set the Enhanced Multicore Performance to Enabled in the Bios for a little boost.
  27. Sorry to necro but it worked for me using this method Im on a Ryzen 7 1700X Just in case anyone is interested.
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×