Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. @MaLd0n Thank you so much for this EFI!!! This is the only EFI that has ever worked for me. I can finally use my hackintosh after two weeks of struggling to make it work~ A few questions: - I have the Fenvi T919 card for Wifi + BT. Should I remove the Intel CNVi card? Right now I have Wifi working, but not Bluetooth (it's always shown as "on"). - As of now, all the USB ports work as intended, but none of the thunderbolt work. If I want to enable Thunderbolt, do I have to give up on the USB ports? - Only one of the Ethernet port is showing, but my Wifi is showing up as Ethernet too. Is it possible to get both Ethernet ports recognized properly and Wifi separately? Please let me know if I should ask a new topic instead of posting here. Any feedback is greatly appreciated, thank you! HW: Z390 Designare + 9900k + Fenvi T919 + RX 590 Nitro+
  3. This is working, with one typo fixed: 3E7538 to 3E79090 should read: 3E7538 to 3E7990 I have also updated stinga11's patch script. I used this script to update my just-updated-to-10.14.6 system, and it worked perfectly. Thanks again @stinga11 !!! 10.14.6 aicpm patch.command.zip
  4. camielverdult

    WhatEverGreen Support Topic

    Hi again, I'm kind of at the end of my rope here. Does anyone have any idea on how to counter the problem I am having? The kernel seems to be throwing a ton of these errors while booting macos: kernel: (AMDRadeonX5000HWLibs) AMD Error: kernel: (AMDRadeonX5000HWLibs) CAIL_ASICSetup() failed (CAILRESULT=1) kernel: (AMDRadeonX5000HWLibs) AMD Error: kernel: (AMDRadeonX5000HWLibs) initializeAdapter() failed!
  5. Witchcraft, man! It worked like a charm, I'm now able to reboot, shutdown and sleep. I had tried so many things already, can't thank you enough! Would be glad to support you, let me know ur PayPal link... se tiver conta no PicPay melhor ainda Abraço!
  6. Today
  7. Proxary

    OpenCore Discussion

    Hello guys I have a little bit problem when I booting with OpenCore 0.5.0 I don't can select my Recovery hard drive at startup has OpenCore a keyboard lock at startup or not ?
  8. bcuraboy3

    HDMI Audio ALC290 IntelHD5500

    I'm afraid not. I tried booting from the USB, with the patched config.plist, but no luck. Booted from the system, still the same. I brought with me a IOReg MacBook Pro de noi.zip
  9. Hervé

    HDMI Audio ALC290 IntelHD5500

    Success?
  10. Hervé

    HDMI Audio ALC290 IntelHD5500

    Yup, that's it. It's using long Find/Replace hexadecimal strings but these ensure that you only patch the desired layout in the kext's binary file and nothing else.
  11. Dopo aver risentito il mio amico c'è stato un cambio di programma: non gli servono nè wi-fi nè bluetooth perchè userà cavetto USB per Hotspot con smartphone Android (ci sono problemi con macOS mojave e l'hotspot da cellulare android con illiad?) Ricapitolando Lui ha già: Case ATX SSD 250 GB Serie 860 EVO 2.5' ALIMENTATORE EVGA 500B 500W a cui vorrei aggiungere questa nuova configurazione: Che ne pensate? E' un mac nativo? tutto compatibile senza problemi? Non avrò da fare nessun magheggio con kext od altro, nel senso che legge tutto nativamente? Grazie per la disponibilità e qualsiasi chiarimento mi vorreste dare
  12. Hervé

    HDMI Audio ALC290 IntelHD5500

    My mistake, I clicked "Save" before I was finished! Previous post is complete now.
  13. bcuraboy3

    HDMI Audio ALC290 IntelHD5500

  14. Hervé

    HDMI Audio ALC290 IntelHD5500

    Ok, so your laptop is running Mojave with Broadwell HD5500 layout-id 0x10260006. I can see the 2nd display attached to FB@1 with DP connector-type 0004 0000. In order to change this to HDMI connector type, you should try and enter the following on-the-fly patch in your Clover config, in the Kexts & Patches section (using CloverConfigurator app): kext: AppleIntelBDWGraphicsFramebuffer \/ Find: 0600261601030303000020020000500100000060D90A0000D90A000000000000000000000000000000000800020000003002000001050B000004000007050000 Replace: 0600261601030303000020020000500100000060D90A0000D90A000000000000000000000000000000000800020000003002000001050B000008000007050000 /\ Basically, if you look at layout 16260006 in the BDW framebuffer kext with an Hex editor, you'll see this (contiguously): 06002616 01030303 00002002 00005001 --> layout 16260006, 3 x display ports 00000060 D90A0000 D90A0000 00000000 00000000 00000000 00000800 02000000 30020000 --> 0000 xxxx = FB@0/port #0, 0200 0000 = built-in LCD 01050B00 00040000 07050000 --> 0105 xxxx = FB@1/port #5, 0004 0000 = DP output 02040B00 00040000 07050000 --> 0204 xxxx = FB@2/port #6, 0004 0000 = DP output You will see this reflected in your IOReg output under FB@0, FB@1 and FB@2, all under IGPU@2. What the patch will do is change DP connector-type 0004 0000 of FB@1/port #5 to HDMI connector-type 0008 0000: 06002616 01030303 00002002 00005001 --> layout 16260006, 3 x display ports 00000060 D90A0000 D90A0000 00000000 00000000 00000000 00000800 02000000 30020000 --> 0000 xxxx = FB@0/port #0, 0200 0000 = built-in LCD 01050B00 00040000 07050000 --> 0105 xxxx = FB@1/port #5, 0084 0000 = HDMI output 02040B00 00040000 07050000 --> 0204 xxxx = FB@2/port #6, 0004 0000 = DP output
  15. quelle che vedi da 99Mb in FAT32 sono le EFI di windows dove sono allocati i file di boot. Clover vede automaticamente questo e li avvia senza problemi quindi si, hai i dischi in GPT UEFI
  16. bcuraboy3

    HDMI Audio ALC290 IntelHD5500

    Yes, i'm aware of it. I have another laptop and I have to choose from the sound menu in status bar. Here's the IOREg. Thank you MacBook Pro de noi.zip
  17. Cyberdevs

    MSI R9 280X

    What about this one? config.plist 2.zip
  18. Hervé

    HDMI Audio ALC290 IntelHD5500

    You're probably missing the HDMI patch in the BDW framebuffer kext where you replace the default display port type to HDMI type 0008 0000. Post a saved IOReg output (from IORegistryExplorer app) when you have HDMI connected. Just to be sure, you know that HDMI audio output is not always automatic and may have to be manually selected, right?
  19. Snikii

    OpenCore Discussion

    The core problem is supposed to be somewhere in Quirks not on ACPI Renames as nothing is affecting CPU in terms of ACPI aside the Quirks and other General Options. There is no way to make a laptop work without rename patches at the current stage not even with OC (there are only rare cases). You need to patch EC Registers that are more than 8-bit that are battery related in order to have Battery Status working (whether you use ACPIBatteryManager.kext + FakeSMC.kext or VirtualSMC.kext + SMCBatteryManager.kext). You need to patch/rename GPRW or a _PRW that causes instant wake from sleep. You need to patch/rename ESEL, XSEL, XWAK (if present) as they cause issues with USB Ports You need to patch/rename your Qxx methods for Fn Buttons like brightness and others so they can work natively without the need of 3rd party apps. You need to patch/rename BAT0 and BAT1 notifiers to BATC if your laptop does have dual batteries so you can use SSDT-BATC to merge dual batteries into one and have hotswap functionality as dual battery support on macOS is bugged/not working natively. ETC But yes i do agree that with OC compared to Clover we need less more than we used.
  20. Quipper

    OpenCore Discussion

    I am not able to load X86 Platform Plugin. With Clover it was working. I edited SSDT-PLUG to match my cpu name with no effect. Can someone point me to the right direction. DSDT.aml SSDT-0.aml DSDT.aml SSDT-PLUG.aml
  21. NorthAmTrans

    OpenCore Discussion

    @Snikii of course! A couple things. Rename patches are frowned on with OC. Someone here with a more articulate answer can fill in the blanks here but the short of it all is that they cause problems and should be avoided. I would go through and figure out which ones are actually necessary and then find some help here about how to make or find a patch for them. I don't know much about laptops here but for pure lucks sake try setting LegacyEnable to YES. You should join the InsanelHack Discord. There is a channel there for OpenCore Laptops. Best of luck to ya. Report back with some progress!
  22. Thank you for your link. I used the Olarila app to download the EFI folder corresponding to my config. I then boot from the installation key, chose my SSD as installation disk. Restart on the installation key and in the chosen clover menu to boot to my SSD, I then fall on a loading menu that tells me that Mojave is installed on the SSD. Then I come across a screen that says "disk2s2: device is not readable" and it constantly reboots to always finish on this error. I do not know what to do. But I must say that this is the first time I go so far in installing my hack.
  23. Snikii

    OpenCore Discussion

    Thanks for pointing that out, added my hardware. But im more concerned about my current issue, i read the Configuration.pdf but can't seem to find a reason why i have a kernel panic related to my CPU.
  24. STLVNUB

    OpenCore Discussion

    good job
  25. rezsicc

    {Guide} DELL INSPIRON N5110

    Hey, I've seen that you would able to install the newest version of Mac OS and it works perfectly for you. I need your help! I've tried to install El Capitan on my machine, but after the Post Install I had no success so I decided to roll back to Yosemite. Unfortunately lots of apps are already deprecated or unsupported, so I can't install them on my system on 10.10. Could you provide me proper kexts for the newest OS, please?! Mohamed Khairy's tutorial is very outdated and I can't find proper kexts... Here is my entry, but nobody has reacted on my post. https://www.insanelymac.com/forum/topic/271573-guide-dell-inspiron-n5110/?do=findComment&comment=2669065 I am waiting for your response! Thanks in advance, Tibor
  26. @ilcondannato I will check radio silence as well! Thanks! BTW, I noticed that iStat does not shows Fan RPM There is also Lulu: https://objective-see.com/products/lulu.html
  27. I used to use Little Snitch, I will give it a try and see if it will solve the issue. Mostly I care to know based on the log if indeed hands off causing the kernel panic. I couldn't find anything else to blame, at first I though that FakeSMC might cause the issue but noting in the logs indicated FakeSMC, and I used FakeSMC before and it worked fine...
  1. Load more activity
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×