Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

All Activity

This stream auto-updates     

  1. Past hour
  2. I think we are getting close! Sleep itself seems to work (still takes a long time, but thats fine) , but on wake-up the screen stays black. Furthermore wake-up is only possible via Power-Button and not via USB-Keyboard New files here
  3. Hi there, I've had my current hardware running OS X -> macOS for many years now and for the most part it has worked exceptionally well. Unfortunately, in the last 8 months or so my USB devices are constantly experiencing errors and malfunctions. Specifically the mouse and keyboard suffer the most, but my USB audio devices suffer some errors as well. I know for a fact that it's not the ports or the devices that are failing, as I've used my Windows 10 install on the same hardware without any issue, and I've also used the mouse and keyboard on other PCs pretty extensively (also without issue). The actual issue is that the USB ports connected to the mouse and keyboard seem to constantly reset power and sometimes freeze up. This will interrupt inputs from the keyboard and also cause the on-board memory for my mouse to erase itself while also causing input errors. Looking at IO Reg in the USB section I see these two devices and sometimes others just spontaneously and sometimes constantly reset as if they're being unplugged and plugged back in. It's gotten so bad that I practically can't use my PC at all when in macOS High Sierra and I'm almost at the point of decided to buy new hardware completely. I've implemented RehabMan's USBInjectAll.kext solution for USB3 along with Fake_PCIID.kext and Fake_PCIID_XHCIMux.kext. I've also implemented patches for EHC1 to EH01, EHC2 to EH02. Here's a copy of my Clover config: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>#DisableDrivers</key> <array> <string>CsmVideoDxe</string> <string>VBoxExt4</string> </array> <key>ACPI</key> <dict> <key>#PatchAPIC</key> <false/> <key>#ResetAddress</key> <string>0x64</string> <key>#ResetValue</key> <string>0xFE</string> <key>#SortedOrder</key> <array> <string>SSDT-3.aml</string> <string>SSDT-1.aml</string> <string>SSDT-2.aml</string> </array> <key>#smartUPS</key> <false/> <key>AutoMerge</key> <false/> <key>DSDT</key> <dict> <key>#DropOEM_DSM</key> <dict> <key>ATI</key> <true/> <key>Firewire</key> <true/> <key>HDA</key> <true/> <key>HDMI</key> <true/> <key>IDE</key> <true/> <key>IntelGFX</key> <true/> <key>LAN</key> <true/> <key>LPC</key> <false/> <key>NVidia</key> <true/> <key>SATA</key> <true/> <key>SmBUS</key> <false/> <key>USB</key> <true/> <key>WIFI</key> <true/> </dict> <key>#Rtc8Allowed</key> <false/> <key>#SuspendOverride</key> <false/> <key>Debug</key> <false/> <key>Fixes</key> <dict> <key>AddDTGP</key> <true/> <key>AddHDMI</key> <true/> <key>AddIMEI</key> <false/> <key>AddMCHC</key> <false/> <key>AddPNLF</key> <true/> <key>DeleteUnused</key> <true/> <key>FakeLPC</key> <false/> <key>FixACST</key> <true/> <key>FixADP1</key> <true/> <key>FixAirport</key> <false/> <key>FixDarwin</key> <false/> <key>FixDarwin7</key> <true/> <key>FixDisplay</key> <true/> <key>FixFirewire</key> <false/> <key>FixHDA</key> <true/> <key>FixHPET</key> <true/> <key>FixHeaders</key> <true/> <key>FixIDE</key> <false/> <key>FixIPIC</key> <true/> <key>FixIntelGfx</key> <false/> <key>FixLAN</key> <true/> <key>FixMutex</key> <false/> <key>FixRTC</key> <true/> <key>FixRegions</key> <true/> <key>FixS3D</key> <true/> <key>FixSATA</key> <false/> <key>FixSBUS</key> <true/> <key>FixShutdown</key> <true/> <key>FixTMR</key> <true/> <key>FixUSB</key> <true/> <key>FixWAK</key> <true/> </dict> <key>Name</key> <string>DSDT.aml</string> <key>Patches</key> <array> <dict> <key>Comment</key> <string>Rename GFX0 to IGPU</string> <key>Disabled</key> <false/> <key>Find</key> <data> R0ZYMA== </data> <key>Replace</key> <data> SUdQVQ== </data> </dict> <dict> <key>Comment</key> <string>change EHC1 to EH01</string> <key>Disabled</key> <false/> <key>Find</key> <data> RUhDMQ== </data> <key>Replace</key> <data> RUgwMQ== </data> </dict> <dict> <key>Comment</key> <string>change EHC2 to EH02</string> <key>Disabled</key> <false/> <key>Find</key> <data> RUhDMg== </data> <key>Replace</key> <data> RUgwMg== </data> </dict> </array> <key>ReuseFFFF</key> <false/> </dict> <key>DisableASPM</key> <false/> <key>DropTables</key> <array> <dict> <key>Signature</key> <string>DMAR</string> </dict> <dict> <key>Signature</key> <string>SSDT</string> <key>TableId</key> <string>CpuPm</string> </dict> <dict> <key>#Length</key> <integer>720</integer> <key>Signature</key> <string>SSDT</string> <key>TableId</key> <string>Cpu0Ist</string> </dict> </array> <key>HaltEnabler</key> <true/> <key>SSDT</key> <dict> <key>#C3Latency</key> <string>0x03E7</string> <key>#DoubleFirstState</key> <true/> <key>#DropOem</key> <true/> <key>#EnableC2</key> <false/> <key>#EnableC4</key> <false/> <key>#EnableC6</key> <true/> <key>#EnableC7</key> <false/> <key>#MaxMultiplier</key> <integer>12</integer> <key>#MinMultiplier</key> <integer>8</integer> <key>#NoDynamicExtract</key> <false/> <key>#NoOemTableId</key> <false/> <key>#PLimitDict</key> <integer>1</integer> <key>#PluginType</key> <integer>0</integer> <key>#UnderVoltStep</key> <integer>1</integer> <key>#UseSystemIO</key> <false/> <key>DropOem</key> <true/> <key>EnableC6</key> <true/> <key>EnableC7</key> <false/> <key>Generate</key> <dict> <key>#APLF</key> <false/> <key>#APSN</key> <false/> <key>#PluginType</key> <false/> <key>CStates</key> <true/> <key>PStates</key> <true/> </dict> </dict> </dict> <key>Boot</key> <dict> <key>#Arguments</key> <string>slide=0 darkwake=0</string> <key>#DefaultLoader</key> <string>boot.efi</string> <key>#LegacyBiosDefaultEntry</key> <integer>0</integer> <key>#XMPDetection</key> <string>-1</string> <key>Arguments</key> <string>-uia_exclude_xhc dart=0 -v darkwake=no</string> <key>Debug</key> <false/> <key>DefaultVolume</key> <string>Macintosh HD</string> <key>DisableCloverHotkeys</key> <false/> <key>Legacy</key> <string>PBR</string> <key>NeverDoRecovery</key> <true/> <key>NeverHibernate</key> <false/> <key>SignatureFixup</key> <false/> <key>SkipHibernateTimeout</key> <false/> <key>StrictHibernate</key> <false/> <key>Timeout</key> <integer>4</integer> </dict> <key>BootGraphics</key> <dict> <key>#DefaultBackgroundColor</key> <string>0xF0F0F0</string> <key>EFILoginHiDPI</key> <integer>1</integer> <key>UIScale</key> <integer>1</integer> </dict> <key>CPU</key> <dict> <key>#BusSpeedkHz</key> <integer>133330</integer> <key>#FrequencyMHz</key> <integer>3140</integer> <key>#HWPEnable</key> <true/> <key>#HWPValue</key> <string>0x30002a01</string> <key>#QPI</key> <integer>4800</integer> <key>#SavingMode</key> <integer>7</integer> <key>#TDP</key> <integer>95</integer> <key>#TurboDisable</key> <true/> <key>#Type</key> <string>0x0201</string> <key>#UseARTFrequency</key> <true/> <key>C6</key> <false/> </dict> <key>Devices</key> <dict> <key>#AddProperties</key> <array> <dict> <key>Device</key> <string>NVidia</string> <key>Key</key> <string>AAPL,HasPanel</string> <key>Value</key> <data> AQAAAA== </data> </dict> <dict> <key>Device</key> <string>NVidia</string> <key>Key</key> <string>AAPL,Haslid</string> <key>Value</key> <data> AQAAAA== </data> </dict> </array> <key>#AirportBridgeDeviceName</key> <string>RP02</string> <key>#Arbitrary</key> <array> <dict> <key>Comment</key> <string>Thunderbolt bridge</string> <key>CustomProperties</key> <array> <dict> <key>Disabled</key> <true/> <key>Key</key> <string>PCI-Thunderbolt</string> <key>Value</key> <integer>3</integer> </dict> </array> <key>PciAddr</key> <string>03:00:00</string> </dict> <dict> <key>Comment</key> <string>Thunderbolt device</string> <key>CustomProperties</key> <array> <dict> <key>Disabled</key> <true/> <key>Key</key> <string>TBTDPLowToHigh</string> <key>Value</key> <data> AQAAAA== </data> </dict> <dict> <key>Disabled</key> <true/> <key>Key</key> <string>ThunderboltUUID</string> <key>Value</key> <data> CO8yvYVBslCHyHKPjwfU/A== </data> </dict> </array> <key>PciAddr</key> <string>05:00:00</string> </dict> <dict> <key>Comment</key> <string>IntelGfx</string> <key>CustomProperties</key> <array> <dict> <key>Key</key> <string>graphic-options</string> <key>Value</key> <data> DAAAAA== </data> </dict> <dict> <key>Key</key> <string>hda-gfx</string> <key>Value</key> <string>onboard-1</string> </dict> <dict> <key>Key</key> <string>AAPL,ig-platform-id</string> <key>Value</key> <data> AAASGQ== </data> </dict> <dict> <key>Key</key> <string>model</string> <key>Value</key> <string>Intel HD Graphics 7000</string> </dict> <dict> <key>Key</key> <string>subsystem-vendor-id</string> <key>Value</key> <data> axAAAA== </data> </dict> <dict> <key>Key</key> <string>subsystem-id</string> <key>Value</key> <data> hoAAAA== </data> </dict> <dict> <key>Disabled</key> <true/> <key>Key</key> <string>@2,AAPL,boot-display</string> <key>Value</key> <true/> </dict> </array> <key>PciAddr</key> <string>00:02:00</string> </dict> <dict> <key>Comment</key> <string>HDA Audio</string> <key>CustomProperties</key> <array> <dict> <key>Key</key> <string>hda-gfx</string> <key>Value</key> <string>onboard-1</string> </dict> </array> <key>PciAddr</key> <string>00:1f:03</string> </dict> <dict> <key>Comment</key> <string>ATI Radeon</string> <key>CustomProperties</key> <array> <dict> <key>Key</key> <string>hda-gfx</string> <key>Value</key> <string>onboard-2</string> </dict> <dict> <key>Key</key> <string>model</string> <key>Value</key> <string>AMD Radeon HD6450</string> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>@AAPL,boot-display</string> <key>Value</key> <true/> </dict> </array> <key>PciAddr</key> <string>01:00:00</string> </dict> </array> <key>#DisableFunctions</key> <string>0x18F6</string> <key>#FakeID</key> <dict> <key>#ATI</key> <string>0x67501002</string> <key>#IMEI</key> <string>0x1e208086</string> <key>#IntelGFX</key> <string>0x01268086</string> <key>#LAN</key> <string>0x100E8086</string> <key>#NVidia</key> <string>0x11de10de</string> <key>#SATA</key> <string>0x25628086</string> <key>#WIFI</key> <string>0x431214e4</string> <key>#XHCI</key> <string>0x0</string> </dict> <key>#ForceHPET</key> <false/> <key>#Inject</key> <false/> <key>#IntelMaxValue</key> <integer>1808</integer> <key>#Properties</key> <string>7a00000001000000010000006e0000000200000002010c00d041030a0000000001010600001b7fff040028000000500069006e0043006f006e00660069006700750072006100740069006f006e00730000000800000001080100180000006c00610079006f00750074002d00690064000000080000000c000000</string> <key>#SetIntelBacklight</key> <false/> <key>#SetIntelMaxBacklight</key> <true/> <key>Audio</key> <dict> <key>#Inject</key> <string>0x0887</string> <key>AFGLowPowerState</key> <true/> <key>Inject</key> <string>2</string> <key>ResetHDA</key> <true/> </dict> <key>NoDefaultProperties</key> <false/> <key>USB</key> <dict> <key>AddClockID</key> <false/> <key>FixOwnership</key> <false/> <key>HighCurrent</key> <true/> <key>Inject</key> <true/> </dict> <key>UseIntelHDMI</key> <false/> </dict> <key>GUI</key> <dict> <key>#ConsoleMode</key> <string>0</string> <key>#Custom</key> <dict> <key>Entries</key> <array> <dict> <key>AddArguments</key> <string>-v</string> <key>Arguments</key> <string>Kernel=mach_kernel</string> <key>Disabled</key> <true/> <key>Hidden</key> <false/> <key>Hotkey</key> <string>M</string> <key>InjectKexts</key> <false/> <key>NoCaches</key> <false/> <key>Path</key> <string>\EFI\BOOT\BOOTX64.efi</string> <key>Title</key> <string>MyCustomEntry</string> <key>Type</key> <string>OSXRecovery</string> <key>Volume</key> <string>D68F1885-571C-4441-8DD5-F14803EFEF54</string> </dict> <dict> <key>Hidden</key> <false/> <key>InjectKexts</key> <false/> <key>NoCaches</key> <false/> <key>SubEntries</key> <array> <dict> <key>AddArguments</key> <string>-v</string> <key>Title</key> <string>Boot OS X 10.8.5 (12F36) Mountain Lion in Verbose Mode</string> </dict> </array> <key>Title</key> <string>OS X 10.8.5 (12F36) Mountain Lion</string> <key>Type</key> <string>OSX</string> <key>Volume</key> <string>454794AC-760D-46E8-8F77-D6EB23D2FD32</string> </dict> </array> <key>Legacy</key> <array> <dict> <key>Disabled</key> <true/> <key>Hidden</key> <false/> <key>Hotkey</key> <string>L</string> <key>Title</key> <string>MyLegacyEntry</string> <key>Type</key> <string>Windows</string> <key>Volume</key> <string>89433CD3-21F2-4D3C-95FC-722C48066D3A</string> </dict> </array> <key>Tool</key> <array> <dict> <key>Arguments</key> <string>-b</string> <key>Disabled</key> <false/> <key>Hidden</key> <false/> <key>Hotkey</key> <string>S</string> <key>Path</key> <string>\EFI\CLOVER\TOOLS\Shell64-v1.efi</string> <key>Title</key> <string>MyCustomShell</string> <key>Volume</key> <string>D68F1885-571C-4441-8DD5-F14803EFEF54</string> </dict> </array> </dict> <key>#CustomIcons</key> <false/> <key>#Hide</key> <array> <string>Windows</string> <string>BOOTX64.EFI</string> </array> <key>#Language</key> <string>ru:0</string> <key>#Mouse</key> <dict> <key>Enabled</key> <true/> <key>Mirror</key> <false/> <key>Speed</key> <integer>2</integer> </dict> <key>#Scan</key> <dict> <key>Entries</key> <true/> <key>Legacy</key> <false/> <key>Tool</key> <true/> </dict> <key>#TextOnly</key> <false/> <key>Language</key> <string>en:0</string> <key>ScreenResolution</key> <string>1920x1080</string> <key>ShowOptimus</key> <false/> <key>Theme</key> <string>applestyle</string> </dict> <key>Graphics</key> <dict> <key>#Connectors</key> <array/> <key>#DualLink</key> <integer>0</integer> <key>#FBName</key> <string>Makakakakala</string> <key>#Inject</key> <dict> <key>ATI</key> <true/> <key>Intel</key> <false/> <key>NVidia</key> <false/> </dict> <key>#LoadVBios</key> <false/> <key>#NVCAP</key> <string>04000000000003000C0000000000000A00000000</string> <key>#NvidiaGeneric</key> <true/> <key>#NvidiaNoEFI</key> <false/> <key>#NvidiaSingle</key> <false/> <key>#PatchVBios</key> <false/> <key>#PatchVBiosBytes</key> <array> <dict> <key>Find</key> <data> gAeoAqAF </data> <key>Replace</key> <data> gAeoAjgE </data> </dict> </array> <key>#RadeonDeInit</key> <true/> <key>#VRAM</key> <integer>1024</integer> <key>#VideoPorts</key> <integer>2</integer> <key>#display-cfg</key> <string>03010300FFFF0001</string> <key>#ig-platform-id</key> <string>0x01620005</string> <key>EDID</key> <dict> <key>#Custom</key> <data> AP///////wAGECGSAAAAAAASAQOAIRV4CunVmVlTjigmUFQAAAAB AQEBAQEBAQEBAQEBAQEB3iGgcFCEHzAgIFYAS88QAAAY3iGgcFCE HzAgIFYAS88QAAAAAAAA/gBXNjU3RwAxNTRXUDEKAAAA/gAjMz1I ZYSq/wIBCiAgAJo= </data> <key>#HorizontalSyncPulseWidth</key> <string>0x11</string> <key>#Inject</key> <true/> <key>#ProductID</key> <string>0x9221</string> <key>#VendorID</key> <string>0x1006</string> <key>#VideoInputSignal</key> <string>0xA1</string> </dict> </dict> <key>KernelAndKextPatches</key> <dict> <key>#ATIConnectorsController</key> <string>6000</string> <key>#ATIConnectorsData</key> <string>000400000403000000010000210302040400000014020000000100000000040310000000100000000001000000000001</string> <key>#ATIConnectorsPatch</key> <string>040000001402000000010000000004040004000004030000000100001102010500000000000000000000000000000000</string> <key>#BootPatches</key> <array> <dict> <key>Comment</key> <string>Example</string> <key>Disabled</key> <true/> <key>Find</key> <data> RXh0ZXJuYWw= </data> <key>MatchOS</key> <string>All</string> <key>Replace</key> <data> SW50ZXJuYWw= </data> </dict> </array> <key>#FakeCPUID</key> <string>0x010676</string> <key>#ForceKextsToLoad</key> <array> <string>\System\Library\Extensions\AMD6000Controller.kext</string> <string>\System\Library\Extensions\AMDFramebuffer.kext</string> </array> <key>#KernelToPatch</key> <array> <dict> <key>Comment</key> <string>Infinite loop at wake</string> <key>Disabled</key> <true/> <key>Find</key> <data> TIn/6PXb/v8= </data> <key>MatchOS</key> <string>10.11</string> <key>Replace</key> <data> 6/7/6PXb/v8= </data> </dict> </array> <key>#KextsToPatch</key> <array> <dict> <key>Disabled</key> <true/> <key>Find</key> <data> SGVhZHBob25lcwA= </data> <key>Name</key> <string>VoodooHDA</string> <key>Replace</key> <data> VGVsZXBob25lcwA= </data> </dict> <dict> <key>Comment</key> <string>Patch_to_not_load_this_driver</string> <key>Find</key> <string>0x04020000</string> <key>InfoPlistPatch</key> <true/> <key>Name</key> <string>AppleHDAController</string> <key>Replace</key> <string>0x44220000</string> </dict> <dict> <key>Comment</key> <string>Make all drives to be internal</string> <key>Find</key> <data> RXh0ZXJuYWw= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> SW50ZXJuYWw= </data> </dict> <dict> <key>Comment</key> <string>TRIM function for non-Apple SSDs</string> <key>Find</key> <data> QVBQTEUgU1NEAA== </data> <key>Name</key> <string>IOAHCIBlockStorage</string> <key>Replace</key> <data> AAAAAAAAAAAAAA== </data> </dict> <dict> <key>Comment</key> <string>ATI Connector patch new way</string> <key>Disabled</key> <false/> <key>Find</key> <data> AAQAAAQDAAAAAQAAIQMCBAQAAAAUAgAAAAEAAAAABAMQ AAAAEAAAAAABAAAAAAAB </data> <key>MatchOS</key> <string>10.9,10.10,10.11</string> <key>Name</key> <string>AMD6000Controller</string> <key>Replace</key> <data> BAAAABQCAAAAAQAAAAAEBAAEAAAEAwAAAAEAABECAQUA AAAAAAAAAAAAAAAAAAAA </data> </dict> <dict> <key>Comment</key> <string>ATI name HD xxxx -&gt; HD6450</string> <key>Disabled</key> <false/> <key>Find</key> <data> SEQgNnh4eA== </data> <key>MatchOS</key> <string>10.12,10.13</string> <key>Name</key> <string>AMD6000Controller</string> <key>Replace</key> <data> SEQgNjQ1MA== </data> </dict> </array> <key>AppleIntelCPUPM</key> <false/> <key>AppleRTC</key> <true/> <key>Debug</key> <false/> <key>DellSMBIOSPatch</key> <false/> <key>KernelCpu</key> <false/> <key>KernelLapic</key> <false/> <key>KernelPm</key> <false/> <key>KernelXCPM</key> <false/> <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>10.12-AppleHDA/Realtek ALC...</string> <key>Disabled</key> <false/> <key>Find</key> <data> ihnUEQ== </data> <key>InfoPlistPatch</key> <false/> <key>Name</key> <string>AppleHDA</string> <key>Replace</key> <data> AAAAAA== </data> </dict> <dict> <key>Comment</key> <string>10.9-10.12-AppleHDA/Realtek ALC898</string> <key>Disabled</key> <false/> <key>Find</key> <data> ixnUEQ== </data> <key>InfoPlistPatch</key> <false/> <key>Name</key> <string>AppleHDA</string> <key>Replace</key> <data> mQjsEA== </data> </dict> <dict> <key>Comment</key> <string>AppleHDA/Resources/xml&gt;zml</string> <key>Disabled</key> <false/> <key>Find</key> <data> eG1sLnps </data> <key>InfoPlistPatch</key> <false/> <key>Name</key> <string>AppleHDA</string> <key>Replace</key> <data> em1sLnps </data> </dict> </array> </dict> <key>RtVariables</key> <dict> <key>BooterConfig</key> <string>0x28</string> <key>CsrActiveConfig</key> <string>0x67</string> <key>MLB</key> <string>C02032109R5DC771H</string> <key>ROM</key> <string>UseMacAddr0</string> </dict> <key>SMBIOS</key> <dict> <key>#BiosReleaseDate</key> <string>05/03/10</string> <key>#BiosVendor</key> <string>Apple Inc.</string> <key>#BiosVersion</key> <string>MB11.88Z.0061.B03.0809221748</string> <key>#Board-ID</key> <string>Mac-F4208CC8</string> <key>#BoardManufacturer</key> <string>Apple Inc.</string> <key>#BoardSerialNumber</key> <string>C02032101R5DC771H</string> <key>#BoardType</key> <integer>10</integer> <key>#BoardVersion</key> <string>Proto1</string> <key>#ChassisAssetTag</key> <string>LatitudeD420</string> <key>#ChassisManufacturer</key> <string>Apple Inc.</string> <key>#ChassisType</key> <integer>16</integer> <key>#Family</key> <string>MacBook</string> <key>#FirmwareFeatures</key> <string>0xC0001403</string> <key>#FirmwareFeaturesMask</key> <string>0xFFFFFFFF</string> <key>#LocationInChassis</key> <string>MLB</string> <key>#Memory</key> <dict> <key>Channels</key> <integer>2</integer> <key>Modules</key> <array> <dict> <key>Frequency</key> <integer>1333</integer> <key>Part</key> <string>C0001403</string> <key>Serial</key> <string>00001001</string> <key>Size</key> <integer>4096</integer> <key>Slot</key> <integer>0</integer> <key>Type</key> <string>DDR3</string> <key>Vendor</key> <string>Kingston</string> </dict> <dict> <key>Frequency</key> <integer>1333</integer> <key>Part</key> <string>C0001404</string> <key>Serial</key> <string>00001002</string> <key>Size</key> <integer>4096</integer> <key>Slot</key> <integer>2</integer> <key>Type</key> <string>DDR3</string> <key>Vendor</key> <string>Kingston</string> </dict> </array> <key>SlotCount</key> <integer>4</integer> </dict> <key>#Mobile</key> <true/> <key>#PlatformFeature</key> <string>0x03</string> <key>#ProductName</key> <string>MacBook1,1</string> <key>#SerialNumber</key> <string>4H629LYAU9C</string> <key>#Slots</key> <array> <dict> <key>Device</key> <string>ATI</string> <key>ID</key> <integer>1</integer> <key>Name</key> <string>PCIe Slot 0</string> <key>Type</key> <integer>16</integer> </dict> <dict> <key>Device</key> <string>WIFI</string> <key>ID</key> <integer>0</integer> <key>Name</key> <string>Airport</string> <key>Type</key> <integer>1</integer> </dict> </array> <key>#SmUUID</key> <string>00000000-0000-1000-8000-010203040506</string> <key>#Trust</key> <true/> <key>#Version</key> <string>1.0</string> <key>BiosReleaseDate</key> <string>02/02/2018</string> <key>BiosVendor</key> <string>Apple Inc.</string> <key>BiosVersion</key> <string>IM142.88Z.0128.B00.1802021101</string> <key>Board-ID</key> <string>Mac-27ADBB7B4CEE8E61</string> <key>BoardManufacturer</key> <string>Apple Inc.</string> <key>BoardSerialNumber</key> <string>*****************</string> <key>BoardType</key> <integer>10</integer> <key>BoardVersion</key> <string>1.0</string> <key>ChassisAssetTag</key> <string>iMac-Aluminum</string> <key>ChassisManufacturer</key> <string>Apple Inc.</string> <key>ChassisType</key> <string>0x0D</string> <key>Family</key> <string>iMac</string> <key>FirmwareFeatures</key> <string>0xE00FE137</string> <key>FirmwareFeaturesMask</key> <string>0xFF1FFF3F</string> <key>LocationInChassis</key> <string>Part Component</string> <key>Manufacturer</key> <string>Apple Inc.</string> <key>Mobile</key> <false/> <key>PlatformFeature</key> <string>0x01</string> <key>ProductName</key> <string>iMac14,2</string> <key>SerialNumber</key> <string>************</string> <key>Version</key> <string>1.0</string> </dict> <key>SystemParameters</key> <dict> <key>#BacklightLevel</key> <string>0x0501</string> <key>#CustomUUID</key> <string>********-****-****-****-************</string> <key>#NoCaches</key> <false/> <key>#NvidiaWeb</key> <false/> <key>InjectKexts</key> <string>Yes</string> <key>InjectSystemID</key> <true/> <key>NvidiaWeb</key> <true/> </dict> </dict> </plist> I can also upload IOReg stuff or even my whole /EFI folder; I'm at such a loss and I really have no idea how to proceed troubleshooting this problem, so any help would be appreciated.
  4. Switch to light mode. That app does not work in dark mode for some reason.
  5. Many final years students do find it difficult to get good final year project materials for either accounting project materials, engineering, and many more. Thereafter, writing the project, they still find it difficult to get an acceptable abstract to write. Why are project abstract Necessary? Abstracts are important parts of reports and research papers and sometimes academic assignments. The abstract is often the last item that you write, but the first thing people read when they want to have a quick overview of the whole paper. Research abstracts are used throughout the research community to provide a concise description about a research project. It is typically a short summary of your completed research. If done well, it makes the reader want to learn more about your research. Some students present their research findings at local and national conferences. Research abstracts are usually requested as part of the application process for conference presenters. These are the basic components of an abstract in any discipline: 1) Motivation/problem statement: Why do we care about the problem? What practical, scientific, theoretical or artistic gap is your research filling? 2) Methods/procedure/approach: What did you actually do to get your results? (e.g. analyzed 3 novels, completed a series of 5 oil paintings, interviewed 17 students) 3) Results/findings/product: As a result of completing the above procedure, what did you earn/invent/create? 4) Conclusion/implications: What are the larger implications of your findings, especially for the problem/gap identified in step 1? However, it’s important to note that the weight accorded to the different components can vary by discipline. For models, try to find abstracts of research that is similar to your research. Reread the article, paper, or report with the goal of abstracting in mind. Look specifically for these main parts of the article, paper, or report: purpose, methods, scope, results, conclusions, and recommendation. If you’re writing an abstract about another person’s article, paper, or report, the introduction and the summary are good places to begin. These areas generally cover what the article emphasizes. After you’ve finished rereading the article, paper, or report, write a rough draft without looking back at what you’re abstracting. Don’t merely copy key sentences from the article, paper, or report: you’ll put in too much or too little information. Don’t rely on the way material was phrased in the article, paper, or report: summarize information in a new way
  6. New bios (1301) has the option the unlock msr 0xe2 under advanced/CPU. So no need to patch bios / use kernel patches anymore.
  7. OK some updates.. The boot fail was fixed by NVidia 610 GPU. So yes 2500 no longer works. Thanks! However the installer still cannot see my SSD on my internal SATA (tested both 3G and 6G ports). Clover can see the drive, but the installer and Disk Utility cannot. So instead I installed a PCIe SATA3 card, a Syba SI-PEX40064 which uses a Marvell chip. The installer can see this and install to it. The installation to SSD on PCIe SATA card seemed to go OK. But it then hangs on first boot, at about 70% through the progress bar. Verbose logs show it is in a loop, with the following apfs logs repeating over and over every 30 seconds or so: apfs: disk1s1: device is not readable apfs_vfsop_unmount: 1487: unmounting devvp <ptr> apfs: total mem allocated: 37473387 (36mb); apfs_vfsop_unmount:1732: all done. going home. (numMountedAPFS Volumes 2) handle_encryption_rolling:4092: er: request granted[8] I don't know if this problem is caused by being on the PCIe Syba card. I believe this Syba card should work in general. Although I don't know if it has an EFI BIOS. But I think the main problem I need to solve is why my the SSD on my internal SATA ports are not detected by the installer/disk utility? Thanks again.
  8. Today
  9. replace, reboot, new SEND_ME http://www37.zippyshare.com/v/6SrePuyx/file.html
  10. Problemi con il mio config.plist

    Grazie gengik84, l'ho messo dentro e mi sembra andare meglio. Mi ci vorrà qualche giorno di test ma i risultati sono incoraggianti!
  11. [Problema] Ronzio continuo su ALC1220

    Giorni fa ho patchato il Kext AppleHDA con il relativo patcher di Mirone, ora ho notato che sono rimasti dei "residui" (3 voci) nel mio config.plist nella sezione "Kernel and Kext patches". Li ho disattivati cliccando sulla spunta "disable", ma il problema rimane. Ripristinare l'SSD e mandare a monte tutto il mio lavoro e rifare tutto daccapo per ora mi farebbe perdere del tempo prezioso. Non c'è un metodo alternativo? Potresti indicarmi dove scaricare un kext vanilla AppleHDA? Aggiungo che durante l'installazione tutti i Kext necessari erano nella partizione EFI della mia pennetta. Grazie ancora!
  12. Hi. How is this supposed to work? All I see is some icon in the menu bar, clicking on it just shows me a big black box
  13. No, I haven't - that's a good idea. I will try that as soon as XCode install finishes. Thanks!
  14. Ok, have you tried a safe mode boot and, if yes, did you see any change(s)?
  15. I had a look at top earlier, but it doesn't show the kernel task, just normal processes. Top shows the same 95+% System usage as Activity Monitor, but AM also shows the kernel specifically: As mentioned I am going to try using DTrace to probe the kernel to see exactly what syscalls it is making, in the hope this will give a clue as to what all that System time is actually doing. I am guessing I will see it's accessing a piece of hardware, or waiting for that hardware, or something like that. If I can work out what it's doing then maybe I can try and stop it doing that. But I'll run ADS first, because maybe that will pinpoint the issue exactly.
  16. Open Terminal window and simply type top You'll see lot of infos about your system and you can easily identify some useful information about cpu usage, memory usage, number of threads....
  17. Thanks, but I have already re-installed the OS from a blank drive, so I don't think this could make any further difference? A bad OS was my first thought and hope, so I wiped the drive and did a fresh install of 10.7.5 from Internet Recovery, then upgraded that 10.8, then again to 10.13.3, and the issue is the same in all. The issue is also the same when booting from a macOS installer USB stick or into the Installer pre-boot - hence it taking 6+ hours to upgrade to 10.13.3. Basically whenever macOS is booted in any way, from any source, the system is dog slow. Only booting Linux gives me a usable system (apart from 30 minutes when it suddenly worked OK in macOS until it suddenly shut down.) There's definitely some kind of hardware/firmware problem, because when the system is powered down the power button doesn't operate properly - it has to be held down for 10 seconds or so, until I hear the boot-up chime, else the system will not start. That problem existed even in Linux. So either I need to work out what the HW fault is and hope I can fix it (unlikely), or else my best hope is that I can find out why the fault is causing the kernel to use 95+% CPU in macOS, but not in Linux. If I can then stop that happening - maybe by disabling a piece of hardware or some feature - I will have a usable MBP except with no sleep. That might be acceptable for general usage. Next step is to run the Apple Diagnostics - once XCode install finishes (2 hours and counting.. )
  18. Thanks, thats awesome Here you are: Dropbox Link
  19. Try this: open a Terminal window and paste this command: sudo update_dyld_shared_cache -force You'll be asked for administrator password. When finished (it can take some minutes) reboot your MBP Good luck
  20. HP 15bs059nl High Sierra

    Fai prima la prova a installare clover in uefi su una usb, successivamente aggiungi i tuoi kext, sostituisci il config etc Bios impostato per effettuare il boot uefi. Se riesci a fare il boot a quel punto ti basta montare la partizione efi del disco, copiare e sostituire la efi con quella funzionante della usb Se hai una cartella efi nella root del disco questa deve essere cancellata come se vi fosse un file boot, stessa cosa se questo è presente nella efi il boot esterno alla cartella efi è presente solo per avvio legacy
  21. HP 15bs059nl High Sierra

    E' quello che ho fatto... stanotte proverò ad installare ex novo dopo aver fatto un back up Time machine.. voglio capire che cosa impedisce di installare Clover correttamente. Solo per curiosità il fatto che l' hd abbia quelle caratteristiche (4096 byte sectors) non has nulla a che vedere con l' errore boot0?
  22. send me new SEND_ME with new files, i'll check
  23. Intel WIFI Driver

    Hello! How is the driver progress? Is it Functional?
  24. Thanks a lot for your help ! DSDT seems to work good, but unfortunately Sleep still does not work I also tried your Config from the first Post and put hibernate mode and dark wake back to original and reset the sleep image Its strange: 1. I press Apple - Sleep 2. Monitor goes of, USB devices go off, internal HDD spins down, but fans keep running 3. After around 2 minutes the fans spin down and the PC seems to be in Sleep Mode 4. I try to wake the PC via power button and it boots from zero, as if I did shut down it completely before. No crash, reboot or error messages. Just looks like a normal boot Do you maybe have another idea? Best regards
  25. Ahh it's OK, I did have it after all - the file was named weirdly (ASD_ssps_004-0470-A) but I found out which was 3S148 with some more Googling. Thanks mate, I will have a go at that when I can. Right now the MBP is installing XCode, which I found I needed before I could run any DTrace scripts. I'm taking bets on how long it's going to take to install XCode, given OS updates have been taking 4-12 hours
  26. Hi, has anybody tried the newest Z820 bios + OS updates with the Meltdown/Spectre fixes?
  1. Load more activity